Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Open-Xchange on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 32, 33, 34 ... 37, 38, 39  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
nife
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2003
Posts: 87

PostPosted: Wed Sep 07, 2005 8:29 pm    Post subject: Reply with quote

Boef wrote:
The problem is, they have changed the structure of the directories since tomcat www-servers/tomcat-5.0.28-r4. I'm currently installing that version and will report it and change the ebuild.

ok, now it finished, they changed the structure try to copy the war-files into "/var/lib/tomcat-5/default/webapps".
This should be the right location.

i'll update the ebuild.


Nope I copied the war's into there and http://localhost:8080/servlet/intranet/ still gives me an error.
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Sep 07, 2005 8:52 pm    Post subject: Reply with quote

nife wrote:
now I'm getting error authentication failed when I try to login... blah


what say the log-files in /var/log/open-xchange?
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Sep 07, 2005 8:57 pm    Post subject: Reply with quote

an other question, it seams you've upgrade from a prior version of tomcat.
Have you start tomcat with
Code:
/etc/init.d/tomcat-5 start
?

Are their any information in the catalina.out?
Back to top
View user's profile Send private message
nife
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2003
Posts: 87

PostPosted: Wed Sep 07, 2005 9:12 pm    Post subject: Reply with quote

Boef wrote:
an other question, it seams you've upgrade from a prior version of tomcat.
Have you start tomcat with
Code:
/etc/init.d/tomcat-5 start
?

Are their any information in the catalina.out?


Nope I haven't upgraded this is a fresh install
the only thing even the least bit weird is that its an amd64 bit machine

catalina.out just complains about log4j and nothing else
Back to top
View user's profile Send private message
nife
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2003
Posts: 87

PostPosted: Wed Sep 07, 2005 9:14 pm    Post subject: Reply with quote

Boef wrote:
nife wrote:
now I'm getting error authentication failed when I try to login... blah


what say the log-files in /var/log/open-xchange?


I'm working on this.. I think I messed up the openldap stuff so I am re-doing that
Back to top
View user's profile Send private message
nife
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2003
Posts: 87

PostPosted: Wed Sep 07, 2005 9:53 pm    Post subject: Reply with quote

could the fact that I am running
java version "1.4.2-02"
Java(TM) 2 Runtime Environment, Standard Edition (build Blackdown-1.4.2-02)
Java HotSpot(TM) 64-Bit Server VM (build Blackdown-1.4.2-02, mixed mode)

lead to the fact that I am not able to run this ?


well It looks like I have a problem with ldap
here is what sessiond.log says:


Code:
Sep 07 18:08:59 localhost openexchange: oxsessiond init (localhost:33333) objectstream=false
Sep 07 18:08:59 localhost openexchange: INTERNAL TLS Support: OFF
Sep 07 18:08:59 localhost openexchange: oxsessiond init (localhost:33335) objectstream=true
Sep 07 18:09:08 localhost openexchange: Authentication failed for user: nife
Sep 07 18:09:08 localhost openexchange: ERROR: Authentification failed
Sep 07 18:09:16 localhost openexchange: Authentication failed for user: nife
Sep 07 18:09:16 localhost openexchange: ERROR: Authentification failed
Sep 07 18:09:20 localhost openexchange: Authentication failed for user: nife
Sep 07 18:09:20 localhost openexchange: ERROR: Authentification failed
Sep 07 18:09:24 localhost openexchange: Authentication failed for user: nife
Sep 07 18:09:24 localhost openexchange: ERROR: Authentification failed
Sep 07 18:09:27 localhost openexchange: Authentication failed for user: nife
Sep 07 18:09:27 localhost openexchange: ERROR: Authentification failed


I have added a user with adduser_ox and it had an error:

Code:
adduser_ox --username="nife1" --passwd="password" --name="Nife" --sname="Nife" --ox_timezone=EDT --maildomain="nife.us"
ldap_bind: Invalid credentials (49)
LDAP Success
SQL Success


Figured that out. It was a permissions error. I had to chown ldap:ldap everything in ldap-data
so the only thing left is to figure out why tomcat hates me
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Sep 07, 2005 10:40 pm    Post subject: Reply with quote

nife wrote:

Code:
adduser_ox --username="nife1" --passwd="password" --name="Nife" --sname="Nife" --ox_timezone=EDT --maildomain="nife.us"
ldap_bind: Invalid credentials (49)
LDAP Success
SQL Success

Figured that out. It was a permissions error. I had to chown ldap:ldap everything in ldap-data
so the only thing left is to figure out why tomcat hates me

hmm, strange, could please remove the user and add him again, if the "ldap_bind"-error still exists.

ok, what went to my mind:

    * did you also initialised your LDAP with the init_ldap.dif from /usr/share/open-xchange?
    * did you also created links from your ldap-schema to your groupware and webmail-directory?
    * did you include the ox-schema into your ldap-file?
    * you could try
    Code:
    ebuild /var/db/pkg/net-mail/open-xchange-0.8.1.2/open-xchange-0.8.1.2 config


and you could also increase your debug-output of ox.
in the file "/etc/open-xchange/groupware/system.properties" set the LOGLEVEL to 10
after restarting ox you should get much more information in your ox-logs.

please post them if it doesn't help.
Back to top
View user's profile Send private message
nife
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2003
Posts: 87

PostPosted: Wed Sep 07, 2005 10:51 pm    Post subject: Reply with quote

Thanks for the reply I edited my post during your reply i guess. hehe
I got the ldap stuff working. it was a simple permissions issue of the db files. so now that is fixed and I have that working but when I login I get a 404 error still.
Tomcat still doesn't see the war's even though I have tried a different jvm I have war's coppied into /usr/share/tomcat-5/server/webapps/ and /var/lib/tomcat-5/default/webapps
the tomcat manager page doesn't show either. though if I try to upload the war it says error
Code:

FAIL - War file "servlet.war" already exists on server


So it looks like /var/lib/tomcat-5/default/webapps is the correct location now something else is wrong... blah.

here is what I have in /var/lib/tomcat-5/default/webapps

Code:
castle webapps # ls -al
total 2648
drwxr-xr-x   7 root   root       280 Sep  7 18:46 .
drwxr-xr-x   3 tomcat tomcat     168 Sep  5 22:24 ..
-rw-r--r--   1 root   root         0 Sep  5 22:24 .keep
drwxr-xr-x   3 tomcat tomcat     248 Sep  5 22:24 ROOT
drwxr-xr-x  21 tomcat tomcat     592 Sep  5 22:24 jsp-examples
-rw-r--r--   1 tomcat tomcat 2004214 Sep  7 18:46 servlet.war
drwxr-xr-x   4 tomcat tomcat     320 Sep  5 22:24 servlets-examples
drwxr-xr-x   9 tomcat tomcat    1136 Sep  5 22:24 tomcat-docs
-rw-r--r--   1 tomcat tomcat  697980 Sep  7 18:46 umin.war
drwxr-xr-x   3 tomcat tomcat     168 Sep  5 22:24 webdav


Isn't there supposed to be a servlet and WEB-INF for all of those things ?? I can't find them
Back to top
View user's profile Send private message
nife
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2003
Posts: 87

PostPosted: Thu Sep 08, 2005 2:01 am    Post subject: Reply with quote

Well I finally got the war to install. It was a permissions issue AGAIN
hehe the webapps folder and the temp folder were owend by root and didn't allow writing I fixed that and they installed.

Now all is up and running.
Now how do I add Procmail to this ?

I desperatly need to have procmail
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Thu Sep 08, 2005 7:09 am    Post subject: Reply with quote

nife wrote:

Now how do I add Procmail to this ?

I desperatly need to have procmail

Fine,fine, now you should just emerge procmail.

The mail-server-part is quasi independend from ox. ox just access the mailboxes per IMAP and sends its mail per SMTP. So if your configuration is working with an imap/smtp-client like kmail, thunderbird, ... it should also work with ox.
If this doesn't help post your email-configuration.
Back to top
View user's profile Send private message
nife
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2003
Posts: 87

PostPosted: Thu Sep 08, 2005 3:48 pm    Post subject: Reply with quote

Boef wrote:
nife wrote:

Now how do I add Procmail to this ?

I desperatly need to have procmail

Fine,fine, now you should just emerge procmail.

The mail-server-part is quasi independend from ox. ox just access the mailboxes per IMAP and sends its mail per SMTP. So if your configuration is working with an imap/smtp-client like kmail, thunderbird, ... it should also work with ox.
If this doesn't help post your email-configuration.


Thanks man you have been awesome. I was just worried because its all virtual mailboxes and procmail will drop the mail in some folder. thanks again
Back to top
View user's profile Send private message
slaapkop
n00b
n00b


Joined: 04 Mar 2004
Posts: 66
Location: Nijmegen

PostPosted: Mon Oct 03, 2005 4:50 pm    Post subject: Reply with quote

Hello,

Great howto, keep up the good work!

I tried to follow the howto and get a OpenXchange server running on my gentoo install.
I came till the point:
Quote:
We're now at the stage where we can add our first user for Open-Xchange. This is the litmus test to see if everything we've done up to this point is correct. This is where it can go all right and give you a huge sense of satisfaction, or terribly wrong and leave you scratching your head for a while.


/usr/local/open-xchange/sbin/adduser_ox
--username=”john”
--passwd=”johnspassword”
--name=”john”
--sname=”smith”
--maildomain=”ox-domain.tld”
--ox_timezone=”EST”


Well the writer was right. About the scratching the head part.... :oops:

I tried to read as much about this subject as possible. Most of the time in this forum:
http://www.open-xchange.org/cgi-bin/simpleforum.cgi?fid=02&search

My error is the following when i try to add a user:

    TRUUS ~ # /usr/local/open-xchange/sbin/adduser_ox --username="pim" --passwd="password" --name="pim" --sname="jansen" --maildomain="localhost" --ox_timezone="Europe/Amsterdam"
    ldap_sasl_interactive_bind_s: Can't contact LDAP server (-1)
    LDAP Success
    SQL Success


My /var/log/messages, most of the time my best friend tells me nothing at this stage.

My (i think) relevant configs are:

/usr/local/open-xchange/etc/admintools.conf
Code:

#!/bin/sh
#
# (c) 2004-2100 ;)
# Author: cutmasta AT netline-is D0T de
#
# OX-SCRIPTS - CONFIGURATION PARAMETER :)
#
############## GENERAL CONFIG STUFF ###############
# Your Company Name
# To which Organisation new User belong!
ORGA="NIX"
# OXBASE
OXBASE=`grep -v '^#' /usr/local/open-xchange/etc/groupware/ldap.conf | grep -i BASE | head -n 1 | awk {'print $2'}`
# LDAP Server - deprecated in favor of LDAPURI
LDAPHOST=`grep -v '^#' /usr/local/open-xchange/etc/groupware/ldap.conf | grep -i HOST | head -n 1 | awk {'print $2'}`
# LDAP URI - supercedes LDAPHOST
LDAPURI=`awk '/^[Uu][Rr][Ii]/ {print $2; exit;}' /usr/local/open-xchange/etc/groupware/ldap.conf`
if [ -z "$LDAPURI" ] ; then
    LDAPURI="ldap://$LDAPHOST/"
fi
# LDAP Admin
BINDDN="cn=Manager,dc=mydomain,dc=nl"
# LDAP Admin Passwd
BINDPW="mypassword"
if [ -z "$BINDDN" -a -z "$BINDPW" ] ; then   # omit unused options
        LDAPCONN="-H $LDAPURI"    # typical for full Kerberos/LDAP
else
        # Note that the -x -should- be a last resort, not the default
        LDAPCONN="-H $LDAPURI -D $BINDDN -w $BINDPW"   # -x is deprecated
fi
# OX LDAP Leaf, where is the "OxObjects" leaf?
OX_LEAF="ou=OxObjects,$OXBASE"
# Default Language
DEFAULT_PREF_LANG="EN"
# Default mail is enabled
DEFAULT_MAIL_ENAB="OK"
# Default the user can send mail to the internet
DEFAULT_INET_MAIL="TRUE"
# Default days of displaying appointments
DEFAULT_OX_APP_DAYS=5
# Default days of displaying tasks
DEFAULT_OX_TASK_DAYS=5
# default the user can write in the global adressbook
DEFAULT_WRITE_GLOBAL_ADDR="TRUE"
# The used Tools - should work on most Systems!
LDAPADD_BIN="ldapadd -ZZ"
#LDAPADD_BIN="ldapadd"
LDAPDELETE_BIN="ldapdelete"
LDAPMODIFY_BIN="ldapmodify"
LDAPSEARCH_BIN="ldapsearch"
GREP_BIN="grep"
SED_BIN="sed"
EXPR_BIN="expr"
SORT_BIN="sort"
HEAD_BIN="head"
TAIL_BIN="tail"
AWK_BIN="awk"
SQL_BIN="psql"
##################################################

###### CONVERT ALL USERNAMES TO LOWERCASE #########
CASE_IGNORE="yes"
##################################################

#################### SQL Stuff #####################
DEFAULT_SQL_HOST="localhost"
DEFAULT_SQL_DB="openexchange"
DEFAULT_SQL_USER="open-xchange"
DEFAULT_SQL_PASS="oxen"

# Default Table where we store the Rights
RIGHTS_TABLE="usr_general_rights"
# Default Template Table where the template is stored!
TEMPLATE_TABLE="sys_gen_rights_template"
# Default Template for creating Users.
# Must exist in the DB
DEFAULT_TEMPLATE_NAME="default_template"
####################################################

####################### LDAP #######################
# Where are the OX Users
USER_BASEDN="ou=Users,$OX_LEAF"
# Where are the OX Groups
GROUP_BASEDN="ou=Groups,$OX_LEAF"
# Where are the OX Resources
RESOURCES_BASEDN="ou=Resources,ou=ResourceObjects,$OX_LEAF"
# Where are the OX Resource Groups
RESOURCE_GROUPS_BASEDN="ou=ResourceGroups,ou=ResourceObjects,$OX_LEAF"
# Where is the Global Adressbook
GLOBAL_ADDRESSBOOKDN="o=AddressBook,$OX_LEAF"
# where are the adressbook admins
GLOBAL_ADDRESSBOOK_ADMINSDN="cn=AddressAdmins,$GLOBAL_ADDRESSBOOKDN"
# TEMPORARY FILE
TMPDIF="/usr/local/open-xchange/var/temporary_ldap_scripts.ldif"
####################################################

####################################################

HOME_DIR="/home/"
DEFAULT_USR_SHELL="/bin/bash"

SHADOW_EXPIRE=0
SHADOW_MIN=0
SHADOW_MAX=9999
SHADOW_WARN=7

STD_GID=500
MIN_UID=501
MIN_GID=500
####################################################




my /etc/openldap/slapd.conf

Code:

# $OpenLDAP: pkg/ldap/servers/slapd/slapd.conf,v 1.23.2.8 2003/05/24 23:19:14 kurt Exp $
#
# See slapd.conf(5) for details on configuration options.
# This file should NOT be world readable.
#

include /etc/openldap/schema/core.schema
include /etc/openldap/schema/cosine.schema
include /etc/openldap/schema/inetorgperson.schema
include /etc/openldap/schema/openldap.schema
include /etc/openldap/schema/misc.schema
include /etc/openldap/schema/nis.schema
include /etc/openldap/schema/openxchange.schema


allow bind_v2

#backend bdb
database bdb



password-hash {CRYPT}
# Define global ACLs to disable default read access.

# Do not enable referrals until AFTER you have a working directory
# service AND an understanding of referrals.
#referral       ldap://root.openldap.org

pidfile         /var/run/openldap/slapd.pid
argsfile        /var/run/openldap/slapd.args

# Load dynamic backend modules:
# modulepath    /usr/lib/openldap/openldap
# moduleload    back_bdb.la
# moduleload    back_ldap.la
# moduleload    back_ldbm.la
# moduleload    back_passwd.la
# moduleload    back_shell.la

# Sample security restrictions
#       Require integrity protection (prevent hijacking)
#       Require 112-bit (3DES or better) encryption for updates
#       Require 63-bit encryption for simple bind
# security ssf=1 update_ssf=112 simple_bind=64

# Sample access control policy:
#       Root DSE: allow anyone to read it
#       Subschema (sub)entry DSE: allow anyone to read it
#       Other DSEs:
#               Allow self write access
#               Allow authenticated users read access
#               Allow anonymous users to authenticate
#       Directives needed to implement policy:
# access to dn.base="" by * read
# access to dn.base="cn=Subschema" by * read
# access to *
#       by self write
#       by users read
#       by anonymous auth
#
# if no access controls are present, the default policy is:
#       Allow read by all
#
# rootdn can always write!

#######################################################################
# ldbm database definitions
#######################################################################


checkpoint      32      30 # <kbyte> <min>
suffix          "dc=mydomain,dc=nl"
rootdn          "cn=Manager,dc=mydomain,dc=nl"
# Cleartext passwords, especially for the rootdn, should
# be avoid.  See slappasswd(8) and slapd.conf(5) for details.
# Use of strong authentication encouraged.
rootpw          {CRYPT}CrypTedPa2w0rD
# The database directory MUST exist prior to running slapd AND
# should only be accessible by the slapd and slap tools.
# Mode 700 recommended.
directory       /var/lib/openldap-data
# Indices to maintain


#loglevel=10


index   objectClass                     pres,eq
index   gidNumber,memberUid             eq
index   uid,mailEnabled,cn,sn,givenname,lnetMailAccess,alias,loginDestination   eq,sub


my /etc/openldap/ldap.conf

Code:

#
# LDAP Defaults
#

# See ldap.conf(5) for details
# This file should be world readable but not world writable.

#BASE   dc=example, dc=com
#URI    ldap://ldap.example.com ldap://ldap-master.example.com:666

#SIZELIMIT      12
#TIMELIMIT      15
#DEREF          never

BASE dc=mydomain,dc=nl
URI ldap://mydomain.nl
HOST mydomain.nl


my /etc/saslauthd.conf

Code:

ldap_servers: ldap://mydomain.nl:389/
ldap_bind_dn: cn=Manager,dc=mydomain,dc=nl
#ldap_bind_pw: ldapsecretpassword
ldap_bind_pw:mypassword
ldap_search_base: dc=mydomain,dc=nl


I don't know why but when i try to restart slapd a get the red!!

    TRUUS ~ # /etc/init.d/slapd restart
    * Caching service dependencies ... [ ok ]
    * Stopping ldap-server ... [ !! ]


So my question is, I 'm a doing something stupid? missing out something?
I did a lot of tweaking, just some stuf i read in the other forum..
If i need to give you some moore info please let me know.........

Thanks for helping me out here........


p.s Sorry for my poor English....
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Mon Oct 03, 2005 6:10 pm    Post subject: Reply with quote

Hi, it sounds like a ldap problem ;)

Ok, first check your logfiles.

Did you upgrade your ldap from 2.1 to 2.2?

What you can, is ldap running on the same machine like ox - than you can use the following lines in your /etc/openldap/ldap.conf.
Code:

URI ldap://127.0.0.1

But you also have to setup ox again.

An other nice solution ;) ox is now in portage currently masked but realy nice. It's a promise.

Hope that helps you a little bit.
Back to top
View user's profile Send private message
slaapkop
n00b
n00b


Joined: 04 Mar 2004
Posts: 66
Location: Nijmegen

PostPosted: Mon Oct 03, 2005 6:31 pm    Post subject: Reply with quote

Hi,


Thanks for your fast reply.
I did'nt upgrade from 2.1 to 2.2. But i might did an emerge -C openldap.
ldap and OX are running on the same machine.
And about the log files for ldap, where can i find it? And is there a way to setup a higher loglevel?
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Mon Oct 03, 2005 8:27 pm    Post subject: Reply with quote

Ok, are you using ldap with an other software (samba or so)?
Did you change the kind of backend?

The good thing for 2.2 is you've got aci enabled by default and it shouldn't make that much problems.
But be carefull when updating it like stated in the ebuild.

I've got my logs in "/var/log/syslog".
You can also try to get more information from ox.

/etc/open-xchange/groupware/system.properties
and change the LOGLEVEL to 10
also /etc/open-xchange/webmail/system.properties

I hope that helps you.
Back to top
View user's profile Send private message
slaapkop
n00b
n00b


Joined: 04 Mar 2004
Posts: 66
Location: Nijmegen

PostPosted: Tue Oct 04, 2005 8:26 am    Post subject: Reply with quote

Hi, no i'm using ldap only for OX. Maybe in the future for samba...
The kind of backend, you meen the

#backend bdb
database bdb

.. part in slapd.conf?

I might changed that, i changed a lot while reading other forums, but not realy knowing wat i was doing... :(
My log are in /var/log/messages, but nothing usefull is comming in here concerning ldap. I maybe thought there was a different location for it somewhere...

And my openxhange folder is in /var/local/openxchange..... is that a problem?

I will check the OX logs as well, but i think it is a ldap problem, or could it be a problem using OX and ldap.
And could it be a problem reinstalling ldap?

The problem i get when adding a user with the
    # /usr/local/open-xchange/sbin/adduser_ox
part.
And i get the error:
    ldap_sasl_interactive_bind_s: Can't contact LDAP server (-1)
    LDAP Success
    SQL Success


Where do a look for this problem, i mean wich log file...

I try it again tonight after work.....
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Tue Oct 04, 2005 9:07 am    Post subject: Reply with quote

Hi =)
One importand thing, is mydomain.nl resolveable!!! ?
best if you do a ping at mydomain.nl and it should ping your ldap-server (localhost).
if not add the informations to /etc/hosts or your dns server


slaapkop wrote:
Hi, no i'm using ldap only for OX. Maybe in the future for samba...
The kind of backend, you meen the

#backend bdb
database bdb

.. part in slapd.conf?

I might changed that, i changed a lot while reading other forums, but not realy knowing wat i was doing... :(
My log are in /var/log/messages, but nothing usefull is comming in here concerning ldap. I maybe thought there was a different location for it somewhere...

If would suggest you to save your ldap data with slapcat, unmerging openldap, move the openldap dirs under /var/lib to a different location and also move the /etc/openldap directory to a new location.
Emerge openldap again and try to setup it again, if you want i can help you.


slaapkop wrote:

And my openxhange folder is in /var/local/openxchange..... is that a problem?

No, this isn't a problem, i would suggest you to use the ebuild in portage it is masked but we are working hardly on it =).

I hope that helps you.
Back to top
View user's profile Send private message
slaapkop
n00b
n00b


Joined: 04 Mar 2004
Posts: 66
Location: Nijmegen

PostPosted: Tue Oct 04, 2005 1:41 pm    Post subject: Reply with quote

Hi,

Yes my domain is resolvable and for my ldap server, you mean the domain where the ldap server is running on? In my case the same so that should be good.

I will try to backup my ldap date with slapcat. reemerge openldap stuff..
And i delete the usr/var/openxchange directory... And then use the ebuild.

I do that after work today.

Thanks for your help!!!
Back to top
View user's profile Send private message
slaapkop
n00b
n00b


Joined: 04 Mar 2004
Posts: 66
Location: Nijmegen

PostPosted: Tue Oct 04, 2005 4:14 pm    Post subject: Reply with quote

Hello,

I copied the /var/lib/opendlap* and /etc/openldap to my homedir.
Then i stopped the slapd service --> /etc/init.d/slapd zap (because the stop funtion did'n work).

But after that when i try to use slapcat it hangs, nothing in any of the logs...

    TRUUS etc # slapcat > /home/pim/opendlapTemp/temp.ldif




What can i do to fix this?
And for the deleting of my already installed verion of openxchange, is it correct to do a rm -r /var/local/openxchange.?

Thanks..
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Tue Oct 04, 2005 5:31 pm    Post subject: Reply with quote

Hi guys,

I'm also trying to install Open-Xchange on my Gentoo-Root-Box. I'm using the hard-masked 0.8.1.3-ebuild-script from the offical portage-repository (http://packages.gentoo.org/search/?sstring=open-xchange). Currently I'm having huge problems to get the OpenLDAP-Stuff to work. The other stuff is working (at least I think so).

Whenever I try to start slapd my /var/log/messages says
Code:

Oct  4 19:43:12 thurisaz slapd[6784]: sql_select option missing
Oct  4 19:43:12 thurisaz slapd[6784]: auxpropfunc error no mechanism available
Oct  4 19:43:12 thurisaz slapd[6784]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
Oct  4 19:43:12 thurisaz slapd[6784]: auxpropfunc error invalid parameter supplied
Oct  4 19:43:12 thurisaz slapd[6784]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: ldapdb
Oct  4 19:43:12 thurisaz slapd[6784]: bdb_db_init: Initializing BDB database
Oct  4 19:43:12 thurisaz slapd[6785]: slapd starting


I also used the search-function where I found the hint (https://forums.gentoo.org/viewtopic-t-151004-highlight-sqlselect+openldap.html) to emerge cyrus-sasl without the MySQL-useflag. This did'nt help :? Instead of this ugly "sql_select option missing" I got an ugly "Mysql not supported" error. I also tried unstable OpenLDAP and cyrus-sasl ebuild but nothing helped.

I also tried the Cyrus and SASL and OpenLDAP-configuration like it is descriped in http://www.mikefetherston.ca/OX/html/index.html but I'm always getting these sql_select- or MySQL-not-supported-errors

What the hell am I doing wrong?? :cry:

P.S: MySQL and Postgresql are installed on my system, the system itself is 100% up to date (Kernel 2.6.12, newest baselayout etc).
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Tue Oct 04, 2005 6:02 pm    Post subject: Reply with quote

Okay, I simply tried the /usr/sbin/adduser_ox, /usr/sbin/addusertogroup_ox and /usr/sbin/addgroup_ox and they seem to work. :D

Nevertheless I can not login, because I get the following error-message on the login-screen after pressing the submit-button:
Quote:
Can not build up Socket!
SessionD running?


This seems to be a certificate-problem...

Code:
Oct 04 20:08:49 localhost openexchange: oxsessiond init (localhost:33333) objectstream=false
Oct 04 20:08:49 localhost openexchange: INTERNAL TLS Support: ON
error loading keyfile: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
Oct 04 20:08:50 localhost openexchange: oxsessiond init (localhost:33335) objectstream=true
error loading keyfile: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch


what can I do to solve this?


Last edited by thurisaz on Tue Oct 04, 2005 6:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Tue Oct 04, 2005 6:08 pm    Post subject: Reply with quote

Currently the problem is the SSL stuff.

Please reemerge ox

Code:
USE="-SSL" emerge open-xchange
.

Because this feature is somehow broken (this feature encrypts communication between the backend components).

But don't worry you are able to securly connect to ox when you enabled ssl in apache.
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Tue Oct 04, 2005 6:12 pm    Post subject: Reply with quote

okay, thanks, I'll try it :D
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Tue Oct 04, 2005 6:15 pm    Post subject: Reply with quote

slaapkop wrote:
Hello,
But after that when i try to use slapcat it hangs, nothing in any of the logs...
What can i do to fix this?

Your hardware is okay?
Check if the openldap directories under /var/lib are ldap:ldap owned.

slaapkop wrote:

And for the deleting of my already installed verion of openxchange, is it correct to do a rm -r /var/local/openxchange.?

yes, should be.
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Tue Oct 04, 2005 6:22 pm    Post subject: Reply with quote

YAHOO!!! NOW IT WORKS!!! THANKS A LOT!!!

The Open-Xchange-Installation has costed me one full day of work, but I'm quite sure that Open-Xchange is it worth :P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 32, 33, 34 ... 37, 38, 39  Next
Page 33 of 39

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum