Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Open-Xchange on Gentoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 33, 34, 35 ... 37, 38, 39  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
slaapkop
n00b
n00b


Joined: 04 Mar 2004
Posts: 66
Location: Nijmegen

PostPosted: Tue Oct 04, 2005 6:32 pm    Post subject: Reply with quote

Hi, i'm trying to download an ebuild.
Maybe a stupid question, but where can i find this ebuild?
I find this page beacuase of the person beforme me:

http://packages.gentoo.org/ebuilds/?open-xchange-0.8.1.3

But i cannot find the ebuild overhere??


this link isn't working for me:

http://gentoo-wiki.com/HOWTO_Open-Xchange
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Tue Oct 04, 2005 6:46 pm    Post subject: Reply with quote

Oh, yes you have to unmask the package currently it is masked.

insert "www-apps/open-xchange" into your "/etc/portage/package.unmask"

If it doesn't function you probably have also insert the entry in /etc/portage/package.keywords.

Hope that helps
Back to top
View user's profile Send private message
slaapkop
n00b
n00b


Joined: 04 Mar 2004
Posts: 66
Location: Nijmegen

PostPosted: Tue Oct 04, 2005 6:57 pm    Post subject: Reply with quote

    TRUUS portage # cat /etc/portage/package.unmask
    www-apps/open-xchange
    TRUUS portage # cat /etc/portage/package.keywords
    dev-java/sun-jdk ~x86
    www-apps/open-xchange
    TRUUS portage # emerge -p open-xchange

    These are the packages that I would merge, in order:

    Calculating dependencies
    emerge: there are no ebuilds to satisfy "open-xchange".

    TRUUS portage #


Do i have to add something to my /etc/make.conf or so? Or update anything to tell the system a changed anything?

Man i don't get it... :roll:
Back to top
View user's profile Send private message
slaapkop
n00b
n00b


Joined: 04 Mar 2004
Posts: 66
Location: Nijmegen

PostPosted: Tue Oct 04, 2005 7:01 pm    Post subject: Reply with quote

Might be a
Quote:
emerge sync
..........
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Wed Oct 05, 2005 9:01 am    Post subject: Reply with quote

One problem is still there: I can not use the webmail-client. Whenever I start the webmail-web-interface I the following error-message

Code:
Der aktuelle Befehl war nicht erfolgreich. Der Mail-Server antwortete:
Exception in FolderSettings/loadFolder
An unknown error has occurred! Please check error message below.

Details: java.lang.NullPointerException


How can I configure it?

/var/log/open-xchange/webmail.log says:

Code:

Oct 05 10:54:17 localhost openexchange: Netline Application Server [NAS 5.0]
Oct 05 10:54:17 localhost openexchange: (c) Netline Internet Service GmbH
Oct 05 10:54:17 [mydomain] openexchange: Linux i386 2.6.12-gentoo-r10
Oct 05 10:54:17 [mydomain] openexchange: 1.5.0_05-b05
Oct 05 10:54:17 [mydomain] openexchange: VM Total Memory       : 20,352 KB
Oct 05 10:54:17 [mydomain] openexchange: VM Free Memory        : 19,860 KB
Oct 05 10:54:17 [mydomain] openexchange: VM Used Memory        : 492 KB
Oct 05 10:54:17 [mydomain] openexchange: System version        : OPEN-XCHANGE [0.8.1-3] initializing ...
Oct 05 10:54:18 [mydomain] openexchange: Using path: /usr/
Oct 05 10:54:18 [mydomain] openexchange: Loglevel set to: 5
Oct 05 10:54:18 [mydomain] openexchange: No LDAP Addressbook Config-file found!
Oct 05 10:54:18 [mydomain] openexchange: Setting timeout           : 60000
Oct 05 10:54:18 [mydomain] openexchange: Setting start_server      : 1
Oct 05 10:54:18 [mydomain] openexchange: Setting thread_pool       : 0
Oct 05 10:54:18 [mydomain] openexchange: Setting db_pool           : 5
Oct 05 10:54:18 [mydomain] openexchange: Allow non pooled threads  : true
Oct 05 10:54:18 [mydomain] openexchange: Setting upload directory  : /tmp/
Oct 05 10:54:19 [mydomain] openexchange: INFO: DefaultEncoding : UTF-8
Oct 05 10:54:19 [mydomain] openexchange: INFO: UserCanSelectEncoding : false
Oct 05 10:54:19 [mydomain] openexchange: INFO: UseServerSearch : false
Oct 05 10:54:19 [mydomain] openexchange: INFO: UseServerSort   : false
Oct 05 10:54:19 [mydomain] openexchange: INFO: DateFormat[DE]  : EEE dd.MM.yyyy HH:mm
Oct 05 10:54:19 [mydomain] openexchange: INFO: DateFormat[EN]  : MMM dd, yyyy hh:mm aaa
Oct 05 10:54:19 [mydomain] openexchange: INFO: Use Html-Editor : true
Oct 05 10:54:19 [mydomain] openexchange: INFO: Mail list style : SEARCH:SCROLL:SORT:LIST:MOVECOPY:DELETE
Oct 05 10:54:19 [mydomain] openexchange: INFO: Max. entries    : 500
Oct 05 10:54:19 [mydomain] openexchange: INFO: Entries on page : 10,15,20,25,50,75,100,125,150,175,200,250,500
Oct 05 10:54:19 [mydomain] openexchange: INFO: Quoted Colors   : #666666
Oct 05 10:54:19 [mydomain] openexchange: INFO: Disp. size lim. : 1000000 bytes
Oct 05 10:54:19 [mydomain] openexchange: INFO: Autocomplete max. Entries : 25
Oct 05 10:54:19 [mydomain] openexchange: INFO: Quota Warn      : 90%
Oct 05 10:54:19 [mydomain] openexchange: INFO: Hide Empty Folder Button : false
Oct 05 10:54:19 [mydomain] openexchange: INFO: Content Type Selection Filter : application/\\S*
Oct 05 10:54:19 [mydomain] openexchange: INFO: Readed webmail.properties: default.sent=INBOX/Sent
Oct 05 10:54:19 [mydomain] openexchange: INFO: Readed webmail.properties: default.trash=INBOX/Trash
Oct 05 10:54:19 [mydomain] openexchange: INFO: Readed webmail.properties: default.drafts=INBOX/Drafts
Oct 05 10:54:19 [mydomain] openexchange: INFO: Readed webmail.properties: default.spam=INBOX/Spam
Oct 05 10:54:19 [mydomain] openexchange: INFO: Readed webmail.properties: default.folder.autocreate=false
------------------------------------------------------------------
Oct 05 10:54:19 - system - 0.8.1-3
System in SpellCheck/loadSpellCheckParameter
Unable to execute: ispell -dgerman -a -P -H -Tlatin1
Please check your configuration and that ispell can be executed by WebMail.
Details: null
------------------------------------------------------------------
Oct 05 10:54:19 [mydomain] openexchange: INTERNAL TLS Support: OFF
Oct 05 10:54:19 [mydomain] openexchange: bind to port 4445
Oct 05 10:54:19 [mydomain] openexchange: upload bind to port 4447
 done
------------------------------------------------------------------
Oct 05 10:54:29 - thurisaz - 0.8.1-3
Exception in FolderSettings/loadFolder
Unable to get folder list.
java.lang.NullPointerException
        at com.openexchange.webmail.FolderSettings.dumpFolder(FolderSettings.java:328)
        at com.openexchange.webmail.FolderSettings.loadFolder(FolderSettings.java:240)
        at com.openexchange.webmail.Management.onBeforeHtmlLoad(Management.java:347)
        at com.openexchange.thread.ComfireThread.validateSession(ComfireThread.java:407)
        at com.openexchange.thread.ComfireThread.run(ComfireThread.java:162)
        at java.lang.Thread.run(Thread.java:595)
------------------------------------------------------------------


According to http://www.mikefetherston.ca/OX/html/#23 I need postfix for Open-Xchange. Nevertheless I'm also running a BugZilla-Server on my root-server which needs sendmail - could this be a problem?

EDIT: okay, I'll try de-install sendmail and install postfix because BugZilla seems to be postfix-compatible

EDIT 2
great, BugZilla seems to work with postfix, nevertheless I still have the Open-Xchange problem that there are no folders in my webmail-client. I have user.default.folder.autocreate=true in my /etc/open-xchange/webmail/webmail.properties but it seems so that there are no auto-created-folders. Can I do this manually? Also when I add new users I have the same problem:
Code:
Exception in FolderSettings/loadFolder
Unable to get folder list.
java.lang.NullPointerException
        at com.openexchange.webmail.FolderSettings.dumpFolder(FolderSettings.java:328)
        at com.openexchange.webmail.FolderSettings.loadFolder(FolderSettings.java:240)
        at com.openexchange.webmail.Management.onBeforeHtmlLoad(Management.java:347)
        at com.openexchange.thread.ComfireThread.validateSession(ComfireThread.java:407)
        at com.openexchange.thread.ComfireThread.run(ComfireThread.java:162)
        at java.lang.Thread.run(Thread.java:595)
------------------------------------------------------------------
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Oct 05, 2005 10:58 am    Post subject: Reply with quote

Theoretically you should be able to use what ever you want.

OX just needs an SMTP server for sending emails and an imap for receiving. So what whatever you use as "email backend" it should function.

Increase your loglevel in /etc/open-xchange/{webmail|groupware}/system.properties to 10.

You can change the email settings in /etc/open-xchange/webmail/webmail.properties this should help you.
You also have to pay attention whether you have imap enabled or just imaps.
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Wed Oct 05, 2005 11:09 am    Post subject: Reply with quote

Code:
Oct 05 13:10:31 myhost openexchange: DEBUG: Pushing database connection org.postgresql.jdbc3.Jdbc3Connection@e45076
Oct 05 13:10:31 myhost openexchange: INTERNAL TLS Support: OFF
Oct 05 13:10:31 myhost openexchange: DEBUG: CLL -> com.openexchange.webmail.UserLogout
Oct 05 13:10:31 myhost openexchange: bind to port 4445
Oct 05 13:10:31 myhost openexchange: upload bind to port 4447
 done
Oct 05 13:10:37 myhost openexchange: DEBUG: Create new ComfireThread ComfireThread 0
Oct 05 13:10:37 myhost openexchange: DEBUG: Run ComfireThread ComfireThread 0
Oct 05 13:10:37 myhost openexchange: DEBUG: Re-use database connection org.postgresql.jdbc3.Jdbc3Connection@e45076
Oct 05 13:10:37 myhost openexchange: Connect to sessiond server: localhost:33333
Oct 05 13:10:37 myhost openexchange: DEBUG: NEWSESSION: uid=xxx, lang=DE, remoteip=62.143.132.93, id=c3764bd58ed6536b7e0e2b269e18a2b8, response=*** :-)
Oct 05 13:10:37 myhost openexchange: DEBUG: Using webmail <-> /servlet/webmail
Oct 05 13:10:37 myhost openexchange: DEBUG: LOGIN: uid=xxx: moduleRights=addr_r cont_r bookm_r data_r task_r doc_r proj_r knowl_r forum_n pin_r webmail
Oct 05 13:10:37 myhost openexchange: DEBUG: LOGIN: uid=xxx, imap=localhost - port=143, smtp=localhost - port= 25, MAILDOMAIN=myhost
Oct 05 13:10:37 myhost openexchange: DEBUG: LOGIN: uid=xxx: User can change mail address=true
Oct 05 13:10:38 myhost openexchange: DEBUG: IMAP: Open connection: CONNECTIONS=1
Oct 05 13:10:38 myhost openexchange: DEBUG: FOLDER : Create default folder ...........=false
Oct 05 13:10:38 myhost openexchange: DEBUG: FOLDER : Create default folder ............=false
Oct 05 13:10:38 myhost openexchange: DEBUG: FOLDER : Create default folder .............=false
Oct 05 13:10:38 myhost openexchange: DEBUG: FOLDER : Create default folder ...............=false
------------------------------------------------------------------
Oct 05 13:10:38 - [xxx] - 0.8.1-3
Exception in FolderSettings/loadFolder
Unable to get folder list.
java.lang.NullPointerException
        at com.openexchange.webmail.FolderSettings.dumpFolder(FolderSettings.java:328)
        at com.openexchange.webmail.FolderSettings.loadFolder(FolderSettings.java:240)
        at com.openexchange.webmail.Management.onBeforeHtmlLoad(Management.java:347)
        at com.openexchange.thread.ComfireThread.validateSession(ComfireThread.java:407)
        at com.openexchange.thread.ComfireThread.run(ComfireThread.java:162)
        at java.lang.Thread.run(Thread.java:595)
------------------------------------------------------------------
Oct 05 13:10:38 myhost openexchange: DEBUG: IMAP: Release connection: CONNECTIONS=0
Oct 05 13:10:38 myhost openexchange: DEBUG: Using non-cached version DE/loadmain
Oct 05 13:10:38 myhost openexchange: DEBUG: Pushing database connection org.postgresql.jdbc3.Jdbc3Connection@e45076
Oct 05 13:10:38 myhost openexchange: DEBUG: Destroy ComfireThread ComfireThread 0
Oct 05 13:10:38 myhost openexchange: DEBUG: Create new ComfireThread ComfireThread 1
Oct 05 13:10:38 myhost openexchange: DEBUG: Run ComfireThread ComfireThread 1
Oct 05 13:10:38 myhost openexchange: DEBUG: Using non-cached version DE/main
Oct 05 13:10:38 myhost openexchange: DEBUG: Create new ComfireThread ComfireThread 2
Oct 05 13:10:38 myhost openexchange: DEBUG: Destroy ComfireThread ComfireThread 1
Oct 05 13:10:38 myhost openexchange: DEBUG: Create new ComfireThread ComfireThread 3
Oct 05 13:10:38 myhost openexchange: DEBUG: Run ComfireThread ComfireThread 2
Oct 05 13:10:38 myhost openexchange: DEBUG: Using non-cached version DE/top
Oct 05 13:10:38 myhost openexchange: DEBUG: Destroy ComfireThread ComfireThread 2
Oct 05 13:10:38 myhost openexchange: DEBUG: Run ComfireThread ComfireThread 3
Oct 05 13:10:38 myhost openexchange: Connect to sessiond server: localhost:33333
Oct 05 13:10:38 myhost openexchange: DEBUG: PINGSESSION: uid=xxx, id=c3764bd58ed6536b7e0e2b269e18a2b8, response=OK: done
Oct 05 13:10:38 myhost openexchange: DEBUG: Using non-cached version DE/left_top
Oct 05 13:10:38 myhost openexchange: DEBUG: Destroy ComfireThread ComfireThread 3


Last edited by thurisaz on Wed Oct 05, 2005 11:22 am; edited 1 time in total
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Wed Oct 05, 2005 11:14 am    Post subject: Reply with quote

Why does the log tell me
Code:
Oct 05 13:10:38 thurisaz.org openexchange: DEBUG: FOLDER : Create default folder ...........=false
Oct 05 13:10:38 thurisaz.org openexchange: DEBUG: FOLDER : Create default folder ............=false
Oct 05 13:10:38 thurisaz.org openexchange: DEBUG: FOLDER : Create default folder .............=false
Oct 05 13:10:38 thurisaz.org openexchange: DEBUG: FOLDER : Create default folder ...............=false

?

In my webmail.property I have
Code:
# Should the default folder be created when they not exists
user.default.folder.autocreate=true
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Wed Oct 05, 2005 11:20 am    Post subject: Reply with quote

This is my hole webmail.properties-file

Code:
# Folder mapping which will be used when a user login the first time
user.default.folder.sent=INBOX/Sent
user.default.folder.trash=INBOX/Trash
user.default.folder.drafts=INBOX/Drafts
user.default.folder.spam=INBOX/Spam


# Should the default folder be created when they not exists
user.default.folder.autocreate=true

# JavaMail property settings. Please take a look to the JavaMail API Specification
# for detailed informations about all available settings.
#mail.debug=true
#mail.smtp.auth=true

# Comment out the following lines if you want to use IMAPS and/or SMTPS
# Detailed informations about the property settings can be found at the
# JavaMail API Documentation.
#mail.imap.socketFactory.class=com.openexchange.tools.ssl.TrustAllSSLSocketFactory
#mail.imap.socketFactory.port=993
#mail.imap.socketFactory.fallback=false
#mail.smtp.starttls.enable=true
#mail.smtp.socketFactory.class=com.openexchange.tools.ssl.TrustAllSSLSocketFactory
#mail.smtp.socketFactory.port=465
#mail.smtp.socketFactory.fallback=false


mail.imap.allowreadonlyselect=true
mail.mime.encodeeol.strict=true
mail.mime.decodetext.strict=false


EDIT

I have just enabled the javamail-debug and there I get some interesting additional informations:
Code:
DEBUG: JavaMail version 1.3.1
DEBUG: java.io.FileNotFoundException: /opt/sun-jdk-1.5.0.05/jre/lib/javamail.providers (No such file or directory)
DEBUG: !anyLoaded


maybe I should downlrade to java 1.4 again...
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Oct 05, 2005 11:44 am    Post subject: Reply with quote

Which imap server do you use?

The javamail.providers errors should not be a problem.

Downgrade to 1.4 could be a solution.
Some of the dependencies couldn't get compiled with jsdk 1.5.
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Wed Oct 05, 2005 12:06 pm    Post subject: Reply with quote

okay, now I have downgraded to 1.4 and re-emerged all java-stuff which had been compiled with 1.5 (at least I hope so). CUrrently I'm a little bit unsettled because I upgrated jdbc3-postgresql-7.4.5 to jdbc3-postgresql-8.0_p312 and I'm not sure whether this works with open-xchange.

Now the javamail.providers-error is gone
Code:
DEBUG: successfully loaded resource: /META-INF/javamail.default.providers

nevertheless the FolderSettings/loadFolder-error is still there:

Code:
DEBUG: not loading resource: /META-INF/javamail.address.map
DEBUG: java.io.FileNotFoundException: /opt/sun-jdk-1.4.2.09/jre/lib/javamail.address.map (No such file or directory)
DEBUG: getProvider() returning javax.mail.Provider[STORE,imap,com.sun.mail.imap.IMAPStore,Sun Microsystems, Inc]
DEBUG: mail.imap.fetchsize: 16384
* OK mydomain Cyrus IMAP4 v2.2.12-Gentoo server ready
A0 CAPABILITY
* CAPABILITY IMAP4 IMAP4rev1 ACL QUOTA LITERAL+ MAILBOX-REFERRALS NAMESPACE UIDPLUS ID NO_ATOMIC_RENAME UNSELECT CHILDREN MULTIAPPEND BINARY SORT THREAD=ORDEREDSUBJECT THREAD=REFERENCES ANNOTATEMORE IDLE STARTTLS AUTH=GSSAPI AUTH=CRAM-MD5 AUTH=DIGEST-MD5 AUTH=NTLM SASL-IR LISTEXT LIST-SUBSCRIBED X-NETSCAPE
A0 OK Completed
A1 LOGIN USER MYHIDDENPASS
A1 OK User logged in
Oct 05 14:01:11 mydomain openexchange: DEBUG: IMAP: Open connection: CONNECTIONS=1
A2 LIST "" INBOX
A2 OK Completed (0.000 secs 1 calls)
A3 LIST "" ..........
A3 OK Completed (0.000 secs 1 calls)
A4 CREATE ..........
A4 NO Invalid mailbox name
Oct 05 14:01:11 mydomain openexchange: DEBUG: FOLDER : Create default folder ..........=false
A5 LIST "" ..........
A5 OK Completed (0.000 secs 1 calls)
A6 LIST "" ...........
A6 OK Completed (0.000 secs 1 calls)
A7 CREATE ...........
A7 NO Invalid mailbox name
Oct 05 14:01:11 mydomain openexchange: DEBUG: FOLDER : Create default folder ...........=false
A8 LIST "" ...........
A8 OK Completed (0.000 secs 1 calls)
A9 LIST "" ............
A9 OK Completed (0.000 secs 1 calls)
A10 CREATE ............
A10 NO Invalid mailbox name
Oct 05 14:01:11 mydomain openexchange: DEBUG: FOLDER : Create default folder ............=false
A11 LIST "" ............
A11 OK Completed (0.000 secs 1 calls)
A12 LIST "" ..........
A12 OK Completed (0.000 secs 1 calls)
A13 CREATE ..........
A13 NO Invalid mailbox name
Oct 05 14:01:11 mydomain openexchange: DEBUG: FOLDER : Create default folder ..........=false
A14 LIST "" ..........
A14 OK Completed (0.000 secs 1 calls)
A15 LSUB "" "%"
A15 OK Completed (0.010 secs 1 calls)
A16 GETQUOTAROOT INBOX
A16 NO Mailbox does not exist


And I have a new " java.io.FileNotFoundException: /opt/sun-jdk-1.4.2.09/jre/lib/javamail.address.map"-error.

I'm note qute sure which IMAP-Server I use, I think it is net-mail/cyrus-imapd-2.2.12


Last edited by thurisaz on Wed Oct 05, 2005 12:08 pm; edited 2 times in total
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Wed Oct 05, 2005 12:07 pm    Post subject: Reply with quote

Why does the log say "Invalid mailbox name"?
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Oct 05, 2005 12:21 pm    Post subject: Reply with quote

invalid mailboxname? the userid and password you use to login into ox is also used for authentication against your imap server.
you should asure that the mailbox of the user exists.
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Wed Oct 05, 2005 12:52 pm    Post subject: Reply with quote

*hui* after emerging and re-emerging stable and unstable ebuilds of cyrus-imapd and re-reading the manual I simply did an

Code:
myhost ~ # cyradm --user cyrus localhost
Password:
localhost> cm user.mynewuser
localhost>


and it worked :P

Thanks A LOT (!!!) for your support Dark_Hunter :D
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Wed Oct 05, 2005 2:39 pm    Post subject: Reply with quote

Appendix
Here I will post some observations which I made or which I will make in the future during the use of Open-Xchange

    It seems so, that the current Version of Open-Xchange is NOT WORKING with >=dev-java/jdbc3-postgresql-8.0 so you better put this in your /etc/portage/package.mask

    During Open-Xchange runs it it tries to access user-setting-files under /var/open-xchange/settings/intranet/myuser. After the login/logout the log-file then complains about the file /var/open-xchange/settings/intranet/myuser which does not exist. If you create it by hand and add the correct permissions the error messages are gone and the file will be used

    ... more to come (I'm quite sure about it ;) )
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Oct 05, 2005 3:36 pm    Post subject: Reply with quote

thurisaz wrote:
Appendix
Here I will post some observations which I made or which I will make in the future during the use of Open-Xchange

    It seems so, that the current Version of Open-Xchange is NOT WORKING with >=dev-java/jdbc3-postgresql-8.0 so you better put this in your /etc/portage/package.mask

Yes, the date format is somehow changed.

thurisaz wrote:

During Open-Xchange runs it it tries to access user-setting-files under /var/open-xchange/settings/intranet/myuser. After the login/logout the log-file then complains about the file /var/open-xchange/settings/intranet/myuser which does not exist. If you create it by hand and add the correct permissions the error messages are gone and the file will be used
... more to come (I'm quite sure about it ;) )
[/list]

If you first login it is normal, that it complains about it. If you create a new user, login to ox and try groupware options in the setup.
Normaly if you save ox should create this file. If not please tell me - than is a bug in ox-ebuild.
Thanks =)
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Wed Oct 05, 2005 5:37 pm    Post subject: Reply with quote

Dark_Hunter wrote:

If you first login it is normal, that it complains about it. If you create a new user, login to ox and try groupware options in the setup.
Normaly if you save ox should create this file. If not please tell me - than is a bug in ox-ebuild.
Thanks =)


okay I see - the file is created correctly if you change/save something in the groupware options ;)

Nevertheless I can not receive emails - I just can send them. But I think I'll have to check my postfix-daemon-configs for this issue:
Code:
warning: dict_ldap_connect: Unable to bind to server ldap://mydomain:389 as : 2 (Protocol error)
[...] alias database unavailable
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Oct 05, 2005 7:14 pm    Post subject: Reply with quote

thurisaz wrote:

Nevertheless I can not receive emails - I just can send them. But I think I'll have to check my postfix-daemon-configs for this issue:
Code:
warning: dict_ldap_connect: Unable to bind to server ldap://mydomain:389 as : 2 (Protocol error)
[...] alias database unavailable


I've got the following lines in my /etc/postfix/main.cf, this should enable the postfix-ldap support

Code:

alias_maps = ldap:ldapsource

ldapsource_server_host = localhost
ldapsource_search_base = dc=your,dc=domaind,dc=which,dc=you,dc=have,dc=defined
ldapsource_query_filter = (mail=%s)
ldapsource_result_attribute = mail
Back to top
View user's profile Send private message
slaapkop
n00b
n00b


Joined: 04 Mar 2004
Posts: 66
Location: Nijmegen

PostPosted: Wed Oct 05, 2005 7:32 pm    Post subject: Reply with quote

Hi,

I removed the open-xchange install from the howto. And I remereged openldap again.
Afer that i unmasked the ebuild en emerge the open-xchenge from portal.
Is it possible to follow the howto over from the

    Configuring OpenLDAP


part of the howto over again? Or do i have to set it up on a different way?

Thanks.
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Wed Oct 05, 2005 7:48 pm    Post subject: Reply with quote

thanks but I have the same settings in my main.cf. After changing some passwords etc I think that I have solved this error, nevertheless I'm getting the next one when postfix tries to deliver an email:
Code:
(connect to /var/imap/socket/lmtp[/var/imap/socket/lmtp]: Permission denied)

this files belongs to root:root :?
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Oct 05, 2005 8:00 pm    Post subject: Reply with quote

slaapkop wrote:

part of the howto over again? Or do i have to set it up on a different way?
Thanks.

(Yes, you can start with the openldap part of the howto, but ...)

You should set the basedn of openldap and also the password.

After you've done this, do the following:
Code:
ebuild /var/db/pkg/www-apps/open-xchange/open-xchange-0.8.1.3.ebuild config

Now ox got configured for your entered values and after that step-by-steps are printed what should be done next.

Most things are already done by the ebuild-package =)
Back to top
View user's profile Send private message
slaapkop
n00b
n00b


Joined: 04 Mar 2004
Posts: 66
Location: Nijmegen

PostPosted: Wed Oct 05, 2005 8:31 pm    Post subject: Reply with quote

Ow I see....

This makes the world a lot easier...

Hmmm, i think i already have a database named openxchange and a dbuser named openxchange.
And i'm not able to log in into postgres sqldatabase with root.

Do i have to reemerge postgresql? Or how can i delete the database user openchange and the database openxchange?

Sorry for my totaly nooB questions.....

:oops:
Back to top
View user's profile Send private message
thurisaz
n00b
n00b


Joined: 02 Mar 2005
Posts: 67
Location: Bochum, Germany

PostPosted: Wed Oct 05, 2005 8:43 pm    Post subject: Reply with quote

My permission problem is fixed - I emerged the newest unstable ebuild and than I simply needed to do the following:
Code:
chown -R cyrus:mail /var/imap/
usermod -G mail cyrus
usermod -G mail postfix 


Now it works and I spend another day on Open-Xchange-Configuration 8O time to go to bed :lol:
Back to top
View user's profile Send private message
Dark_Hunter
Apprentice
Apprentice


Joined: 28 Mar 2003
Posts: 230
Location: Germany

PostPosted: Wed Oct 05, 2005 9:16 pm    Post subject: Reply with quote

slaapkop wrote:

Hmmm, i think i already have a database named openxchange and a dbuser named openxchange.
And i'm not able to log in into postgres sqldatabase with root.

This is no problem, in the howto of Mike they create the user through login per postgres user.

But you can do this also per this three, four lines like stated in the howto of ebuild config.

The best is you just copy those lines under "Setup database" and execute each line as root.

You can change the database options to the options you want, change the databasename or change the database user.
Just execute the config script of the ebuild and everything is setup in open-xchange configuration. After that follow the lines in the little howtos in the config script.

slaapkop wrote:

Do i have to reemerge postgresql? Or how can i delete the database user openchange and the database openxchange?

An easy way is to use webmin to delete the just the ox database.

A dirty way is to delete (all postgresql databases) the content under /var/lib/postgresql and after that just

Code:

ebuild /var/db/pkg/dev-db/postgresql-x.x.x/postgresql-x.x.x.ebuild config

This creates the base postgresql config.

slaapkop wrote:

Sorry for my totaly nooB questions.....
:oops:

Don't worry ;)
Back to top
View user's profile Send private message
slaapkop
n00b
n00b


Joined: 04 Mar 2004
Posts: 66
Location: Nijmegen

PostPosted: Wed Oct 05, 2005 9:17 pm    Post subject: Reply with quote

Well got that part working...

But when i do the:
    slapadd -l /usr/share/open-xchange/init_ldap.ldif

It hangs, just like i had with the previous install....

    TRUUS ~ # slapadd -l /usr/share/open-xchange/init_ldap.ldif




Or is this a proces that takes more than an hour?

Thanks...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 33, 34, 35 ... 37, 38, 39  Next
Page 34 of 39

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum