Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Some useful tips for Gnome 2.8
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
MaxDamage
l33t
l33t


Joined: 03 Jan 2004
Posts: 650
Location: Oviedo, Spain

PostPosted: Wed Oct 13, 2004 5:32 pm    Post subject: Some useful tips for Gnome 2.8 Reply with quote

Hi folks. I just installed Gnome 2.8 yesterday and spent some time fighting with some stupid issues and discovering new features. I post here what I found out so you haven't to redo all the researching:

1) I recommend using hal/dbus/gnome volume manager. Works very well, and you can then drop super/submount, and have one less program in kernel space ;) The problem was, I had udev working, and my /dev entries appeared when I inserted a CD, or plugged the USP camera, but they didnt mount. Solution: add users option in your /etc/fstab entries, or only root will be able to mount them.
Code:
/dev/camara   /mnt/camara   vfat   ro,iocharset=iso8859-15,noauto,users   0   0

Remember that you must unmount a device before disconnecting it (I hated supermount for that).

2) Gnome PDF viewer and GGV now work with all PDFs!! (at least with some ones I could only read correctly using acrobat before). I've been waiting for months to use those instead the reader, and now looks like this has been fixed. Also both programs have been improved.

3) No need of emerging and configuring by hand a thightvnc server. Now Gnome has a vnc server integrated: vino.

4) You can unmerge balsa because evolution 2.0 supports nntp accounts ;) just create a new account and inside the druid select nntp.

5) Udev integrates in Gnome so in the "system" folder, where the filesystem appeared now are all the removable drives and partitions of the system, being able to mount all of them only clicking.

6) This could sound stupid, but now you can move the entries of the bookmarks bar to left and right inside epiphany. I've missed it for long...

Well there are lot of improvements, like the evolution-gaim contact lists integration, the "show hidden files" option in the nautilus view menu, the new network and system tools, etc. Only wanted to tell about the ones I saw more useful. And why not? to say I love how Gnome is becoming a marvelous desktop environment.
_________________
La PDA de tungsteno
Back to top
View user's profile Send private message
Xamindar
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1155
Location: California

PostPosted: Thu Oct 14, 2004 8:00 am    Post subject: Reply with quote

also, disable famd. Am I right on saying this? Once I disabled it, the new gnome-volume-manager was able to work with my cdroms.
Back to top
View user's profile Send private message
MaxDamage
l33t
l33t


Joined: 03 Jan 2004
Posts: 650
Location: Oviedo, Spain

PostPosted: Thu Oct 14, 2004 8:53 am    Post subject: Reply with quote

Xamindar wrote:
also, disable famd. Am I right on saying this? Once I disabled it, the new gnome-volume-manager was able to work with my cdroms.


My cdroms are mounting ok, and I have famd enabled. There are other issues that can make them not to mount nicely:

- Add "users" to your /etc/fstab line, as I said before .
Code:
/dev/hdc  /mnt/sony  iso9660  ro,iocharset=iso8859-15,noauto,users     0   0


- I added this to /etc/conf.d/local.start some time ago for automount, don't know if it's needed anymore, but things work just ok:
Code:
sysctl -w dev.cdrom.autoclose=0 > /dev/null

_________________
La PDA de tungsteno
Back to top
View user's profile Send private message
slaterson
Apprentice
Apprentice


Joined: 26 Feb 2003
Posts: 254

PostPosted: Thu Oct 14, 2004 4:40 pm    Post subject: Reply with quote

regarding hal and the gnome volume manager...

it (hald? gvm?) added entries to my fstab file, even for my usb card reader, which i already had an entry for. also, after the first startup all my partitions were mounted twice (/, /boot, /mnt/local, among others), once in the proper location and a second time under /media/... i have removed several entries that were automatically added to fstab, but they keep re-appearing. is there a configuration setting somewhere that allows me to specify mount points and what hald and gvm should monitor?

basically, i want it to mount my usb card automagically and _maybe_ cds, but nothing else.

thanks,
slate
Back to top
View user's profile Send private message
MaxDamage
l33t
l33t


Joined: 03 Jan 2004
Posts: 650
Location: Oviedo, Spain

PostPosted: Thu Oct 14, 2004 5:46 pm    Post subject: Reply with quote

I had that problem the first time. I was just re-installing gentoo, and hadn't configured udev. When I did, and the /dev entries that I used in /etc/fstab (like "/dev/camara") were created, then no more mountpoints were added by HAL.

What I want to say is that if you have udev running and creating the /dev entries you use in /etc/fstab, GVM/HAL will stop creating aditional ones. At least in my case.

Don't know if you'll find the solution, but I'll post you an example of an entry that works, so you can check it:

- The /etc/udev/rules.d/10-local.rules entry:
Code:
# USB stick and digital camera will have each one their own desktop icon
BUS="usb", SYSFS{product}="USB Mass Storage Device", KERNEL="sd?", NAME="%k", SYMLINK="xtick"
BUS="usb", SYSFS{product}="Digital Camera", KERNEL="sd?1", NAME="%k", SYMLINK="camara"


- And the fstab entry:
Code:
/dev/camara  /mnt/camara  vfat    ro,iocharset=iso8859-15,noauto,users         0       0
/dev/xtick   /mnt/xtick   vfat    rw,iocharset=iso8859-15,noauto,users         0       0

_________________
La PDA de tungsteno
Back to top
View user's profile Send private message
sog
Guru
Guru


Joined: 04 Apr 2004
Posts: 356

PostPosted: Thu Oct 14, 2004 10:15 pm    Post subject: Reply with quote

i don't think i'm putting all the pieces together here, as neither my USB key nor camera are automounting at all.

thus far i've done:

1. emerged Gnome 2.8 (with hald USE flags) - kernel is 2.6.7 gentoo-dev-sources
2. added hald, dbusd and hotplug to my default run level

and that's it. i have not:

1. altered my fstab
2. disabled famd
3. configured anything in udev (i.e. rules - don't know where to start there)

am i right in assuming that to get either my USB key or camera to automount, i need to manual insert an fstab entry? or is hal supposed to do this for me (it's not doing that if it's supposed to)?

if so, where do i get the information necessary to create the fstab? (the emerge of Gnome 2.8 did not apparently include a hal-device-manager)

if it helps, dmesg gives me something like the following when i insert the USB key:
Code:

usb 2-1: new full speed USB device using address 2
scsi0 : SCSI emulation for USB Mass Storage devices
  Vendor: IBM       Model: Memory Key        Rev: 1.01
  Type:   Direct-Access                      ANSI SCSI revision: 02
SCSI device sda: 250000 512-byte hdwr sectors (128 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
 /dev/scsi/host0/bus0/target0/lun0:
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0,  type 0
USB Mass Storage device found at 2

so apologies for the basic question, but i'm not connecting the dots here. would love to have these devices automount however.
_________________
------------------------------------------------
(blog) http://www.redmonk.com/sogrady/
Back to top
View user's profile Send private message
slaterson
Apprentice
Apprentice


Joined: 26 Feb 2003
Posts: 254

PostPosted: Thu Oct 14, 2004 10:57 pm    Post subject: Reply with quote

MaxDamage,
I have udev configured make a device named '/dev/flash', which is my usb flash card reader. It works perfectly, with or without Gnome. hald and gvm pick it up correctly and it gets mounted. So that part is great. However there are still annoyances...

Here is how my system is laid out...

Two IDE hard drives are installed (hda and hdb). Both are just one large partition that holds data only. In fact, hdb isn't normally mounted.
Three SCSI hard drives (sda, sdb and sdc). SDA is where grub is installed, my primary drive. I have an Windows on sdc1. Two completely independent installs of Gentoo exist, one on sda and the other on sdb (sdX1, sdX2, sdX3).
And IDE DVD/CD burner and a SCSI CD-ROM are also present.

HALD and GVM are mounting _all_ of the drives. When booting into Gentoo (either install) I only mount the necessary partitions (sda or sdb partitions) plus hda1. I really don't want the other partitions mounted unless I explicitly say so.

Hopefully there is a device option to tell GVM 'don't mount me automatically' without all this fstab non-sense. And I really hope I don't have to mess with udev, just because when I do want to mount the other drives it could cause a lot more work than is reasonable.

I do like the automounting of my flash cards though.
Back to top
View user's profile Send private message
slaterson
Apprentice
Apprentice


Joined: 26 Feb 2003
Posts: 254

PostPosted: Thu Oct 14, 2004 11:04 pm    Post subject: Reply with quote

sog wrote:

i have not:

1. altered my fstab
2. disabled famd
3. configured anything in udev (i.e. rules - don't know where to start there)

am i right in assuming that to get either my USB key or camera to automount, i need to manual insert an fstab entry? or is hal supposed to do this for me (it's not doing that if it's supposed to)?



what's up sog? hows the rake treating you? :)

i didn't have to disable famd. it's actually running right now and my cdroms and flash card reader automount perfectly.

regarding editing of your fstab... i didn't have to edit it other than adding a correct entry for my flash card reader. gnome did all the rest.

configuring udev was actually easy. i found a web site (somewhere in these forums is the link) that had an example of what to do for usb card readers. i modified the example and it worked on the first try. very encouraging... here is what i did:

in
Code:
/etc/udev/rules.d/10-local.rules

enter
Code:
BUS="usb", SYSFS{product}="USB Storage Device", NAME[all_partitions]="flash"

you will need to find the appropriate 'product' for your device with the command
Code:
udevinfo
for help with that one.

slate
Back to top
View user's profile Send private message
sog
Guru
Guru


Joined: 04 Apr 2004
Posts: 356

PostPosted: Thu Oct 14, 2004 11:23 pm    Post subject: Reply with quote

hahaha - hey there.

the rake is currently beating me down, as i'm still at the office ;)

anyhow, appreciate the tip. one point of clarification, however. i'll hunt down that link, but in the meantime i should mention that i have no /etc/udev/rules.d/10-local.rules. all i have is /etc/udev/rules.d/50-udev.rules.

you think i can just nano in the 10-local-rules file?

additionally, a udevinfo is giving me issues, saying:

Code:
unable to open udev database


i'm off to hunt some of these down, any thoughts are appreciated. and watch for that rake ;)
_________________
------------------------------------------------
(blog) http://www.redmonk.com/sogrady/
Back to top
View user's profile Send private message
sog
Guru
Guru


Joined: 04 Apr 2004
Posts: 356

PostPosted: Thu Oct 14, 2004 11:27 pm    Post subject: Reply with quote

update: looks like my udev is screwed up similar to what's in here:

https://forums.gentoo.org/viewtopic.php?t=202140&highlight=unable+udev+database
_________________
------------------------------------------------
(blog) http://www.redmonk.com/sogrady/
Back to top
View user's profile Send private message
slaterson
Apprentice
Apprentice


Joined: 26 Feb 2003
Posts: 254

PostPosted: Thu Oct 14, 2004 11:28 pm    Post subject: Reply with quote

sog wrote:
anyhow, appreciate the tip. one point of clarification, however. i'll hunt down that link, but in the meantime i should mention that i have no /etc/udev/rules.d/10-local.rules. all i have is /etc/udev/rules.d/50-udev.rules.

you think i can just nano in the 10-local-rules file?


yeah. instead of nano, use vi. it's better. :) i had to create the 10-local-rules file myself, but it worked. i have to go play golf now, but when i get back i'll try to dig up some links on the udev stuff.

good luck!
slate
Back to top
View user's profile Send private message
sog
Guru
Guru


Joined: 04 Apr 2004
Posts: 356

PostPosted: Fri Oct 15, 2004 1:42 am    Post subject: Reply with quote

ok, i think i'm getting closer, but more questions. as i understand it, udev is a requirement for hal/dbus/etc, correct?

but according to this, i can't run devfs and udev concurrently:

http://webpages.charter.net/decibelshelp/LinuxHelp_UDEVPrimer.html

so am i to understand i need to go through that whole process for this to work? if so, i wish i'd known that before.
_________________
------------------------------------------------
(blog) http://www.redmonk.com/sogrady/
Back to top
View user's profile Send private message
slaterson
Apprentice
Apprentice


Joined: 26 Feb 2003
Posts: 254

PostPosted: Fri Oct 15, 2004 2:29 am    Post subject: Reply with quote

no devfs if you run udev. it's amazingly simple.

there is some info here:
https://forums.gentoo.org/viewtopic.php?t=189250&highlight=nptl+howto

and here:
http://www.gentoo.org/doc/en/udev-guide.xml

and here:
http://webpages.charter.net/decibelshelp/LinuxHelp_UDEVPrimer.html

the first one is mostly nptl stuff, but it installs a system to use udev instead of devfs also.
Back to top
View user's profile Send private message
Xamindar
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1155
Location: California

PostPosted: Fri Oct 15, 2004 4:35 am    Post subject: Reply with quote

slaterson wrote:
regarding hal and the gnome volume manager...

it (hald? gvm?) added entries to my fstab file, even for my usb card reader, which i already had an entry for. also, after the first startup all my partitions were mounted twice (/, /boot, /mnt/local, among others), once in the proper location and a second time under /media/... i have removed several entries that were automatically added to fstab, but they keep re-appearing. is there a configuration setting somewhere that allows me to specify mount points and what hald and gvm should monitor?

basically, i want it to mount my usb card automagically and _maybe_ cds, but nothing else.

thanks,
slate


It is probably adding duplicates of your devices but using a different /dev link. Go in you fstab and change your current /dev/whatever entries for your stuff to whatever hald is using in its added entries. As far as I know hal will not add an entry if that device already has it's own entry. I think it ignores all the rest.
Back to top
View user's profile Send private message
sog
Guru
Guru


Joined: 04 Apr 2004
Posts: 356

PostPosted: Fri Oct 15, 2004 5:00 am    Post subject: Reply with quote

uh-oh - trouble.

i followed the instructions slate linked to here - http://www.gentoo.org/doc/en/udev-guide.xml

and now my machine won't boot into Gnome. it goes through the load fine, no errors, but when it goes to aunch X (GDM), i just get a blank screen. nothing.

basically the only changes i made were the following:
Code:


1. unchecked "Automatically mount at boot"
File systems --->
  Pseudo Filesystems --->
    [*] /dev file system support (OBSOLETE)
      [ ]   Automatically mount at boot


2. removed hotplug from default and added to boot

that's it. i didn't alter grub, and i didn't screw with my /etc/conf.d/rc script.

but something's clearly borqed. i did do the tests, and i do have /dev/console and /dev/null if that's relevant.

any ideas?
_________________
------------------------------------------------
(blog) http://www.redmonk.com/sogrady/
Back to top
View user's profile Send private message
slaterson
Apprentice
Apprentice


Joined: 26 Feb 2003
Posts: 254

PostPosted: Fri Oct 15, 2004 5:06 am    Post subject: Reply with quote

make sure you have all the required versions of support apps and libraries. since you are going into x when it stop, maybe it's something to do with your video card. check this out:

Code:
udev and nvidia
If you use the proprietary driver from nVidia and the X server fails to start on a udev-only system, then make sure you have:

the nvidia module listed in /etc/modules.autoload.d/kernel-2.6
a version of nvidia-kernel equal to or greater than media-video/nvidia-kernel-1.0.5336-r2
a version of baselayout equal to or greater than sys-apps/baselayout-1.8.12


does the machine completely die or is it just X dieing? can you ssh to it?
Back to top
View user's profile Send private message
sog
Guru
Guru


Joined: 04 Apr 2004
Posts: 356

PostPosted: Fri Oct 15, 2004 5:13 am    Post subject: Reply with quote

yeah, i did see that. i'm not using the nvidia drivers however - it's just the plain old ATI drivers from X.

and it doesn't die, precisely, it just doesn't do anything. i get through the launch script, and...blah...nothing.

as for SSH, i'll try it tomorrow when i get to the office. but i may try to get in from a boot disk and put it back if i can't get a quick answer. i hate breaking my production machine ;)

EDIT: I'm not the only one, apparently this is semi-common. going to try this out tomorrow:

https://forums.gentoo.org/viewtopic.php?t=227041&highlight=udev+xorg
_________________
------------------------------------------------
(blog) http://www.redmonk.com/sogrady/
Back to top
View user's profile Send private message
sog
Guru
Guru


Joined: 04 Apr 2004
Posts: 356

PostPosted: Fri Oct 15, 2004 3:01 pm    Post subject: Reply with quote

if anybody has that problem, click the thread as it's got the fix. i had to jump through a few more hoops - but it worked just fine in the end. will get on with the further udev config shortly.
_________________
------------------------------------------------
(blog) http://www.redmonk.com/sogrady/
Back to top
View user's profile Send private message
sog
Guru
Guru


Joined: 04 Apr 2004
Posts: 356

PostPosted: Fri Oct 15, 2004 3:42 pm    Post subject: Reply with quote

YES! apparently the two steps i took - moving hotplug to the boot runlevel and removing "Automatically boot devfs" at startup - fixed my udev (altho it required a change to my xorg.conf which i hadn't anticipated), b/c i just popped in my USB key to try and try and run udevinfo to setup fstab, etc, and what happened?

Gnome picked it up and popped up a window with the USB contents in it. magical ;)

so to sum up, given my original question - you do NOT have to muck with fstab, disable famd or setup udev rules. if you've compiled Gnome with hal, etc, and properly inserted hald, hotplug, and dbusd into your runlevel - AND properly configured udev (see links above), you should be all set.

or so it seems thus far. thx for all the help everyone, particular u slates.
_________________
------------------------------------------------
(blog) http://www.redmonk.com/sogrady/
Back to top
View user's profile Send private message
slaterson
Apprentice
Apprentice


Joined: 26 Feb 2003
Posts: 254

PostPosted: Fri Oct 15, 2004 3:49 pm    Post subject: Reply with quote

Xamindar wrote:
It is probably adding duplicates of your devices but using a different /dev link. Go in you fstab and change your current /dev/whatever entries for your stuff to whatever hald is using in its added entries. As far as I know hal will not add an entry if that device already has it's own entry. I think it ignores all the rest.


Xamindar,
I fixed up my fstab with the proper values. now, no new entries are created in fstab, however all these partitions are mounted when i boot, which i _really_ don't want. i even have 'noauto' specified on all the devices i _don't_ want mounted.

any ideas?

thanks,
slate
Back to top
View user's profile Send private message
slaterson
Apprentice
Apprentice


Joined: 26 Feb 2003
Posts: 254

PostPosted: Fri Oct 15, 2004 3:53 pm    Post subject: Reply with quote

sog wrote:
so to sum up, given my original question - you do NOT have to muck with fstab, disable famd or setup udev rules. if you've compiled Gnome with hal, etc, and properly inserted hald, hotplug, and dbusd into your runlevel - AND properly configured udev (see links above), you should be all set.


glad you got it workin'. i am still using xfree, haven't upgraded to xorg yet, but i probably will on my second install. have you all that fancy shit working? transparency and shadows and stuff like that?
Back to top
View user's profile Send private message
sog
Guru
Guru


Joined: 04 Apr 2004
Posts: 356

PostPosted: Fri Oct 15, 2004 4:06 pm    Post subject: Reply with quote

nah, i gave them a whirl and got shadows working - tho not transparency - but as i understand it Gnome 2.8 doesn't play nicely with composite enabled.

i switched more b/c xfree is deprecated in Gentoo, and thus would have to do it eventually anyway.
_________________
------------------------------------------------
(blog) http://www.redmonk.com/sogrady/
Back to top
View user's profile Send private message
MaxDamage
l33t
l33t


Joined: 03 Jan 2004
Posts: 650
Location: Oviedo, Spain

PostPosted: Fri Oct 15, 2004 9:41 pm    Post subject: Reply with quote

slaterson wrote:
Xamindar wrote:
It is probably adding duplicates of your devices but using a different /dev link. Go in you fstab and change your current /dev/whatever entries for your stuff to whatever hald is using in its added entries. As far as I know hal will not add an entry if that device already has it's own entry. I think it ignores all the rest.


Xamindar,
I fixed up my fstab with the proper values. now, no new entries are created in fstab, however all these partitions are mounted when i boot, which i _really_ don't want. i even have 'noauto' specified on all the devices i _don't_ want mounted.

any ideas?

thanks,
slate


I have the same problem. Also tried "noauto" but the partitions are mounted anyway. Somebody has found a solution?
_________________
La PDA de tungsteno
Back to top
View user's profile Send private message
Xamindar
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1155
Location: California

PostPosted: Sat Oct 16, 2004 8:03 am    Post subject: Reply with quote

wow, you are right. My XP partition is mounted and I have "noauto" in fstab. You should file a bug. (I dont want to do it, did it wrong last time :oops: )
Back to top
View user's profile Send private message
Xamindar
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1155
Location: California

PostPosted: Sat Oct 16, 2004 8:15 am    Post subject: Reply with quote

sog wrote:
nah, i gave them a whirl and got shadows working - tho not transparency - but as i understand it Gnome 2.8 doesn't play nicely with composite enabled.

i switched more b/c xfree is deprecated in Gentoo, and thus would have to do it eventually anyway.


I'm currently enjoying drop shadows and transparency. I downgraded back to metacity-2.8.1 and can now use xcompmgr to set most settings like drop shadows and menu fade and use transset so set transperency for program windows. I used metacity-2.8.5 for a while but it is still unstable with these features, though, it's fading effects looked a lot better because it didn't have drop shadows, which it doesn't do yet. Drop shadows add a darkness behind the window and when it fades it just looks a little dirty (or dark) where the fading kind of shines when there are not drop shadows. Anyway, I'm rambling now. I really look forward to the next few releases of metacity.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum