Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Laptop (Ti G4 - 2001) won't boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
bjgilger
n00b
n00b


Joined: 16 Oct 2004
Posts: 4

PostPosted: Sat Oct 16, 2004 5:35 pm    Post subject: Laptop (Ti G4 - 2001) won't boot Reply with quote

I decided to move from Debian to Gentoo on my Ti G4 PowerBook (2001 model). I followed the Gentoo Install Guide exactly. Everything seems to have gone well except the reboot.

I ran yabootconfig and it produced this for a yaboot.conf:
--------------------------------------
boot=/dev/hda2
device=/pci@f2000000/mac-io@17/ata-4@1f000/disk@0:
partition=4
root=/dev/hda4
timeout=30
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot

image=/vmlinux
label=Linux
read-only
------------------------------
On reboot, this was displayed:
------------------------------
Welcome to Linux, kernel 2.6.8-gentoo-r7

linked at :0xc0000000
frame buffer at :0xb6008000 (phys), 0xd0008000 (log)
klimit :0xc03d836c
MSR :0x00003030
HID0 :0x8014c0ac
ICTC :0x00000000

pmac_init(): exit
id mach(): done
MMU:enter
MMU:hw init
hash:enter
hash:find piece
hash:patch
hash:done
MMU:mapin
MMU:setio
MMU:exit
setup_arch: enter
setup_arch: bootmem
arch: exit
openpic: enter
openpic: timer
openpic: external
openpic: spurious
openpic: exit

-----------------------------
That was all. It stopped

I modified yaboot.conf to this (which worked flawlessly with Debian):
-------------------------
boot=/dev/hda2
device=hd:
partition=4
root=/dev/hda4
timeout=30
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot

image=/vmlinux
label=Linux
read-only
---------------------------
The only difference is device=hd:

I got the same results on reboot.

I also tried the Command,Option,P,R on reboot. Same results :(

Any ideas or fixes?

TIA

--John
Back to top
View user's profile Send private message
porodzila
Guru
Guru


Joined: 22 May 2004
Posts: 307
Location: Terrapin Station

PostPosted: Sat Oct 16, 2004 8:05 pm    Post subject: Reply with quote

This is a kernel config problem.

My machine does this too, it seems to be intermittant. I think it has to do with the boot logo and/or bootsplash, if you have either, turn them off.
_________________
ubi primum potero, me hinc subduco.
Back to top
View user's profile Send private message
porodzila
Guru
Guru


Joined: 22 May 2004
Posts: 307
Location: Terrapin Station

PostPosted: Sat Oct 16, 2004 8:07 pm    Post subject: Reply with quote

oh, and either yaboot config should work fine. I do it the second way on my machine.
_________________
ubi primum potero, me hinc subduco.
Back to top
View user's profile Send private message
enrique
Guru
Guru


Joined: 03 Sep 2002
Posts: 342
Location: Denmark

PostPosted: Sat Oct 16, 2004 8:38 pm    Post subject: Reply with quote

Hey bjgilger

I also have a PB G4 from 2001, I have put some info about it online:

http://www.rockhopper.dk/linux/powerbook/powerbook-titanium.html

I can upload my yaboot and kernel config tomorrow if you can use them.
_________________
Kind regards, enrique
Workstation,HTPC,Powerbook
Back to top
View user's profile Send private message
bjgilger
n00b
n00b


Joined: 16 Oct 2004
Posts: 4

PostPosted: Sat Oct 16, 2004 9:54 pm    Post subject: Reply with quote

Thanks. I'll take a close look at my .config file and see what I can find :)

--John
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sun Oct 17, 2004 12:37 am    Post subject: Reply with quote

You're probably missing the FrameBuffer device from your kernel. From menu config: Device Drivers -> Graphics Support -> Turn on support for FB devices and make sure your video card is built in as well. (Probably ATI Radeon)

If this still doesn't work, let us know.
Back to top
View user's profile Send private message
bjgilger
n00b
n00b


Joined: 16 Oct 2004
Posts: 4

PostPosted: Sun Oct 17, 2004 4:47 am    Post subject: Reply with quote

I verified .config -- ensured that FrameBuffer support and ATI Rage 128 support was there.

re-compiled kernel.

Ran ybin -v

Rebooted -- same result :(

--John
Back to top
View user's profile Send private message
porodzila
Guru
Guru


Joined: 22 May 2004
Posts: 307
Location: Terrapin Station

PostPosted: Sun Oct 17, 2004 9:44 pm    Post subject: Reply with quote

yeah, like I said, I have the same problem. I took out the bootsplash/bootup logo and it worked fine.
_________________
ubi primum potero, me hinc subduco.
Back to top
View user's profile Send private message
bjgilger
n00b
n00b


Joined: 16 Oct 2004
Posts: 4

PostPosted: Sun Oct 17, 2004 10:09 pm    Post subject: Reply with quote

Where is the bootsplash and bootup logo?

--John
Back to top
View user's profile Send private message
porodzila
Guru
Guru


Joined: 22 May 2004
Posts: 307
Location: Terrapin Station

PostPosted: Mon Oct 18, 2004 5:32 pm    Post subject: Reply with quote

Its in the same area as framebuffer console.

Also, what I did was just keep turning it on and off and it would eventually boot.
_________________
ubi primum potero, me hinc subduco.
Back to top
View user's profile Send private message
no_dice
n00b
n00b


Joined: 12 Aug 2003
Posts: 29

PostPosted: Fri Oct 22, 2004 4:30 pm    Post subject: Reply with quote

Likewise problem for me. G4 pbook that would crap out at openpic at boot. As porodzilla said, normally trying to boot a few times would fix my problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum