Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
"<>|"-Key doesn't work with X11 on my iBook
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
tassilo80
Guru
Guru


Joined: 26 Mar 2003
Posts: 346
Location: Koblenz, Germany

PostPosted: Thu Oct 21, 2004 6:04 pm    Post subject: "<>|"-Key doesn't work with X11 on my iBook Reply with quote

Hi,

on my iBook I cannot use the "<>|"-Key (you know, the key with the pipe and < and > on a german keyboard, right of the left shift key) when I am in X.

If I work on a terminal I can use this key.

In my /etc/X11/xorg.conf I have:
Code:

Section "InputDevice"
    Identifier "Keyboard0"
    Driver "keyboard"
    Option "XkbRules" "xfree86"
    Option "XkbLayout" "de"
    Option "XkbVariant" "nodeadkeys"
EndSection


I have the following keymap in my /etc/rc.conf:
Code:

KEYMAP="mac-de-latin1-nodeadkeys"


What can I do?
I need to edit some html files which is quite annoying without < and >. :wink:

Regards,
Tassilo
Back to top
View user's profile Send private message
Lore
Apprentice
Apprentice


Joined: 16 Feb 2004
Posts: 152
Location: Karlsruhe

PostPosted: Fri Oct 22, 2004 12:45 am    Post subject: Reply with quote

Try

Code:
Option "XkbModel" "pc105"
Back to top
View user's profile Send private message
tassilo80
Guru
Guru


Joined: 26 Mar 2003
Posts: 346
Location: Koblenz, Germany

PostPosted: Fri Oct 22, 2004 2:04 pm    Post subject: Reply with quote

Hi Lore,

I'll try it this evening when my girlfriend comes back from work. It's her notebook. :wink:

I'll report back if that is the solution.

Regards,
Tassilo
Back to top
View user's profile Send private message
tassilo80
Guru
Guru


Joined: 26 Mar 2003
Posts: 346
Location: Koblenz, Germany

PostPosted: Fri Oct 22, 2004 4:16 pm    Post subject: Reply with quote

Hi Lore,

you were right. With this option inserted <>| work fine.

Thanks a lot,
Tassilo
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Wed Feb 01, 2006 10:49 pm    Post subject: Reply with quote

I have the same problem here, but with "pc105".
Code:
Section "InputDevice"
        Identifier      "Keyboard0"
        Driver          "kbd"

        Option          "XkbGeometry"   "macintosh"
        Option          "XkbOptions"    "ctrl:nocaps, lv3:lwin_switch"

        Option          "XkbModel"      "pc105"
        Option          "LeftAlt"       "Meta"
        Option          "RightAlt"      "LWin"

        Option          "Xkblayout"     "de"
EndSection

I have a working .Xmodmap now, but I can't get it loading with X, only manually. But /etc/X11/xinit/xinitrc seems to load all users .Xmodmap's?
I am using kdm/KDE. Is there any startup script I could use?

In the terminal I fixed the problem by writing my own keymap including "de-latin1...".
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum