Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sound problems on powerbook
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
xavier10
Guru
Guru


Joined: 19 Jan 2004
Posts: 449
Location: Paris, France

PostPosted: Tue Nov 02, 2004 4:40 pm    Post subject: sound problems on powerbook Reply with quote

I have had a powerbook alu for almost one year now.

Sound is a nightmare. It used to work. Some upgrades broke it. I spent some time looking at that and it did not work. Then it worked again but I did not understand why. And it stopped working again recently, after emerging kde! Now I get some kind of saturation noise (however it is not very loud) but NO audible sound.

So I decided to reinstall the kernel and to re-install alsa. I followed the procedure of the howto and it still does not work (still the same saturation noise).

I reviewed all the previous posts on this topic with no result.

Could someone help ? or just explain me if there is somehting rationale in alsa on powerbooks ?
(I notice so many posts about different problems on that theme yet none of them helps me ; same conclusion for the howtos).
Back to top
View user's profile Send private message
eniac
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 233
Location: Belgium, Brussels

PostPosted: Tue Nov 02, 2004 5:17 pm    Post subject: Reply with quote

I have the same problem, but on an ibook.
_________________
Turns out the pony only had one trick.
Back to top
View user's profile Send private message
blubbfisch
n00b
n00b


Joined: 19 Oct 2003
Posts: 55
Location: World->Pacific->New Zealand->Hamilton

PostPosted: Tue Nov 02, 2004 8:56 pm    Post subject: Reply with quote

re the bad/quiet sound, try those:

1) fire up alsamixer
2) Mute DRC (Digital Range Control)
3) Set PCM to 50
4) Control the volume by the Master fader

Have fun*
Back to top
View user's profile Send private message
xavier10
Guru
Guru


Joined: 19 Jan 2004
Posts: 449
Location: Paris, France

PostPosted: Tue Nov 02, 2004 10:11 pm    Post subject: Reply with quote

blubbfisch wrote:
re the bad/quiet sound, try those:

1) fire up alsamixer
2) Mute DRC (Digital Range Control)
3) Set PCM to 50
4) Control the volume by the Master fader

Have fun*


Thank you for your post. I tried this but remarked no improvement at all. All I can hear is noise with noatun. Xmms will not work.

Regards,

Xavier
Back to top
View user's profile Send private message
eniac
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 233
Location: Belgium, Brussels

PostPosted: Tue Nov 02, 2004 10:25 pm    Post subject: Reply with quote

same !
_________________
Turns out the pony only had one trick.
Back to top
View user's profile Send private message
blubbfisch
n00b
n00b


Joined: 19 Oct 2003
Posts: 55
Location: World->Pacific->New Zealand->Hamilton

PostPosted: Tue Nov 02, 2004 10:49 pm    Post subject: Reply with quote

What happens, if you use alsaplayer?
xmms sometimes seems to have endianness problems (sounds like static/tube distortion)
Back to top
View user's profile Send private message
xavier10
Guru
Guru


Joined: 19 Jan 2004
Posts: 449
Location: Paris, France

PostPosted: Wed Nov 03, 2004 8:25 am    Post subject: Reply with quote

blubbfisch wrote:
What happens, if you use alsaplayer?
xmms sometimes seems to have endianness problems (sounds like static/tube distortion)


Thanks for the suggestion, but still the same noise-with-no-music-sound-at-all :(

Regards,

Xavier
Back to top
View user's profile Send private message
eniac
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 233
Location: Belgium, Brussels

PostPosted: Wed Nov 03, 2004 8:44 am    Post subject: Reply with quote

same but mine is more music-with-alot-of-noise-sound
_________________
Turns out the pony only had one trick.
Back to top
View user's profile Send private message
xavier10
Guru
Guru


Joined: 19 Jan 2004
Posts: 449
Location: Paris, France

PostPosted: Wed Nov 03, 2004 10:16 am    Post subject: just solved... Reply with quote

I was using kde. I switched to enlightenment and can hear a nice music right now from xmms.

So, I guess something is screwed inside KDE.
By the way, note that xmms was not working on KDE, so the problem should not be the applications I used under KDE but the sound management inside KDE itself.

I should bug report but feel I lack data.

Regards,

Xavier
Back to top
View user's profile Send private message
xavier10
Guru
Guru


Joined: 19 Jan 2004
Posts: 449
Location: Paris, France

PostPosted: Thu Nov 04, 2004 11:18 am    Post subject: Reply with quote

Solution under Kde found:

- Turn off the sound system in the Sound & Multimedia tab.
- Boost the DRC Rang in gnome-alsamixer
- Adjust the Master swich setting in the gnome-alsamixer

This allowed me to get a nice sound under Kde.

I do not understand all the steps involved here.

I was ready to ditch Kde for enlightenment but still prefer the Kde wm.

Regards,

Xavier
Back to top
View user's profile Send private message
xavier10
Guru
Guru


Joined: 19 Jan 2004
Posts: 449
Location: Paris, France

PostPosted: Thu Nov 04, 2004 11:18 am    Post subject: Reply with quote

PS : eniac, does it work for you ?

Regards,

Xavier
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum