Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Fritz!Card pcmcia + capi + kernel 2.6
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
genstef
Retired Dev
Retired Dev


Joined: 13 Jun 2004
Posts: 668
Location: M/Bay/Germany

PostPosted: Wed Jun 08, 2005 10:30 pm    Post subject: Reply with quote

Please dont use the fcpcmcia driver,

please use the workaround postet in the bug:

https://bugs.gentoo.org/show_bug.cgi?id=84061#c12
Back to top
View user's profile Send private message
sebastianm
n00b
n00b


Joined: 06 Jun 2005
Posts: 16
Location: Germany, Moenchengladbach

PostPosted: Thu Jun 09, 2005 6:35 am    Post subject: Reply with quote

As far as I unterstood the other postings, the fcpcmcia driver should be no problem, using a kernel < 2.6.11? Isn't that right?

Till now, I did not succeed with bringing the workaround to function properly, but I'll have a few more tries today.

I'll post my success later in here.
Back to top
View user's profile Send private message
genstef
Retired Dev
Retired Dev


Joined: 13 Jun 2004
Posts: 668
Location: M/Bay/Germany

PostPosted: Thu Jun 09, 2005 9:19 pm    Post subject: Reply with quote

Dirk_H reportet that it also has problems with 2.6.10, should I maybe add a warning to the ebuild or remove the driver if I detect a recent kernel? What do you think is best to keep people from failing?
Back to top
View user's profile Send private message
Freanan
Tux's lil' helper
Tux's lil' helper


Joined: 14 Feb 2005
Posts: 113
Location: Esthal, Pfalz, Germany

PostPosted: Fri Jun 10, 2005 5:52 am    Post subject: Reply with quote

I think a warning maybe with the url of the workaround included would be best...

After all i think i just won't upgrade to the new kernel - i hope in future releases the avm-card will be supported with capi again...
Back to top
View user's profile Send private message
sebastianm
n00b
n00b


Joined: 06 Jun 2005
Posts: 16
Location: Germany, Moenchengladbach

PostPosted: Fri Jun 10, 2005 8:30 am    Post subject: Reply with quote

Nothing new in here right now, but as I booted the 2.6.9-gentoo-r9 kernel, I remember that I never had a try with this one because the framebuffer did not work. Now it is working and I'll try to get it working with CAPI.

As I read some ISDN-related sites, I noticed that on one page was written to disable preemptible kernel for it could crash isdn (don't know if it was espacially capi) on some machines. When I look at the error message, Dirk_H got, I think it would be worth to give it a try.

EDIT: Disabeling preemptible kernel results in much other modules not to be able to be build in "make modules_install".

ANOTHER EDIT: Finally, I decided to use the HiSax driver with my 2.6.11-gentoo-r9 kernel. The vesafb-tng in the 2.6.9 kernel does not work and i like that framebuffer very much :?

But to make things again a bit complicated, I have the same problem like the guy in this Thread :arrow: klick me. Any ideas? It's driving me insane :twisted:
Back to top
View user's profile Send private message
Freanan
Tux's lil' helper
Tux's lil' helper


Joined: 14 Feb 2005
Posts: 113
Location: Esthal, Pfalz, Germany

PostPosted: Mon Jul 25, 2005 5:36 am    Post subject: Reply with quote

I suggest to stay with 2.6.9 and use capi until a new kernel arrives, for which the capi driver is reported to work again.
Or are there any important new options or security fixes that make it really unreasonable to stay with 2.6.9?
I really hate having such exotic hardware - with every new kernels everything has to be redone in a completely different way then before and maybe it does not even work...
Back to top
View user's profile Send private message
Freanan
Tux's lil' helper
Tux's lil' helper


Joined: 14 Feb 2005
Posts: 113
Location: Esthal, Pfalz, Germany

PostPosted: Mon Aug 29, 2005 10:44 am    Post subject: Reply with quote

Anything new about this card with the 2.6.13 kernel..?
It would be cool to use this thread also for updates concerning new kernel versions and the avm a1 card, so that everyone just ahd to check here if he or she should install the newest kernel verison or if it would break internet connectivity.
Back to top
View user's profile Send private message
genstef
Retired Dev
Retired Dev


Joined: 13 Jun 2004
Posts: 668
Location: M/Bay/Germany

PostPosted: Mon Aug 29, 2005 12:34 pm    Post subject: Reply with quote

Well, it should work with the latest ~x86 version.
As you can see I marked the bug as RESOLVED,FIXED:
https://bugs.gentoo.org/show_bug.cgi?id=84061
Back to top
View user's profile Send private message
Freanan
Tux's lil' helper
Tux's lil' helper


Joined: 14 Feb 2005
Posts: 113
Location: Esthal, Pfalz, Germany

PostPosted: Tue Aug 30, 2005 5:19 am    Post subject: Reply with quote

Cool, thanks!
I will upgrade as soon as possible.
Back to top
View user's profile Send private message
Freanan
Tux's lil' helper
Tux's lil' helper


Joined: 14 Feb 2005
Posts: 113
Location: Esthal, Pfalz, Germany

PostPosted: Sat Sep 23, 2006 10:23 am    Post subject: Reply with quote

The last kernel version that i have tried and that has worked with this hardware and the tutorial posted in here was 2.6.12.
I think i tried 2.6.14 or something once, but that did not work.

Has anyone experiences with the newer kernel versions? As far as i know there is already a 2.6.17 and since i am doing a new install at the moment i would like to use the newest possible kernel.

I have searched the web and looked at the bugreport above, but could not find anything.
Back to top
View user's profile Send private message
newmario
n00b
n00b


Joined: 23 Mar 2004
Posts: 49

PostPosted: Sat Sep 23, 2006 11:09 pm    Post subject: Reply with quote

Hi !

also wenn du willst, könnten wir uns zusammen schließen, hab gestern gentoo neu installiert (incl. gentoo-sources-2.6.17-r5) und schaff es nicht, meine fritz card pcmcia v2.0 zum laufen zu bekommen. (das hab ich mir vor dem neuen install eh schon gedacht :) ).

lg
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum