Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Waar is 'soundcore ' in menuconfig voor kernel?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
Grik
Tux's lil' helper
Tux's lil' helper


Joined: 30 Sep 2004
Posts: 88
Location: Netherlands

PostPosted: Thu Nov 04, 2004 3:53 pm    Post subject: Waar is 'soundcore ' in menuconfig voor kernel? Reply with quote

Hallo,

Ik probeer mijn geluid aan de praat te krijgen in Linux. Ik heb een Asus A7N8X-X moederbord met Nvida Nforce onboard sound. Ik heb alle Alsa drivers ge-emerged, maar het geluid werkt niet.
Ik ben op de Alsa site gaan kijken, en heb
Code:
modinfo soundcore
ingevoerd om te kijken of ik soundcore in de kernel heb gebakken. Dat blijkt niet zo te zijn. Dus ik heb "make menuconfig" gedaan, en me suf gezocht naar "soundcore", wat ik 'aan' moet zetten volgens Alsa. Ik heb wel allerlei andere Alsa-dingen aangekruist, maar geen soundcore gevonden. Ik heb de kernel opnieuw gecompileerd, gekopieerd en opnieuw geboot. Maar volgens "modinfo soundcore" is soundcore nog steeds niet geinstalleerd. Ik heb nog eens goed gekeken in menuconfig, maar ik kan hem niet vinden.
Wie weet wat ik moet doen?
Ik heb kernel 2.6.7-gentoo-r11.
Back to top
View user's profile Send private message
BlackEdder
Advocate
Advocate


Joined: 26 Apr 2004
Posts: 2588
Location: Dutch enclave in Egham, UK

PostPosted: Thu Nov 04, 2004 4:11 pm    Post subject: Reply with quote

Volgens mij (ik heb ook een nforce chipset onboard geluidskaart0 moet je de snd-intel8x0 gebruiken. Ik kan mij niks herinneren van een soundcore module. Gewoon alsa met ondersteuning voor intel8x0 (beware je krijgt geen hardware mixing, dus zonder geluidserver niet meerdere geluiden tegelijkertijd). Je kan trouwens ook de nvidea drivers proberen, zij produceren hun eigen drivers en de nieuwste versie is geloof ik niet al te slecht. het geeft je hardware mixing, maar het zijn OSS (=open sound system?) drivers geen alsa
Back to top
View user's profile Send private message
Grik
Tux's lil' helper
Tux's lil' helper


Joined: 30 Sep 2004
Posts: 88
Location: Netherlands

PostPosted: Thu Nov 04, 2004 4:19 pm    Post subject: Reply with quote

Nou, ik heb dus alle drivers geinstalleerd, maar het geluid werkt niet.
En ik gok dat dit komt doordat ik toch die soundcore module niet kan vinden oid.
Back to top
View user's profile Send private message
sgaap
l33t
l33t


Joined: 16 Aug 2002
Posts: 754
Location: Enschede, The Netherlands

PostPosted: Thu Nov 04, 2004 5:44 pm    Post subject: Reply with quote

als het goed is dan is dat de volgende optie

device drivers > sound > sound card support (deze kun je als module bouwen en heet als het goed is "soundcore")

Om alsa in je kernel te bouwen moet je deze module sowiezow hebben, dus alleen als je alsa apart van de kernel bouw (lees alsa-driver ebuild) dan moet je deze nog extra in de kernel of als module bouwen
_________________
In "old" Europe we already have a word for "pre-emptive strikes" mr Bush: its called "war"
Back to top
View user's profile Send private message
Grik
Tux's lil' helper
Tux's lil' helper


Joined: 30 Sep 2004
Posts: 88
Location: Netherlands

PostPosted: Thu Nov 04, 2004 7:50 pm    Post subject: Reply with quote

Ik probeer de drivers nu niet te emergen, maar te installeren zoals het op de site staat.
Ik krijg de volgende foutmelding :( :
Code:
checking for built-in ALSA... "yes"
configure: error: You have built-in ALSA in your kernel.
make all-deps
make[1]: Entering directory `/usr/src/alsa/alsa-driver-1.0.7rc2'
make[1]: Nothing to be done for `all-deps'.
make[1]: Leaving directory `/usr/src/alsa/alsa-driver-1.0.7rc2'

Please, run the configure script as first...

rm -f /snd*.*o /persist.o /isapnp.o
make[1]: Entering directory `/usr/src/alsa/alsa-driver-1.0.7rc2/acore'
Makefile:6: /usr/src/alsa/alsa-driver-1.0.7rc2/Makefile.conf: No such file or directory
make[1]: *** No rule to make target `/usr/src/alsa/alsa-driver-1.0.7rc2/Makefile.conf'.  Stop.
make[1]: Leaving directory `/usr/src/alsa/alsa-driver-1.0.7rc2/acore'
make: *** [install-modules] Error 1


Wat wordt hiermee bedoeld?
Back to top
View user's profile Send private message
theBlackDragon
l33t
l33t


Joined: 23 Nov 2002
Posts: 762
Location: Gent (Belgium)

PostPosted: Thu Nov 04, 2004 8:20 pm    Post subject: Reply with quote

Grik wrote:
Ik probeer de drivers nu niet te emergen, maar te installeren zoals het op de site staat.
Ik krijg de volgende foutmelding :( :
Code:
checking for built-in ALSA... "yes"
configure: error: You have built-in ALSA in your kernel.
make all-deps
make[1]: Entering directory `/usr/src/alsa/alsa-driver-1.0.7rc2'
make[1]: Nothing to be done for `all-deps'.
make[1]: Leaving directory `/usr/src/alsa/alsa-driver-1.0.7rc2'

Please, run the configure script as first...

rm -f /snd*.*o /persist.o /isapnp.o
make[1]: Entering directory `/usr/src/alsa/alsa-driver-1.0.7rc2/acore'
Makefile:6: /usr/src/alsa/alsa-driver-1.0.7rc2/Makefile.conf: No such file or directory
make[1]: *** No rule to make target `/usr/src/alsa/alsa-driver-1.0.7rc2/Makefile.conf'.  Stop.
make[1]: Leaving directory `/usr/src/alsa/alsa-driver-1.0.7rc2/acore'
make: *** [install-modules] Error 1


Wat wordt hiermee bedoeld?


Je hebt waarschijnlijk een 2.6 kernel en je probeert de howto voor 2.4 kernels te volgen. De 2.6 kernels hebben alsa al ingebouwd in de kernel zodat zowat alle alsa ebuild in portage overbodig zijn voor die kernel.
_________________
Fvwm|Fvwm forum
Back to top
View user's profile Send private message
Grik
Tux's lil' helper
Tux's lil' helper


Joined: 30 Sep 2004
Posts: 88
Location: Netherlands

PostPosted: Thu Nov 04, 2004 8:46 pm    Post subject: Reply with quote

Ik heb het probleem al door; ik had het niet ingebakken als module. Met een nieuwe kernel is het me gelukt om te installeren, met behulp van deze handleiding.

Ik kom alleen hier niet uit:

The snddevices script sets the permissions for the devices it creates to root. You should
Code:
chmod a+rw /dev/dsp /dev/mixer /dev/sequencer /dev/midi


Nu snap ik wat er bedoeld wordt, maar als ik dit regeltje uitvoer, bestaan al deze directories niet.
De voornaamste, /dev/dsp dus ook niet.
Hoe krijg ik deze geinstalleerd? Ik heb heel de handleiding gevolgd, en ik heb geen errors voorbij zien komen.
Back to top
View user's profile Send private message
theBlackDragon
l33t
l33t


Joined: 23 Nov 2002
Posts: 762
Location: Gent (Belgium)

PostPosted: Thu Nov 04, 2004 9:31 pm    Post subject: Reply with quote

Grik wrote:
Ik heb het probleem al door; ik had het niet ingebakken als module. Met een nieuwe kernel is het me gelukt om te installeren, met behulp van deze handleiding.

Ik kom alleen hier niet uit:

The snddevices script sets the permissions for the devices it creates to root. You should
Code:
chmod a+rw /dev/dsp /dev/mixer /dev/sequencer /dev/midi


Nu snap ik wat er bedoeld wordt, maar als ik dit regeltje uitvoer, bestaan al deze directories niet.
De voornaamste, /dev/dsp dus ook niet.
Hoe krijg ik deze geinstalleerd? Ik heb heel de handleiding gevolgd, en ik heb geen errors voorbij zien komen.


Heb je je pc in de tussentijd nog herstart? Indien niet, probeer dat dan eens :)

hth
_________________
Fvwm|Fvwm forum
Back to top
View user's profile Send private message
Grik
Tux's lil' helper
Tux's lil' helper


Joined: 30 Sep 2004
Posts: 88
Location: Netherlands

PostPosted: Fri Nov 05, 2004 7:24 am    Post subject: Reply with quote

theBlackDragon wrote:
Grik wrote:
Ik heb het probleem al door; ik had het niet ingebakken als module. Met een nieuwe kernel is het me gelukt om te installeren, met behulp van deze handleiding.

Ik kom alleen hier niet uit:

The snddevices script sets the permissions for the devices it creates to root. You should
Code:
chmod a+rw /dev/dsp /dev/mixer /dev/sequencer /dev/midi


Nu snap ik wat er bedoeld wordt, maar als ik dit regeltje uitvoer, bestaan al deze directories niet.
De voornaamste, /dev/dsp dus ook niet.
Hoe krijg ik deze geinstalleerd? Ik heb heel de handleiding gevolgd, en ik heb geen errors voorbij zien komen.


Heb je je pc in de tussentijd nog herstart? Indien niet, probeer dat dan eens :)

hth


Ja, meerdere keren, maar dit helpt niets.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum