Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.9-gentoo-r1 (gentoo-dev-sources) doesn't work on a 7300
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
skunkworx
Guru
Guru


Joined: 02 Feb 2003
Posts: 420
Location: Planet Houston

PostPosted: Sun Nov 07, 2004 6:27 am    Post subject: 2.6.9-gentoo-r1 (gentoo-dev-sources) doesn't work on a 7300 Reply with quote

Hello all.

I am unable to boot my OldWorld PowerMac 7300/200 (upgraded to a G3) when using a gentoo-dev-sources 2.6.9-r1 kernel. The last kernel I compiled for this machine was gentoo-dev-sources 2.6-7-r14, and it works fine. When I try to boot with the 2.6.9-r1 kernel, I see random dots strewn across the screen immediately after the bootloader (BootX) switches to linux, and the boot goes no further.

I suspect this is a problem with frame buffer support for the 7300. Whenever I had compiled previous kernels without the correct frame buffer driver, I would see the same video garbage I'm seeing with 2.6.9-r1. However, the older kernels would still boot, I just wouldn't be able to see console text. 2.6.9-r1 will not boot at all.

When updating my kernel configuration from 2.6.7-r14 to 2.6.9-r1, I did not enable any new features. I noticed there were some new frame buffer features available, but I opted out of all of them. My kernel configuration can be seen here.

Is anybody aware of an issue with frame buffer support or other problems affecting the 7300 in the latest kernels? Or maybe there's something else I should be enabling in the kernel now. Any help will be appreciated. Thanks!
_________________
Proud to be a... eh, forget it.

"Everyday is just one day." -- not the Traveling Wilburys
Back to top
View user's profile Send private message
cummings66
n00b
n00b


Joined: 22 Feb 2004
Posts: 42
Location: Moberly, MO

PostPosted: Sun Nov 07, 2004 2:44 pm    Post subject: Reply with quote

I am running on a 7200/90 for fun, sort of. It's close to what you have and I noticed you don't have some of the configuration items I do. I'm running the 2.6.9 kernel at this point with no problems and wonder if there's a lot of difference between it and the -r1?

After I finish emerging qt I'll try it out, but qt takes forever to emerge on this platform.
Back to top
View user's profile Send private message
pre_pl
n00b
n00b


Joined: 04 Nov 2004
Posts: 6

PostPosted: Mon Nov 08, 2004 10:03 am    Post subject: Reply with quote

I got also problems booting my system (Mac G4 Gigabit eth)

Exactly the same kernel, but I did not take a closer look at the options ...
Back to top
View user's profile Send private message
skunkworx
Guru
Guru


Joined: 02 Feb 2003
Posts: 420
Location: Planet Houston

PostPosted: Tue Nov 09, 2004 3:08 am    Post subject: Reply with quote

cummings66 wrote:
I'm running the 2.6.9 kernel at this point with no problems and wonder if there's a lot of difference between it and the -r1?


I don't know, but I'll have a go at 2.6.9 and see what happens. I would be interested to know what your results are with 2.6.9-r1, also. Thanks!
_________________
Proud to be a... eh, forget it.

"Everyday is just one day." -- not the Traveling Wilburys
Back to top
View user's profile Send private message
skunkworx
Guru
Guru


Joined: 02 Feb 2003
Posts: 420
Location: Planet Houston

PostPosted: Wed Nov 10, 2004 2:56 am    Post subject: Reply with quote

No luck with 2.6.9 either, I'm afraid. For what it's worth, I believe the 7200 and 7300 have some differences under the hood. I remember back when the 7200 first came out that there was a hardware "upgrade path" available that bumped it to the equivalent of the 7600, which (I think) was essentially a 7300 with some A/V capture hardware and a slower processor.

Anyway, I guess I'll stick with 2.6.7-r14 until the next revision comes out, unless there are other suggestions. Thanks for the input so far!
_________________
Proud to be a... eh, forget it.

"Everyday is just one day." -- not the Traveling Wilburys
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum