Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error installing (using bootstrap.sh) (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
paer
n00b
n00b


Joined: 10 Nov 2004
Posts: 5

PostPosted: Wed Nov 10, 2004 1:57 pm    Post subject: Error installing (using bootstrap.sh) (solved) Reply with quote

Hi!

Background:
I'm trying to install Gentoo 2004.2 on my Powerbook G4 867MHz, alongside with Mac OS X Panther. I'm following the PPC Handbook (www.gentoo.org/doc/en/handbook/handbook-ppc.xml) and also having a look at some other sites (mainly about partitioning with Mac OS X). Everything looks fine, although I did have a few problems trying to boot from the CD (mini-install). I simply had to throw it away and use the (big) universal live cd instead. I think this was because some issues with a firmware update by Mac OS X <10.2.8.

The next problem was unpacking the stage1-file from the installation disc (I couldn't find it anywhere on the mirrors.xml so I had to go with the supplied one on the disc). I got a lot of errors but it seems like I found the answer at https://forums.gentoo.org/viewtopic.php?t=243607, that is mounting the dev filessystem AFTER unpacking the stage. I think this fixed it (at least I didn't get anymore errors at that point), but I guess it's good if I mention it here because maybe someone else can see that I actually did wrong at this step and tell me how to do it right.

Anyway:

The problem:
When trying to bootstrap ("6.c. Progressing from Stage1 to Stage2", http://www.gentoo.org/doc/en/handbook/handbook-ppc.xml?full=1#book_id2744890_chap3), I get the following errors (I have already - successfully - done "cd /usr/portage; scripts/bootstrap.sh -f" to fetch the sources in advance):

Code:
Could not run/locate "gcc"
Could not run/locate "gcc"
ldd: ./libctest: No such file or directory
rm: cannot remove 'libctest': No such file or directory
Could not run/locate "gcc"
make: *** [libsandbox.o] Error 1

!!! ERROR: sys-apps/portage-2.0.51-r3 failed.
!!! Function src_compile, Line 77, Exitcode 2
!!! (no error message)


I have no idea why this happens. My only guess was the untarring problems I had before, but when doing the dev-mounting afterwards instead of forwards I got away from that error. So please give me a point in the right direction!


I'm sorry if I'm not making myself clear due to bad english or me being a beginner with gentoo, please ask for further details if needed.

Thanks for helping.
Back to top
View user's profile Send private message
paer
n00b
n00b


Joined: 10 Nov 2004
Posts: 5

PostPosted: Wed Nov 10, 2004 5:36 pm    Post subject: Re: Error installing (using bootstrap.sh) (solved) Reply with quote

OK, after chatting at IRC with atac (thanks!) it seems like the problem is solved. atac pointed me at https://bugs.gentoo.org/show_bug.cgi?id=23338, where gcc-config was mentioned.

I did "gcc-config powerpc-unknown-linux-gnu-3.3.3" and "source /etc/profile" and then everything was fine.

I hope this will help anyone else having this problem.
Back to top
View user's profile Send private message
syrex314
n00b
n00b


Joined: 29 Jul 2003
Posts: 25

PostPosted: Fri Jan 14, 2005 3:21 am    Post subject: thanks Reply with quote

Thanks for posting this solution-- I just ran into the same problem. Is there a reason this is not in the installation handbook?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum