Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problema: Rato PS/2 Not Working
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
verde
n00b
n00b


Joined: 09 Nov 2004
Posts: 6
Location: Braga

PostPosted: Thu Nov 11, 2004 10:02 am    Post subject: Problema: Rato PS/2 Not Working Reply with quote

Eu tenho o gentoo-2.6.9-r1 e o meu rato optico PS/2 (Samsung) não funciona.

Já recompilei o kernel e o suporte para ratos PS/2 esta activado.

Quando instalei o gentoo a partir do livecd ,o rato, estava a darm, mas a partir da instalaçao
deixou de dar (durante a instalação compilei o kernel com o genkernel, e como já referi, voltei
a recompila-lo, manualmente, mais tarde e continua a nao dar).

Se alguém me poder ajudar com mais um problema com o meu gentoo era mto fixe.

OBRIGADO.
Thanks.
Back to top
View user's profile Send private message
bozoh
n00b
n00b


Joined: 15 Nov 2004
Posts: 5
Location: Natal-RN-Brasil

PostPosted: Mon Nov 15, 2004 4:11 pm    Post subject: X Reply with quote

já tentou configurar o servidor X ?! (X.org ou XFree)
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7695
Location: Pelotas, BR

PostPosted: Tue Nov 16, 2004 12:01 am    Post subject: Reply with quote

Ou instalou o pacote gpm? Se ele estava usando o LiveCD, acho que ele nao estava falando de mouse no X.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
verde
n00b
n00b


Joined: 09 Nov 2004
Posts: 6
Location: Braga

PostPosted: Wed Nov 17, 2004 12:20 pm    Post subject: Reply with quote

Quando estava a fazer a instalaçao do gentoo, a partir do LiveCD, o rato estava a funcionar.
Ao fim de fazer o reboot, no final da instalaçao, o rato nunca mais deu.
O problema nao está em ele dar ou nao no X (é claro que é isso que eu quero,
ja agora estou a utilizar o Xorg e tenho o rato configurado para dar), mas o maior problema e que ele nao da em parte nenhuma...

Quando faço #cat /dev/psaux ou #cat /dev/mouse (agora nao tenho a certeza se é /dev/psaux ou /etc/psaux) nao aprarece NADA.

Já recompilei o kernel e tenho o suporte para ps2 activado, nao sei se é necessária mais alguma opção activada no kernel ou se e necessário
instalar mais qualquer coisa.

Obrigado....
Back to top
View user's profile Send private message
Hal[PT]
n00b
n00b


Joined: 09 Feb 2003
Posts: 33
Location: Lisbon

PostPosted: Fri Dec 10, 2004 7:15 pm    Post subject: Reply with quote

Pois... eu agora tou com o mesmo problema. Não pegava no pc há algum tempo já e quando ontem peguei o rato não funcionava.

Hoje com mais atenção conferi o setup do meu kernel... ps/2 enabled e mesmo no dmesg ele parece reconhecer o rato ao ponto de dar o tipo certo de rato no meio das mensagens (dmesg | grep mice).

No entanto o rato não funciona nem na consola (gpm) nem no X. Fui ver se tinha saltado para outro device, mas um cat (ou um oc) a qualquer que seja o device candidato (mice, mouse0, mouse1, ... psaux, ...) ou não dá nada (mesmo movendo furiosamente o rato) ou dá que o device não existe.

verde, já passou quase 1 mês desde esse post... sempre conseguiste resolver o problema? É que esta thread foi tipo das primeiras referências que têm a ver que eu encontrei :P ao menos já serve para saber que não sou o único.
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Fri Dec 10, 2004 9:30 pm    Post subject: Reply with quote

Você compilou o link psaux no kernel? O psaux é um dispositivo de legado, e que é ligado à /dev/mice, que por sua vez é um aglomerado de todos os mouses ligados, /dev/mouseX. Tenta fazer um cat no /dev/input/mouse0 ou /dev/input/mice.
_________________
RTFM!
Back to top
View user's profile Send private message
verde
n00b
n00b


Joined: 09 Nov 2004
Posts: 6
Location: Braga

PostPosted: Tue Dec 14, 2004 2:24 pm    Post subject: Reply with quote

Tecnicamente o problema ficou resolvido quando comprei um rato USB,
no entanto o no que diz respeito ao rato ps2 continuei com o mesmo problema.

Nem eu nem os meus colegas conseguimos resolver o problema.


Obrigado pelos que tentaram ajudar
8)
Back to top
View user's profile Send private message
GothicKnight
Tux's lil' helper
Tux's lil' helper


Joined: 02 Aug 2004
Posts: 123
Location: Santa Maria da Feira/Portugal

PostPosted: Wed Dec 22, 2004 1:12 am    Post subject: Reply with quote

Tenta criar um gerador de eventos para o rato metendo a seguinte opção no kernel

Device Drivers-->Input Device Suport-->Event Interface [*]

Eu tive um problema parecido com o meu touchpad... ele é PS/2, não sei se pode ajudar mas tentar não custa nada.
_________________
Se a vida não te sorri... Faz-lhe cocegas.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum