Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ADB mouse not working with 1.4 PPC
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
lazloman
Guru
Guru


Joined: 27 Dec 2003
Posts: 343
Location: Skokie, Il. USA

PostPosted: Sat Dec 27, 2003 5:01 pm    Post subject: ADB mouse not working with 1.4 PPC Reply with quote

I've done a quick search and see this is not uncommon for older PPC's, but there does not seem to be a definitive fix. Anyway, here's the mouse input section of my config file. I've played around with this section several ways, changi Protocol to "Auto" or "ImPS/2" but nothing works. If anyone has any tips, please pass them on. By the way X starts up just fine. I have not yet installed a WM, but once the mouse is working I'll try that.

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Busmouse"
Option "Device" "/dev/input/mice"

# Mouse-speed setting for PS/2 mouse.

# Option "Resolution" "256"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

# Option "Protocol" "Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

# Option "BaudRate" "9600"
# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

# Option "Emulate3Buttons"
# Option "Emulate3Timeout" "50"

# ChordMiddle is an option for some 3-button Logitech mice

# Option "ChordMiddle"

EndSection
_________________
Gentoo x86
2x Dell Optiplex GX200

"My Break-Dancing days are over, but there's always the Funky Chicken."
--The Full Monty
Back to top
View user's profile Send private message
bahkyp
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jul 2002
Posts: 86
Location: Sydney Australia

PostPosted: Sun Nov 21, 2004 11:35 pm    Post subject: Reply with quote

Ok, haven't booted the 7600 in a while and was looking how to get Screen Resolution but may as wall answer this while here.

I have a mouseman logitech 3 button ADB mouse. It worked out of the box. I can check the settings but yours look wrong. I did not use logitech mouse settings just generic settings.

The mouse was ps/2 not busmouse. (busmouse is PC not PPC).

I used Xautoconf to set the mouse correctly, not xeasyconfig. (Xfree setup was a 2 step process, Xautoconf then xeasyconfig)

The kernel had some settings in it as well for memory for the mouse. These may be missing / not set in later Kernels as older support drops.
_________________
I'm so small, I can fit under the door.
I was here yesterday, this is a recording.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum