Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to reboot after installing the base system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
deep
n00b
n00b


Joined: 04 May 2004
Posts: 9

PostPosted: Thu Dec 02, 2004 3:05 pm    Post subject: Unable to reboot after installing the base system Reply with quote

Hi, all
I'm trying to install gentoo on my albook 15" along side debian/sid. In yaboot.conf configured in debian I have some thing like this:

#for debian
label=Linux
partition=4
root=/dev/hda4
initrd=....

#for gentoo
label=Gentoo
partition=7
root=/dev/hda7
sysmap = System.map
read-only

The problem occurs when I boot Gentoo. It hangs while it's trying to check my root filesystem, the output error look like this:

*checking root file system
ext2fs_check_if_mount : no such file or directory while determining whether /dev/hda7 is mounted
fsck.ext3:no suchh file .....
*filesystem couldn't be fixed

It seems that I've missed something during the installation, but I don't know where :-(
Any help would be appreciated
Best regards
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Thu Dec 02, 2004 3:27 pm    Post subject: Reply with quote

Quote:
*checking root file system
ext2fs_check_if_mount : no such file or directory while determining whether /dev/hda7 is mounted
fsck.ext3:no suchh file .....
*filesystem couldn't be fixed


i would say you didnt emerge the fs specific tools (xfsprogs, e2fsprogs, etc) as it cannot find fsck.ext3 f.ex.
Double check the fstab too; maybe you can bring it to boot by changing the latest numbers in each line ( somthing like 1 1 at the end) to 0 0.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
deep
n00b
n00b


Joined: 04 May 2004
Posts: 9

PostPosted: Thu Dec 02, 2004 3:52 pm    Post subject: Reply with quote

I sent my fstab file in the post above :

https://forums.gentoo.org/viewtopic.php?t=260911

I have the same prblem as discribe there.
Back to top
View user's profile Send private message
deep
n00b
n00b


Joined: 04 May 2004
Posts: 9

PostPosted: Thu Dec 02, 2004 6:16 pm    Post subject: Reply with quote

After emerging devfsd, I finaly managed to reboot my new Gentoo system. But, there's one more problem. When I try to log in it says:

Code:
login : PAM Failure, aborting : Critical error-immediate abort


Arrrrg :-(
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Thu Dec 02, 2004 7:14 pm    Post subject: Reply with quote

Quote:
login : PAM Failure, aborting : Critical error-immediate abort


no idea, i searched a bit in google and maybe this is helpful.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
deep
n00b
n00b


Joined: 04 May 2004
Posts: 9

PostPosted: Thu Dec 02, 2004 7:25 pm    Post subject: Reply with quote

It seems to a bug in the 2004.3 realease,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum