Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
k3b mp3->audio cd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
aronchi
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2004
Posts: 94

PostPosted: Fri Dec 03, 2004 1:11 am    Post subject: k3b mp3->audio cd Reply with quote

With k3b I get no errors on building audio-cds from mp3 collections, but when I try to listen to it my cds are made only of noises.

I have mp3 support and MAD, mp3 use vars into make.conf

What causes this problem?
_________________
Alessandro Ronchi Home Page
SOASI: Sviluppo Software e Sistemi Open Source Forlì
Back to top
View user's profile Send private message
hardcore
l33t
l33t


Joined: 01 Nov 2003
Posts: 626
Location: MSU, MI

PostPosted: Fri Dec 03, 2004 8:26 am    Post subject: Reply with quote

Have you tried converting the files to .wav manually, then listening to them?
_________________
Nothing can stop me now, cuz I just don't care.
Back to top
View user's profile Send private message
aronchi
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2004
Posts: 94

PostPosted: Fri Dec 03, 2004 11:38 am    Post subject: Reply with quote

No, I didn't.

How can I do that?
Does this test help me to solve the original problem, or it's only an alternaive way to burn the audio-cd?
_________________
Alessandro Ronchi Home Page
SOASI: Sviluppo Software e Sistemi Open Source Forlì
Back to top
View user's profile Send private message
hardcore
l33t
l33t


Joined: 01 Nov 2003
Posts: 626
Location: MSU, MI

PostPosted: Fri Dec 03, 2004 11:44 am    Post subject: Reply with quote

You can do it like this:
Code:
lame --decode blabla.mp3


If you can decode an mp3, then the problem is more than likely with k3b. Do you have ATAPI burning enabled, or is it SCSI emulation?
_________________
Nothing can stop me now, cuz I just don't care.
Back to top
View user's profile Send private message
aronchi
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2004
Posts: 94

PostPosted: Fri Dec 03, 2004 12:09 pm    Post subject: Reply with quote

I'm using 2.6.9 kernel, and I think I have atapi emulation. Other burnings of data-cd worked correctly. I have this problem only on audio cd from mp3.
_________________
Alessandro Ronchi Home Page
SOASI: Sviluppo Software e Sistemi Open Source Forlì
Back to top
View user's profile Send private message
bruda
Guru
Guru


Joined: 06 May 2004
Posts: 376
Location: Sherbrooke, QC, Canada

PostPosted: Fri Dec 03, 2004 1:19 pm    Post subject: Reply with quote

Sounds like an endianness issue to me. As suggested, try to decode your mp3s first with the same command used by k3b and see what you get. If that command is lame and you get static after this step, try to pass -x to lame and see whether this fixes things.

I have never used k3b specifically, but static audio is typically caused by failing to take endianness into consideration during audio encoding conversions.
_________________
Quid latine dictum sit altum videtur
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum