Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Enabling Japanese (or: CJK in KDE & Gnome)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6 ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2968
Location: Germany

PostPosted: Tue Aug 30, 2005 6:29 pm    Post subject: Reply with quote

I don't know what happened, but after an emerge world update, the Japanese support I had working is suddenly gone. Scim shows up as usual, but I can only select English/European or Raw Input. Support for Japanese language is gone completely.

What can have gone wrong? How do I get Japanese back?! :?
Back to top
View user's profile Send private message
eealex
n00b
n00b


Joined: 29 Oct 2004
Posts: 65
Location: Japan

PostPosted: Wed Aug 31, 2005 12:47 pm    Post subject: Reply with quote

Try emerge again the scim-anthy or scim-uim (which you have installed).
I have had a similar problem before.
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2968
Location: Germany

PostPosted: Thu Sep 01, 2005 5:28 pm    Post subject: Reply with quote

Okay, it looks like I overdid it a little with the re-emerging. Now I can not only input 日本語, but over 20 other languages as well, some of which I never heard of before. The language selection menu takes like half the screen when I click on it. Talk about crazy. ;-) Still, I wonder what broke it in the first place. I'll keep an eye on my emerge log should it ever happen again...

Thank you! :D
Back to top
View user's profile Send private message
yaneurabeya
Veteran
Veteran


Joined: 13 May 2004
Posts: 1754
Location: Seattle

PostPosted: Fri Sep 02, 2005 1:55 pm    Post subject: Reply with quote

Run SCIM's config to eliminate the unnecessary languages for input at least.
Back to top
View user's profile Send private message
jettjunker
Apprentice
Apprentice


Joined: 10 Sep 2005
Posts: 267

PostPosted: Mon Sep 12, 2005 5:11 am    Post subject: Reply with quote

I ran into a wall pretty early, when I try emerge world --newuse I get:

Code:
Calculating world dependencies ...done!
>>> emerge (1 of 8) dev-python/wxpython-2.4.2.4-r2 to /
>>> md5 files   ;-) wxpython-2.4.2.4-r2.ebuild
>>> md5 files   ;-) wxpython-2.6.0.0-r1.ebuild
>>> md5 files   ;-) wxpython-2.6.1.0.ebuild
>>> md5 files   ;-) wxpython-2.4.2.4.ebuild
>>> md5 files   ;-) files/wxversion.py
>>> md5 files   ;-) files/scripts-multiver-2.6.1.0.diff
>>> md5 files   ;-) files/digest-wxpython-2.4.2.4
>>> md5 files   ;-) files/digest-wxpython-2.6.1.0
>>> md5 files   ;-) files/wxpy-config.py
>>> md5 files   ;-) files/scripts-multiver-2.6.0.0.diff
>>> md5 files   ;-) files/digest-wxpython-2.4.2.4-r2
>>> md5 files   ;-) files/digest-wxpython-2.6.0.0-r1
>>> md5 src_uri ;-) wxPythonSrc-2.4.2.4.tar.gz
>>> Unpacking source...
>>> Unpacking wxPythonSrc-2.4.2.4.tar.gz to /var/tmp/portage/wxpython-2.4.2.4-r2/work
>>> Source unpacked.
!!! set-wxconfig: Error:  Can't find normal or debug version:
!!! set-wxconfig:         /usr/bin/wxgtk2u-2.4-config not found
!!! set-wxconfig:         /usr/bin/wxgtk2ud-2.4-config not found
!!! You need to emerge wxGTK with unicode in your USE


Well, there were 10 things but the first two went through fine.
I put unicode in my make.conf, as instructed, and re-emerged wxGTK. I even tried USE="unicode" emerge wxGTK to no avail.

Oh, and I am using gnome

PS: I'm more after Greek and German than Japanese (though I do sorta want it too), I can get those working through the same stuff, right?
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2968
Location: Germany

PostPosted: Mon Sep 12, 2005 6:17 am    Post subject: Reply with quote

Greek, yes. German, I don't know. When I select "English/Keyboard" in SCIM, I actually get my default layout (which is already in German). So I never tried typing umlauts using scim...
Back to top
View user's profile Send private message
valuial
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2004
Posts: 85

PostPosted: Mon Sep 12, 2005 12:55 pm    Post subject: Reply with quote

To write German umlauts, just set youre Keyboard layout with the Gnome utility (I'm no Gnomer, so I don't know how it is called). I switch between English layout and German layout using the KDE Keyboard Tool, an icon in the task tray...

English/Keyboard only disables the scim engine...

Could be the same with greek, too.
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2968
Location: Germany

PostPosted: Mon Sep 12, 2005 1:02 pm    Post subject: Reply with quote

Must be annoying for a foreigner having to learn german keyboard layout. I know it took me a long time fiddling about finding the keys for us keyboard. The letters are the same execpt switched Y/Z, but everything else is different. It'd probably be easier to just bind the umlauts somewhere.
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Tue Sep 13, 2005 1:45 am    Post subject: Reply with quote

brjames wrote:
Anyway, Suderian if you could please update the front page... I did a text search on the first page so I didnt just miss it (my that would be embarrassing).


Sure, burinnjames :roll:

Seriously, I have a prefence for gtk, but will test this when I can. A placeholder note is up for now.

Should probably make a disclaimer for the Unicode tag and Wx* - I have run into problems there before.

Due to PMs and IMs I've gotten, I'm thinking of a partial rewrite... too many times of not quite knowing if it is UIM or SCIM that is the problem.

At that point I'll make a wiki copy, with the usual 'this info may be old' disclaimer. http://gentoo-wiki.com has the request, anyways.

-Sud.


17672 hits !?! I hope most of those aren't people with trouble...
_________________
...
Back to top
View user's profile Send private message
jettjunker
Apprentice
Apprentice


Joined: 10 Sep 2005
Posts: 267

PostPosted: Tue Sep 13, 2005 9:07 am    Post subject: Reply with quote

Cool, thanks for the info. German works just great using the gnome keyboard utility, since it only needs an extra 7 letters. The greek doesn't really work, since it needs major accent support.

I did, however, find Thessalonica, which works great for my purposes (only need greek for oowriter). you will need java jdk and jre. I had problems with the blackdown one (so unmerged it), but sun worked fine once i set it as default java jdk and re-emerged openoffice-ximian with java in the USE. I don't know if the re-emerge was necessary (or the USE flag), but that got around problems I was having before. (jvmsetup missing, or simply not saving)



Sorry that is a bit off topic, but I figured I would post the info for anyone who comes here from a search.
Back to top
View user's profile Send private message
Jenden
n00b
n00b


Joined: 14 Nov 2004
Posts: 59

PostPosted: Sun Oct 23, 2005 4:55 am    Post subject: Reply with quote

Ok, I've gotten SCIM working for firefox, gaim, gedit, and xterm, but for the life of me I can't get it to work in Open Office. I'm running openoffice-bin 2.0.0 and put the following in my .xprofile:
Code:
LC_CTYPE=ja_JP.UTF-8
export GTK_IM_MODULE=scim
export XMODIFIERS=@im=SCIM


I actually had scim working at one point in OO, but the enxt time I opened it up it wasnt' wroking anymore.... so I know I've got everything somewhere, its just gotta be a setting somewhere I'm missing.
Back to top
View user's profile Send private message
lo-jay
l33t
l33t


Joined: 27 Feb 2005
Posts: 862

PostPosted: Thu Oct 27, 2005 10:06 pm    Post subject: can't launch skim w/ ctrl space? Reply with quote

got scim / skim-1.41 installed, got the little icon, but can't launch it with crt space -
how's that :?:

my .xinitrc looks like this
Code:

export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim
export LC_CTYPE="zh_CN.GBK"


 skim -d



thanks!
_________________
lo-jay

The mechanic "One of 'em Dodge Chargers - let him go by."
The driver "Not today!"

taken from "Two Lane Blacktop"
Back to top
View user's profile Send private message
melange
Tux's lil' helper
Tux's lil' helper


Joined: 16 Sep 2004
Posts: 110

PostPosted: Sun Oct 30, 2005 6:17 pm    Post subject: Reply with quote

MrPixel wrote:
I have tried repeatedly to follow the instructions above (except I don't need input for any Qt apps (or are Firefox and Thunderbird Qt?), so I skip that part), I but keep getting the same problem: SCIM crashes almost everything I try to run: gedit, Firefox, Thunderbird. When trying to run from a terminal, this error is generated:
Code:
*** glibc detected *** free(): invalid pointer: 0x08295f78 ***


I also have this problem :(

does anyone know how to fix it?

NB: I'm don't have ACCEPT_KEYWORDS="~x86" in my make.conf !
Back to top
View user's profile Send private message
NebuK
n00b
n00b


Joined: 07 Nov 2005
Posts: 2

PostPosted: Mon Nov 07, 2005 11:54 pm    Post subject: Reply with quote

hi guys ...

this guide helped my very much ... thanks alot :P


but i stil have 2 little problems ... whereas one has almost nothing to do with scim i assume.

the first thing is that whenever i start a urxvt or uxterm or whatever terminal with LANG=ja_JP.UTF-8 and LC_ALL=ja_JP.UTF-8 the startup takes about 40 seconds to one minute. this is rahter getting on your nerves with the time :P i tried around a bit and figured out what it is ...

Code:

read(5, "\1\242\0\332\0\0\0\17\0\1\371\371\377\377\377\377\20&\247"..., 32) = 32
readv(5, [{"8-misc-fixed-bold-r-normal--13-1"..., 60}, {"", 0}], 2) = 60
writev(5, [{"1\1\0\v\0\1\0#", 8}, {"-*-*-*-R-*-*-13-*-*-*-*-*-ISO885"..., 35}, {"\0", 1}], 3) = 44
read(5, "\1\242\0\333\0\0\0\17\0\1\371\371\377\377\377\377\20&\247"..., 32) = 32
readv(5, [{"8-misc-fixed-bold-r-normal--13-1"..., 60}, {"", 0}], 2) = 60
writev(5, [{"1\1\0\v\0\1\0#", 8}, {"-*-*-*-R-*-*-13-*-*-*-*-*-ISO885"..., 35}, {"\0", 1}], 3) = 44
read(5, "\1\242\0\334\0\0\0\17\0\1\371\371\377\377\377\377\20&\247"..., 32) = 32
readv(5, [{"8-misc-fixed-bold-r-normal--13-1"..., 60}, {"", 0}], 2) = 60
writev(5, [{"1\1\0\r\0\1\0)", 8}, {"-*-*-*-R-*-*-13-*-*-*-*-*-JISX02"..., 41}, {"\0\0\0", 3}], 3) = 52
read(5, "\1\242\0\335\0\0\0\22\0\1\371\371\377\377\377\377\20&\247"..., 32) = 32
readv(5, [{"D-misc-kochi gothic-medium-r-nor"..., 72}, {"", 0}], 2) = 72
writev(5, [{"1\1\0\f\0\1\0(", 8}, {"-*-*-*-R-*-*-13-*-*-*-*-*-KSC560"..., 40}], 2) = 48
read(5, 0x7ffe6d50, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(6, [5], NULL, NULL, NULL)        = 1 (in [5])
read(5, "\1\242\0\336\0\0\0\0\0\0\371\371\377\377\377\377\20&\247"..., 32) = 32
writev(5, [{"1\1\0\f\0\1\0(", 8}, {"-*-*-*-R-*-*-14-*-*-*-*-*-KSC560"..., 40}], 2) = 48
read(5, 0x7ffe6d50, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(6, [5], NULL, NULL, NULL)        = 1 (in [5])
read(5, "\1\242\0\337\0\0\0\0\0\0\371\371\377\377\377\377\20&\247"..., 32) = 32
writev(5, [{"1\1\0\f\0\1\0(", 8}, {"-*-*-*-R-*-*-12-*-*-*-*-*-KSC560"..., 40}], 2) = 48
read(5, 0x7ffe6d50, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(6, [5], NULL, NULL, NULL)        = 1 (in [5])
read(5, "\1\242\0\340\0\0\0\0\0\0\0\214\0\0\0\6\20\'5\370\0\0\2"..., 32) = 32
writev(5, [{"1\1\0\f\0\1\0(", 8}, {"-*-*-*-R-*-*-11-*-*-*-*-*-KSC560"..., 40}], 2) = 48
read(5, 0x7ffe6d50, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(6, [5], NULL, NULL, NULL)        = 1 (in [5])
read(5, "\1&\0\341\0\0\0\0\0\0\376t\0\0\0\6\20\'5\370\0\0\2\324"..., 32) = 32
writev(5, [{"1\1\0\f\0\1\0(", 8}, {"-*-*-*-R-*-*-15-*-*-*-*-*-KSC560"..., 40}], 2) = 48
read(5, 0x7ffe6d50, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(6, [5], NULL, NULL, NULL)        = 1 (in [5])
read(5, "\1\377\0\342\0\0\0\0\0\0\371\371\377\377\377\377\20&\247"..., 32) = 32
writev(5, [{"1\1\0\6\0\1\0\20", 8}, {"*-KSC5601.1987-0", 16}], 2) = 24
read(5, 0x7ffe6d50, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(6, [5], NULL, NULL, NULL)        = 1 (in [5])
read(5, "\1&\0\343\0\0\0\0\0\0\376t\0\0\0\6\20\'5\370\0\0\2\324"..., 32) = 32
writev(5, [{"1\1\0\7\0\1\0\22", 8}, {"*-*-KSC5601.1987-0", 18}, {"\0\0", 2}], 3) = 28
read(5, 0x7ffe6d50, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(6, [5], NULL, NULL, NULL)        = 1 (in [5])
read(5, "\1&\0\344\0\0\0\0\0\0\0\300\0\0\0\6\20\'5\370\0\0\2\324"..., 32) = 32
writev(5, [{"1\1\0\7\0\1\0\24", 8}, {"*-*-*-KSC5601.1987-0", 20}], 2) = 28
read(5, 0x7ffe6d50, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(6, [5], NULL, NULL, NULL)        = 1 (in [5])
read(5, "\1\377\0\345\0\0\0\0\0\0\371\371\377\377\377\377\20&\247"..., 32) = 32
writev(5, [{"1\1\0\10\0\1\0\26", 8}, {"*-*-*-*-KSC5601.1987-0", 22}, {"\0\0", 2}], 3) = 32
read(5, 0x7ffe6d50, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(6, [5], NULL, NULL, NULL)        = 1 (in [5])
read(5, "\1&\0\346\0\0\0\0\0\0\376x\0\0\0\6\20\'5\370\0\0\2\377"..., 32) = 32
writev(5, [{"1\1\0\10\0\1\0\30", 8}, {"*-*-*-*-*-KSC5601.1987-0", 24}], 2) = 32
read(5, 0x7ffe6d50, 32)                 = -1 EAGAIN (Resource temporarily unavailable)
select(6, [5], NULL, NULL, NULL <unfinished ...>


urxvt seems to brute-force checking which fonts are available and which arent ... what do i have to install or disable so urxvt starts instantly? :(

the other - more unimportant - thing is firefox ... in firefox the fonts became really really small if you start ff with LANG and LC_ALL set to ja_JP.UTF-8 ... not a major issue, but its getting on ones eyes :P

well ... it would be really really nice if you could help me :P

also sorry for my crappy english ... german fellow and its already a bit too late for writing good english :P please forgive me.

thanks for reading :P, and again thanks for the great guide :P
Back to top
View user's profile Send private message
BillyD
Guru
Guru


Joined: 05 May 2002
Posts: 315
Location: Australia

PostPosted: Tue Nov 08, 2005 3:35 am    Post subject: Reply with quote

Hi NebuK,

I have no idea about your issues with urxvt, but I might have a suggestion that could help your Firefox problems (might not too ;) ). Have you tried setting the font size to something larger under Edit>Preferences>General>Fonts & Colours? Perhaps that will fix your issue.
_________________
We used to have hominid cousins that were vegetarian. The palæontological record suggests that our ancestors killed them and ate them.
Back to top
View user's profile Send private message
NebuK
n00b
n00b


Joined: 07 Nov 2005
Posts: 2

PostPosted: Tue Nov 08, 2005 12:21 pm    Post subject: Reply with quote

thats the strange thing with firefox ... simply setting the fontsize to something higher doesnt work. it works for the content - but not for menus, etc. ... it seems like theres no setting affecting the menu font size :(

ive also looked through about:config - maybe i'm just blind, but i didnt find anything :(

btw: the font thing became even more strange ... ive tried around a bit, and realized, that the "slow startup" happens with every .UTF-8 LANG/LC_ALL ... i just dont understand it :/

also ive tried to set the font paths (/usr/share/fonts/kochi-substitute, mika-chan and jisx0239(or some other number - forgot)) both in xorg.conf and /etc/X11/fs/cofig ... no luck with that one :(
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Sat Nov 19, 2005 1:55 am    Post subject: Reply with quote

So, 10 months and a fresh install of Gentoo later, Japanese input doesn't go. I select anthy or canna for the input method, start typing in a GTK app, and all I get is the english characters. KDE apps don't even let me change input methods.

Here's my .xprofile file:
Code:
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim
export LANG=en_NZ.UTF-8
export LC_CTYPE=ja_JP.UTF-8


I'm wondering if it's not picking up the correct font somehow. I use Bitstream Vera Sans as default everywhere, and I know that doesn't have the required characters, but it should pick up kochi-substitute when I switch to Japanese input, at least that's what it did on my old Gentoo install.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
AmosMutke
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 235
Location: Akita, Japan.

PostPosted: Sat Nov 19, 2005 11:54 am    Post subject: Reply with quote

Biggles wrote:
So, 10 months and a fresh install of Gentoo later, Japanese input doesn't go. I select anthy or canna for the input method, start typing in a GTK app, and all I get is the english characters. KDE apps don't even let me change input methods.


I'm assuming you have followed the HOWTO and have all the correct software installed, but can you provide more info.

what does "locale" dispaly

here's mine
Code:
 me> locale
LANG=en_US.UTF-8
LC_CTYPE=ja_JP.utf8
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=


what USE variables did you have set when you emerged scim? What window manager(s) are you using? (more specificly, QT or GKT interface)
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Sat Nov 19, 2005 10:19 pm    Post subject: Reply with quote

locale:
Code:
LANG=en_NZ.UTF-8
LC_CTYPE=ja_JP.UTF-8
LC_NUMERIC="en_NZ.UTF-8"
LC_TIME="en_NZ.UTF-8"
LC_COLLATE="en_NZ.UTF-8"
LC_MONETARY="en_NZ.UTF-8"
LC_MESSAGES="en_NZ.UTF-8"
LC_PAPER="en_NZ.UTF-8"
LC_NAME="en_NZ.UTF-8"
LC_ADDRESS="en_NZ.UTF-8"
LC_TELEPHONE="en_NZ.UTF-8"
LC_MEASUREMENT="en_NZ.UTF-8"
LC_IDENTIFICATION="en_NZ.UTF-8"
LC_ALL=


uses for scim:
Code:
app-i18n/scim-1.4.2  +gtk -immqt +immqt-bc


I use XFCE4 as my WM, and I use both GTK and QT apps. Scim does run, I get the switcher icon in the taskbar and can tell it to switch. It just doesn't appear to actually do anything. :)
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
kloune
Apprentice
Apprentice


Joined: 09 May 2004
Posts: 185
Location: lost

PostPosted: Sun Nov 20, 2005 12:04 am    Post subject: Reply with quote

Same problem here too, scim was working without problem for 2 month now and now, suddenly, it stopped working, everything looks right and i can't remember changing any configuration. It just doesn't seem to capture any characters anymore.
Back to top
View user's profile Send private message
AmosMutke
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 235
Location: Akita, Japan.

PostPosted: Sun Nov 20, 2005 1:39 am    Post subject: Reply with quote

Biggles wrote:

uses for scim:
Code:
app-i18n/scim-1.4.2  +gtk -immqt +immqt-bc


I use XFCE4 as my WM, and I use both GTK and QT apps. Scim does run, I get the switcher icon in the taskbar and can tell it to switch. It just doesn't appear to actually do anything. :)


Interesting, for some reason I have "LC_CTYPE=ja_JP.utf-8" and you have "LC_CTYPE=ja_JP.UTF-8". I have "export LC_CTYPE=ja_JP.UTF-8" in /etc/xprofile, ~/.xprofile, and ~/.profile (for good measure). But yet the output of locale for me prints the UTF in lower case. I don't know the reason for this or if it matters.

The only peice missing should be the XMODIFIERS, GTK_IM_MODULE, and QT_IM_MODULE variables. I had the same problem. scim was starting, but I couldn't actually switch to JP input. It turned out that I had mis-entered the XMODIFIERS variable. Make sure you enter them EXACTLY as listed in the howto. It's (afaik) case sensitive. Once I fixed that, it started working.

This howto wrote:
Now, Qt needs an aditional step to use scim - GTK+-only users do not need this;

emerge skim

emerge scim-qtimm




kloune wrote:
Same problem here too, scim was working without problem for 2 month now and now, suddenly, it stopped working, everything looks right and i can't remember changing any configuration. It just doesn't seem to capture any characters anymore.


same advice. Check to see that all your variables are still being set correctly. ie, check the output of locale and the XMODIFIERS, and GTK_IM_MODULE/QT_IM_MODULE variables using echo. If all this seems ok, then I'd suggest re-emerging scim, anthy, and scim-anthy.
Back to top
View user's profile Send private message
kloune
Apprentice
Apprentice


Joined: 09 May 2004
Posts: 185
Location: lost

PostPosted: Sun Nov 20, 2005 12:07 pm    Post subject: Reply with quote

I checked all the variable again and the exports too, they are exactly as written in the turotial. I unmerged and emerged everything already twice and deleted all the scim config files before emerging again, so I think the problem is somewhere else.

There is one thing I forgot to tell that I noticed. In the small scim bar, usually i have the scim icon, then the pin, the current input method and some option for that input method and then the help/about icon. Now, the input method is still there, but the option for the input method are gone.

For the moment I'm using scim-uim with uim-anthy. If i try to use scim-anthy, everything crashes already at the beginning.
Back to top
View user's profile Send private message
AmosMutke
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 235
Location: Akita, Japan.

PostPosted: Sun Nov 20, 2005 2:17 pm    Post subject: Reply with quote

did you use the -immqt use flag when compiling scim? I guess that's unstable.
Also, when you start scim are you using "scim -f socket -c socket -d" ?
the command to start scim changed in a recent update. I don't know if this is related or not... I'm really just grasping at staws.

EDIT: also, give the scim-setup a try. maybe a config got messed up someplace. couldn't hurt to try.
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Sun Nov 20, 2005 8:50 pm    Post subject: Reply with quote

My .xprofile (and, now, my .profile and /etc/xprofile) all match the howto's versions and the versions I had in my old install. No change in behaviour.

Running scim-setup didn't help. I don't know what command starts scim as I don't start it myself, it starts automagically.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
AmosMutke
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 235
Location: Akita, Japan.

PostPosted: Sun Nov 20, 2005 10:39 pm    Post subject: Reply with quote

Biggles wrote:
I don't know what command starts scim as I don't start it myself, it starts automagically.


really? you don't load it in your .xinitrc file? RU sure it's running? I sounds like you can see the scim window, so it must be running.

Code:
 >ps -ef | grep scim
shawn     8579     1  0 Nov20 ?        00:00:00 /usr/lib/scim-1.0/scim-launcher -d -c socket -e all -f socket
shawn     8653     1  0 Nov20 ?        00:00:00 /usr/lib/scim-1.0/scim-helper-manager
shawn     8654     1  0 Nov20 ?        00:00:00 /usr/lib/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
shawn     8655  8654  0 Nov20 ?        00:00:00 /usr/lib/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
shawn     8656  8655  0 Nov20 ?        00:00:00 /usr/lib/scim-1.0/scim-panel-gtk --display :0.0 -c socket -d --no-stay
shawn    21038  8669  0 07:36 pts/0    00:00:00 grep scim


This is what I have listed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6 ... 10, 11, 12  Next
Page 5 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum