Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Enabling Japanese (or: CJK in KDE & Gnome)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
kloune
Apprentice
Apprentice


Joined: 09 May 2004
Posts: 185
Location: lost

PostPosted: Mon Nov 21, 2005 7:30 am    Post subject: Reply with quote

If you use GDM, KDM or XDM, you have to put the variable declarations
Code:

export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim

in the .xprofile file. Somehow, scim is started with that. Don't ask me exactly how it does it. Anyway, the scim things are running and the problem is that the input doesn't get captured. The scim bar is there and has some icons missing which were there before, but else, everything seems ok.

Furthermore, it worked for us before and somehow now it doesn't work anymore, so we can assume that the configuration was right at one point in time. Why would we change it if it works. I think it really has to be something else.
Back to top
View user's profile Send private message
AmosMutke
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 235
Location: Akita, Japan.

PostPosted: Tue Nov 22, 2005 1:40 am    Post subject: Reply with quote

Because it's possible something you emerged erased your config files in /etc. For example, I've had my /etc/fstab reset twice after emerges. I suppose it's partially my fault for always taking the "auto" -5 option when running etc-update, but the fact still remains that even an emerge sync could have caused changes in your /etc files.

And it's often the simple things that we overlook that is the problem. After I updated SCIM (about a month ago) it quit working completely. I had to go thru the whole howto process to try and fix it. After a couple days of re-emerging and trying several things, it turned out to be a typing mistake in XMODIFIERS=@im=SCIM

As soon as I fixed that, it worked fine. Before that I could see the scim panel, but I couldn't switch input methods... It appears you have this set correctly, so it must be something else. I was just trying to eliminate possibilities.
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Tue Nov 22, 2005 7:33 am    Post subject: Reply with quote

In my case it wouldn't be a config file being overwritten as I use cfg-update, which is much better about preventing accidental overwrites. However, I'm coming in with a fresh install of gentoo and have followed the HOWTO from scratch. When I compare to my old config files from my previous install, they're all identical.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
kroenecker
n00b
n00b


Joined: 10 Aug 2005
Posts: 64

PostPosted: Wed Nov 23, 2005 5:34 am    Post subject: Reply with quote

FYI

If you are using amd64 (or i686 for that matter), you don't have to install skim.

Just installing using the tutorial through scim-uim makes it easy enough. Make sure to make the proper environmental changes in the text files. Do the x server restart env-update etc and finally hit ctrl+space to start up scim-uim.

Done 8)
Back to top
View user's profile Send private message
hosikawafuzi
n00b
n00b


Joined: 24 Nov 2005
Posts: 2

PostPosted: Thu Nov 24, 2005 3:23 am    Post subject: Reply with quote

I've been reading through the thread, and I see a lot of info on modifying a system once it's up and running. Since Gentoo is so flexible in its installation process, is it possible to include everything needed for good Japanese integration from the very beginning?

I'm thinking of switching from Fedora to Gentoo, but I've gotten used to certain tools that come installed on a Fedora system. For instance, there is a panel in Gnome called the “ü—Í•ûŽ®ƒXƒCƒbƒ`. Is UIM the same basic thing?

Also, I use a Japanese 106 keyboard. I didn't read anything on how the UIM behaves with those keyboards. Such as ”¼Šp/‘SŠp button and the •ÏŠ· button. I prefer to be able to use my input buttons rather than having to stop what I'm typing and clicking on an IME applet.

Any information would be greatly appreciated. I'd really like to switch to Gentoo, especially on my computer at work.

¯ì “¡
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Thu Nov 24, 2005 6:42 am    Post subject: Reply with quote

You can set it all up during installation quite easily. When you get to the USE flags setting step of the install, remember to add the necessary USE flags for this stuff (cjk, nls, any others). Then once the main installation process is complete, install scim, etc. After they're installed, add the environment variables. It should work after that.

Scim is essentially the same thing as “ü—Í•ûŽ®ƒXƒCƒbƒ`. It does the same thing; allow you to switch input methods. I don't know how well UIM and Scim handle the extra buttons on a Japanese keyboard though. I would expect that, assuming your keyboard works with X, they will be configurable to use the buttons. I've never used one in Gentoo (you just can't buy them here and they're too bulky to bring back from Japan), so I don't know for sure.

I highly recommend you read this document before installing, too. You need utf-8 for complete Japanese support. Also read this one for a guide on setting other localisation stuff correctly.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
hosikawafuzi
n00b
n00b


Joined: 24 Nov 2005
Posts: 2

PostPosted: Thu Nov 24, 2005 7:34 am    Post subject: Reply with quote

I appreciate the reply.

The way the Gnome applet works has been very useful for me. I use the Japanese version of WindowsXP and Fedora setup with Japanese localization, so it's very frustrating for me to use a computer that isn't setup that way. It's nice to just hit the button an go.

Another thing that I wonder about Gentoo is the availability of the man pages in Japanese. My co-workers can't use English as well as I can, so if they were to use Gentoo, they'd probably need them.

I really want to use Gentoo, but the localization seems to be a big hurdle for me right now. I'm not good enough with the OS stuff to sit down and figure out what all was done in Fedora to get the Japanese localization. Having all the applications, menus, man pages, [nearly] everything in Japanese would be best before I could switch off of Fedora.

Anyway, I really appreciate the reply. I have a computer at home that I can mess with and I'll see what I can come up with.

¯ì
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Thu Nov 24, 2005 7:55 am    Post subject: Reply with quote

Gentoo definitely has man pages in Japanese. I watched them get installed just a few days ago. One of the use flags must have pulled them down, as I don't actually need them so didn't install them explicitly.

Gentoo is actually considered one of the leading distributions for asian language support. It was pretty much the first to have any form of decent support for asian language input and display that you could setup without having to find all sorts of weird packages on the web and install them manually, alter lots of config files in strange ways, etc. There is a lot of good documentation in the forums about how to do it all. Do a search of the Documentation forum, and also do a search of the forums using google (put site:forums.gentoo.org as your first search term in google). Of course, in many cases whether a program has Japanese menus, etc will depend on that program. Using Gnome or KDE apps will help as they can use the Gnome or KDE localisation stuff.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
sito
n00b
n00b


Joined: 30 Nov 2005
Posts: 1

PostPosted: Wed Nov 30, 2005 11:47 pm    Post subject: Here's how I get Japanese input Reply with quote

Hi people,

I got OpenOffice accepting Japanese input after a lot of attempts and after reading most of the posts other people made.
I've got uim, anthy and scim installed on my box. Scim is for easy text input under most Gnome applications. Scim works on top of anthy. I've set up my .xprofile to use scim whenever I start X.
I use uim exclusively for typing Japanese text under OpenOffice:
I made a script (oowriter_japones) with the following code:

uim-xim &
LC_ALL="ja_JP.utf8" oowriter &

and made it executable with chmod u+x oowriter_japones

when I type ./oowriter_japones, uim starts and stays in the background, the locale is temporarily changed to Japanese UTF-8 (since my system is Unicode-aware) and Writer starts.

It seems that entering the commands above one for one in the console doesn't work. But they work for me within a script.

The only problem is that uim keeps running after Writer is closed. I have to kill uim manually...

Bye
Back to top
View user's profile Send private message
AmosMutke
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 235
Location: Akita, Japan.

PostPosted: Mon Dec 05, 2005 2:52 am    Post subject: Reply with quote

sito, how are you able to input japanese in oowriter? I only get grey space characters when I press <ctrl>+<space>.

I haven't been able to figure out how to change input modes in any of the Open Office programs yet.

I tried your script, but no change.

thanx
Back to top
View user's profile Send private message
AmosMutke
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 235
Location: Akita, Japan.

PostPosted: Thu Dec 08, 2005 4:28 am    Post subject: Reply with quote

I found a typo in this howto that I'm sure many other people are having trouble with.

XMODIFIERS should be XMODIFIER.
i.e. no "S"

Once I did this and restarted Xorg, I can now input japanese in Open Office 2 with SCIM.
Back to top
View user's profile Send private message
_nightw0lf
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2004
Posts: 98
Location: /Israel/home

PostPosted: Fri Dec 16, 2005 5:48 am    Post subject: Reply with quote

Hello there.

First of all thanks for this guide! it helped me to set up Hebrew using scim.

now I have a question about scim,
Why when I add hotkeys for my Hebrew layout and I do apply, then when I press the hotkeys combination, it don't switch to Hebrew?

Thanks in advance.
Back to top
View user's profile Send private message
AmosMutke
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 235
Location: Akita, Japan.

PostPosted: Fri Dec 16, 2005 7:52 am    Post subject: Reply with quote

can you be a little more specific? Does this only not work with the "ctrl+space" combination? By that I mean, can you manually select your input method using the scim gui.

Are you only having a problem with specific applications?
Back to top
View user's profile Send private message
_nightw0lf
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2004
Posts: 98
Location: /Israel/home

PostPosted: Fri Dec 16, 2005 9:22 am    Post subject: Reply with quote

ok its solved.

I didn't knew I should use ctrl+space.. now its working.
thanks :oops:
Back to top
View user's profile Send private message
Jimmy Jazz
Apprentice
Apprentice


Joined: 04 Oct 2004
Posts: 290
Location: Strasbourg

PostPosted: Sun Dec 18, 2005 3:46 pm    Post subject: Re: Here's how I get Japanese input Reply with quote

sito wrote:
Hi people,

I got OpenOffice accepting Japanese input after a lot of attempts and after reading most of the posts other people made.
I've got uim, anthy and scim installed on my box. Scim is for easy text input under most Gnome applications. Scim works on top of anthy. I've set up my .xprofile to use scim whenever I start X.
I use uim exclusively for typing Japanese text under OpenOffice:
I made a script (oowriter_japones) with the following code:

uim-xim &
LC_ALL="ja_JP.utf8" oowriter &

and made it executable with chmod u+x oowriter_japones

when I type ./oowriter_japones, uim starts and stays in the background, the locale is temporarily changed to Japanese UTF-8 (since my system is Unicode-aware) and Writer starts.

It seems that entering the commands above one for one in the console doesn't work. But they work for me within a script.

The only problem is that uim keeps running after Writer is closed. I have to kill uim manually...

Bye


Hello,

you could modify your script to this one:

Code:


#!/bin/sh
uim-xim &
PID=$!

LC_ALL="ja_JP.utf8" oowriter

kill $PID



Jj
_________________
« La seule condition au triomphe du mal, c'est l'inaction des gens de bien » E.Burke
Code:

+----+----+----+
|    |::::|    |
|    |::::|    |
+----+----+----+

motto: WeLCRO
WritE Less Code, Repeat Often
Back to top
View user's profile Send private message
Hoshimaru
Apprentice
Apprentice


Joined: 09 Nov 2003
Posts: 225
Location: Belgium

PostPosted: Tue Dec 27, 2005 2:18 pm    Post subject: Reply with quote

This is gonna sound stupid, but what's the default key to cycle through the kanji's when you typed a word in hiragana?
Like "‚킽‚µ" ? I can't get it to show them... In works well with Gnome on my desktop, but I find it harder to configure with KDE on my laptop ^^'
And where can I change that key ? I managed to get SHIFT+Space to switch to UIM-Anthy and back to European keyboard, but that's it. Please advice me m(_ _)m
Back to top
View user's profile Send private message
AmosMutke
Apprentice
Apprentice


Joined: 24 Dec 2003
Posts: 235
Location: Akita, Japan.

PostPosted: Tue Dec 27, 2005 4:20 pm    Post subject: Reply with quote

Hoshimaru wrote:
This is gonna sound stupid, but what's the default key to cycle through the kanji's when you typed a word in hiragana?
Like "‚킽‚µ" ? I can't get it to show them... In works well with Gnome on my desktop, but I find it harder to configure with KDE on my laptop ^^'
And where can I change that key ? I managed to get SHIFT+Space to switch to UIM-Anthy and back to European keyboard, but that's it. Please advice me m(_ _)m


I use the "space" key to toggle thru the kanji... It works in fluxbox anyway.
Back to top
View user's profile Send private message
Hoshimaru
Apprentice
Apprentice


Joined: 09 Nov 2003
Posts: 225
Location: Belgium

PostPosted: Tue Dec 27, 2005 8:02 pm    Post subject: Reply with quote

AmosMutke wrote:
Hoshimaru wrote:
This is gonna sound stupid, but what's the default key to cycle through the kanji's when you typed a word in hiragana?
Like "‚킽‚µ" ? I can't get it to show them... In works well with Gnome on my desktop, but I find it harder to configure with KDE on my laptop ^^'
And where can I change that key ? I managed to get SHIFT+Space to switch to UIM-Anthy and back to European keyboard, but that's it. Please advice me m(_ _)m


I use the "space" key to toggle thru the kanji... It works in fluxbox anyway.


That key doesn't work for some reason... not in kwrite, not in kopete, not in OpenOffice and so on :'(
Back to top
View user's profile Send private message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Tue Jan 03, 2006 8:25 pm    Post subject: Reply with quote

I followed the guide here and it works great. Thanks.

However, my problem is that... Although I turned off all shortcuts, SKIM tends to turn on by itself. When I do programming, I often use Shift+Ctrl+Left arrow or Shift+Ctrl+Right Arrow key combinations to do highlighting. It always turns on SKIM and suddenly I see Japanese texts in my program. This is very annoying and I can't seem to turn it off. Any ideas?
Back to top
View user's profile Send private message
Pajarico
Guru
Guru


Joined: 01 May 2004
Posts: 493
Location: Madrid, España.

PostPosted: Tue Jan 03, 2006 11:02 pm    Post subject: Reply with quote

Hi, i just installed the fonts for korean, chinese and japanese listed on the first part of the HOWTO. Then did a fc-cache -fv and firefox started to use the fonts inmediately. The only glitch is that the titlebar is still showing the typical square with numbers inside:
screenshot | the page I was watching

Also, if i execute fc-cache -fv, do i have to add the directories containing the asian fonts to xorg.conf? Is it the same?
_________________
Gentoo: the only software worth paying that is free.


Last edited by Pajarico on Tue Jan 10, 2006 6:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Wed Jan 04, 2006 2:50 am    Post subject: Reply with quote

Update time for my little problem! After lots of time of... not really doing anything to it, followed by an update yesterday that pulled in a new version of skim (now at skim-1.4.2) and anthy (now at anthy-7100b-r1), it's suddenly started semi-working with both canna and anthy. They sometimes allow input of Japanese characters (including kana to kanji conversion), and at other times don't. Canna appears to be more reliable than anthy, but it still seems pretty random. It was working in Firefox when I started writing this and now isn't, but at the same time is still working in xchat. Still no clue what was/is wrong, but maybe it's gradually fixing itself.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
ovokinder
n00b
n00b


Joined: 27 Feb 2005
Posts: 13

PostPosted: Sun Jan 08, 2006 6:12 pm    Post subject: Reply with quote

Although I've religiously followed the HOWTO, japanese input was a no-go for me.

Skim did launch, I could configure it, I could see lotsa IMEs, but no input.
Left clicking on the icon showed an empty menu, instead of the input methods it was supposed to.

I've managed to make it work with some ugly workarounds:
1. In /etc/xprofile (or my own .xprofile)
Code:

export LC_CTYPE="ja_JP.UTF-8"

Strangely enough, that made it work on most apps. On some other, text would go nuts (eg. matlab).
No big deal, since I don't need japanese on matlab and could easily be fixed with
Code:
LC_CTYPE="pt_PT.UTF-8" matlab
...

2. In /etc/xprofile (or my own...)
Code:

export XMODIFIERS=@im=SCIM
export XMODIFIER=@im=SCIM
export GTK_IM_MODULE=XIM
export QT_IM_MODULE=XIM

Notice the IM for qt/gtk apps is xim and not scim.

Simply put, one of these two would make things work (I'm using the second since I can keep my locales to what I want 'em).

The problem comes when closing skim. Every app that uses input crashes.
Why would I want to close skim? I wouldn't. It happens when I log out of KDE, and the session manager shuts down all apps. The session manager itself ends up crashing too and instead of rebooting/shutting down/etc I'm just thrown to the console (same as ctrl+alt+f1).
Once again, I've worked it around by killing skim manually, but that crashes all apps over again (but I can shutdown/reboot). Kind of annoying... :?

Other thing that doesn't work for me is enabling/disabling scim/skim.
It doesn't seem to respect my locales or keyboard definitions.
Being portuguese, I *NEED* (and I can't stress that enough) latin chars with accents (eg. áéíúó).
So I've got ctrl+space > English/European(got it working with my locale, pt_PT.UTF-8 ) and ctrl+shift+space > Anthy. In other words, I never disable it, just keep switching between two input types (I know by disabling it I'd also be switching between im's, but you got the picture...).
Not what I'd like, but hey... it works... :roll:

I don't really mind having to use these unorthodox methods to get japanese input to work. What really pisses me off is the app crashing thing.

I'm using KDE 3.5.0, uim-1.0.0, skim 1.4.3, scim 1.4.3, scim-uim 0.1.3, anthy 7100b-r1.
If you need any other info...

どうもありがとう
_________________
Live forever!!! or die trying...
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Sun Jan 08, 2006 11:51 pm    Post subject: Reply with quote

Now, about that wiki request...

http://gentoo-wiki.com/HOWTO_Enabling_Japanese is a significant rewrite of the current HOWTO. The rewrite is in it's first draft, so I would ask people to comment on it here or PM me on issues more important on it that spelling corrections and wikifying it, until the warning is removed.

I'd love some feedback.



-Sud.
_________________
...
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Mon Jan 09, 2006 5:45 am    Post subject: Reply with quote

New update! Changing XMODIFIERS to XMODIFIER appears to have fixed any remaining problems. It all works lovely now. Weird.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
Pajarico
Guru
Guru


Joined: 01 May 2004
Posts: 493
Location: Madrid, España.

PostPosted: Mon Jan 09, 2006 2:25 pm    Post subject: Reply with quote

My problem is gone, now I have asian characters in the title bar and I can copy/paste those special characters to/from the clipboard. I'm not sure what I did, I think upgrading firefox to 1.5 did it.
_________________
Gentoo: the only software worth paying that is free.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 5, 6, 7 ... 10, 11, 12  Next
Page 6 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum