Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Enabling Japanese (or: CJK in KDE & Gnome)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
_nightw0lf
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2004
Posts: 98
Location: /Israel/home

PostPosted: Mon Jan 09, 2006 4:11 pm    Post subject: Reply with quote

Hey guys, I've managed to make it work with firefox, and it did worked with Licq, but now i've upgraded Licq to the last version 1.32, and I set it to use
qt-gui plugin, (couldn't install the kde one)
anyways, when I press CTRL+Space, nothing happen, and I cannot change to the language I want, same goes with Opera, and Konqueror.
It works on FireFox tho.

Thanks in advance.
Back to top
View user's profile Send private message
shuusaku
n00b
n00b


Joined: 11 Jan 2006
Posts: 5
Location: Tokyo, Japan

PostPosted: Wed Jan 11, 2006 4:29 pm    Post subject: what about kopete? Reply with quote

Hello. I've just installed the Japanese support on my laptop (gentoo 2.6.14.r5) and everything works almost fine. There is however the problem that some programs do not accept Japanese input, they accept only normal text. In particular, Kopete (the KDE instant messanger), all the text editors found with KDE, and the Konsole (these at least are the ones I tried).

Is there anything I am missing? Thanks for your help
Back to top
View user's profile Send private message
tuber
Apprentice
Apprentice


Joined: 12 Nov 2004
Posts: 267

PostPosted: Fri Jan 13, 2006 6:32 am    Post subject: Reply with quote

I am able to enter Chinese text inside Kopete 3.4.3. To do so, first choose the input method using the SKIM icon in the KDE tray. Once in Kopete, right click in the entry window (the bottom one) and choose Select Input Method->XIM. That should do it.
Back to top
View user's profile Send private message
Kateikyoushi
n00b
n00b


Joined: 06 Jan 2006
Posts: 39

PostPosted: Fri Jan 13, 2006 8:52 pm    Post subject: Reply with quote

I use ratpoision therefore I do not have a taskbar, should this work for me without that ?
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Fri Jan 13, 2006 11:54 pm    Post subject: Reply with quote

Kateikyoushi wrote:
I use ratpoision therefore I do not have a taskbar, should this work for me without that ?


Without a Notification area, you will probably feel comfortable using straight UIM-anthy. Refer to the new Wiki link.

-Sud.
_________________
...
Back to top
View user's profile Send private message
ranmakun
Guru
Guru


Joined: 06 Nov 2002
Posts: 372
Location: Buenos Aires - Argentina

PostPosted: Sun Jan 15, 2006 10:47 pm    Post subject: Reply with quote

Hey, thanks for the great HOWTO!!, unfortunately I have a problem, since I changed my locale from "es_AR" to "es_AR.UTF-8" some things started to appear with wrong characters, for example this output from mplayer: (Not sure if the wrong characters will show up)

Quote:

MPlayer ha sido interrumpido por se�l 11 en el m�ulo: decode_video
- MPlayer se detuvo por mal uso de CPU/FPU/RAM.
Recompila MPlayer con la opci� --enable-debug y hace un backtrace en
'gdb' y un desensamblado. Para m� detalles, vea
DOCS/HTML/es/bugreports_what.html#bugreports_crash
- MPlayer se detuvo. Esto no deber� haber pasado.
Puede ser un defecto en el c�igo de MPlayer _o_ en sus controladores
_o_ en su versi� de gcc. Si piensa que es la culpa de MPlayer, por
favor lea DOCS/HTML/es/bugreports.html y siga las instrucciones que all
se encuentran. No podemos y no lo ayudaremos a menos que nos provea esa
informaci� cuando este reportando algn posible defecto.


Is there any way to solve this problem?, Im able to write any kind of characters in the console without problems, just these are wrong. Ive also found some wrong characters in kmail (they show as a square or two squares per character), some old mails, but not all my mails.
Thank you.
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Mon Jan 16, 2006 2:34 am    Post subject: Reply with quote

ranmakun wrote:
since I changed my locale from "es_AR" to "es_AR.UTF-8" some things started to appear with wrong characters...


edit /etc/rc.conf and change the

UNICODE="no"
to
UNICODE="yes"

See if this helps the mplayer output.

-Sud.
_________________
...
Back to top
View user's profile Send private message
ranmakun
Guru
Guru


Joined: 06 Nov 2002
Posts: 372
Location: Buenos Aires - Argentina

PostPosted: Wed Jan 18, 2006 1:18 am    Post subject: Reply with quote

Sudrien wrote:
ranmakun wrote:
since I changed my locale from "es_AR" to "es_AR.UTF-8" some things started to appear with wrong characters...


edit /etc/rc.conf and change the

UNICODE="no"
to
UNICODE="yes"

See if this helps the mplayer output.

-Sud.


Tried that, in fact, that was my original setting. There are a lot of problems with my characters, accented characters in mails appear wrong, in konsole, etc. But, for example, if I login remotely also using console I can see the mplayer error with the correct character. Any ideas?
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Wed Jan 18, 2006 3:45 am    Post subject: Reply with quote

ranmakun wrote:
Tried that, in fact, that was my original setting. There are a lot of problems with my characters, accented characters in mails appear wrong, in konsole, etc. But, for example, if I login remotely also using console I can see the mplayer error with the correct character. Any ideas?


Since this seems to be a UTF8 issue, I'd suggest looking through other threads on the issue, like http://www.gentoo.org/doc/en/utf-8.xml and https://forums.gentoo.org/viewtopic-t-166984.html. I could offer a few things to check before asking questions there:

What font is your terminal using?

What is your mail client (and is it terminal based)?

I really can't say much about how mapping fonts to characters changes when using utf8 - you just may have success when not using the utf8 locale.

-Sud.
_________________
...
Back to top
View user's profile Send private message
Gentist
Apprentice
Apprentice


Joined: 20 Mar 2004
Posts: 247

PostPosted: Wed Jan 18, 2006 6:28 pm    Post subject: Reply with quote

I have a few questions: How do I switch input without deleting what I've previously written? Writing something in, say, hiragana and then switching back to the English input makes all the hiragana disappear. Also, I can't seem to copy (mark it and ctrl+c) or otherwise alter Japanese text written through scim. For example, how do I make a plain space? Pressing spacebar brings up alternative ways of spelling it instead.
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Wed Jan 18, 2006 8:09 pm    Post subject: Reply with quote

Gentist wrote:
I have a few questions: How do I switch input without deleting what I've previously written? Writing something in, say, hiragana and then switching back to the English input makes all the hiragana disappear. Also, I can't seem to copy (mark it and ctrl+c) or otherwise alter Japanese text written through scim. For example, how do I make a plain space? Pressing spacebar brings up alternative ways of spelling it instead.


To end a phrase in hiragana, just hit the 'Enter' key, accepting the hiragana version. You need to hit 'Enter' twice to get a line break.

Copy and paste aren't allowed while there is an indeterminate/unaccepted phrase. Make sure you hit 'Enter' before selecting.

Since hiragana/kanji are essentially a fixed width font, only the wider spaces are available in hiragana mode. Switch back to Raw input/English to get 'normal' spacing.

-Sud.
_________________
...
Back to top
View user's profile Send private message
Gentist
Apprentice
Apprentice


Joined: 20 Mar 2004
Posts: 247

PostPosted: Thu Jan 19, 2006 6:43 am    Post subject: Reply with quote

Sudrien wrote:
To end a phrase in hiragana, just hit the 'Enter' key, accepting the hiragana version. You need to hit 'Enter' twice to get a line break.

Ah, so that's how it works. Thanks.

I suppose there's no way to make this work in apps that aren't GTK+/Qt based, such as terminals, or do I have to copy/paste things from GTK+/Qt based apps?
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Thu Jan 19, 2006 8:16 am    Post subject: Reply with quote

You can use a terminal that supports it. Konsole and gnome-terminal both do. I use gnome-terminal myself. It happily displays and inputs in Japanese eveything.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
ranmakun
Guru
Guru


Joined: 06 Nov 2002
Posts: 372
Location: Buenos Aires - Argentina

PostPosted: Fri Jan 20, 2006 7:52 pm    Post subject: Reply with quote

Sudrien wrote:
ranmakun wrote:
Tried that, in fact, that was my original setting. There are a lot of problems with my characters, accented characters in mails appear wrong, in konsole, etc. But, for example, if I login remotely also using console I can see the mplayer error with the correct character. Any ideas?


Since this seems to be a UTF8 issue, I'd suggest looking through other threads on the issue, like http://www.gentoo.org/doc/en/utf-8.xml and https://forums.gentoo.org/viewtopic-t-166984.html. I could offer a few things to check before asking questions there:

What font is your terminal using?

What is your mail client (and is it terminal based)?

I really can't say much about how mapping fonts to characters changes when using utf8 - you just may have success when not using the utf8 locale.

-Sud.


Ok, I've read that document but the problem continues (although it was usefull for other things, thank you.)
I'm using KDE, konsole and kmail as my terminal and mail programs.
In kmail the problem is that I see the old mails without problems, but the new ones have squares in the place of special characters. I guess the problem is that I'm not using an unicode font, but then my question would be, how can I know if the font I'm using is unicode or not?
The other question is, when I switch to the unicode font, will I see wrong all the old mails that were coded in extended ASCII?
On the other hand I find hard to believe that the font I'm using is not unicode, since I can write japanese without problems, and I can see every web page in japanese, spanish, english and portuguese without encoding problems.
Back to top
View user's profile Send private message
vf1sveritech
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2004
Posts: 90

PostPosted: Sun Jan 22, 2006 8:41 am    Post subject: Reply with quote

ok, i have followed the first post on this forum and the wiki, and the problem i have is that there doesnt seem to be any input modes in skim. Skim shows up just fine in the system tray, or in some dockable window that i cna move around, but when i click it it shows this tiny little empty box which i assume is where the different input modes go. however, its empty...in the configure window it looks like everythings fine i have all the japanese things selected. I have restarted and tried different things and havent figured it out.


OK OK i got it working in Gaim, upon right clicking the text box it shows a scim input thing and i selected that and then the thing showed other input methods. However, firefox and kwrite dont seem to have that in the right click menu...
_________________
VT


Last edited by vf1sveritech on Sun Jan 22, 2006 8:56 am; edited 1 time in total
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Sun Jan 22, 2006 8:54 am    Post subject: Reply with quote

Woo! One hard drive crash and reinstall later, and this time it went first try. :)

vf1sveritech: What input methods do you have installed? If you have anthy installed, it *should* be available under the Japanese submenu (although from the sounds of it you don't get any menu at all). If it's canna, make sure you start the canna service. If you're not actually getting a menu at all... well I ran into that a few times with my last install and I think it was because I was playing around with the LANG and LC_CTYPE variables. Make sure they're set correctly in your .xprofile file.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
vf1sveritech
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2004
Posts: 90

PostPosted: Sun Jan 22, 2006 9:28 am    Post subject: Reply with quote

woh a quick reply. Ok i've got it working in gaim and konqueror cause when you right click a text box area, like an instant message window or when i went to rename a file, it says "input methods" and it lists a whole bunch, and one of them is scims input method, and so i can use those. However Firefox doesn't have such an option.

I have both canna and anthy installed, anthy is the default one for scim i think...

The howto didnt say to put Lang or LC in xprofile, but after reading some more of this post it said

Code:

export LANG=de_DE.UTF-8
export LC_CTYPE=ja_JP.UTF-8


so do i Just change de_DE.UTF-8 to my own? and leave LC_TYPE set to japanese?
_________________
VT
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Sun Jan 22, 2006 10:32 am    Post subject: Reply with quote

Set LANG to your local one (in my case, it's en_NZ.UTF-8). Set LC_CTYPE to the language you want to be able to use as secondary, which is Japanese for me but may also be Korean or Chinese. If you want multiple from those three... well I don't really know what to do in that case.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
Gentist
Apprentice
Apprentice


Joined: 20 Mar 2004
Posts: 247

PostPosted: Sun Jan 22, 2006 7:36 pm    Post subject: Reply with quote

Biggles wrote:
You can use a terminal that supports it. Konsole and gnome-terminal both do. I use gnome-terminal myself. It happily displays and inputs in Japanese eveything.

That would work. However, I want a lightweight terminal that doesn't depend on all that GNOME/KDE stuff. The reason is that I run neither as desktop environment. My terminal supports Unicode, and provided that I switch font to one that supports Japanese, displaying it shouldn't be a problem. However, since the terminal isn't based on GTK+ or Qt, the regular SCIM method won't work. What I was wondering was whether there's another way or another plugin which would take care of Japanese input for non-GTK+/Qt apps. If not, I suppose I'll have to copy/paste from an editor.
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Mon Jan 23, 2006 3:18 am    Post subject: Reply with quote

I don't know of any input method selectors that don't use GTK or QT. I think the only way to do it otherwise is tell your system that you have a different keyboard layout, which would probably affect every program and wouldn't really help as you'd have to type blind.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
Kateikyoushi
n00b
n00b


Joined: 06 Jan 2006
Posts: 39

PostPosted: Mon Jan 23, 2006 3:28 pm    Post subject: Reply with quote

Sudrien wrote:
Kateikyoushi wrote:
I use ratpoision therefore I do not have a taskbar, should this work for me without that ?


Without a Notification area, you will probably feel comfortable using straight UIM-anthy. Refer to the new Wiki link.

-Sud.


Thanks indeed it works well, I am surprised zenkaku hankaku key is mapped. Quite good.
Back to top
View user's profile Send private message
Remillard
Apprentice
Apprentice


Joined: 07 Mar 2003
Posts: 200
Location: Irvine, CA

PostPosted: Tue Jan 24, 2006 6:01 pm    Post subject: Reply with quote

I've been trying to get this to work for several days and last night finally had some success with it. However it seems to be strange success based on the comments I've read.

I've followed the wiki instructions and have installed everything, have emerged with new use flags for back compatibility, etc. I've modified the .xprofile (and the one in /etc too). I've got scim and skim.

So, I right click on the text area in KMail, and voila, I can select input methods which is great. I sent some e-mail last night using that, that I hadn't been able to before.

However NO other application as far as I can tell allows that method (right-click). Konsole doesn't. KWrite doesn't. Kate doesn't. KWord (I was VERY disappointed here) doesn't.

For the non-KDE applications, the ctrl-space method doesn't work. It just puts in a space (or in KWord it seems to put in a hard space, or at least a highlighted space.) OpenOffice doesn't seem to permit it. No Java applications support it.

So, what am I missing for the ctrl-space method not to work? I've got the skim icon in the taskbar and I've verified that the basic functionality DOES work in KMail. But I'm at a loss at what's missing for everything else.

Anyone have any ideas on this?

Best regards,
Remillard
_________________
This signature is printed with 100% post-consumer recycled electrons.
Back to top
View user's profile Send private message
Magnum44
Guru
Guru


Joined: 21 May 2003
Posts: 538

PostPosted: Fri Jan 27, 2006 1:02 am    Post subject: Japanese UIM not let work programs Reply with quote

Hi, I've been reading this whole topic and... I don't know if I almost forgot how to read or what! because I can't get the japanese UIM working without crashing my programs.
Now I have the UIM working ok, I can open a kwrite and test it, or just a gnome app, but with KDE lots of programs doesn't work.

I'm going to write all the stuff so anybody helps me! arf :oops:

First, the errors that some programs give me:
Code:
$ thunderbird
No running windows found
/usr/libexec/mozilla-launcher: line 116: 31101 Violación de segmento   "$mozbin" "$@"
thunderbird-bin exited with non-zero status (139)

$ firefox
No running windows found
/usr/libexec/mozilla-launcher: line 116: 31986 Violación de segmento   "$mozbin" "$@"
firefox-bin exited with non-zero status (139)

$ kopete
ScimInputContextPlugin()

$ konqueror
ScimInputContextPlugin()
*** glibc detected *** free(): invalid pointer: 0x0813bec0 ***
Temporizador

$ smb4k
ScimInputContextPlugin()
*** glibc detected *** free(): invalid next size (fast): 0x082c0410 ***
smb4k: ERROR: Communication problem with smb4k, it probably crashed.


Now the error that (I think "vi") is throwing me when I try to etc-update through console:
Code:

# etc-update
.
.
.
.
Please select a file to edit by entering the corresponding number.
              (don't use -3 or -5 if you're unsure what to do)
              (-1 to exit) (-3 to auto merge all remaining files)
                           (-5 to auto-merge AND not use 'mv -i'): 1

invalid charset name
1) Replace original with update
2) Delete update, keeping original as is
3) Interactively merge original with update
4) Show differences again


Now, my config:
Code:
$ cat /etc/xprofile
export LANG=es_ES.UTF-8
export LC_CTYPE=ja_JP.UTF-8 # this modification is needed if you want to use openoffice with scim!!!!!!!!
export XMODIFIERS=@im=SCIM
export XMODIFIER=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim
Code:
$ cat /etc/rc.conf |grep UNICODE
# UNICODE specifies whether you want to have UNICODE support in the console.
# If you set to yes, please make sure to set a UNICODE aware CONSOLEFONT and
UNICODE="yes"

Code:
$ locale
LANG=es_ES@euro
LC_CTYPE="es_ES@euro"
LC_NUMERIC="es_ES@euro"
LC_TIME="es_ES@euro"
LC_COLLATE="es_ES@euro"
LC_MONETARY="es_ES@euro"
LC_MESSAGES="es_ES@euro"
LC_PAPER="es_ES@euro"
LC_NAME="es_ES@euro"
LC_ADDRESS="es_ES@euro"
LC_TELEPHONE="es_ES@euro"
LC_MEASUREMENT="es_ES@euro"
LC_IDENTIFICATION="es_ES@euro"
LC_ALL=es_ES@euro
Code:
$ locale -a | grep utf8
en_US.utf8
es_ES.utf8
es_ES.utf8@euro
ja_JP.utf8


And to finish my versions of the programs:
Code:
*  app-i18n/scim-uim
      Latest version available: 0.1.3
      Latest version installed: 0.1.3

*  app-i18n/scim-qtimm
      Latest version available: 0.9.3
      Latest version installed: 0.9.3

*  app-i18n/scim
      Latest version available: 1.4.2
      Latest version installed: 1.4.2

*  app-i18n/anthy
      Latest version available: 6700b
      Latest version installed: 6700b

*  app-i18n/skim
      Latest version available: 1.4.2
      Latest version installed: 1.4.2



I'm sick of punching this thing... I don't know what the hell crash my KDE programs when KDE is working correctly... Any ideas?


Thaaaaaaaaaaaaaaanks!
_________________
"La suerte favorece sólo a la mente preparada." (Isaac Asimov citando a Louis Pasteur).
"Fortune favors the prepared mind." (Isaac Asimov quoting Louis Pasteur).
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Fri Jan 27, 2006 2:01 am    Post subject: Reply with quote

You're launching all those programs from a terminal, but the locale variables, etc haven't been exported there. Otherwise locale should show the values that you're exporting (es_ES.UTF-8 and ja_JP.UTF-8). For example, when I run locale I get:

Code:
~ $ locale
LANG=en_NZ.UTF-8
LC_CTYPE=ja_JP.UTF-8
LC_NUMERIC="en_NZ.UTF-8"
LC_TIME="en_NZ.UTF-8"
LC_COLLATE="en_NZ.UTF-8"
LC_MONETARY="en_NZ.UTF-8"
LC_MESSAGES="en_NZ.UTF-8"
LC_PAPER="en_NZ.UTF-8"
LC_NAME="en_NZ.UTF-8"
LC_ADDRESS="en_NZ.UTF-8"
LC_TELEPHONE="en_NZ.UTF-8"
LC_MEASUREMENT="en_NZ.UTF-8"
LC_IDENTIFICATION="en_NZ.UTF-8"
LC_ALL=


And in both my ~/.xprofile and ~/.bashrc I have:

Code:
export XMODIFIER=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim
export LANG=en_NZ.UTF-8
export LC_CTYPE=ja_JP.UTF-8


Try adding the exports you have in your xprofile file to your ~/.bashrc file. I'm not sure why your programs are crashing (is that a segmentation fault?), but try this anyway.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
KK_r
Apprentice
Apprentice


Joined: 17 Dec 2003
Posts: 182

PostPosted: Fri Jan 27, 2006 2:39 pm    Post subject: Reply with quote

All my locales are set to sv_SE.UTF-8 but by starting the xim-deamon with LC_CTYPE=ja_JP.UTF-8 everything except ooffice works (ooffice works if started with LC_CTYPE=ja_JP.UTF-8 ). So you don't have to change LC_CTYPE for the rest of your programs. This is from my .xinitrc:
Code:
LC_CTYPE=ja_JP.UTF-8 exec uim-xim &

and this is /etc/env.d/99xim:
Code:
XIM="uim"
XMODIFIER="@im=uim"
QT_IM_MODULE="uim"
GTK_IM_MODULE="uim"

(change uim to scim if that is what you use)
_________________
Seamos realistas, exijamos lo imposibile
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 10, 11, 12  Next
Page 7 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum