Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Enabling Japanese (or: CJK in KDE & Gnome)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 7, 8, 9, 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Magnum44
Guru
Guru


Joined: 21 May 2003
Posts: 538

PostPosted: Fri Jan 27, 2006 5:01 pm    Post subject: Some objectives reached! Reply with quote

Well well well... I think that I've repaired something:

Code:
$ locale
LANG=es_ES.UTF-8
LC_CTYPE="es_ES.UTF-8"
LC_NUMERIC="es_ES.UTF-8"
LC_TIME="es_ES.UTF-8"
LC_COLLATE="es_ES.UTF-8"
LC_MONETARY="es_ES.UTF-8"
LC_MESSAGES="es_ES.UTF-8"
LC_PAPER="es_ES.UTF-8"
LC_NAME="es_ES.UTF-8"
LC_ADDRESS="es_ES.UTF-8"
LC_TELEPHONE="es_ES.UTF-8"
LC_MEASUREMENT="es_ES.UTF-8"
LC_IDENTIFICATION="es_ES.UTF-8"
LC_ALL=es_ES.UTF-8


And after reemerge firefox and thunderbird, this two works. Now I'm reemerging a lot of packages with new uses expectating that this repairs all my kde apps that still not works.
For example, konqueror fails when I try to open it from konsole running just konqueror:
Code:
$ konqueror
ScimInputContextPlugin()
KCrash: Application 'konqueror' crashing...
ScimInputContextPlugin()
*** glibc detected *** free(): invalid next size (fast): 0x082b9420 ***

But when I use the icon on desktop it works (this icon execute: kfmclient openProfile webbrowsing)

Annnd... I've observed that in OpenOffice 2.0 some dialogs seems to crash or something because there are menues and buttons with no text (for example the buttons on "save as" dialog or in export to pdf)

Is this a problem of scim and company or is this a separate problem that has not union to UIMs ? It's the first time that I run this new version.

Thanks all. :wink:
_________________
"La suerte favorece sólo a la mente preparada." (Isaac Asimov citando a Louis Pasteur).
"Fortune favors the prepared mind." (Isaac Asimov quoting Louis Pasteur).
Back to top
View user's profile Send private message
Magnum44
Guru
Guru


Joined: 21 May 2003
Posts: 538

PostPosted: Mon Jan 30, 2006 11:19 am    Post subject: less invalid charset Reply with quote

Hi all!

KDE problems solved! But there is one more problem that is driving me crazy:
Code:
# less
invalid charset name


Any ideas? :cry:
_________________
"La suerte favorece sólo a la mente preparada." (Isaac Asimov citando a Louis Pasteur).
"Fortune favors the prepared mind." (Isaac Asimov quoting Louis Pasteur).
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Fri Feb 03, 2006 6:58 pm    Post subject: Reply with quote

After (quite) a bit of reformatting, The new revision of the HOWTO has been copied over from the wiki.

-Sud.
_________________
...
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2968
Location: Germany

PostPosted: Tue Feb 14, 2006 3:44 pm    Post subject: Reply with quote

About the XMODIFIERS vs. XMODIFIER issue, taken from the X.Org sourcecode:

lib/X11/lcWrap.c
Code:
char *
XSetLocaleModifiers(
    const char *modifiers)
{
    XLCd lcd = _XlcCurrentLC();
    char *user_mods;

    if (!lcd)
        return (char *) NULL;
    if (!modifiers)
        return lcd->core->modifiers;
    user_mods = getenv("XMODIFIERS");
    modifiers = (*lcd->methods->map_modifiers) (lcd,
                                                user_mods, (char *)modifiers);
    if (modifiers) {
        if (lcd->core->modifiers)
            Xfree(lcd->core->modifiers);
        lcd->core->modifiers = (char *)modifiers;
    }
    return (char *)modifiers;
}


So XMODIFIERS can't be wrong. Also, the X man page (man X) lists XMODIFIERS only.

Although I've read in some threads of the forums that it's supposed to be XMODIFIER instead of XMODIFIERS, I can't see how that can be true. There is no reference to XMODIFIER at all in the X source code. Of course, that doesn't mean that nobody's using it, but if someone does, I'd consider that a bug.

EDIT: To the people who solved problems by changing XMODIFIERS to XMODIFIER, could you verify that the problem is back when you change it to XMODIFIERS again, and that the problem persists when you just comment XMODIFIERS out? And if this is the case, which application are you having problems with?
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2968
Location: Germany

PostPosted: Tue Feb 14, 2006 3:51 pm    Post subject: Reply with quote

I can't get scim to work in Openoffice, most likely due to this error:

Code:
# scim -d
Smart Common Input Method 1.4.2

Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
Launching a SCIM process with x11...
Loading socket Config module ...
Creating backend ...
Loading x11 FrontEnd module ...
Failed to load x11 FrontEnd module.
Failed to launch SCIM.


scim -l however lists the x11 frontend module as present. Any ideas?

According to what I've found on the web, the x11 frontend module is required for all applications that have to rely on XIM input method.
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Tue Feb 14, 2006 6:06 pm    Post subject: Reply with quote

I didn't think the XMODIFIERS vs XMODIFIER thing made sense either, since mine used to work fine with XMODIFIERS, and the source code pretty much prooves it. I'll try changing it back to that again when I turn on my laptop in a couple of hours. Maybe it was just the presence of XMODIFIERS?
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
Wonderbike
n00b
n00b


Joined: 25 Jan 2006
Posts: 2
Location: Akita, Japan

PostPosted: Wed Feb 15, 2006 2:47 am    Post subject: Reply with quote

I've followed every step of this post a few times and I still don't have Japanese input in Gnome. The input mode box that says "_A" is on my toolbar. I can click on it, and see the other options for hiragana and such, but when I click on them, the box stays just "_A". The shortcut keys to change input modes also have no effect. If I right-click the "_A" and go into properties, everything seems in order, but in Firefox, OpenOffice, Gaim, and Text Editor, and everything else I've tried, the "_A" never changes to "_‚ " (copy-pasted that one). Did I skip something?

thanks in advance.
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Wed Feb 15, 2006 4:35 am    Post subject: Reply with quote

I tried removing XMODIFIER(S) from my config files, and it didn't appear to make any difference at all. This suggests that the variable is irrelevant.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2968
Location: Germany

PostPosted: Mon Feb 20, 2006 1:44 pm    Post subject: Reply with quote

frostschutz wrote:
I can't get scim to work in Openoffice, most likely due to this error:

Code:
[...]
Failed to load x11 FrontEnd module.
[...]


I solved it by upgrading all scim to ~x86 (that is scim 1.4.4 & co, not just scim 1.4.4):
Code:
~#> cd /usr/portage
/usr/portage#> for f in app-i18n/scim*; do echo "$f" >> /etc/portage/package.keywords; done;
/usr/portage#> emerge --pretend --deep --update world
Back to top
View user's profile Send private message
wisnij
n00b
n00b


Joined: 23 Feb 2006
Posts: 3
Location: a planet called Erp

PostPosted: Thu Feb 23, 2006 3:27 am    Post subject: Reply with quote

So is there any way to install things that depend on canna while I've got tetex installed? 'Cause if not, I guess I'm just out of luck. :(
Back to top
View user's profile Send private message
Biggles
Tux's lil' helper
Tux's lil' helper


Joined: 06 Nov 2003
Posts: 123
Location: New Zealand

PostPosted: Thu Feb 23, 2006 5:24 am    Post subject: Reply with quote

What do you mean? I have both canna and tetex installed.
_________________
Never eat anything bigger than your own head.
Back to top
View user's profile Send private message
wisnij
n00b
n00b


Joined: 23 Feb 2006
Posts: 3
Location: a planet called Erp

PostPosted: Thu Feb 23, 2006 6:14 am    Post subject: Reply with quote

Ah, my mistake. I've got +doc set in make.conf and the documentation for canna depends on ptex, which conflicts with tetex. I thought it was canna itself.
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2968
Location: Germany

PostPosted: Thu Feb 23, 2006 7:31 am    Post subject: Reply with quote

wisnij wrote:
Ah, my mistake. I've got +doc set in make.conf and the documentation for canna depends on ptex, which conflicts with tetex. I thought it was canna itself.


Thanks for pointing that out, I was wondering about it too. I guess I'll disable doc just for canna in /etc/portage/package.use

It'd be interesting to know wether it really requires ptex, or wether it should just require virtual/tex or something. I.e. does it require any feature of ptex that is not provided by tetex (if it does, most likely, this will be CJK support, but who knows...)
Back to top
View user's profile Send private message
rocketrabbit
n00b
n00b


Joined: 30 Mar 2006
Posts: 58

PostPosted: Mon May 15, 2006 12:30 pm    Post subject: Reply with quote

Quote:
Setting Locale

which file do i set locale in?
Back to top
View user's profile Send private message
KK_r
Apprentice
Apprentice


Joined: 17 Dec 2003
Posts: 182

PostPosted: Mon May 15, 2006 3:52 pm    Post subject: Reply with quote

/etc/env.d/02locale
_________________
Seamos realistas, exijamos lo imposibile
Back to top
View user's profile Send private message
FlumMmicH
n00b
n00b


Joined: 31 Oct 2004
Posts: 58
Location: Sweden

PostPosted: Tue May 30, 2006 10:05 pm    Post subject: Reply with quote

ありがとうございます!
it works very well :D tyvm!
_________________
Less is more.
Back to top
View user's profile Send private message
Xamindar
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1155
Location: California

PostPosted: Fri Jun 02, 2006 8:30 am    Post subject: Reply with quote

If you make a folder or filename in japanese on any drive (usb or fat or ntfs) and try to view it in windows is it in any way messed up? I'm having that problem right now and could use some help fixing it. https://forums.gentoo.org/viewtopic-p-3354060.html#3354060

Same thing happens if I make a file with japanese characters in windows and then attempt to see it in Linux, I just get a bunch of "??????"
Back to top
View user's profile Send private message
Magnum44
Guru
Guru


Joined: 21 May 2003
Posts: 538

PostPosted: Wed Jun 14, 2006 6:24 pm    Post subject: Greather than and lower than symbols Reply with quote

Hello again, I'm inspired again so I'm trying to solve another problem that came with UTF-8 and Japanese input, the symbols of "greather than" and "lower than" (the key next to left shift in my spanish layout keyboard) don't work... Does anybody nows how to fix this?

And another problem is that in OpenOffice I can't use accents... Any ideas?

Thanks all folks! :roll:
_________________
"La suerte favorece sólo a la mente preparada." (Isaac Asimov citando a Louis Pasteur).
"Fortune favors the prepared mind." (Isaac Asimov quoting Louis Pasteur).
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Thu Jun 15, 2006 9:25 pm    Post subject: Re: Greather than and lower than symbols Reply with quote

Magnum44 wrote:
Hello again, I'm inspired again so I'm trying to solve another problem that came with UTF-8 and Japanese input, the symbols of "greather than" and "lower than" (the key next to left shift in my spanish layout keyboard) don't work... Does anybody nows how to fix this?

And another problem is that in OpenOffice I can't use accents... Any ideas?

Thanks all folks! :roll:


I would think this is an Xorg-x11 keyboard issue - the layout can be configured seperately http://www.gentoo.org/doc/en/xorg-config.xml#doc_chap4_sect2 - I would assume it was working correctly before?

-Sud.
_________________
...
Back to top
View user's profile Send private message
Magnum44
Guru
Guru


Joined: 21 May 2003
Posts: 538

PostPosted: Fri Jun 16, 2006 9:01 am    Post subject: Xorg keyboard issue Reply with quote

Mmm... I'm reading that link and looking my xorg.conf, I think I have that ok:
Code:
* x11-base/xorg-x11
     Available versions:  6.8.2-r7 [M]6.9.0-r1 ~7.0-r1 ~7.1
     Installed:           6.8.2-r7

My keyboard section in xorg.conf:
Code:
Section "InputDevice"

    Identifier  "Keyboard1"
    Driver      "kbd"

    Option "AutoRepeat" "500 30"


    Option "XkbModel"   "pc104"
    Option "XkbLayout"  "es"

EndSection



Quote:
I would assume it was working correctly before?

Yes, before upgrade to UTF-8 and Japanese input, when I was using the default 8859-1 or 8859-15 (Occidental Europe) all the keyboard worked well.

More ideas?
_________________
"La suerte favorece sólo a la mente preparada." (Isaac Asimov citando a Louis Pasteur).
"Fortune favors the prepared mind." (Isaac Asimov quoting Louis Pasteur).
Back to top
View user's profile Send private message
Sudrien
Apprentice
Apprentice


Joined: 01 Oct 2003
Posts: 207
Location: Michigan

PostPosted: Fri Jun 16, 2006 12:26 pm    Post subject: Re: Xorg keyboard issue Reply with quote

Magnum44 wrote:
Quote:
I would assume it was working correctly before?

Yes, before upgrade to UTF-8 and Japanese input, when I was using the default 8859-1 or 8859-15 (Occidental Europe) all the keyboard worked well.

More ideas?


https://bugs.freedesktop.org/show_bug.cgi?id=3988 seems to have a similar problem mentioned. I think the issue may be that you want more than anthy's 'raw keyboard input' can handle (probably understandably).

Try looking for a specifice UIM module that supports ES input, or upgrading to uim-1.1.0 (is it in portage yet?)

-Sud.
_________________
...
Back to top
View user's profile Send private message
Magnum44
Guru
Guru


Joined: 21 May 2003
Posts: 538

PostPosted: Fri Jun 16, 2006 12:51 pm    Post subject: Reply with quote

Nope, that bug is not the point... I can use accents in KDE (not in Openoffice, another thing to do). In KDE the only thing that don't work is greather and lower keys...
:cry:
_________________
"La suerte favorece sólo a la mente preparada." (Isaac Asimov citando a Louis Pasteur).
"Fortune favors the prepared mind." (Isaac Asimov quoting Louis Pasteur).
Back to top
View user's profile Send private message
pèdratan
n00b
n00b


Joined: 04 Feb 2003
Posts: 32
Location: Japon

PostPosted: Tue Jun 27, 2006 9:57 am    Post subject: Re: Xorg keyboard issue Reply with quote

Sudrien wrote:


https://bugs.freedesktop.org/show_bug.cgi?id=3988 seems to have a similar problem mentioned. I think the issue may be that you want more than anthy's 'raw keyboard input' can handle (probably understandably).

Try looking for a specifice UIM module that supports ES input, or upgrading to uim-1.1.0 (is it in portage yet?)

-Sud.


I filed that bug, but I have not verified if the fix works because I changed from uim to scim + scim-anthy + scim-qtimm. Anyway, that only happened when you used QT_IM_MODULE=uim, as stated before in this howto. It was solved if you used scim instead, so it should work now.

Funny thing is everything (accents included) worked until a week ago. Now I have the same problem in qt, but without uim at all. I have just posted in a bug filed by other person about this deadkeys issue:

https://bugs.gentoo.org/show_bug.cgi?id=131644

If anyone is interested ;)
Back to top
View user's profile Send private message
olof
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2004
Posts: 78
Location: Japan

PostPosted: Thu Jul 13, 2006 1:22 am    Post subject: Reply with quote

If anyone is interested, I posted some ebuilds for Tomoe in bugzilla (tomoe, libtomoe-gtk, scim-tomoe). Tomoe is a japanese handwriting recognition engine, and with scim-tomoe it integrates nicely into scim, giving you something close to the full IME in windows. It may not be quite as good as the Microsoft handwriting recognition yet, but at least it is usable. For a nice description take a look here.

If you have any comments on the ebuilds pleast let me know, it's my first time submitting ebuilds.
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2968
Location: Germany

PostPosted: Tue Aug 01, 2006 8:38 pm    Post subject: Reply with quote

Thanks, I'll definitely test this tomoe out sometime. Until now I was using kanjipad, which kind of works, but it's extremely uncomfortable. First you have to draw the kanji, then hit a 'search' button, then select the correct one from the list, then click copy, then paste it into your target application... for single kanji this is okay but it's tedious when you have to look up more.

On the Sharp Zaurus (Japanese portable Linux device) you have much better handwriting recognition, 3 input fields, so you can just draw one kanji, continue in the next field, and so on, and the recognized characters will automatically be inserted into the text. If this tomoe thing can work in a similar fashion, I'll be happy. :-)

===

Now onto some problems I have: After doing a fresh Gentoo install, Japanese input stopped working with xterm/urxvt and OpenOffice. When pressing ctrl+space, the input window comes up, however inserting the Japanese text into the application does not work. For example, when typing something like ひらがな, the result that gets pasted into the application is "*c2ccc", along with some special characters. However, it's not that the applications can't handle Japanese - copy&pasting Japanese text works and gets displayed properly. So my guess is that SCIM sends crap or uses wrong charset (whole system runs in UTF-8 mode as per this Howto though).

Anyone else seeing this behaviour?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 7, 8, 9, 10, 11, 12  Next
Page 8 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum