Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Enabling Japanese (or: CJK in KDE & Gnome)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5 ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
liuspider
Apprentice
Apprentice


Joined: 03 Feb 2003
Posts: 237

PostPosted: Wed Jun 15, 2005 12:45 pm    Post subject: Reply with quote

that's largely caused by incompatible C++ ABI, which beyond our control

but if anything app has a problem with the gtk im module, you can just use xim im module, details

MOD EDIT: Added bbCode tags for that URL of yours. Please use them, especially for long addresses, they break the page layout... --plate
_________________
BLOG: http://liucougar.scim-im.org
Back to top
View user's profile Send private message
yaneurabeya
Veteran
Veteran


Joined: 13 May 2004
Posts: 1754
Location: Seattle

PostPosted: Fri Jun 17, 2005 5:51 am    Post subject: Reply with quote

Really? glibc reports a bunch of errant free() errors, so it looks like a few malloc() / free() pair of calls gone bad. Might be something completely out of the SCIM dev's control though...
Back to top
View user's profile Send private message
lo-jay
l33t
l33t


Joined: 27 Feb 2005
Posts: 862

PostPosted: Mon Jul 11, 2005 9:43 pm    Post subject: scim-confusion Reply with quote

:? o.k.
did set up scim & the locales on my (non kde ) system.
when i try to start scim from a console i get

Quote:
(scim-panel-gtk:8959):Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.


and don't get it running.
what am i missing?

thanks again!
_________________
lo-jay

The mechanic "One of 'em Dodge Chargers - let him go by."
The driver "Not today!"

taken from "Two Lane Blacktop"
Back to top
View user's profile Send private message
yaneurabeya
Veteran
Veteran


Joined: 13 May 2004
Posts: 1754
Location: Seattle

PostPosted: Wed Jul 13, 2005 8:01 am    Post subject: Reply with quote

Prolly have to add the locale to the locales file somewhere in the /etc folder (I forget where exactly) and recompile glibc and all related programs since you used the userlocales USE flag with glibc and had a shortened (deleted Japanese locale codes) locales list from the default.
Back to top
View user's profile Send private message
lo-jay
l33t
l33t


Joined: 27 Feb 2005
Posts: 862

PostPosted: Wed Jul 13, 2005 6:19 pm    Post subject: Reply with quote

well, my locales look like this now

Code:
LANG=de_DE.UTF-8
LC_CTYPE=zh_CN.UFT-8
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=


still scim doesn't work:

Code:
(scim-panel-gtk:8964):Gtk-WARNING **: Locale not supported by Xlib

(scim-panel-gtk:8964):Gtk-WARNING **: cannot set locale modifiers


thanks again
_________________
lo-jay

The mechanic "One of 'em Dodge Chargers - let him go by."
The driver "Not today!"

taken from "Two Lane Blacktop"
Back to top
View user's profile Send private message
liuspider
Apprentice
Apprentice


Joined: 03 Feb 2003
Posts: 237

PostPosted: Wed Jul 13, 2005 7:30 pm    Post subject: Reply with quote

please consult this

btw: as you are trying to use Chinese, you may want to post in the Chinese forum
_________________
BLOG: http://liucougar.scim-im.org
Back to top
View user's profile Send private message
lo-jay
l33t
l33t


Joined: 27 Feb 2005
Posts: 862

PostPosted: Wed Jul 13, 2005 8:53 pm    Post subject: Reply with quote

i did follow this wiki, but no success till now.

but you're right, will move to the chinese forum.

thanks!
_________________
lo-jay

The mechanic "One of 'em Dodge Chargers - let him go by."
The driver "Not today!"

taken from "Two Lane Blacktop"
Back to top
View user's profile Send private message
yaneurabeya
Veteran
Veteran


Joined: 13 May 2004
Posts: 1754
Location: Seattle

PostPosted: Wed Jul 13, 2005 10:58 pm    Post subject: Reply with quote

You mistyped your locales...

Code:

LANG=de_DE.UTF-8
LC_CTYPE=zh_CN.UFT-8 # Make this LC_CTYPE=zh_CN.UTF-8
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
Back to top
View user's profile Send private message
valuial
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2004
Posts: 85

PostPosted: Sun Jul 17, 2005 6:41 pm    Post subject: Reply with quote

Hi there.

I tried to install skim and the like on my own, and during the process (I used some Versions not yet in portage) got the thing working when starting scim manually... So I tried to configure my system to start the necessary things automatically ... and failed.

After cleaning my system from my futile attemps I tried it following this howto.
It works with firefox. But not with kwrite for example (haven't tested too many apps but kde-apps as well as a certain qt-app were not successful).

my /etc/env.d/02locale:
Code:
LANG=de_DE
LC_CTYPE=ja_JP.UTF-8


as well as my /etc/xprofile:
Code:
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim


Any suggestions?

V.
Back to top
View user's profile Send private message
yaneurabeya
Veteran
Veteran


Joined: 13 May 2004
Posts: 1754
Location: Seattle

PostPosted: Mon Jul 18, 2005 10:44 am    Post subject: Reply with quote

You forgot that you have to recompile QT to get Japanese support :)?
Back to top
View user's profile Send private message
valuial
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2004
Posts: 85

PostPosted: Mon Jul 18, 2005 10:57 am    Post subject: Reply with quote

I did
Code:
emerge world --newuse -av
... Qt was recompiled as I remember... Useflags as stated in this howto...
Back to top
View user's profile Send private message
fctk
Veteran
Veteran


Joined: 28 Jan 2004
Posts: 1424
Location: Milan, Italy, EU

PostPosted: Tue Jul 19, 2005 4:52 pm    Post subject: Reply with quote

I read the Japanese fonts' related part (I'm not interested in input, I just want to see japanese text in firefox :lol: ) so... do I need to recompile everything with the cjk use flag?
Back to top
View user's profile Send private message
G2k
l33t
l33t


Joined: 06 Mar 2004
Posts: 672
Location: Rome, Italy

PostPosted: Tue Jul 19, 2005 6:05 pm    Post subject: Reply with quote

I think that if you follow this guide you should be pretty much set. And you should emerge a couple of Japanese fonts just in case.

P.S.
Mi sono accorto che sei Italiano dopo aver scritto il post. :wink:
_________________
Animula vagula blandula,
Hospes comesque corporis,
Quae nunc abibis in loca
Pallidula rigida nudula,
Nec ut soles dabis iocos...
- Imp. Caesar Hadrianus
Back to top
View user's profile Send private message
yaneurabeya
Veteran
Veteran


Joined: 13 May 2004
Posts: 1754
Location: Seattle

PostPosted: Sat Jul 23, 2005 5:12 am    Post subject: Reply with quote

All you really need is the nls (non-Latin script I believe) flag and the cjk/unicode flags, plus the proper locale setup. The rest is just extra fluff for 'improved' interfacing for the user.

All I can say is that I love my Mac's Japanese input system :).
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Mon Jul 25, 2005 5:47 am    Post subject: Reply with quote

yaneurabeya wrote:
... nls (non-Latin script I believe) ...

Wrong! nls stands for Native Language Support. it enables apps to show output in whatever language you set as your "native language", and not just plain old English.
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
fctk
Veteran
Veteran


Joined: 28 Jan 2004
Posts: 1424
Location: Milan, Italy, EU

PostPosted: Mon Jul 25, 2005 8:04 am    Post subject: Reply with quote

yaneurabeya wrote:
All you really need is the nls (non-Latin script I believe) flag and the cjk/unicode flags, plus the proper locale setup. The rest is just extra fluff for 'improved' interfacing for the user.

so i need the cjk use flag? but even without it i'm able to see japanese/chinese etc... with firefox quite well... :?
Back to top
View user's profile Send private message
yaneurabeya
Veteran
Veteran


Joined: 13 May 2004
Posts: 1754
Location: Seattle

PostPosted: Mon Jul 25, 2005 12:17 pm    Post subject: Reply with quote

kimchi_sg wrote:
yaneurabeya wrote:
... nls (non-Latin script I believe) ...

Wrong! nls stands for Native Language Support. it enables apps to show output in whatever language you set as your "native language", and not just plain old English.


Ah yes... oops :oops:.

cjk and a lot of the other flags/libs listed on the first page are only needed for writing as you can just install a font (kochi-substitute is the name I believe-see the beginning of the webpage for more details) without having to go through the process of recompiling/installing a bunch more libs.
Back to top
View user's profile Send private message
fctk
Veteran
Veteran


Joined: 28 Jan 2004
Posts: 1424
Location: Milan, Italy, EU

PostPosted: Mon Jul 25, 2005 12:33 pm    Post subject: Reply with quote

k... so no need to recompile. i suggest to revise the layout of the first post... :) it would be even better to copy this howto on gentoo-wiki if it isn't already there... :)
Back to top
View user's profile Send private message
valuial
Tux's lil' helper
Tux's lil' helper


Joined: 03 Feb 2004
Posts: 85

PostPosted: Tue Jul 26, 2005 7:06 pm    Post subject: Reply with quote

Writing my last Mail I came upon another curious behaviour:
KMail as well as KEdit, but not KWrite have an context menu to select an Input Method.
Whenever I select XIM the japanese input works (I even can select keyboard, UIM-anthy etc. using the skim taskbar tool),
but when I select "simple composing input method" I only get the latin writing.

Any sugesstions to get scim working?

-V-

PS: I did recompile qt as suggested above.

valuial wrote:

my /etc/env.d/02locale:
Code:
LANG=de_DE
LC_CTYPE=ja_JP.UTF-8


as well as my /etc/xprofile:
Code:
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim

Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2968
Location: Germany

PostPosted: Thu Aug 11, 2005 10:28 pm    Post subject: Reply with quote

Thanks for this HOWTO. Input seems to work somehow (although I haven't yet figured out when/why that scim button keeps (dis)appearing randomly). However, I can't get it to work together with xterm properly. Does any of you use Japanese / UTF8 in xterm?

My xterm detects multi-byte characters correctly and all, but it just prints an empty box instead of the actual letter. So I guess it's a font issue. So I tried changing the font to "Arial Unicode MS" or to "Bitstream Cyberbit" (some of the fonts that I think are used by and work well in Firefox).

This works only partially, meaning: The Japanese letters are displayed correctly, but there are many side effects (bad redrawing of letters; big spaces between normal roman letters; etc.) that make it unusable. :cry:

Does any of you have a terminal emulator configuration that displays normal text and japanese perfectly

EDIT: Got it working in xterm and urxvt, with these settings. I think the important ones are utf8 and font. The fonts have to be installed, I guess (I just emerged all fonts portage had to offer).

Code:

!!! XTERM SETTINGS !!!

XTerm*locale:           true
XTerm*scrollBar:        true
XTerm*background:       black
XTerm*foreground:       white
XTerm*cursorColor:      yellow
XTerm*scrollTtyOutput:  false
XTerm*scrollKey:        true
XTerm*loginShell:       true
XTerm*utf8:             1
XTerm*VT100*font:       -Misc-Fixed-Medium-R-Normal--18-120-100-100-C-90-ISO10646-1
XTerm*VT100*wideFont:   -Misc-Fixed-Medium-R-Normal-ja-18-120-100-100-C-180-ISO10646-1
XTerm*multiScroll:      true
XTerm*saveLines:        4096

!!! RXVT-UNICODE SETTINGS !!!

URxvt*background:       black
URxvt*foreground:       white
URxvt*font:             -Misc-Fixed-Medium-R-Normal--18-120-100-100-C-90-ISO10646-1,\
                        -Misc-Fixed-Medium-R-Normal-ja-18-120-100-100-C-180-ISO10646-1

URxvt*saveLines:        4096
Back to top
View user's profile Send private message
branana
n00b
n00b


Joined: 03 Sep 2004
Posts: 29

PostPosted: Wed Aug 24, 2005 1:47 am    Post subject: Reply with quote

Guys, I have followed the guide. I think I have problems with the /etc/xprofile part. Because when I do startx, xprofile doesn't seem to be checked. echo $GTK_IM_MODULE does nothing.

I use startx to get into xfce4 4.2. I don't use Gnome or KDE.

When I try something like, gaim, typing a new message. The SCIM icon does not automatically come up in the tray. If I manually start "scim" from terminal, it comes up in the tray but I cannot left-click it to select any input methods or anything. Please help!!
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2968
Location: Germany

PostPosted: Wed Aug 24, 2005 10:02 am    Post subject: Reply with quote

I don't have a /etc/xprofile either - if I remember correctly, it works only with a certain window / login manager (kde/kdm or gnome, I don't remember). Anyway, I'm using xdm and fluxbox; to make things work, I just put the stuff into my home profile and load it in ~/.fluxbox/startup.

Also, after following the guide, for some strange reason not all scim input modules were installed, and scim didn't work with kate. So I manually emerged /usr/portage/app-i18n/scim* (filtering out the masked packages), which solved the problem. I guess I'm missing a kde use flag or something that caused it not to be installed properly in the first place. (I have kde installed for a couple of kde apps like kate or kmail only).
Back to top
View user's profile Send private message
eealex
n00b
n00b


Joined: 29 Oct 2004
Posts: 65
Location: Japan

PostPosted: Sun Aug 28, 2005 8:07 am    Post subject: Reply with quote

branana wrote:
Guys, I have followed the guide. I think I have problems with the /etc/xprofile part. Because when I do startx, xprofile doesn't seem to be checked. echo $GTK_IM_MODULE does nothing.

I use startx to get into xfce4 4.2. I don't use Gnome or KDE.

When I try something like, gaim, typing a new message. The SCIM icon does not automatically come up in the tray. If I manually start "scim" from terminal, it comes up in the tray but I cannot left-click it to select any input methods or anything. Please help!!

Hi Branana,
I am also using XFCE4.2. I didn't read much about this thread but I put my scim related stuff in my ~/.xinitrc
Code:
alex@eealex ~ $ cat .xinitrc
export LANG="ja_JP.UTF-8"
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE=scim
scim -d -f x11
xfce-mcs-manager
xfwm4 --daemon
xftaskbar4 &
xfdesktop &
xbindkeys &
exec xfce4-panel

Hope useful for you.
Back to top
View user's profile Send private message
brjames
n00b
n00b


Joined: 30 Sep 2003
Posts: 52

PostPosted: Mon Aug 29, 2005 1:17 am    Post subject: Reply with quote

I have the same problem as valuial...

As far as i know everything has been recompiled and what not, but skim (or scim or whatever) just doesnt work with most kde programs. Cntrl-Space does nothing... Left click on the skim icon does nothing until i input into a gtk program...

Has anybody gotten skim to work completely with KDE?
Back to top
View user's profile Send private message
brjames
n00b
n00b


Joined: 30 Sep 2003
Posts: 52

PostPosted: Mon Aug 29, 2005 1:47 am    Post subject: Reply with quote

OMFG!!!! I am so pissed at what the solution is...

If anybody else is having the same problem as me or visualize, the solution is the following:

Code:
emerge -vp scim-qtimm



Obviously, the procedure by suderian on the first page worked at some point, so apparently some developer decided to remove scim-qtimm as a dependency of either skim or qt with qtimm use flag enabled... there might be a good reason for that, but im still kinda irritated that ive spend days trying to get this thing working when the only problem was a stupid missing dependency.

Anyway, Suderian if you could please update the front page... I did a text search on the first page so I didnt just miss it (my that would be embarrassing).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4, 5 ... 10, 11, 12  Next
Page 4 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum