Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Issue with mounting /dev/hda on OldWorld Mac
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
flaffer
n00b
n00b


Joined: 25 Jan 2003
Posts: 7

PostPosted: Fri Dec 10, 2004 3:13 am    Post subject: Issue with mounting /dev/hda on OldWorld Mac Reply with quote

I cannot get my mac to boot gentoo after the system setup. I ran through all the step successfully. However, when I boot from BootX, I get the following error:
Code:

ext2fs_check_if_mount: No such file or directory while determining whether /dev/hda9 is mounted....
/dev/hda9:
The Superblock could not be read or does not describe a correct ext2 filesystem.


It then drops me into rmaintenance mode.

I can mount /dev/hda9 when booting from the CD with no problem. I compiled my own kernel and verified that ext3 is compiled into the kernel.

Here is my fstab:
Code:

/dev/hda9    /    ext3    noatime   00
/dev/hda8    /var   ext3   noatime    00
/dev/hda7    none    swap    noauto,ro    00

none     /proc    proc    defaults


And some other stuff dealing with the CD-ROM mountpoint and /dev/shm.

There is no /dev/hda9 (or hda anything) in /dev.

Am I missing something here?
Back to top
View user's profile Send private message
porodzila
Guru
Guru


Joined: 22 May 2004
Posts: 307
Location: Terrapin Station

PostPosted: Fri Dec 10, 2004 4:58 am    Post subject: Reply with quote

yes you are definitely missing something. I dont know what yet. I thought hdx was for ide drives, maybe something else in /dev/ will help you?
_________________
ubi primum potero, me hinc subduco.
Back to top
View user's profile Send private message
flaffer
n00b
n00b


Joined: 25 Jan 2003
Posts: 7

PostPosted: Fri Dec 10, 2004 5:58 pm    Post subject: Reply with quote

I figured it out. I had to boot into the CD, remount my harddrive (it is IDE), chroot into it and then emerge devfsd. It was not emerged when I did a system emerge. I did a stage3 tar install and it must not be installed with that as well!

Flaffer
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum