Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Errors setting user font?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
_savage
Guru
Guru


Joined: 06 Jun 2004
Posts: 308
Location: Redmond, WA

PostPosted: Wed Dec 15, 2004 12:41 pm    Post subject: Errors setting user font? Reply with quote

Hello,

I am not quite sure when I introduced this error/warning or whatever it is. When I boot up the system, I get this output

Code:
 * Setting user font ...
 action_compat: error unlinking: "vcsa2" No such file or directory
 action_compat: error unlinking: "vcs4"  No such file or directory
 action_compat: error unlinking: "vcsa4" No such file or directory                                                                                     
 action_compat: error unlinking: "vcs6"  No such file or directory
 action_compat: error unlinking: "vcsa6" No such file or directory
 action_compat: error unlinking: "vcs7"  No such file or directory


Interestingly, it changes from time to time and I am not really sure why. What's going on here, where does that come from, and how can I get rid of it?

Cheers,
Jens
_________________
Jens Troeger
http://savage.light-speed.de/
Back to top
View user's profile Send private message
porodzila
Guru
Guru


Joined: 22 May 2004
Posts: 307
Location: Terrapin Station

PostPosted: Wed Dec 15, 2004 8:25 pm    Post subject: Reply with quote

hmm, well, your font setting will be in /etc/rc.conf

try changing it to something (cybercafe - cause its easy to type) and setting it manually :

/etc/init.d/consolefont stop
/etc/init.d/consolefont start

and see what it does
_________________
ubi primum potero, me hinc subduco.
Back to top
View user's profile Send private message
-anusaya-
n00b
n00b


Joined: 14 Dec 2004
Posts: 28
Location: New Zealand

PostPosted: Wed Dec 15, 2004 11:48 pm    Post subject: Reply with quote

Your not doing crazy stuff like having both devfs and udev running together are you?
Back to top
View user's profile Send private message
_savage
Guru
Guru


Joined: 06 Jun 2004
Posts: 308
Location: Redmond, WA

PostPosted: Thu Dec 16, 2004 9:18 am    Post subject: Reply with quote

-anusaya- wrote:
Your not doing crazy stuff like having both devfs and udev running together are you?


Erm... frankly, I am not sure but now that you mention it... How can I find out? :-D

Jens
_________________
Jens Troeger
http://savage.light-speed.de/
Back to top
View user's profile Send private message
-anusaya-
n00b
n00b


Joined: 14 Dec 2004
Posts: 28
Location: New Zealand

PostPosted: Thu Dec 16, 2004 10:06 pm    Post subject: Reply with quote

If you have sys-fs/udev installed then ensure that devfs is not automatically started upon boot:

1. disable automatic mounting of devfs in the kernel
Code:
File systems  --->
  Pseudo filesystems  --->
    /dev file system support (OBSOLETE)
      [ ] Automatically mount at boot (NEW)


2. If you want to keep devfs support in your kernel (i.e. "/dev file system support (OBSOLETE)" is enabled) then add "gentoo=nodevfs" as a kernel parameter.
Back to top
View user's profile Send private message
pindar
Apprentice
Apprentice


Joined: 30 Apr 2004
Posts: 220

PostPosted: Thu Dec 16, 2004 10:12 pm    Post subject: Reply with quote

It's a kernel option. Grep for DEVFS in your .config:
Code:

grep DEVFS /usr/src/linux/.config
# CONFIG_DEVFS_FS is not set

But if you want to recompile your kernel without devfs support, have a look at the documentation here and here, there are some pitfalls (expertus dico).
Back to top
View user's profile Send private message
_savage
Guru
Guru


Joined: 06 Jun 2004
Posts: 308
Location: Redmond, WA

PostPosted: Fri Dec 17, 2004 4:43 am    Post subject: Reply with quote

-anusaya- wrote:
If you have sys-fs/udev installed then ensure that devfs is not automatically started upon boot


Both seem to be installed and running. ps showed both a devfsd and a udevd.

-anusaya- wrote:
2. If you want to keep devfs support in your kernel (i.e. "/dev file system support (OBSOLETE)" is enabled) then add "gentoo=nodevfs" as a kernel parameter.


I tried this for a start. What happened was that during early bootup Gentoo dumped a message that it requires either DEVFS or UDEV installed (both are) and that it assumes DEVFS by default. After 15 seconds it continues to boot and runs devfsd.

I'll see if I can find a how-to on udev, and then get rid of devfs. Can you point me to something?

Cheers,
Jens

PS@pindar: Ah thanks for the links :-)
_________________
Jens Troeger
http://savage.light-speed.de/
Back to top
View user's profile Send private message
_savage
Guru
Guru


Joined: 06 Jun 2004
Posts: 308
Location: Redmond, WA

PostPosted: Fri Dec 17, 2004 9:30 am    Post subject: Reply with quote

Ok, I followed the installation guide for udev, and now it works most excellent... Thanks heaps! :-D

Jens
_________________
Jens Troeger
http://savage.light-speed.de/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum