Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
swapped blue and red colors
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
kodi_gda
n00b
n00b


Joined: 09 Dec 2004
Posts: 6

PostPosted: Sun Dec 19, 2004 6:21 pm    Post subject: swapped blue and red colors Reply with quote

I have a Tibook, G4 400, Ati Rage 128. After installation, i finally managed to run Xorg 6.8. But.. I have swapped blue and red colors. Like instead of RGB i have BGR. What's wrong? i have screen depth of 24bits, FBdev mode.

BTW is it possible to run this ATI card in native mode with some acceleration? Or i'm stuck to FB driver?
Back to top
View user's profile Send private message
bruda
Guru
Guru


Joined: 06 May 2004
Posts: 376
Location: Sherbrooke, QC, Canada

PostPosted: Sun Dec 19, 2004 10:35 pm    Post subject: Reply with quote

My wife's machine is a CRT iMac with a Rage 128 PRO AGP 4x. It works fine with the r128 driver (i.e., in native mode), but DRI is problematic (works but brings the system to an abysmal performance). Here are the relevant pieces from xorg.conf:
Code:
Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "record"
        Load  "xtrap"
        Load  "freetype"
        Load  "speedo"
        Load  "type1"
#       Load  "dri"
        Load  "drm"
        Load  "glx"
        Load  "GLcore"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        ModelName    "iMac Monitor"
        HorizSync 60-60
        VertRefresh 75-117
        DisplaySize 269 202
        Option      "DPMS"
EndSection

Section "Device"
        Identifier  "Card0"
        Driver      "r128"
        Option      "UseFBDev"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"

        DefaultDepth    16
        SubSection "Display"
                Depth     16
                Modes    "1024x768"
        EndSubSection
        SubSection "Display"
                Depth     24
                Modes    "1024x768"
        EndSubSection
EndSection

The monitor settings are of course different in your case but the idea should be the same.

I don't know why are the colours shifted though.
_________________
Quid latine dictum sit altum videtur
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum