Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ALSA broken on Old World boxes?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
lazloman
Guru
Guru


Joined: 27 Dec 2003
Posts: 343
Location: Skokie, Il. USA

PostPosted: Fri Jan 07, 2005 9:13 pm    Post subject: ALSA broken on Old World boxes? Reply with quote

I can't get sound to work since moving to the 2.6 kernel. When I use KDE to configure sound, I get a crash invloving KNotify that points to kdelibcore.so.4 Gnome says that there are no mixer sound devices. I can use alsamixer to mute/unmute sound, but all I ever hear is an ocassional crackle from the internal speaker. I went through the ALSA configuration guide. I tried to install alsa-driver, but it failed. I'm not sure if I need it. The guide recommends it, but I found other posts that say its uneccessary for the 2.6 kernel (I have 2.6.9-r9). I installed alsa-utils w/o trouble and alsasound starts w/o error. It also finds my sound card, AWACS Screamer. In make.conf, I added ALSA_CARDS="powermac" before emergeing alsa-driver and alsa-utils. One other thing is that I added the ALSA stuff to the kernel, not as modules. I might try recompiling as modules, but since ALSA finds my sound card, it should n't make a difference, right.
sorry, I don't have the exact error messages, I'm not at home right now, but someone else out there must have had this problem and maybe they can give me step by step instructions on how this is done.
Any help appreciated
_________________
Gentoo x86
2x Dell Optiplex GX200

"My Break-Dancing days are over, but there's always the Funky Chicken."
--The Full Monty
Back to top
View user's profile Send private message
lazloman
Guru
Guru


Joined: 27 Dec 2003
Posts: 343
Location: Skokie, Il. USA

PostPosted: Wed Feb 23, 2005 4:30 pm    Post subject: Reply with quote

Not quite, it seems one needs to be sure to have the 'arts' keyword in make.conf before emerging kdemultimedia.
_________________
Gentoo x86
2x Dell Optiplex GX200

"My Break-Dancing days are over, but there's always the Funky Chicken."
--The Full Monty
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum