Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VGA out on Ibook 12" 1,2 Ghz
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
aronchi
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2004
Posts: 94

PostPosted: Sun Jan 09, 2005 12:49 am    Post subject: VGA out on Ibook 12" 1,2 Ghz Reply with quote

Does anyone managed to make this feature works? It's really important for me, but I don't know if now it's possible and anyone has done it before.
_________________
Alessandro Ronchi Home Page
SOASI: Sviluppo Software e Sistemi Open Source Forlì
Back to top
View user's profile Send private message
toojays
Apprentice
Apprentice


Joined: 21 Jul 2002
Posts: 150
Location: Adelaide, Australia

PostPosted: Sun Jan 09, 2005 11:39 am    Post subject: Reply with quote

Progress is being made on this front, but it's slow. With the latested xorg snapshot in portage (6.8.1.901) you can kind of do it. Just disable the "UseFBDev" option in your xorg.conf, plug in the external monitor, and restart the X server. The problem with this is that the LCD panel of the laptop flickers horribly. However, if you only need to use the external VGA, just turn off the backlight on the LCD, and it won't bother you.

I've tried building just the latest driver from xorg CVS, and that seemed to solve the flickering problem, but for some reason now I can't get it to detect the second head at all. This may be due to me using the CVS version of the driver with an older version of the server though.
Back to top
View user's profile Send private message
aronchi
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2004
Posts: 94

PostPosted: Sun Jan 09, 2005 12:36 pm    Post subject: Reply with quote

Can you put here your xorg.conf for the 6.8.1.901 version?
_________________
Alessandro Ronchi Home Page
SOASI: Sviluppo Software e Sistemi Open Source Forlì
Back to top
View user's profile Send private message
spitzwegerich
l33t
l33t


Joined: 04 Mar 2003
Posts: 697
Location: Lower Bavaria, Central Europe

PostPosted: Sun Jan 09, 2005 12:54 pm    Post subject: Reply with quote

toojays:

You seem to be very well-informed about the status of the VGA out. Could you inform us here in the PPC-Forum once that the VGA out runs without problems?
_________________
"Work is the curse of the drinking classes."
-Oskar Wilde
Back to top
View user's profile Send private message
toojays
Apprentice
Apprentice


Joined: 21 Jul 2002
Posts: 150
Location: Adelaide, Australia

PostPosted: Tue Jan 11, 2005 7:20 am    Post subject: Reply with quote

Here's what I use for 6.8.1.901:
Code:
Section "Files"
   RgbPath       "/usr/lib/X11/rgb"
   ModulePath    "/usr/lib/modules"
   FontPath   "/usr/share/fonts/truetype/"
   FontPath   "/usr/share/fonts/corefonts/"
   FontPath   "/usr/share/fonts/truetype/western/"
   FontPath   "/usr/share/fonts/truetype/decoratives/"
   FontPath   "/usr/share/fonts/truetype/vera/"
   FontPath   "/usr/share/fonts/TTF/"
   FontPath   "/usr/share/fonts/misc/"
   FontPath      "/usr/share/fonts/Speedo/"
   FontPath      "/usr/share/fonts/Type1/"
   FontPath      "/usr/share/fonts/100dpi/"
   FontPath      "/usr/share/fonts/75dpi/"
        FontPath        "/usr/share/fonts/baekmuk"
        FontPath        "/usr/share/fonts/ttf/korean/baekmuk"
        FontPath        "/usr/share/fonts/ttf/zh_CN"
        FontPath        "/usr/share/fonts/ttf/zh_TW"
EndSection

Section "Module"
   Load  "extmod"
   Load  "freetype"
   Load  "int10"
   Load  "dri"
   Load  "dbe"
   Load  "record"
   Load  "xtrap"
   Load  "glx"
   #Load  "speedo"
   Load  "type1"
EndSection

Section   "InputDevice"
   Identifier   "Keyboard0"
   Driver      "kbd"
   Option      "XkbModel"      "macintosh"
   Option      "XkbLayout"      "us"
   Option      "XkbVariant"   "ibook"
EndSection

Section "InputDevice"
   Identifier   "Mouse0"
   Driver      "mouse"
   Option      "Protocol"      "ExplorerPS/2"
   Option      "ZAxisMapping"   "4 5"
   Option      "Device"      "/dev/input/mice"
EndSection

Section "Monitor"
   Identifier      "Monitor0"
   VendorName      "Monitor Vendor"
   ModelName       "Monitor Model"
        Gamma           1.8     # Apple use 1.8 instead of 2.2? or vice-versa?
EndSection

Section "Device"
   Identifier     "Card0"
   Driver         "radeon"
   VendorName     "ATI"
   BoardName      "Radeon Mobility 9200 M9+"
   Option        "AGPMode"   "4"
   Option      "EnablePageFlip" "true"
   Option      "DynamicClocks" "true"
   Option      "CRT2Position"   "Above"
   BusID          "PCI:0:16:0"
EndSection

Section "Screen"
   Identifier    "Screen0"
   Device      "Card0"
   Monitor       "Monitor0"
   DefaultDepth    16
   SubSection "Display"
      Depth    1
      Modes     "1024x768" "640x480" "800x600"
   EndSubSection
   SubSection "Display"
      Depth    4
      Modes     "1024x768" "640x480" "800x600"
   EndSubSection
   SubSection "Display"
      Depth    8
      Modes     "1024x768" "640x480" "800x600"
   EndSubSection
   SubSection "Display"
      Depth    15
      Modes     "1024x768" "640x480" "800x600"
   EndSubSection
   SubSection "Display"
      Depth    16
      Modes     "1024x768" "640x480" "800x600"
   EndSubSection
   SubSection "Display"
      Depth    24
      Modes     "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "DRI"
   Mode 0666
EndSection

Section "ServerLayout"
   Identifier        "XFree86    Configured"
   Screen      "Screen0"   0 0
   InputDevice       "Mouse0"    "CorePointer"
   InputDevice       "Keyboard0" "CoreKeyboard"
EndSection
I imagine that it's really only the "Device" section that's relevant.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum