Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Automounting local filesystems with autofs
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
jsosic
Guru
Guru


Joined: 02 Aug 2004
Posts: 510
Location: Split (Croatia)

PostPosted: Mon Jan 10, 2005 10:24 pm    Post subject: HOWTO: Automounting local filesystems with autofs Reply with quote

Automounting devices with autofs
revision 1.12

1. What will I learn?
I think Subject is pretty clear :) No NFS will be discussed here.

2. Why to choose autofs among ivman, gnome-volume-manager, submount and others? What are advantages and disadvantages of autofs?

PROS:
    1. autofs doesn't mount media after you insert it, but when you access mountpoint
    2. autofs is capable of automatic umounting after configured time period of non usage of the mounted device
    3. less dependencies than other automounters (lighter)

CONS:
    1. autofs is !not! userspace, but kernelbased
    2. autofs is not inteligent, you must configure all new device before you use them

If you know some other +/- then please tell it and I'll expand the list :)

Now first the short explanation of how autofs works:
Quote:
When you instert cdrom into drive, nothing happens. Then you enter /media dir and type ls. Nothing appears. You type cd cdrom and TAADDDDAAA. Youre in /media/cdrom. Autofs created the dir and mounted device. Once you exit that dir, and stop using your drive, tray is still locked for timeout T, and after T seconds drive is unlocked and you can take out you compact disc.
Things can be made simplier by adding symbolic links and/or icons. Version 4.x has ghosting feature, that keeps directories exist even if device is not mounted, so you can see all configured devices by typing ls /media.


    1. log on as root or su

    2. re-configure, recompile and reboot your kernel
    Code:
    # cd /usr/src/linux
    # make menuconfig

    turn this on:
    Code:
    File systems --->
    <*>  Kernel automounter version 4 support (also supports v3)
    Note that it doesn't matter if it's builtin or a module, do it how you prefer. If it's compiled as a module, it will be loaded automatically upon startup of autofs daemon, so you don't need to load it manually. After exiting menuconfig and saving new kernel config file, you should recompile it. If autofs is built into the kernel (<*>) then you can just run "make bzImage" and copy new image in /boot, and if it's selected as a module (<M>) then you don't need to recompile kernel image, but just modules ("make modules modules_install"). After doing this, don't forget to re-emerge additional kernel modules (like nforce-audio, sys-fs/fuse, lircd, fglrx.....) that you use.

    3. fetch and compile autofs
    Code:
    # emerge net-fs/autofs


    4. setup "/etc/autofs/auto.master"
    Code:
    /media   /etc/autofs/auto.media   --option1 --option2
    Quote:
    1. First option tells autofs under what directory devices will be mounted
    2. Second option tells autofs what configuration file to use for selected dir
    3. Third come the options that will be passed to automounter. --timeout=1 means that any device configured in auto.media file will be umounted after 1s of inactivity. --ghost can be added too, and some other opts.
    NOTE: You can have multiple configuration files, for different dirs or different devices...just as auto.media file can have multiple devices, so auto.master can also have multiple auto.?? files defined...and the sky is limit! This way, you can have different options for each mountpoint (e.g.: if you don't want automatic umounting of NFS mounts, or ghosting for cd/dvd devices, etc). This flexibility really show's off if you want different filesystems to umount after different period of inactivity.
    NOTE 2: If you don't pass any options in auto.master, then daemon will act on default policy settings. These are set in 6th step of this howto. BUT, this options will be passed to ALL mountpoints! You can still override them, offcourse, by setting them up here, in auto.master file.


    5. setup "/etc/autofs/auto.media"
    Code:
    cdrom      -fstype=iso9660,ro,nosuid,nodev   :/dev/cdroms/cdrom1
    cdrw      -fstype=iso9660,ro,nosuid,nodev   :/dev/cdroms/cdrom0
    camera      -fstype=vfat,rw,uid=0,gid=100,fmask=0117,dmask=0007,nosuid,nodev:/dev/sda1
    Quote:
    1. First option tells autofs what is the name of dir to mount device. Dir will be placed under directory stated previously in auto.master (in this case: /media/cdrom).
    2. Second option configures fstype and various permisions what will be passed to mount. Also for vfat you must set various masks for user-vulgaris to be able to access it.
    3. Third place states device.
    You may have noticed some "strange" options for VFAT file system. FAT filesystem doesn't have file classic Unix file security, it doesn't support file ownership, groups and access rights. If we mount it under Unix, files on the VFAT will get default ownership and access rights. This is sometimes unacceptable, but we can change it if we want. Here's quick explanation:
    1. uid - ID of a user who will be owner of the files on the monted media
    2. gid - ID of a group who will be group owner of files on mounted media
    3. fmask - bitmask of the permissions applied to regular files only, value is octal - if you want 660, you'll write 117 - reverse
    4. dmask - same as fmask, but for directories


    6. setup additional options in "/etc/conf.d/autofs"
    Code:
    daemonoptions='--timeout=1 --ghost'
    Quote:
    This file is parsed during autofs daemon startup, and checked for daemonoptions. If you don't want ghosting on all your mountpoints, don't put it in dameonoptions but in auto.master file, third section.
    NOTE: This kind of setting up options is Gentoo-specific. Other distros use other methods, and if you wish to have distro-unspecific setup, then all the options should be set like described in section 4. This also stands for other distro users.
    NOTE 2: If you don't know, --ghost is pretty nice option. It request that directories in the automount must be shown but not mounted until accesssed. This way you can eliminate the need of symlinks, and this makes life a lot easier ;)
    NOTE 3: '--ghost' option is avaliable ONLY in automount 4.x, not in 3.x, and must be put in daemonoptions variable, not localoptions like before.


    7. start autofs daemon and add it to runlevel
    Code:
    # /etc/init.d/autofs start
    # rc-update add autofs default


    8. test automounter
    Insert disc into cdrom and type $ cd /media/cdrom. Then, type $ cd .. and wait for timeout. If everything went ok, you can now unload tray of your cdrom drive. You passed the test, congratulations!

    9. make symbolic links and/or icons
    NOTE: If you use automounter4, and have --ghost option enabled, than you can skip this step. I will leave it online for users of old, 3.x version wich didn't support ghosting.
    Insert cd in cdrom, dvdrom, cdrw. Plug usb sticks, cameras, etc (you can do it one by one). Automount them (acces /media/cdrom trough xterm). Open new xterm window and type (as root):
    Code:
    # cd /mnt
    # ln -s /media/cdrom cdrom
    # ln -s /media/cdrw cdrw
    # ln -s /media/camera camera
    ...etc...
    Now you can unplug/eject devices, and if you want to make icons, point them to /mnt/cdrom, /mnt/cdrw, etc. Now, if you want to access cdrom drive, you don't need console at all. Yust point your file manager to /mnt/cdrom and cdrom will automatically mount. Set for example Digikam to use "USB mass storage" and as dir enter /mnt/camera. And you'll have almost a perfect automounter!

    10. Adding new devices
    If you at some point wish to add new device to your automounter, you can do that (described in steps 5. & 8.). But don't forget to restart autofs daemon after that, autofs won't notice the changes 'cause it picks up "auto.master" setup file when daemon starts, so if you change something, you've got to restart it again.




That's it!!!

What am I using?
- kernel 2.6.9-gentoo-r13
- autofs 3.1.7-r5

- kernel 2.6.10-gentoo-r6
- autofs 4.1.3
- autofs 4.1.3-r2
- autofs 4.1.3-r3
- autofs 4.1.3-r4

I recomend the latest version of autofs -> 4.1.3-r4. Also I've been running many versions of kernels back to 2.4.23 with no problems regarding autofs, so if you have problems, it's very unlikely that they're kernel based...

Disclaimer: All damage done to your system by following this howto is not my responsability, do this at your, and your risk only. This document can have errors too, so please correct me, nobody's perfect (excpet Seven of Nine). I tried to explain even smallest details but it's unlikely that everyone will understand everything. So, if you have any troubles using autofs or have any doubts with this howto, feel free to mail me. Live long and prosper \V/


Additional note: If you're interested in using autofs with network filesystems (NFS) then read my other autofs document: HOWTO: Automounting network filesystems with autofs.


Last edited by jsosic on Thu May 03, 2007 1:09 pm; edited 19 times in total
Back to top
View user's profile Send private message
DrWoland
l33t
l33t


Joined: 13 Nov 2004
Posts: 603

PostPosted: Tue Jan 11, 2005 9:25 pm    Post subject: Reply with quote

I don't see how this isn't more popular, this OWNS the utopia project.
Back to top
View user's profile Send private message
DrWoland
l33t
l33t


Joined: 13 Nov 2004
Posts: 603

PostPosted: Wed Jan 12, 2005 8:02 am    Post subject: Reply with quote

Hmmm, doesn't seem to work with audio devices. What's the dillio?
Back to top
View user's profile Send private message
PrakashP
Veteran
Veteran


Joined: 27 Oct 2003
Posts: 1249
Location: C.C.A.A., Germania

PostPosted: Wed Jan 12, 2005 11:40 am    Post subject: Reply with quote

This is nice, indeed. Does anybody know how to properly integrate it with kde? If I use a device, kde tries to mount it and then gives an error that it already has been mounted, but works otherwise...

If I use a symlink, then I can't change the icon, as kde wants to write into the symlink, whcih is the cd... Beside the icon issue, the symlink works as expected though.

Ahh, OK, I need to make a link to konqueror and with it start the folder. Here I can change icon and everything works as expected. Nice! :)


Uhm, new problem: How can I actually write to a floppy? DO I have to change permissions every time? (It seems I can't change user permissions?)

OK, I got it:

Code:

floppy          -fstype=auto,rw,nosuid,sync,user,gid=11,umask=002       :/dev/fd0
Back to top
View user's profile Send private message
Jimmy Jazz
Apprentice
Apprentice


Joined: 04 Oct 2004
Posts: 290
Location: Strasbourg

PostPosted: Wed Jan 12, 2005 2:29 pm    Post subject: Reply with quote

Hello,

i have some problems with autofs when i'm using the last 4.1.3-r2 version.

Please, read my post for more informations

https://forums.gentoo.org/viewtopic.php?t=277731&start=0&postdays=0&postorder=asc&highlight=

With autofs 3.1.7-r5, it works and i have the following messages:
Code:

Jan 12 15:44:21 [automount] starting automounter version 3.1.7, path = /media aptype = file, mapname = /etc/autofs/auto.media
Jan 12 15:44:21 [automount] using kernel protocol version 3
Jan 12 15:44:24 [automount] attempting to mount entry /media/cdrw
Jan 12 15:44:35 [automount] expired /media/cdrw
Jan 12 15:45:30 [automount] shutting down, path = /media


but autofs-4.1.3-r2 returns:

Code:

Jan 12 15:46:34 [automount] >> mount: périphérique spécial /dev/cdroms/cdrom1  n'existe pas
Jan 12 15:46:34 [automount] mount(generic): failed to mount /dev/cdroms/cdrom1  (type auto) on /media/cdrw
Jan 12 15:46:34 [automount] failed to mount /media/cdrw
Jan 12 15:46:34 [automount] >> mount: périphérique spécial /dev/cdroms/cdrom1  n'existe pas
Jan 12 15:46:34 [automount] mount(generic): failed to mount /dev/cdroms/cdrom1  (type auto) on /media/cdrw
Jan 12 15:46:34 [automount] failed to mount /media/cdrw
Jan 12 15:46:34 [automount] >> mount: périphérique spécial /dev/cdroms/cdrom1  n'existe pas
Jan 12 15:46:34 [automount] mount(generic): failed to mount /dev/cdroms/cdrom1  (type auto) on /media/cdrw
Jan 12 15:46:34 [automount] failed to mount /media/cdrw


Have you made this test with autofs 4.1.3-r2 version ?


Jj
Back to top
View user's profile Send private message
DrWoland
l33t
l33t


Joined: 13 Nov 2004
Posts: 603

PostPosted: Wed Jan 12, 2005 4:24 pm    Post subject: Reply with quote

Jimmy Jazz wrote:
Hello,

i have some problems with autofs when i'm using the last 4.1.3-r2 version.

Please, read my post for more informations

https://forums.gentoo.org/viewtopic.php?t=277731&start=0&postdays=0&postorder=asc&highlight=

With autofs 3.1.7-r5, it works and i have the following messages:
Code:

Jan 12 15:44:21 [automount] starting automounter version 3.1.7, path = /media aptype = file, mapname = /etc/autofs/auto.media
Jan 12 15:44:21 [automount] using kernel protocol version 3
Jan 12 15:44:24 [automount] attempting to mount entry /media/cdrw
Jan 12 15:44:35 [automount] expired /media/cdrw
Jan 12 15:45:30 [automount] shutting down, path = /media


but autofs-4.1.3-r2 returns:

Code:

Jan 12 15:46:34 [automount] >> mount: p�riph�rique sp�cial /dev/cdroms/cdrom1  n'existe pas
Jan 12 15:46:34 [automount] mount(generic): failed to mount /dev/cdroms/cdrom1  (type auto) on /media/cdrw
Jan 12 15:46:34 [automount] failed to mount /media/cdrw
Jan 12 15:46:34 [automount] >> mount: p�riph�rique sp�cial /dev/cdroms/cdrom1  n'existe pas
Jan 12 15:46:34 [automount] mount(generic): failed to mount /dev/cdroms/cdrom1  (type auto) on /media/cdrw
Jan 12 15:46:34 [automount] failed to mount /media/cdrw
Jan 12 15:46:34 [automount] >> mount: p�riph�rique sp�cial /dev/cdroms/cdrom1  n'existe pas
Jan 12 15:46:34 [automount] mount(generic): failed to mount /dev/cdroms/cdrom1  (type auto) on /media/cdrw
Jan 12 15:46:34 [automount] failed to mount /media/cdrw


Have you made this test with autofs 4.1.3-r2 version ?


Jj


I use 4.1.3-r2 and it works tres bien :)

Edit: Are you trying to mount an audio CD? Cuz it seems like those can't really be mounted in the traditional sense.
Back to top
View user's profile Send private message
Jimmy Jazz
Apprentice
Apprentice


Joined: 04 Oct 2004
Posts: 290
Location: Strasbourg

PostPosted: Wed Jan 12, 2005 6:39 pm    Post subject: Reply with quote

No of course i don't try to mount an audio cd. I use zinf for that ;)

Strange that i cannot get it work ... :(

Jj
Back to top
View user's profile Send private message
PrakashP
Veteran
Veteran


Joined: 27 Oct 2003
Posts: 1249
Location: C.C.A.A., Germania

PostPosted: Wed Jan 12, 2005 7:06 pm    Post subject: Reply with quote

New problem: I have a zip drive and disks formatted with ext2. So how to make it writable for the user? Here gid and umask don't work...
Back to top
View user's profile Send private message
iwankoenig
Tux's lil' helper
Tux's lil' helper


Joined: 31 Mar 2004
Posts: 83
Location: Germany(Hannover)

PostPosted: Thu Jan 13, 2005 2:55 pm    Post subject: Reply with quote

I have the following error:
Code:

make bzImage
  SPLIT   include/linux/autoconf.h -> include/config/*
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
  CHK     include/asm-i386/asm_offsets.h
  CHK     include/linux/compile.h
  CC      drivers/cdrom/cdrom.o
drivers/cdrom/cdrom.c: In function `cdrom_open':
drivers/cdrom/cdrom.c:899: error: too few arguments to function `open_for_data'
make[2]: *** [drivers/cdrom/cdrom.o] Error 1
make[1]: *** [drivers/cdrom] Error 2
make: *** [drivers] Error 2

What`s now?
_________________
"Vivat Fratres Intimi Ferro Iuncti."
Back to top
View user's profile Send private message
DrWoland
l33t
l33t


Joined: 13 Nov 2004
Posts: 603

PostPosted: Thu Jan 13, 2005 9:09 pm    Post subject: Reply with quote

iwankoenig wrote:
I have the following error:
Code:

make bzImage
  SPLIT   include/linux/autoconf.h -> include/config/*
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
  CHK     include/asm-i386/asm_offsets.h
  CHK     include/linux/compile.h
  CC      drivers/cdrom/cdrom.o
drivers/cdrom/cdrom.c: In function `cdrom_open':
drivers/cdrom/cdrom.c:899: error: too few arguments to function `open_for_data'
make[2]: *** [drivers/cdrom/cdrom.o] Error 1
make[1]: *** [drivers/cdrom] Error 2
make: *** [drivers] Error 2

What`s now?


Hmmm what kernel are you using?
Back to top
View user's profile Send private message
iwankoenig
Tux's lil' helper
Tux's lil' helper


Joined: 31 Mar 2004
Posts: 83
Location: Germany(Hannover)

PostPosted: Fri Jan 14, 2005 7:33 am    Post subject: Reply with quote

Linux v2.6.8.1
_________________
"Vivat Fratres Intimi Ferro Iuncti."
Back to top
View user's profile Send private message
jsosic
Guru
Guru


Joined: 02 Aug 2004
Posts: 510
Location: Split (Croatia)

PostPosted: Fri Jan 14, 2005 5:03 pm    Post subject: Reply with quote

PrakashKC wrote:
This is nice, indeed. Does anybody know how to properly integrate it with kde?


That's pretty easy. I'm using KDE too. You have to remove your KDE icons and make a new one's. Also, icons should point to SYMLINKS!

I've added one to my K menu. Here are options:
Name: cdrom
Description:
Comment: Load & mount CD-ROM
Command: krusader --right /mnt/cdrom

Note that /mnt/cdrom points to /misc/cdrom :)

Hope this helps...
Back to top
View user's profile Send private message
PrakashP
Veteran
Veteran


Joined: 27 Oct 2003
Posts: 1249
Location: C.C.A.A., Germania

PostPosted: Fri Jan 14, 2005 5:07 pm    Post subject: Reply with quote

Well, I found it out on my, own, as I wrote above. ;) I am now more interested on how to set permissions to ext2 on zip disk, so that user can access mount point.
Back to top
View user's profile Send private message
iwankoenig
Tux's lil' helper
Tux's lil' helper


Joined: 31 Mar 2004
Posts: 83
Location: Germany(Hannover)

PostPosted: Sat Jan 15, 2005 12:55 am    Post subject: Reply with quote

Code:
6. start autofs daemon and add it to runlevel
Code:
# /etc/init.d/autofs start
# rc-update add autofs default


7. test automounter
Insert disc into cdrom and type $ cd /misc/cdrom. Then, type $ cd .. and wait for timeout. If everything went ok, you can now unload tray of your cdrom drive. You passed the test, congratulations!


Fine. But when i insert the disk into dvd-rom , so is the order /misc empty.

$ cd /misc/dvd
-bash: cd: /misc/dvd: No such file or directory

And what was with my kernel? I don`t know. But i have got the kernel-2.6.9. It works fine!
_________________
"Vivat Fratres Intimi Ferro Iuncti."
Back to top
View user's profile Send private message
DeathAndTaxes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2003
Posts: 124

PostPosted: Tue Jan 18, 2005 5:50 am    Post subject: Reply with quote

Between this thead and this link:

http://freespace.sourceforge.net/guidod/howto/autofs.html

I got this up and running very nicely. I noticed cedega was unable to figure it out, but I just opened shells and cd'd into those directories to keep the drives mounted. With this, the installers worked nicely and I got a few win32 games up and running.

Since supermount isn't really supported anymore, we're stuck with strange things like autofs (or other, stranger alternatives) to handle our CD mounting. The good thing about autofs is it also provides a method for mounting remote shares...Using one app and one config file for all these things is definitely handy.
Back to top
View user's profile Send private message
davecs
Guru
Guru


Joined: 08 Nov 2003
Posts: 436
Location: Dagenham, GB

PostPosted: Wed Jan 19, 2005 12:28 pm    Post subject: Reply with quote

I'm impressed. I might try this when I get home. One little thing, if unmounting takes a long time (for example if I have written loads of data to a USB storage device) do I get a progress bar so that I know when to pull it out?

I assume it copes well with udev, as I have set up different devices for USB key, CF card and MP3 player etc.
_________________
Gentoo, PCLOS-pre-81a and Windows 98SE.
Shuttle SN41G2V2
Athlon XP2500+ o/c to 3200+, 2x256Mb Geil Value RAM, FX5200.
Ntlworld cable internet via ethernet
and PC-Chips Desknote Laptop (with PCLOS-pre-81a )
Back to top
View user's profile Send private message
DrWoland
l33t
l33t


Joined: 13 Nov 2004
Posts: 603

PostPosted: Wed Jan 19, 2005 3:43 pm    Post subject: Reply with quote

davecs wrote:
I'm impressed. I might try this when I get home. One little thing, if unmounting takes a long time (for example if I have written loads of data to a USB storage device) do I get a progress bar so that I know when to pull it out?

I assume it copes well with udev, as I have set up different devices for USB key, CF card and MP3 player etc.


Works perfectly with udev, I have a purely udev system.
Back to top
View user's profile Send private message
jsosic
Guru
Guru


Joined: 02 Aug 2004
Posts: 510
Location: Split (Croatia)

PostPosted: Wed Jan 19, 2005 7:11 pm    Post subject: autofs-4.1.3-r2 has a bug.... Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=77077

Be aware...it's not my howto to blame but autofs package gentoo maintainer...

Hope he fixes this soon.
Back to top
View user's profile Send private message
davecs
Guru
Guru


Joined: 08 Nov 2003
Posts: 436
Location: Dagenham, GB

PostPosted: Wed Jan 19, 2005 9:42 pm    Post subject: Reply with quote

So far I've set up my DVD-RW to work. It would not unmount using v4.1.3-r2 of autofs so I followed the advice in other threads and used v4.1.3

To put a DVD shortcut on my desktop, dragging a copy of the link at /mnt/dvdrw was not a good idea, as /misc/dvdrw/ is not a writable directory and so I cannot change the default icon.

Instead I right-clicked on Desktop and selected Create New > File > Link to Location (URL). A dialogue box that comes up you type in /misc/dvdrw and make the Filename whatever you want to see under the icon I just typed "DVD". This produced a desktop icon which I could then right-click on to change the icon.

The sweet thing though is that I will be able to add menu items which will be all the more important in other desktop systems which don't have icons on the desktop, eg XFCE, IceWM etc. It certainly seems more elegant than the rather crude script used in XFCE.

Now to sort out my other removable devices ...
_________________
Gentoo, PCLOS-pre-81a and Windows 98SE.
Shuttle SN41G2V2
Athlon XP2500+ o/c to 3200+, 2x256Mb Geil Value RAM, FX5200.
Ntlworld cable internet via ethernet
and PC-Chips Desknote Laptop (with PCLOS-pre-81a )
Back to top
View user's profile Send private message
davecs
Guru
Guru


Joined: 08 Nov 2003
Posts: 436
Location: Dagenham, GB

PostPosted: Wed Jan 19, 2005 11:45 pm    Post subject: Reply with quote

ORIGINAL POST BEFORE EDIT

Quote:
It was all going so well until ...

I set up three devices. I have used UDEV to ensure that various USB devices seen by the computer as USB-SCSI storage devices got different /dev/ shortcuts. The /dev shortcuts in my /etc/autofs/auto.misc file all work.

auto.misc:
Code:
# $Id: auto.misc,v 1.2 2002/10/27 05:21:15 bcowan Exp $
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage
#boot  -fstype=ext2  :/dev/hda1
#cd  -fstype=iso9660,ro :/dev/cdrom
#floppy  -fstype=auto  :/dev/fd0

dvdrw -fstype=iso9660,ro,nosuid,nodev :/dev/hdc

usbflash -fstype=auto,rw,uid=0,gid=100,fmask=0117,dmask=0007,nosuid,nodev :/dev/usbstorage/flashdrive

mp3player -fstype=auto,rw,uid=0,gid=100,fmask=0117,dmask=0007,nosuid,nodev :/dev/usbstorage/mp3player

cflash -fstype=vfat,rw,uid=0,gid=100,fmask=0117,dmask=0007,nosuid,nodev :/dev/usbstorage/compactflash


Now for some reason I cannot create a short cut to /misc/cflash it just won't accept a further file in /misc is this why they patched autofs? And why it isn't quite right yet? Is there a limit as to how many I can do? I have two more to go. My Compact Flash reader and my Multi-card reader. Why won't it let me create them?


Solution? I reverted back to version 3.1.7-r5

As far as I can see, version 4 does not work properly in any form, with or without the Gentoo patches. I could only have 3 devices in v4, and even then, if I clicked on the shortcut when there was no device (CD out of drawer, USB flash card not plugged in) I would get an empty Konqueror window. However, with version 3 I get an error message unless there is something plugged in, in which case it "just works".

Moral? As yet, don't bother with version 4 at all.
_________________
Gentoo, PCLOS-pre-81a and Windows 98SE.
Shuttle SN41G2V2
Athlon XP2500+ o/c to 3200+, 2x256Mb Geil Value RAM, FX5200.
Ntlworld cable internet via ethernet
and PC-Chips Desknote Laptop (with PCLOS-pre-81a )
Back to top
View user's profile Send private message
jsosic
Guru
Guru


Joined: 02 Aug 2004
Posts: 510
Location: Split (Croatia)

PostPosted: Sat Jan 22, 2005 5:42 pm    Post subject: Reply with quote

I don't know about you but v4 works fine for me without genpatches. I have 5 devices configured:
Code:
$ cat /etc/autofs/auto.media
# $Id: auto.misc,v 1.2 2002/10/27 05:21:15 bcowan Exp $
# This is an automounter map and it has the following format
# key [ -mount-options-separated-by-comma ] location
# Details may be found in the autofs(5) manpage
#
#boot      -fstype=ext2   :/dev/hda1
floppy      -fstype=auto,rw   :/dev/fd0
cdrom      -fstype=auto,ro,nosuid,nodev   :/dev/cdroms/cdrom1
cdrw      -fstype=auto,ro,nosuid,nodev   :/dev/cdroms/cdrom0
camera      -fstype=vfat,rw,uid=0,gid=100,fmask=0117,dmask=0007,nosuid,nodev:/dev/sda1
usbhdd1      -fstype=auto,rw,uid=0,gid=100,fmask=0117,dmask=0007,nosuid,nodev:/dev/sda1
Back to top
View user's profile Send private message
Jimmy Jazz
Apprentice
Apprentice


Joined: 04 Oct 2004
Posts: 290
Location: Strasbourg

PostPosted: Sat Jan 22, 2005 6:09 pm    Post subject: Reply with quote

jsosic,

which kernel module are you using autofs or autofs4 ?

Do you load it at boot time or is it part of the kernel ?

Jj
Back to top
View user's profile Send private message
jsosic
Guru
Guru


Joined: 02 Aug 2004
Posts: 510
Location: Split (Croatia)

PostPosted: Sat Jan 22, 2005 8:19 pm    Post subject: Reply with quote

Module is automounter v4 and it's built into kernel. I think it must be part of the kernel, not standalone module... I've read something about it... Correct me if wrong ;)
Back to top
View user's profile Send private message
Jimmy Jazz
Apprentice
Apprentice


Joined: 04 Oct 2004
Posts: 290
Location: Strasbourg

PostPosted: Sat Jan 22, 2005 10:20 pm    Post subject: Reply with quote

jsosic wrote:
Module is automounter v4 and it's built into kernel. I think it must be part of the kernel, not standalone module... I've read something about it... Correct me if wrong ;)


That could be my problem, "autofs4" is declared as a module but i'm too lazy to compile the kernel again to check if automount will work again ;)

Code:

...
CONFIG_AUTOFS4_FS=m
...


Code:

#lsmod

Module                  Size  Used by
...
autofs4                16388  0
...


Jj
Back to top
View user's profile Send private message
davecs
Guru
Guru


Joined: 08 Nov 2003
Posts: 436
Location: Dagenham, GB

PostPosted: Sat Jan 22, 2005 11:37 pm    Post subject: Reply with quote

Just to add that I used v4 compiled into kernel.

All I can say about which version works and which one does not, is that 3.1.7-r5 worked for me, and the v4 versions didn't. Maybe it depends on other aspects of the system, hardware etc.

If it doesn't work with all systems, then unless there is something basically wrong with that system, there's a bug! But I'm glad that v4 works for others!
_________________
Gentoo, PCLOS-pre-81a and Windows 98SE.
Shuttle SN41G2V2
Athlon XP2500+ o/c to 3200+, 2x256Mb Geil Value RAM, FX5200.
Ntlworld cable internet via ethernet
and PC-Chips Desknote Laptop (with PCLOS-pre-81a )
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum