Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: get gDesklets 0.3x running (stop the crash on start)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
riksta
n00b
n00b


Joined: 16 Apr 2004
Posts: 73
Location: Manchester, UK

PostPosted: Tue Jan 11, 2005 12:30 am    Post subject: HOWTO: get gDesklets 0.3x running (stop the crash on start) Reply with quote

Hi, i've been trying to a while to get gDesklets to work properly, and stop crashing as soon as you start the daemon.

Anyway, you'll be pleased I have traced the problem. It requires a more modern version of libgtop than is specified in the ebuild

here goes:

edit /etc/portage/package.keywords

add

Code:

=gnome-base/libgtop-2.8.2 ~x86


then update libgtop:
Code:

emerge =libgtop-2.8.2


then just launch gDesklets (hopefully it should now start the daemon)

Hope this helps

Rick
Back to top
View user's profile Send private message
iverson0881
Apprentice
Apprentice


Joined: 08 Jan 2004
Posts: 285
Location: CA

PostPosted: Tue Jan 11, 2005 1:04 am    Post subject: Reply with quote

You may want to report this as a bug as well.
Back to top
View user's profile Send private message
riksta
n00b
n00b


Joined: 16 Apr 2004
Posts: 73
Location: Manchester, UK

PostPosted: Tue Jan 11, 2005 1:07 am    Post subject: Reply with quote

already added my comments to an exisiting bug that was open
Back to top
View user's profile Send private message
LostControl
l33t
l33t


Joined: 02 Mar 2004
Posts: 885
Location: La Glane, Suisse

PostPosted: Tue Jan 11, 2005 9:51 am    Post subject: Reply with quote

Thank you :D

I spend more than 2 hours trying to have my gdesklets-core-0.33.1 running :cry: Emerging libgtop-2.8.2 resolves the problem :D

A+
_________________
http://www.jaqpot.net
http://www.fail2ban.org
Back to top
View user's profile Send private message
hank
n00b
n00b


Joined: 11 Jan 2005
Posts: 4

PostPosted: Tue Jan 11, 2005 10:22 am    Post subject: Reply with quote

THANK YOU!!! I've done everything I could do to get this to work, and you solved it! I even went to the #gdesklets IRC Channel on irc.gnome.org and asked them and they were clueless. Told me to switch distros...:P

Trying it now to see if it works...
Back to top
View user's profile Send private message
RealNitro
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jul 2004
Posts: 98

PostPosted: Tue Jan 11, 2005 10:55 am    Post subject: Reply with quote

This tip solved my problems too (I could start gdesklets, but it always crashed in within 2 minutes).
Back to top
View user's profile Send private message
hank
n00b
n00b


Joined: 11 Jan 2005
Posts: 4

PostPosted: Tue Jan 11, 2005 12:05 pm    Post subject: Reply with quote

ARGH - didn't work for me. I even got the newest libgtop (2.9.4) and it still crashes when i double click a desklet. Thanks for solving everyone else's problem.
Back to top
View user's profile Send private message
riksta
n00b
n00b


Joined: 16 Apr 2004
Posts: 73
Location: Manchester, UK

PostPosted: Tue Jan 11, 2005 12:18 pm    Post subject: Reply with quote

but did you try the exact version that i explained? possibly it isn't compatible with the very latest version also. Which is why i specified 2.8.2

Rick
Back to top
View user's profile Send private message
skamp
n00b
n00b


Joined: 19 Jan 2004
Posts: 13

PostPosted: Fri Jan 21, 2005 6:33 am    Post subject: Reply with quote

i have tried everything i saw on the forums and bugzilla and have the version of libgtop that you specified but it still crashes with the same exact error on every desklet
:x

Code:

Connected to daemon in 3703 milliseconds.
Traceback (most recent call last):
  File "/usr/bin/gdesklets", line 132, in ?
    ident = daemon.open_display(path)
  File "/usr/share/gdesklets/main/client.py", line 54, in open_display
    return self.__send(COMMAND_OPEN_DISPLAY, path)[0]
TypeError: unsubscriptable object



if i need to ill email my world file if someone wants to try and see what it is that i messed up
:oops: [/code]
Back to top
View user's profile Send private message
silverpig
Tux's lil' helper
Tux's lil' helper


Joined: 10 Dec 2003
Posts: 143
Location: Vancouver BC

PostPosted: Wed Jan 26, 2005 1:43 am    Post subject: Reply with quote

Hmm, didn't work for me. I'm re-emerging gdesklets right now to see if it works. Then I'll try different versions of libgtop etc. I'd love to get this working though :)
_________________
'Cause I can.
Back to top
View user's profile Send private message
silverpig
Tux's lil' helper
Tux's lil' helper


Joined: 10 Dec 2003
Posts: 143
Location: Vancouver BC

PostPosted: Wed Jan 26, 2005 1:53 am    Post subject: Reply with quote

Hmm, still no dice.

Connecting to the daemon from the command line works fine, but starting up a display results in an immediate crash. Argh.
_________________
'Cause I can.
Back to top
View user's profile Send private message
kamagurka
Veteran
Veteran


Joined: 25 Jan 2004
Posts: 1026
Location: /germany/munich

PostPosted: Wed Jan 26, 2005 8:20 pm    Post subject: Reply with quote

i think most of the sensors in portage don't work anymore with the new desklets version.
this is strictly speaking a bug in dependency tracking, but i'm too lazy to report that.
i should probably install a couple displays manually, but i'm too lazy for that either, right now.
_________________
If you loved me, you'd all kill yourselves today.
--Spider Jerusalem, the Word
Back to top
View user's profile Send private message
tSp
Apprentice
Apprentice


Joined: 19 Jan 2004
Posts: 214
Location: Maysville, KY

PostPosted: Sat Jan 29, 2005 12:21 am    Post subject: Reply with quote

those still having troubles with gdesklets-0.3x - make sure you have these versions emerged:

Use
pyorbit-2.0.1
pygtk-2.4.1
gnome-python-2.6.1
_________________
tSp
http://www.rhpstudios.com
http://www.xtremewebhosts.com
http://www.maysville-linux-users-group.org
http://www.edwiget.name

Registered Linux User #162711
Back to top
View user's profile Send private message
kamagurka
Veteran
Veteran


Joined: 25 Jan 2004
Posts: 1026
Location: /germany/munich

PostPosted: Sat Jan 29, 2005 10:53 am    Post subject: Reply with quote

hmm, i have all those, and while the gdesklets daemon starts, i can't seem to find any displays that work (i tried manually installing a few from the website). can anyone tell me some that are known to work?
_________________
If you loved me, you'd all kill yourselves today.
--Spider Jerusalem, the Word
Back to top
View user's profile Send private message
tSp
Apprentice
Apprentice


Joined: 19 Jan 2004
Posts: 214
Location: Maysville, KY

PostPosted: Sat Jan 29, 2005 12:38 pm    Post subject: Reply with quote

kamagurka wrote:
hmm, i have all those, and while the gdesklets daemon starts, i can't seem to find any displays that work (i tried manually installing a few from the website). can anyone tell me some that are known to work?


I dont know what the difference was, but I posted those a little early....because even after I posted them and finished my emerge on the ones that werent up to date, it still didnt work.

What did work though was unmerging gdesklets-core and then downloading the code straight from the web site and compiling it.

http://gdesklets.gnomedesktop.org/

Then installing sensors from the web site was as simple as dragging the link to the gdesklets window that was open after it started.
_________________
tSp
http://www.rhpstudios.com
http://www.xtremewebhosts.com
http://www.maysville-linux-users-group.org
http://www.edwiget.name

Registered Linux User #162711
Back to top
View user's profile Send private message
kamagurka
Veteran
Veteran


Joined: 25 Jan 2004
Posts: 1026
Location: /germany/munich

PostPosted: Sat Jan 29, 2005 7:42 pm    Post subject: Reply with quote

tSp wrote:
Then installing sensors from the web site was as simple as dragging the link to the gdesklets window that was open after it started.


do you mean the gDesklets-shell?
_________________
If you loved me, you'd all kill yourselves today.
--Spider Jerusalem, the Word
Back to top
View user's profile Send private message
tSp
Apprentice
Apprentice


Joined: 19 Jan 2004
Posts: 214
Location: Maysville, KY

PostPosted: Sat Jan 29, 2005 8:14 pm    Post subject: Reply with quote

kamagurka wrote:
tSp wrote:
Then installing sensors from the web site was as simple as dragging the link to the gdesklets window that was open after it started.


do you mean the gDesklets-shell?

it has a gdesklets manager (edited to include- it does say gDesklets Shell) box that shows up now in the fluxbox bar after I run gdesklets - this is 0.3.1 screenshot taken today (unfortunately the gdesklets manager thingy isnt visable) - http://www.maysville-linux-users-group.org/screenshot.png
_________________
tSp
http://www.rhpstudios.com
http://www.xtremewebhosts.com
http://www.maysville-linux-users-group.org
http://www.edwiget.name

Registered Linux User #162711
Back to top
View user's profile Send private message
arma
Apprentice
Apprentice


Joined: 07 Nov 2004
Posts: 198
Location: Belgium

PostPosted: Sat Jan 29, 2005 9:33 pm    Post subject: Reply with quote

well... i had exactly the same problem.
today, i just downgraded may gentoo from unstable to stable (except for the three mentionned package and the gdesklet-core-O.33.1) and suddently, today, in a deseperate "anoter try - try n°23985" ... it works....

well yeaaaaaaah, it really works, i was deseperate.

sorry this isn't helping the discution, but i was so happy :D

so i think the problem is in another package.
_________________
l'alcool est un ennemi...
et en quelque sorte,...
fuir l'ennemi, c'est lâche
Back to top
View user's profile Send private message
dragonsbreath
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2005
Posts: 93

PostPosted: Sun Feb 06, 2005 3:41 am    Post subject: Reply with quote

how do you emerge gdesklets and ligbtop since theses are masked...
Back to top
View user's profile Send private message
comprookie2000
Developer
Developer


Joined: 25 Jul 2004
Posts: 925
Location: Sun City Center, Florida

PostPosted: Sun Feb 06, 2005 1:25 pm    Post subject: Reply with quote

Here is my /ect/portage/package.keywords
Code:
media-fonts/artwiz-aleczapka-en ~x86
gnome-extra/gdesklets-core ~x86
dev-python/gnome-python ~x86
dev-python/pyorbit ~x86
x11-plugins/desklet-starterbar ~x86
x11-plugins/desklet-goodweather ~x86
x11-plugins/desklet-weather ~x86
x11-plugins/desklet-psisensors ~x86
x11-plugins/desklet-psiextras ~x86
x11-plugins/desklet-psidisplays ~x86
x11-plugins/desklet-clock ~x86

Its working for now...
_________________
http://dev.gentoo.org/~dabbott/
Back to top
View user's profile Send private message
sirex
n00b
n00b


Joined: 09 Nov 2002
Posts: 6

PostPosted: Wed Feb 16, 2005 11:17 am    Post subject: Reply with quote

Code:
sirex@laptop gdesklets-core $ gdesklets
Starting gdesklets-daemon...
Connected to daemon in 947 milliseconds.
Traceback (most recent call last):
  File "/usr/bin/gdesklets", line 140, in ?
    open_profile(myprofile)
  File "/usr/bin/gdesklets", line 70, in open_profile
    mydaemon.open_display_with_id(mypath, myident)
  File "/usr/share/gdesklets/main/client.py", line 69, in open_display_with_id
    return self.__send(COMMAND_OPEN_DISPLAY_WITH_ID, path, ident)[0]
TypeError: unsubscriptable object



Help???

P.S. Forgot to mention that I had 0.32 working from the get go. I emerged Evolution and decided to reboot afterwards. After boot up, couldn't start gdesklets as you can see above.
Back to top
View user's profile Send private message
sobers_2002
Veteran
Veteran


Joined: 16 Mar 2004
Posts: 1128

PostPosted: Thu Feb 17, 2005 6:33 pm    Post subject: Reply with quote

having problems with getting a lot of displays to start
in the 0.3.x versions......all work fine in 0,26.x.......
anyone solved that problem???

i don't wanna lose my calender disply :(
_________________
Pdict - dockable dictionary client for linux
FREE97WIN: Use this code on Dreamhost and you get $97 off !!
Back to top
View user's profile Send private message
kamagurka
Veteran
Veteran


Joined: 25 Jan 2004
Posts: 1026
Location: /germany/munich

PostPosted: Thu Feb 17, 2005 9:02 pm    Post subject: Reply with quote

i can't get most displays to work either. suckitude ensues.
_________________
If you loved me, you'd all kill yourselves today.
--Spider Jerusalem, the Word
Back to top
View user's profile Send private message
thunderbolt23
n00b
n00b


Joined: 28 Dec 2004
Posts: 9

PostPosted: Wed Feb 23, 2005 11:01 am    Post subject: Reply with quote

Hey guys,

I think I found a possible solution at the official gdesklets-forum. 8)
It seems that expat-1.95.7 can cause some trouble: switch to 1.95.8 and it should work.
I had the same problems with gdesklets-core-0.34 (connecting to daemon is ok, but crash when loading desklet), but now it works like a charm.

Hope it helps!
Back to top
View user's profile Send private message
gsven
n00b
n00b


Joined: 27 Feb 2005
Posts: 8

PostPosted: Sun Feb 27, 2005 4:46 pm    Post subject: gdesklets-core-0.34 Reply with quote

i've just installed 0.34, it is not in the portage, though i modified an ebuild to do that.
so if you wanna breakYourGentoo, here it is: gdesklets-core-0.34_portage.tar
or wait for the official ebuild.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum