Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libstdc++-v3 emerge fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
syrex314
n00b
n00b


Joined: 29 Jul 2003
Posts: 25

PostPosted: Fri Jan 21, 2005 6:10 am    Post subject: libstdc++-v3 emerge fails Reply with quote

On a G3, I went to emerge libstdc++-v3-3.3.4, and it fails every time:

Code:

eabi.S: Assemblyer messages:
eabi.S:255: Error: operand out of range (6 is not between 0 and 1)
eabi.S:255: Error: missing operand


Any ideas? Should I submit a bug report?
Back to top
View user's profile Send private message
sirlark
Guru
Guru


Joined: 25 Oct 2004
Posts: 305
Location: Cape Town, South Africa

PostPosted: Fri Jan 21, 2005 12:14 pm    Post subject: is this a libtool problem? Reply with quote

Just a shot in the dark here, but are you trying to emerge it to fix compilation bugs relating to libtool?

If so you want to run the fix_libtool_file.sh script like so

fix_libtool_files 3.3.4

where 3.3.4 is your old gcc version
_________________
Adopt an unanswered post today
Back to top
View user's profile Send private message
syrex314
n00b
n00b


Joined: 29 Jul 2003
Posts: 25

PostPosted: Sat Jan 22, 2005 1:02 am    Post subject: Reply with quote

No, I'm re-emerging everything (emerge -e world) because I wanted to change some CFLAGS (went from -O2 to -O3 and added -mpowerpc-gfxopt) and have those changes affect my whole system.

I tried putting =sys-lib/libstdc++-v3-3.3.4 in /etc/portage/package.mask to try to get emerge to pick an older version (3.3.3-r1) in hopes that would work, but placing that line in my package.mask does not seem to make a difference, and emerge -e world still tries 3.3.4.
Back to top
View user's profile Send private message
syrex314
n00b
n00b


Joined: 29 Jul 2003
Posts: 25

PostPosted: Sat Jan 22, 2005 4:19 am    Post subject: oops... Reply with quote

...turns out I should have had sys-libs in my package.mask instead of sys-lib... we'll see if 3.3.3-r1 works.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum