Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hardware clock resets to 1903 on EVERY BOOT!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
chota
n00b
n00b


Joined: 09 Sep 2004
Posts: 13
Location: Little Rock, AR

PostPosted: Thu Jan 27, 2005 9:04 pm    Post subject: Hardware clock resets to 1903 on EVERY BOOT! Reply with quote

Hello,

I have an Aluminum Powerbook G4 12-inch, running kernel 2.6.10-gentoo-r6.

Whenever I reboot, the system clock gets set back to the year 1903. While this normally wouldn't bother me (I have ntp-client running on boot, too), everytime I boot up, it takes FOR EVER because it has to check the filesystem (something about being unchecked for some ungodly amount of days).

So, is there either:

1) A way for me to run ntp-client before mounting the hard disk (yeah, right)...

2) Some way for me to make it not check the disk for errors, or...

3) A way to stop making my clock reset upon reboot!

This is driving me quite mad.

Thanks,

chris.
Back to top
View user's profile Send private message
southsider
Guru
Guru


Joined: 05 Jul 2004
Posts: 358

PostPosted: Thu Jan 27, 2005 9:07 pm    Post subject: Reply with quote

The millennium bug has come back and bit you in the ass...

Try changing CLOCK="UTC" to CLOCK="local" in /etc/rc.conf (or vice versa) to see if the problem goes away. This isn't really a fix, but it should help to figure out what's going on.

HTH - Al
Back to top
View user's profile Send private message
chota
n00b
n00b


Joined: 09 Sep 2004
Posts: 13
Location: Little Rock, AR

PostPosted: Thu Jan 27, 2005 9:39 pm    Post subject: Reply with quote

Thanks for the tip... I'm building X right now, so it may be a while before I can check it. :D
Back to top
View user's profile Send private message
chota
n00b
n00b


Joined: 09 Sep 2004
Posts: 13
Location: Little Rock, AR

PostPosted: Fri Jan 28, 2005 12:28 am    Post subject: Reply with quote

Excellent!

It works now. I switched UTC to localtime.

What exactly was the problem? Y2K?? What?!!?
Back to top
View user's profile Send private message
aronchi
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2004
Posts: 94

PostPosted: Fri Jan 28, 2005 7:26 am    Post subject: Reply with quote

I have a similar problem. I have the hardware clock set to UTC, but my localtime is Europe/Rome. I've set
Code:
CLOCK="local"

on /etc/rc.conf and /etc/conf.d/clock
and
Code:
Europe/Rome

in /etc/timezone

but when I do
Code:
/etc/init.d/ntp-client restart

and then
Code:
date

it shows
Code:
ven gen 28 07:26:18 UTC 2005


What's the problem?
_________________
Alessandro Ronchi Home Page
SOASI: Sviluppo Software e Sistemi Open Source Forlì
Back to top
View user's profile Send private message
southsider
Guru
Guru


Joined: 05 Jul 2004
Posts: 358

PostPosted: Fri Jan 28, 2005 11:57 pm    Post subject: Reply with quote

Not sure what the problem with setting your clock to UTC is but I had problems where I'd lose half an hour or so every boot. I changed it to local and it worked flawlessly. I recently changed it back to UTC but I have ntp-client on my default runlevel so I never notice any problems.

Would quite like to know why I lose half an hour without ntp though.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum