Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Van Dale woordenboeken in Linux?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
koder
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jan 2005
Posts: 83
Location: Belgium

PostPosted: Wed Feb 02, 2005 3:27 pm    Post subject: Van Dale woordenboeken in Linux? Reply with quote

Hey,

VanDale heeft zo van die electronische woordenboeken op CD-ROM. Mijn vriendin heeft die allemaal gekocht, geïnstalleerd, en ze heeft ze allemaal nodig!

De dingen draaien op Windows, en met een patch ook op XP. De laatste versie werkt naar behoren onder Wine. Maar ik vroeg me af of niemand weet heeft van een Linux versie van die dingen?

Klinkt misschien als een domme vraag. Maar het programma is door Novell geschreven. Enkel de productie en de content lijkt van Van Dale te zijn. En ik neem aan dat Novell dit programma ook aan andere (misschien grotere) projecten heeft ge-licensed.

Als voor zo een ander Novell-woordenboek een Linux versie bestaat, dan zou die misschien ook wel voor de Van Dale woordenboeken kunnen werken...

Anyone?


greetz

koder
_________________
game not over - www.mame.be
Back to top
View user's profile Send private message
Mon
n00b
n00b


Joined: 17 Jul 2003
Posts: 34
Location: The Netherlands

PostPosted: Wed Feb 02, 2005 5:09 pm    Post subject: Reply with quote

Voor een encyclopedie ben je denk ik al gauw op wikipedia.org aangewezen. Dat Novell de ontwikkeling ervan heeft gedaan is leuk maar ik zou voorlopig geen linux binaries verwachten.
2 Mogelijkheden dus: wikipedia (en andere sites natuurlijk) en wine.
Back to top
View user's profile Send private message
garo
Bodhisattva
Bodhisattva


Joined: 15 Jul 2002
Posts: 860
Location: Edegem,BELGIUM

PostPosted: Wed Feb 02, 2005 6:38 pm    Post subject: Reply with quote

Mon wrote:
Voor een encyclopedie ben je denk ik al gauw op wikipedia.org aangewezen. Dat Novell de ontwikkeling ervan heeft gedaan is leuk maar ik zou voorlopig geen linux binaries verwachten.
2 Mogelijkheden dus: wikipedia (en andere sites natuurlijk) en wine.

Als woordenboek kan je beter de Wiktionary gebruiken (WikiWoordenboek in het Nederlands). Dit is net zoals de wikipedia ook een project van Wikimedia.
_________________
My favorite links this month:
- Surf Random
- Web-based SSH
- Stop Spam
Back to top
View user's profile Send private message
koder
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jan 2005
Posts: 83
Location: Belgium

PostPosted: Thu Feb 03, 2005 11:56 am    Post subject: Reply with quote

garo wrote:
Als woordenboek kan je beter de Wiktionary gebruiken (WikiWoordenboek in het Nederlands). Dit is net zoals de wikipedia ook een project van Wikimedia.

Het Wiktionary project is heel leuk en lekker open en zo, maar helaas nogal beperkt, en vast en zeker niet van dezelfde inhoudskwaliteit als Van Dale.

Voor mij zou dit volstaan, maar voor iemand die professioneel afhankelijk is van correcte tekst natuurlijk niet.

In hoeverre is OpenOffice.org compatible met Word-plugins? Kan dit met Wine? Heeft iemand dat al ooit gedaan?


greetz

koder
_________________
game not over - www.mame.be
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Thu Feb 03, 2005 3:54 pm    Post subject: Reply with quote

koder wrote:
In hoeverre is OpenOffice.org compatible met Word-plugins?

Niet
Quote:
Kan dit met Wine? Heeft iemand dat al ooit gedaan?

Je kunt met crossover ms office draaien.
Back to top
View user's profile Send private message
BartNL
n00b
n00b


Joined: 29 Aug 2004
Posts: 65

PostPosted: Thu Feb 03, 2005 4:04 pm    Post subject: Reply with quote

Misschien off-topic, maar wat voor toegevoegde waarde hebben de cd-rom's als je op http://www.vandale.nl het complete woordenboek kan raadplegen, en zoals hierboven al genoemd, wikipedia kunt gebruiken?
Back to top
View user's profile Send private message
AlterEgo
Veteran
Veteran


Joined: 25 Apr 2002
Posts: 1619

PostPosted: Thu Feb 03, 2005 7:24 pm    Post subject: Reply with quote

Er is ook gnuvd .
Dat is een tooltje waarmee je de online versie van van dale kan raadplegen. Er slingeren een paar ebuilds rond in bugzilla.

Ik heb die geprobeerd, maar ze werken niet voor de laatste versie van gnuvd (in mijn handen):
gnuvd/gnuvd-1.0_beta5.ebuild
Code:
 gnuvd/gnuvd-1.0_beta5.ebuild
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2

DESCRIPTION="Consult the online Van Dale dictionary"
HOMEPAGE="http://www.djcbsoftware.nl/projecten/gnuvd/"
LICENSE="GPL-2"
inherit eutils
IUSE="gnome"
DEPEND="gnome? ( gnome-base/libgnome
               gnome-extra/gtkhtml
               =x11-libs/gtk+-1.2* )"

KEYWORDS="x86 ppc"
SLOT="0"

VERSION="1.0beta5"

SRC_URI="http://www.djcbsoftware.nl/projecten/gnuvd/gnuvd-${VERSION}.tar.gz"

S="${WORKDIR}/gnuvd-${VERSION}"

src_unpack() {
   unpack gnuvd-${VERSION}.tar.gz
   cd ${S}
#   epatch ${FILESDIR}/gnuvd-1.0b.diff
}
src_compile() {
use gnome || export GNOME_CONFIG=no
   econf
   emake || die "Compilation Failed :("
}

src_install() {
   einstall || die "Failed to install GnuVD :("
}

pkg_postinst() {
   use gnome \
      && einfo "Start the Gui version with 'gnovd'." \
      && einfo "If gnovd complains about gconf, start gconfd-1 first."
}


Als er iemand handig genoeg is om het werkend te krijgen: gaarne.
Back to top
View user's profile Send private message
ikke
Apprentice
Apprentice


Joined: 14 Jan 2005
Posts: 225
Location: Belgium

PostPosted: Thu Feb 03, 2005 9:11 pm    Post subject: Reply with quote

Hierzo:
Code:
moonwalker ~ $ cat /usr/local/portage/app-dicts/gnuvd/gnuvd-1.0_beta5.ebuild
DESCRIPTION="Consult the online Van Dale dictionary"
HOMEPAGE="http://www.djcbsoftware.nl/projecten/gnuvd/"
LICENSE="GPL-2"
inherit eutils

#Wat zijn de deps?
DEPEND=""

KEYWORDS="~x86"
SLOT="0"

VERSION="1.0beta5"

SRC_URI="http://www.djcbsoftware.nl/projecten/gnuvd/gnuvd-${VERSION}.tar.gz"

S="${WORKDIR}/gnuvd-${VERSION}"

src_compile() {
        econf || die "Configure failed"
        emake || die "Make failed"
}

src_install() {
        einstall || die "Install failed"
}

1e lijntje weglaten he

Works fine here.

Is wel "lelijke" ebuild, post dus zeker niet in bugzilla ofzo: DEPEND is niet ingesteld, en de bepaling van VERSION kan veel mooier met wat awk, mar ik heb nu geen tijd en goesting om dat te doen ;)
_________________
Working day and night to enhance your Linux Desktop experience :)
Blog
Back to top
View user's profile Send private message
AlterEgo
Veteran
Veteran


Joined: 25 Apr 2002
Posts: 1619

PostPosted: Fri Feb 04, 2005 9:21 am    Post subject: Reply with quote

Ik had dat Gnome-use vlaggetje erin gezet om het volgende compile-probleem te voorkomen:
Code:

creating libgnuvd.la
(cd .libs && rm -f libgnuvd.la && ln -s ../libgnuvd.la libgnuvd.la)
Making all in gnovd
mkdir .libs
i686-pc-linux-gnu-gcc -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/include/gtk-1.2 -I/usr/X11R6/include -I/usr/include/gnome-1.0 -DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include -I/usr/include/gdk-pixbuf-1.0 -I/usr/include/gtkhtml-1.1 -I/usr/include/freetype2 -I/usr/include/gnome-xml -I/usr/include/gal-1.0 -I/usr/include/libglade-1.0 -I/usr/include/gconf/1 -I/usr/include/orbit-1.0 -DGTKHTML_HAVE_GCONF -march=athlon-xp -O2 -pipe -fomit-frame-pointer -ftracer -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/include/gtk-1.2 -I/usr/X11R6/include -I/usr/include/gnome-1.0 -DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include -I/usr/include/gdk-pixbuf-1.0 -I/usr/include/gtkhtml-1.1 -I/usr/include/freetype2 -I/usr/include/gnome-xml -I/usr/include/gal-1.0 -I/usr/include/libglade-1.0 -I/usr/include/gconf/1 -I/usr/include/orbit-1.0 -DGTKHTML_HAVE_GCONF -Wl,-O1 -o .libs/gnovd gnovd.o -rdynamic  ../libgnuvd/.libs/libgnuvd.so -L/usr/lib -L/usr/X11R6/lib /usr/lib/libgtkhtml-1.1.so -lgal /usr/lib/libgnomeprint.so /usr/lib/libfreetype.so /usr/lib/libglade-gnome.so /usr/lib/libglade.so /usr/lib/libxml.so -lz /usr/lib/libgnomeui.so /usr/lib/libart_lgpl.so /usr/lib/libgdk_imlib.so -lSM -lICE /usr/lib/libgnome.so /usr/lib/libgnomesupport.so /usr/lib/libesd.so /usr/lib/libaudiofile.so -ldb1 /usr/lib/libgdk_pixbuf.so /usr/lib/libgnomecanvaspixbuf.so -lgconf-gtk-1 -lgconf-1 /usr/lib/liboaf.so /usr/lib/libORBitCosNaming.so /usr/lib/libORBit.so /usr/lib/libIIOP.so /usr/lib/libORBitutil.so /usr/lib/libgtk.so /usr/lib/libgdk.so /usr/lib/libgmodule.so /usr/lib/libglib.so -ldl -lXi -lXext -lX11 -lm
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.5/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lgal
collect2: ld returned 1 exit status
make[2]: *** [gnovd] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

!!! ERROR: app-office/gnuvd-1.0_beta5 failed.
!!! Function src_compile, Line 20, Exitcode 2
!!! Make failed
!!! If you need support, post the topmost build error, NOT this status message.


want ik wist niet wat ik met gal-1.0 moest.
Back to top
View user's profile Send private message
ikke
Apprentice
Apprentice


Joined: 14 Jan 2005
Posts: 225
Location: Belgium

PostPosted: Fri Feb 04, 2005 9:36 am    Post subject: Reply with quote

Mjah, bij mij wordt gnovd niet gebuild omdat ik blijkbaar een andere versie van GtkHTML heb staan. Hebk toch niet nodig ook ;)

Ik heb hier enkel libgal-2.0.so staan, dus zou ook failen daarop.

Gnovd lijkt op GTK1 gebaseerd te zijn, dus redelijk outdated. Mss best proberen eerst zonder GUI support (dus enkel gnuvd) te compileren.
_________________
Working day and night to enhance your Linux Desktop experience :)
Blog
Back to top
View user's profile Send private message
koder
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jan 2005
Posts: 83
Location: Belgium

PostPosted: Thu Feb 10, 2005 3:32 pm    Post subject: Reply with quote

BartNL wrote:
Misschien off-topic, maar wat voor toegevoegde waarde hebben de cd-rom's als je op http://www.vandale.nl het complete woordenboek kan raadplegen, en zoals hierboven al genoemd, wikipedia kunt gebruiken?

Wel, ten eerste is het zo dat op de CD-ROM veel meer te vinden is dan via het web.

Daarnaast heeft ze vooral de vertaalwoordenboeken nodig, en die zijn niet op het web beschikbaar (voor zover ik weet tenminste...)


greetz
koder
_________________
game not over - www.mame.be
Back to top
View user's profile Send private message
koder
Tux's lil' helper
Tux's lil' helper


Joined: 05 Jan 2005
Posts: 83
Location: Belgium

PostPosted: Thu Feb 10, 2005 3:34 pm    Post subject: Reply with quote

AlterEgo wrote:
Er is ook gnuvd .
Dat is een tooltje waarmee je de online versie van van dale kan raadplegen.

Ik ken GnuVD hoor. Maar ook dat is gewoon een interface op het webgebeuren van de VD website.

Het gaat echt wel om de CD-ROMs, niet over de website.


greetz
koder
_________________
game not over - www.mame.be
Back to top
View user's profile Send private message
tHeoo
n00b
n00b


Joined: 20 Mar 2003
Posts: 50
Location: Bammental, Deutschland

PostPosted: Fri Feb 18, 2005 10:10 am    Post subject: Re: Van Dale woordenboeken in Linux? Reply with quote

koder wrote:
Hey,
De dingen draaien op Windows, en met een patch ook op XP. De laatste versie werkt naar behoren onder Wine. Maar ik vroeg me af of niemand weet heeft van een Linux versie van die dingen?

Van andere woordenboeken die de Novell technologie gebruiken weet ik niet. Ik gebruik wel veel cdromwoordenboeken onder Linux.

1. Euroglot. Versie 3.0 werkt prima onder Wine. Uiteraard zonder koppeling met een tekstverwerker, maar aangezien ik mijn teksten onder Emacs voor TeX schrijf, is dat geen probleem.

2. Van Dale groot Woordenboek EN/NL versie 1.0. Ik kan die echter alleen onder Wine aan de gang krijgen als ik de data van de cdrom naar de harddisk kopieer en bij het opstarten van het programma de paden opgeef. De installer heb ik nooit aan de gang gekregen.

3. Collins Cobuild advanced English Dictionary on CDrom, versie 4. Probleem is hier dat de cd zo is gemaakt dat de programmabestanden onder linux niet zichtbaar worden. Cd laden onder windows, privékopie maken op nieuwe cdrom en dan werkt het uit de kunst onder Wine.

4. Duden Universalwörterbuch, Langenscheidt Deutsch als Fremdsprache, Duden Fremdwörterbuch, alle binnen de Linux-versie van de Office-Bibliothek. De linux-omgeving is te downloaden van het web en de cd's met de woordenboeken zijn generiek en in de linux-omgeving in te passen. Wunderbar.

Ik vraag me af waarom je een linux-versie wilt als er een goeie wine-versie is. Ik heb een fake_windows dir die minus woordenboeken nog geen 10 mb inneemt. Dat lijkt me verder geen bezwaar. Performance-verlies is er eigenlijk ook niet.[/list]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum