Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Harddisk trouble on iBook G3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
BetterUnborn
n00b
n00b


Joined: 28 Sep 2004
Posts: 57
Location: Germany

PostPosted: Wed Feb 02, 2005 5:00 pm    Post subject: Harddisk trouble on iBook G3 Reply with quote

Hi there,

Due to a user error *sigh* I had to reinstall gentoo on my iBook ... I should mention that it worked like a charm, it was my own stupidity spoiling it :-(
At the moment I have serious trouble using my iBook with gentoo linux ... at boot time, irq unmask and dma mode is activated for my hard drive, but it falls back to no irq unmask and pio mode randomly. I first thought this could be a kernel related, I had never used 2.6.10 before, so I fell back to 2.6.8-pegasos-r3, and it became much better, now it doesn't fall back to pio mode randomly, only on heavy load (which of course doesn't improve usability very much ... heavy load and pio brings the computer to the knees instantly)
I can't see what's causing this, because except from the kernel and the headers (2.6.6 -> 2.6.8.1) I used exactly the same settings before: nptl, gcc-3.4, newest glibc etc
Because my old setup worked flawlessly, that brings me to this question: Is it possible to get the old ebuilds back? I know that everything worked best with linux-headers-2.6.6 and ppc-dev-sources-2.6.6, so I want to restore this state although it might not be up-to-date any more.

My disk problem can't be something hardware-related, because MacOSX hasn't done anything unnatural so far.

Thx in advance
Back to top
View user's profile Send private message
BetterUnborn
n00b
n00b


Joined: 28 Sep 2004
Posts: 57
Location: Germany

PostPosted: Fri Feb 11, 2005 3:28 pm    Post subject: Reply with quote

OK, I got it under control ...
.. but unfortunately only the "hard way" worked :cry:
I reinstalled gentoo, this time avoiding anything vital for the system to be ~ppc and <voila> it runs like a charm, gentoo-dev-sources-2.6.10-r6 do a fine job ... at least for the last 2 days its been up and compiling non-stop and no problem at all.

Beats me what caused all that trouble, maybe the 2.6.8.1-headers are no good on ppc. Now I run with 2.4.22-headers, this shouldn't be a too serious drawback (maybe I'll miss nptl here and there).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum