Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
stubborn DRI won't work [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Sun Feb 13, 2005 6:48 pm    Post subject: stubborn DRI won't work [SOLVED] Reply with quote

I've got a blueberry laptop that I can't seem to get DRI working on. I've got the mach64 driver compiled and running by way of the mach64/common downloads from the DRI project, and everything looks good as far as X config and kernel config go (yeah, using a color depth of 16 because of the 6 mb of vid mem on this POS :). Anyway, if anyone who has gotten this stupid mach64 vid chip to work in DRI can take a peek at this, I would be most greatful:


bash-2.05b$ glxinfo | grep render
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect
bash-2.05b$



bash-2.05b$ lsmod
Module Size Used by
mach64 62308 0
drm 86076 1 mach64
agpgart 37868 1 drm
airport 7328 0
orinoco 50996 1 airport
hermes 15136 2 airport,orinoco
bash-2.05b$




bash-2.05b# lspci
0000:00:0b.0 Host bridge: Apple Computer Inc. UniNorth AGP
0000:00:10.0 VGA compatible controller: ATI Technologies Inc Rage Mobility L AGP 2x (rev 64)
0001:10:0b.0 Host bridge: Apple Computer Inc. UniNorth PCI
0001:10:17.0 Class ff00: Apple Computer Inc. KeyLargo Mac I/O (rev 02)
0001:10:18.0 USB Controller: Apple Computer Inc. KeyLargo USB
0001:10:19.0 USB Controller: Apple Computer Inc. KeyLargo USB
0002:20:0b.0 Host bridge: Apple Computer Inc. UniNorth Internal PCI
0002:20:0f.0 Class ffff: Apple Computer Inc. UniNorth GMAC (Sun GEM) (rev ff)






xorg.conf:

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/Speedo/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/CID/"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/100dpi/"
EndSection

Section "Module"
Load "extmod"
Load "dri"
Load "dbe"
Load "record"
Load "xtrap"
Load "glx"
Load "speedo"
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "accel" # [<bool>]
#Option "crt_display" # [<bool>]
#Option "composite_sync" # [<bool>]
#Option "hw_cursor" # [<bool>]
#Option "mmio_cache" # [<bool>]
#Option "test_mmio_cache" # [<bool>]
#Option "panel_display" # [<bool>]
#Option "probe_clocks" # [<bool>]
#Option "reference_clock" # <freq>
#Option "shadow_fb" # [<bool>]
#Option "sw_cursor" # [<bool>]


#Option "ForcePCIMode" "True"

Identifier "Card0"
Driver "ati"
VendorName "ATI"
BoardName "Rage Mobility L AGP 2x"
ChipSet "ati"
ChipId 0x4c4e
ChipRev 0x64
#BusID "PCI:0:16:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 16

SubSection "Display"
Viewport 0 0
Depth 24
Modes "800x600"
EndSubSection

SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600"
EndSubSection
EndSection

Section "dri"
Mode 0666
EndSection




dmesg info:

airport: card registered for interface eth1
Linux agpgart interface v0.100 (c) Dave Jones
[drm] Initialized drm 1.0.0 20040925
[drm] Initialized mach64 1.0.0 20020904 on minor 0: ATI Technologies Inc Rage Mobility L AGP 2x
[drm] Used old pci detect: framebuffer loaded
hda: Set PIO timing for mode 0, reg: 0x1090032b



bits from Xorg log:


(II) Loading extension X-Resource
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="X.Org Foundation"
compiled for 6.7.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="X.Org Foundation"
compiled for 6.7.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension XFree86-DRI
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="X.Org Foundation"
compiled for 6.7.0, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER





Sorry for the long post, but I've spent all weekend on this, and can't figure it out at all. Man, dreaming of a nvidia chip right now :)
Thanks in advance to anyone how might have a tip for me.


Last edited by dakster on Sat Feb 19, 2005 8:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
stimuli
Apprentice
Apprentice


Joined: 16 Dec 2002
Posts: 292
Location: Vancouver, BC, Canada

PostPosted: Mon Feb 14, 2005 4:08 am    Post subject: Reply with quote

Nvidia has shit drivers under linux/ppc.

are you in fact using xorg for opengl, and not something else (eg: software Mesa)? There's an opengl-something utility that you use to select your opengl implementation with.
Back to top
View user's profile Send private message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Mon Feb 14, 2005 4:24 am    Post subject: Reply with quote

DRI doesn't really have anything to do with the opengl-config does it? DRI is all hardware based, I'm not sure that switching the config with opengl-config will change whether or not DRI is working. I didn't know about he nvidia tho, only used it on x86 & amd64, and it kicks arse in both. Sux about the ppc.
Back to top
View user's profile Send private message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Mon Feb 14, 2005 10:58 am    Post subject: hmmph Reply with quote

Well, I've been poking around on the forums quite a bit, and about the best idea I can find is to wait for 6.8.2 to become stable for ppc. Apparently 6.8.1 and 6.8.2 have a mach64 dri driver now. I looked at emerging the unstable, but it was blocked, and I don't really feel like dealing. It'll come eventually :)
If anyone has any ideas besides moving to a newer Xorg, i'm all ears....



https://forums.gentoo.org/viewtopic-t-274079-highlight-mach64+dri.html
Back to top
View user's profile Send private message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Sat Feb 19, 2005 2:04 pm    Post subject: well... Reply with quote

Well, I emerged xorg-x11 6.8.2, and that didn't magically get DRI working with the mach64 like I was hoping :)
I can't emerge x11-drm with the 2.6 kernel, and the kernel itself doesn't have dri drivers for the mach64. I think I'm going to try compiling the dri common/mach64 again and see how that works against this xorg version. This takes about 12 years on the blueberry, so it'll take a while to figure out if it works :)



bash-2.05b# glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
GLX extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_fbconfig
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
OpenGL extensions:
GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_transpose_matrix, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_logic_op,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_copy_texture, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_point_parameters,
GL_EXT_polygon_offset, GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
GL_EXT_stencil_two_side, GL_EXT_stencil_wrap, GL_EXT_subtexture,
GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias, GL_EXT_texture_object,
GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels,
GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,
GL_ATIX_texture_env_combine3, GL_IBM_texture_mirrored_repeat,
GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,
GL_NV_blend_square, GL_NV_point_sprite, GL_NV_texgen_reflection,
GL_NV_texture_rectangle, GL_SGIS_generate_mipmap,
GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp,
GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 16 tc 0 16 0 r y . 5 6 5 0 0 16 0 0 0 0 0 0 0 None
0x24 16 tc 0 16 0 r y . 5 6 5 0 0 16 8 16 16 16 0 0 0 None
0x25 16 tc 0 24 0 r y . 5 6 5 8 0 16 8 16 16 16 16 0 0 None
0x26 16 tc 0 24 0 r . . 5 6 5 8 0 16 8 16 16 16 16 0 0 None
0x27 16 dc 0 16 0 r y . 5 6 5 0 0 16 0 0 0 0 0 0 0 None
0x28 16 dc 0 16 0 r y . 5 6 5 0 0 16 8 16 16 16 0 0 0 None
0x29 16 dc 0 24 0 r y . 5 6 5 8 0 16 8 16 16 16 16 0 0 None
0x2a 16 dc 0 24 0 r . . 5 6 5 8 0 16 8 16 16 16 16 0 0 None
bash-2.05b#
Back to top
View user's profile Send private message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Sat Feb 19, 2005 8:16 pm    Post subject: Pheww Reply with quote

Ok, well, its' still pretty slow, but that's to be expected given what it is (mach64).

Anyway, so to get it working I downloaded dri common & mach64 like in the howto, and compiled that. My kernel has drm enabled, but no drivers selected (2.6.10-gentoo-r6). After the kernel and that dri mach64 installation is done, you have to remerge xorg. I emerged xorg-x11 6.8.2 with dri, drm, and insecure-drivers as USE flags. dont' know if dri or drm do anythign, but I think that insecure-driver thing is needed. I added mach64 to the module autoloading, and voila!!! direct rendering FINALLY enabled. Don't know if it'll actually help much, but glad to know I'm actually using my hardware :)
Back to top
View user's profile Send private message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Sat Feb 19, 2005 8:22 pm    Post subject: almost forgot... Reply with quote

Almost forgot. I had a problem with this:
_LoaderFileToMem() lseek() failed: Invalid argument

when I tried to start X. I fixed this by moving /usr/lib/modules/extensions/dri-old.libglx.a back to libglx.a. This way you're getting the mach64 driver from the dri package, but using xorg's libglx. Gogo gadget blueberry iBook! lol
Back to top
View user's profile Send private message
Marctraider
Guru
Guru


Joined: 24 Dec 2003
Posts: 387

PostPosted: Wed May 31, 2006 2:08 pm    Post subject: Reply with quote

I have some questions, i also have the bluebery notebook and im trying to get it working.

1. Can you post your xorg.conf file? and your /var/log/Xorg.0.log?

2. What kernel version are you using?

3. What FPS do you get in glxgears?

4. Did you enable agpgart and uninorth chipset in the kernel under character devices?

5. What how-to did you use? the mach64-common stuff is only for i386 right? If you mean the ones on http://dri.freedesktop.org/snapshots/ anyway...

Please help me!?
_________________
MOBO: Maximus II Gene
RAM: DDR2 OCZ 4GB
CPU: E6400 Conroe
GPU: HD2600XT
SATA: 3x 250GB.
Back to top
View user's profile Send private message
dakster
Apprentice
Apprentice


Joined: 26 Jul 2004
Posts: 178
Location: New England

PostPosted: Wed May 31, 2006 2:13 pm    Post subject: Reply with quote

Sorry, I finally caved and got a nice Asus z71v laptop with a nvidia 6600 and 128 MB of vid memory. Fantastic.

I gave up on the old ibook. I never did get accelerated X working correctly on the ibook from what I recall. It always broke something else, but that was a while ago. Don't have the ibook anymore I'm afraid, sorry.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum