Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nvidia drivers installen... Geen xorg.conf file?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
skabaas
n00b
n00b


Joined: 12 Feb 2005
Posts: 9

PostPosted: Mon Feb 14, 2005 10:26 pm    Post subject: Nvidia drivers installen... Geen xorg.conf file? Reply with quote

Hallo! Ik ben vrij nieuw met betrekking tot Gentoo, maar ik heb vaker met Linux gespeeld en dus was ik van plan om vanavond de nvidia drivers te installeren voor mijn GeForce 3, met 64 MB RAM aan boord. Ik doorloop netjes nVidia guide op gentoo.org, maar ik heb helemaal geen xorg.conf file! Alleen een xorg.conf.example file en als ik die naar xorg.conf kopieer, dan zit ik met allerlei vreemde instellingen. Wie kan mij helpen de juiste regels toe te voegen en degene die ik niet nodig heb te verwijderen?!
Back to top
View user's profile Send private message
jurrie
Apprentice
Apprentice


Joined: 14 Mar 2004
Posts: 177
Location: Netherlands

PostPosted: Mon Feb 14, 2005 10:28 pm    Post subject: Reply with quote

als je `xorgconfig` draait kun je met een stap-voor-stap guide een config file laten genereren.

Pas deze ietwat aan voor de goeie driver en het zou goed moeten zijn :o
Back to top
View user's profile Send private message
skabaas
n00b
n00b


Joined: 12 Feb 2005
Posts: 9

PostPosted: Mon Feb 14, 2005 10:41 pm    Post subject: Reply with quote

Geweldig! Nu heb ik een xorg.conf file, maar nu duikt het volgende probleem op... Bij het uitvoeren van " glxinfo | grep direct" zou je " direct rendering: Yes" moeten krijgen... Ik krijg echter het volgende:

Code:

wortel X11 # glxinfo | grep direct
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".


What have i done wrong?!
Back to top
View user's profile Send private message
rockfly
Apprentice
Apprentice


Joined: 27 Apr 2003
Posts: 179

PostPosted: Tue Feb 15, 2005 10:39 am    Post subject: Reply with quote

heb je wel het volgende gedaan?

Code:

emerge nvidia-glx


??
Back to top
View user's profile Send private message
BlackEdder
Advocate
Advocate


Joined: 26 Apr 2004
Posts: 2588
Location: Dutch enclave in Egham, UK

PostPosted: Tue Feb 15, 2005 10:46 am    Post subject: Reply with quote

Vergeet niet (word je verteld te doen aan het eind van emerge nvidia-glx):
Code:
opengl-update nvidia

Als het dan nog niet werkt graag even je xorg.conf posten
Back to top
View user's profile Send private message
skabaas
n00b
n00b


Joined: 12 Feb 2005
Posts: 9

PostPosted: Tue Feb 15, 2005 1:06 pm    Post subject: Reply with quote

ik heb even rondgesnuffeld hier op 't forum en daar werd gezegd dat ik "emerge --sync && emerge nvidia-glx" moest doen... Hierdoor kreeg ik een melding dat ik Xorg moest updaten, dus dat heb ik ook gedaan... Nog steeds dezelfde foutmeldingen, maar nadat ik opnieuw opstartte en "startx" uitvoerde kreeg ik keurig netjes het Nvidia opstartscherm te zien... Ik neem aan dat het gewoon opgelost is dus :)
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Wed Feb 16, 2005 12:50 am    Post subject: Reply with quote

Zet in de "module" section van je xorg bestand:

Load "glx"

BTW

Wat hebben ze gedaan? Ben ik een weekje niet op het forum geweest, vernaggelen ze het door de reply velden 15 keer zo groot te maken ??!
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Wed Feb 16, 2005 1:20 am    Post subject: Reply with quote

Rainmaker wrote:
Wat hebben ze gedaan? Ben ik een weekje niet op het forum geweest, vernaggelen ze het door de reply velden 15 keer zo groot te maken ??!

Mja, ik vind het juist wel handig, zo is het replyveld even groot als de tekst die er uiteindelijk komt te staan, zodoende creeer je een wat beter wysiwyg effect :)
Back to top
View user's profile Send private message
skabaas
n00b
n00b


Joined: 12 Feb 2005
Posts: 9

PostPosted: Wed Feb 16, 2005 12:22 pm    Post subject: Reply with quote

Rainmaker wrote:
Zet in de "module" section van je xorg bestand:

Load "glx"



Had ik gedaan... :roll: Maar, no worries... Alles werkt nu zoals het hoort! Bedankt in ieder geval!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum