Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cyclic portage deps - xorg-x11->opengl-update->xorg-x1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
habib
n00b
n00b


Joined: 15 Feb 2005
Posts: 3

PostPosted: Tue Feb 15, 2005 9:02 pm    Post subject: cyclic portage deps - xorg-x11->opengl-update->xorg-x1 Reply with quote

hi guys,

i am trying to upgrade from xorg-x11-6.7.0-r3 to xorg-x11-6.8.2, but i have problem with dependencies:

xorg-x11-6.8.2 needs opengl-update-2.1.1-r1 and it needs xorg-x11-6.8.0-r4

this is strange to me, anyway, the problem is, that xorg-x11-6.8.0-r4 is masked with -ppc, so i can not install it. do you have any advice? or better, an explanation why do I need install older version of xorg prior to the newest.

btw, with earlier versions of xorg-6.8.x, some windows and other objects changed their color to yellow-green after certain actions (mouse click to make them active or so), 6.7.x is fine. did anyone of you have similar issue?
G3/700MHz ibook, ATI Radeon Mobility 7500

relevant part of my xorg.conf:
Code:

Section "Module"
        Load    "dbe"
        Load    "extmod"
        Load    "glx"
        Load    "dri"

        Load    "speedo"
        Load    "xtrap"

        Load    "freetype"
        Load    "type1"
EndSection

Section "Device"
        Identifier      "TiBook Internal Video"
        Driver          "radeon"

        Option          "UseFBDev"
        Option          "DRIReinit"
EndSection

Section "DRI"
        Group   "dri"
        Mode    0666
EndSection


thank you for any help.
Back to top
View user's profile Send private message
stimuli
Apprentice
Apprentice


Joined: 16 Dec 2002
Posts: 292
Location: Vancouver, BC, Canada

PostPosted: Wed Feb 16, 2005 12:00 am    Post subject: Reply with quote

Try unmerging opengl-update?
Back to top
View user's profile Send private message
habib
n00b
n00b


Joined: 15 Feb 2005
Posts: 3

PostPosted: Wed Feb 16, 2005 10:00 am    Post subject: Reply with quote

but as i wrote, xorg-x11-6.8.2 needs opengl-update-2.1.1-r1 and it needs xorg-x11-6.8.0-r4, opengl-update higher than 2.1 is required. and it can not be installed on a ppc, because it requires xorg-x11-6.8.0-r4.
to be sure, i did what you are telling, it is the same, look above. thaks anyway.
Back to top
View user's profile Send private message
BetterUnborn
n00b
n00b


Joined: 28 Sep 2004
Posts: 57
Location: Germany

PostPosted: Wed Feb 16, 2005 5:05 pm    Post subject: Reply with quote

I had the same problem ... got it solved by
Code:
emerge --nodeps "=x11-base/opengl-update-2.1.1-r1"

(eventually you'll have to add ~ppc to your keywords)
opengl-update was still functional after that, right now I'm compiling xorg-x11-6.8.2 (looking forward to transparency, shadows, mergedfb, better radeon drivers, xinerama ... cool stuff!!)

I will tell whether the new version of x.org does well on ppc (I hope it doesn't do the same anoying things 6.8.0 did)
Back to top
View user's profile Send private message
BetterUnborn
n00b
n00b


Joined: 28 Sep 2004
Posts: 57
Location: Germany

PostPosted: Wed Feb 16, 2005 9:34 pm    Post subject: Reply with quote

OK, xorg-x11-6.8.2 is up and running on my iBook :D

And it looks nice ... no weird things happend so far!

For Enabling MergedFB I had to disable UseFBDev, this also forced me to specify the MonitorLayout Option in xorg.conf (for me TMDS, CRT).

transparency and shadows are unusable for me, my Radeon Mobility M6 LY doesn't have enough power to make such things enjoyable :? maybe later I'll tweak my settings a bit to make use of that.

X seems to be more responsive, and mergedfb is really fine if you want to use a secondary display. This upgrade was definitely worth the trouble!!
Back to top
View user's profile Send private message
BetterUnborn
n00b
n00b


Joined: 28 Sep 2004
Posts: 57
Location: Germany

PostPosted: Thu Feb 17, 2005 3:30 pm    Post subject: Reply with quote

So, I'm back again.

As I expected, not everything went well ... though there aren't as serious troubles as there were with xorg-x11-6.8.0 on ppc.
So far I have discovered 3 bugs:

** opening windows with a su - or sux - shell makes X crash! This happens always every time I open windows in an X server started with startx from a user account, kdm hasn't crashed yet when I didn't load the Composite-Extension (*sigh* transparencies getting more unusable)

** when I open pictures in Konqueror, they are too yellow. So far no other app has done this, the Desktop wallpaper is normal and when browsing I don't get that ill effect.

** when double-clicking on pictures opened in konqueror (showing that yellow effect as above), konqueror crashes

Altogether this isn't too bad, transparencies were too slow, so I won't miss that feature too much.
I'll recompile qt and/or kde-base, maybe that'll help with konqueror.
Back to top
View user's profile Send private message
habib
n00b
n00b


Joined: 15 Feb 2005
Posts: 3

PostPosted: Sun Feb 20, 2005 1:41 pm    Post subject: Reply with quote

thanks to your suggestion i am now using xorg 6.8.2. i have not even tried that composite stuff on my ibook, i played with that on my i86 machine with slackware.

fortunately, i have no problems with new version of xorg so far, i use gnome and fluxbox as a wm.
thank you again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum