Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
app-pda/multisync fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
kubrick2001
n00b
n00b


Joined: 24 Nov 2004
Posts: 56

PostPosted: Sun Feb 20, 2005 8:48 pm    Post subject: app-pda/multisync fails Reply with quote

Hi, I have problems with emerging multisync on my ibook. Somebody an idea ?

Quote:
ACCEPT_KEYWORDS="~ppc" emerge app-pda/synce-multisync_plugin
Calculating dependencies ...done!
>>> emerge (1 of 2) app-pda/multisync-0.83_pre20050115 to /
>>> md5 src_uri ;-) multisync-0.82.tar.bz2
>>> md5 src_uri ;-) multisync-20050115-snapshot.tar.gz
>>> Unpacking source...
>>> Unpacking multisync-0.82.tar.bz2 to /var/tmp/portage/multisync-0.83_pre20050115/work
>>> Source unpacked.
* Building Multisync with these plugins:
* backup_plugin
* syncml_plugin
* evolution2_sync
You should update your `aclocal.m4' by running aclocal.
* econf: updating multisync-0.82/plugins/palm_sync/conduit/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating multisync-0.82/plugins/palm_sync/conduit/config.sub with /usr/share/gnuconfig/config.sub
* econf: updating multisync-0.82/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating multisync-0.82/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=powerpc-unknown-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib
configure: WARNING: If you wanted to set the --build type, don't use --host.
If a cross compiler is detected then cross compile mode will be used.
configure: error: cannot find install-sh or install.sh in . ./.. ./../..

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/multisync-0.83_pre20050115/work/multisync-0.82/config.log

!!! ERROR: app-pda/multisync-0.83_pre20050115 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Feb 21, 2005 1:14 am    Post subject: Reply with quote

I can't replicate this, can you provide the output of emerge info?

Thanks
Back to top
View user's profile Send private message
bruda
Guru
Guru


Joined: 06 May 2004
Posts: 376
Location: Sherbrooke, QC, Canada

PostPosted: Mon Feb 21, 2005 4:09 am    Post subject: Reply with quote

Your symptom suggests that somehow you thrashed one of your installed versions of automake (the one the package is happening to want). I did this once too, automake-1.4-something got thrashed by some as of yet unknown reason and the symptom was the same. To fix, re-emerge the respective version. In my case
Code:
emerge '<automake-1.5'

did it, but I have no idea what version is bad in your case (try them up in order, these are small packages so it's not a big deal). Hope this helps.
_________________
Quid latine dictum sit altum videtur
Back to top
View user's profile Send private message
kubrick2001
n00b
n00b


Joined: 24 Nov 2004
Posts: 56

PostPosted: Mon Feb 21, 2005 5:48 pm    Post subject: Reply with quote

# emerge info
Portage 2.0.51-r15 (default-linux/ppc/2004.3, gcc-3.4.3, glibc-2.3.4.20041102-r0, 2.6.10-gentoo-r6 ppc)
=================================================================
System uname: 2.6.10-gentoo-r6 ppc 7447A, altivec supported
Gentoo Base System version 1.6.8
Python: dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb 9 2005, 17:30:02)]
dev-lang/python: 2.3.4-r1
sys-devel/autoconf: 2.13, 2.59-r6
sys-devel/automake: 1.7.9-r1, 1.8.5-r3, 1.5, 1.6.3, 1.4_p6, 1.9.4
sys-devel/binutils: 2.15.90.0.3-r4
sys-devel/libtool: 1.5.10-r3
virtual/os-headers: 2.4.22
ACCEPT_KEYWORDS="ppc"
AUTOCLEAN="yes"
CFLAGS="-O2 -mtune=powerpc -fno-strict-aliasing -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mtune=powerpc -fno-strict-aliasing -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="ftp://ftp.gentoo.mesh-solutions.com/gentoo/ ftp://mir.zyrianes.net/gentoo/ http://gentoo.mirror.icd.hu/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d aalib alsa altivec apm arts berkdb bitmap-fonts cdr cups curl divx4linux dvd emboss encode esd evo f77 fam fbcon flac font-server fortran gb gd gdbm ggi gif gnome gphoto2 gpm gstreamer gtk gtk2 guile imagemagick imlib java jpeg libwww mad mikmod mime mng motif mozilla mpeg ncurses nls oggvorbis openal opengl oss pam pda pdflib perl phyton png ppc python qt quicktime readline scanner sdl sndfile softmmu sox spell ssl tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts usb wmf xine xinerama xml xml2 xmms xprint xv xvid zlib"
Unset: ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
kubrick2001
n00b
n00b


Joined: 24 Nov 2004
Posts: 56

PostPosted: Mon Feb 21, 2005 6:15 pm    Post subject: Reply with quote

bruda wrote:
Your symptom suggests that somehow you thrashed one of your installed versions of automake (the one the package is happening to want). I did this once too, automake-1.4-something got thrashed by some as of yet unknown reason and the symptom was the same. To fix, re-emerge the respective version. In my case
Code:
emerge '<automake-1.5'

did it, but I have no idea what version is bad in your case (try them up in order, these are small packages so it's not a big deal). Hope this helps.


You were right, i re-emerged every automake version and now it works. Thanks :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum