Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xdm won't start, but startx works fine
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
lazloman
Guru
Guru


Joined: 27 Dec 2003
Posts: 343
Location: Skokie, Il. USA

PostPosted: Wed Feb 23, 2005 5:16 am    Post subject: xdm won't start, but startx works fine Reply with quote

I'm running xorg-x11-6.8.2 and when I try /etc/init.d/xdm start, I get these two error messages:
Failed to load module "speedo"
Failed to load module "keyboard"

I can just type startx and my windowmanager starts up just fine. What should do to get xdm working properly?
TIA
_________________
Gentoo x86
2x Dell Optiplex GX200

"My Break-Dancing days are over, but there's always the Funky Chicken."
--The Full Monty
Back to top
View user's profile Send private message
gordin
Guru
Guru


Joined: 11 Oct 2002
Posts: 300
Location: Germany/WI

PostPosted: Fri Feb 25, 2005 2:35 am    Post subject: Reply with quote

same problem here with kdm.
it is just not working
startx works fine
Back to top
View user's profile Send private message
Sodki
Guru
Guru


Joined: 11 Aug 2003
Posts: 419
Location: London, U.K. & Lisbon, Portugal

PostPosted: Fri Feb 25, 2005 7:59 am    Post subject: Re: xdm won't start, but startx works fine Reply with quote

lazloman wrote:
Failed to load module "speedo"
Failed to load module "keyboard"

Try commenting out the "speedo" line and changing "keyboard" to "kbd".

gordin wrote:
same problem here with kdm

Is it the same error message?
Back to top
View user's profile Send private message
lazloman
Guru
Guru


Joined: 27 Dec 2003
Posts: 343
Location: Skokie, Il. USA

PostPosted: Fri Feb 25, 2005 2:36 pm    Post subject: Reply with quote

Thanks, I tried, but I got the same error.
_________________
Gentoo x86
2x Dell Optiplex GX200

"My Break-Dancing days are over, but there's always the Funky Chicken."
--The Full Monty
Back to top
View user's profile Send private message
gordin
Guru
Guru


Joined: 11 Oct 2002
Posts: 300
Location: Germany/WI

PostPosted: Sat Feb 26, 2005 6:09 pm    Post subject: Re: xdm won't start, but startx works fine Reply with quote

lazloman wrote:
gordin wrote:
same problem here with kdm

Is it the same error message?


I think these are just warnings, no real errors.
Nonetheless, it's not the case with me... no errors, just a flash on the screen and then back to console again. I turned debugging for kdm on, but kdm.log is ok, just the normal messages from xorg.
Maybe recompiling kdebase will solve the problem, but I had no time to try.
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sat Feb 26, 2005 7:05 pm    Post subject: Reply with quote

What is the value for XSESSION in /etc/rc.conf?
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
gordin
Guru
Guru


Joined: 11 Oct 2002
Posts: 300
Location: Germany/WI

PostPosted: Sat Feb 26, 2005 8:08 pm    Post subject: Reply with quote

rc.conf:
...
# Gnome - will start gnome-session
# kde-<version> - will start startkde (ex: kde-3.0.2)
# Xsession - will start a terminal and a few other nice apps

XSESSION="kde-3.3.2"
Back to top
View user's profile Send private message
lazloman
Guru
Guru


Joined: 27 Dec 2003
Posts: 343
Location: Skokie, Il. USA

PostPosted: Sat Feb 26, 2005 11:27 pm    Post subject: Reply with quote

Same here, mine is also kde-3.3.2
_________________
Gentoo x86
2x Dell Optiplex GX200

"My Break-Dancing days are over, but there's always the Funky Chicken."
--The Full Monty
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Feb 27, 2005 3:22 pm    Post subject: Reply with quote

Any message in /var/log/xdm or /var/log/Xorg.0.log?
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
lazloman
Guru
Guru


Joined: 27 Dec 2003
Posts: 343
Location: Skokie, Il. USA

PostPosted: Sun Feb 27, 2005 5:50 pm    Post subject: Reply with quote

Here's the error I see in xdm.log:

(EE) Failed to load module "speedo" (module does not exist, 0)
(EE) Failed to load module "Keyboard" (module does not exist, 0)
(EE) No Input driver matching `Keyboard'
No core keyboard

Fatal server error:
failed to initialize core devices


The same errors appear in Xorg.0.log

I don't know about the keyboard error, but I've commented out every reference to "speedo" that I could find in xorg.conf, and the error still appears.
_________________
Gentoo x86
2x Dell Optiplex GX200

"My Break-Dancing days are over, but there's always the Funky Chicken."
--The Full Monty
Back to top
View user's profile Send private message
bruda
Guru
Guru


Joined: 06 May 2004
Posts: 376
Location: Sherbrooke, QC, Canada

PostPosted: Sun Feb 27, 2005 9:15 pm    Post subject: Reply with quote

I have had similar problems awhile ago. I am not sure what is the problem with the speedo module, but I am not using it anyway so I just commented out the appropriate line in the `Module' section. As for the other error, it went away after switching from `keyboard' to `kbd' in the appropriate `InputDevice' section. The section ended up looking like this:
Code:
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel"      "pc101"
        Option      "XkbLayout"     "us"
EndSection

I am pretty sure that the keyboard initialization error is the one that causes the crash, and I believe that the `kbd' versus `keyboard' is a new issue in Xorg 6.8.x, so that might be the problem. All of this being said, I am not using any form of xdm, all of my happening happened in a normal X session. I hope this helps nonetheless.
_________________
Quid latine dictum sit altum videtur
Back to top
View user's profile Send private message
lazloman
Guru
Guru


Joined: 27 Dec 2003
Posts: 343
Location: Skokie, Il. USA

PostPosted: Mon Feb 28, 2005 1:18 am    Post subject: Reply with quote

I just made the change to "kbd" and I still get the same result. How do you start your X session?
_________________
Gentoo x86
2x Dell Optiplex GX200

"My Break-Dancing days are over, but there's always the Funky Chicken."
--The Full Monty
Back to top
View user's profile Send private message
gordin
Guru
Guru


Joined: 11 Oct 2002
Posts: 300
Location: Germany/WI

PostPosted: Mon Feb 28, 2005 2:16 pm    Post subject: Reply with quote

I remerged kdebase yesterday and after updating the configs with rc-update kdm was working. But it fails again after a reboot. I did not change anything. Just rebooted. So I think it should be related to kdmrc, but could not figure out in what way so far.

@bruda: I'm already using kdb in xorg.conf. But this should not be a problem with xorg (or xorg.conf), because the xserver is running without any problems if I start with "startx"

I don't have any errors in kdm.log or Xorg.0.log
Back to top
View user's profile Send private message
gordin
Guru
Guru


Joined: 11 Oct 2002
Posts: 300
Location: Germany/WI

PostPosted: Mon Feb 28, 2005 2:34 pm    Post subject: Reply with quote

I finally solved the problem. I'm running linux on an iBook. Currently my battery is broken. So after every reboot the time was set to 1970/1/1. Starting kdm will fail, then. When setting the time to current time everything is working. Very strange...

So it might be also a problem with /etc/adjtime and changing the time to somewehere in the past every reboot.
Back to top
View user's profile Send private message
bruda
Guru
Guru


Joined: 06 May 2004
Posts: 376
Location: Sherbrooke, QC, Canada

PostPosted: Mon Feb 28, 2005 2:53 pm    Post subject: Reply with quote

lazloman wrote:
I just made the change to "kbd" and I still get the same result. How do you start your X session?

I just `startx' from the console. It is kind of weird what you are getting (typically X eister starts or not). Somebody mentions a clock issue that might be the problem, other than this I have no idea.
_________________
Quid latine dictum sit altum videtur
Back to top
View user's profile Send private message
lazloman
Guru
Guru


Joined: 27 Dec 2003
Posts: 343
Location: Skokie, Il. USA

PostPosted: Mon Feb 28, 2005 6:24 pm    Post subject: Reply with quote

Thanks for the reply. startx works for me also, I wont' troubleshoot anymore, I'll just wait for the next update and see if that fixes it.
_________________
Gentoo x86
2x Dell Optiplex GX200

"My Break-Dancing days are over, but there's always the Funky Chicken."
--The Full Monty
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum