Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kan init niet vinden
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
Its_me_117
n00b
n00b


Joined: 10 Dec 2004
Posts: 15
Location: The Netherlands

PostPosted: Wed Feb 23, 2005 8:14 pm    Post subject: Kan init niet vinden Reply with quote

Ben voor me gevoel al een leuk eind opweg met de installatie van Gentoo

Ben nu bij de reboot-fase aangekomen

Dwz, ik heb alles gedaan zoals stond beschreven. Halverwegen het opnieuw opstarten krijg ik de melding dat de init niet kan worden gevonden. Nog even zoiets als de init= overslaan ofzo, maar verders niets.

Heb voor zover ik weet een foutje gemaakt in de grub.conf file

bij de regel kernel /kernel-2.6.28-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda3 heb ik het stukje real_boot... op een nieuwe regel gezet. Kwam ik achter na controlle (na booten en bovenstaande foutmelding)

Terug opgestart met een bootflop, mijn bootdirectory gemount en de grub.conf aangepast. Dacht dat dit voldoende was. Tegenovergestelde blijkt waar.

Wat moet ik doen om van die init fout af te komen?
Moet ik het commando: grub-install --root-directory=/boot /dev/hda nog een keer uitvoeren, of had ik alles weer moeten mounten, moeten chrooten, env-update en source /etc/profile ...?

BVD
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Thu Feb 24, 2005 1:02 am    Post subject: Reply with quote

je moet inderdaad eerst je /boot partitie mounten vanaf bijv een livecd. Dan editten. chrooten en alles zou niet nodig hoeven te zijn.
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
Its_me_117
n00b
n00b


Joined: 10 Dec 2004
Posts: 15
Location: The Netherlands

PostPosted: Thu Feb 24, 2005 9:49 am    Post subject: Reply with quote

Grub.conf heb ik al aangepast. Melding blijft. Wat nu? Welke handeling zou ik nog uit kunnen voeren om gentoo wel te laten opstarten?

Rainmaker zegt dat de rest niet nodig zou HOEVEN zijn. Kan ik hieruit opmaken dat ik het nog wel kan proberen of verziek ik daar juist de handel mee?

BVD
Back to top
View user's profile Send private message
webkiller71
n00b
n00b


Joined: 29 Nov 2003
Posts: 20

PostPosted: Thu Feb 24, 2005 10:51 am    Post subject: Reply with quote

Heb je het handboek gelezen? http://www.gentoo.org/doc/nl/handbook/handbook-x86.xml?part=1&chap=10 (deze is synchroon met het Engels handboek)
Wat me opvalt is dat je de kernel in / heb gezet en dat je 2.6.28 hebt, je kunt 2.4.28 hebben of 2.6.x, maar die x is maximaal 11 nu (als je een release canidate gebruikt)
Back to top
View user's profile Send private message
Its_me_117
n00b
n00b


Joined: 10 Dec 2004
Posts: 15
Location: The Netherlands

PostPosted: Fri Feb 25, 2005 4:57 pm    Post subject: Reply with quote

Haha, domme fout. Ik bedoel natuurlijk kernel-2.4.28-gentoo-r6. De kernel staat toch niet in de root zelf? Tenminste... ik heb m in de /boot staan. Door root (hd0,0) aan te geven en na de kernel de real_root=/dev/hda3 klopt dat toch weer?
Verder heb ik geloof ik alles gedaan zoals aangegeven is in de handleiding.

Iemand nog een tip?

BVD

Nog even de precieze waarschuwing:
Warning: unable to open an initial console.
Kernel panic: No init found. Try passing init= options to kernel.

Daarnaast knipperen de lampjes boven het numerieke deel van mijn toetsenbord.
Back to top
View user's profile Send private message
polle
Veteran
Veteran


Joined: 28 Feb 2003
Posts: 1498
Location: Belgium

PostPosted: Fri Feb 25, 2005 7:33 pm    Post subject: Reply with quote

Post hier anders eens je:
-grub.conf
-/etc/fstab
Back to top
View user's profile Send private message
Its_me_117
n00b
n00b


Joined: 10 Dec 2004
Posts: 15
Location: The Netherlands

PostPosted: Sat Feb 26, 2005 10:05 am    Post subject: Reply with quote

Ok, eerst me grub.conf
Code:
default 0
timeout 30
splashimage=(hd0,0)/grub/splash.xpm.gz

title=Gentoo Linux 2.4.28-r6
root (hd0,0)
kernel /kernel-2.4.28-gentoo-r6 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda3
initrd /initrd-2.4.28-gentoo-r6


Code:

/dev/hda1  /boot  ext2  defaults,noatime  1 2
/dev/hda3  /  ext3  noatime  0 0
/dev/hda2  none  swap  sw  0 1
/dev/fd0  /mnt/floppy  auto  noauto  0 0
none  /proc  proc  defaults  0 0
none  /dev/shm  tmpfs  nodev,nosuid,noexec  0 0
none  /proc/bus/usb  usbfs  defaults  0 0


Bovenstaande fstab is een ingekorte versie (alle #xxx zijn weggelaten. Kon met geen mogelijkheid /dev/fd0 mounten om de file ff te kopieren. Kernel van me bootflop ondersteund nl geen fat.)

Mogelijk dat iemand een fout ziet.

BVD iig maar weer

Ps. wat ik ook vreemd vind is dat in grub howto's wordt gesproken over root=/de/hda3 en in de handleiding gentoo real_root=/dev/hda3
Back to top
View user's profile Send private message
polle
Veteran
Veteran


Joined: 28 Feb 2003
Posts: 1498
Location: Belgium

PostPosted: Sat Feb 26, 2005 5:15 pm    Post subject: Reply with quote

heb je al eens gecheckt of die bewuste initrd in /boot staat.
Ik weet niet juist hoe genkernel werkt (ik veronderstel dat je dat gebrukt hebt, ik werk er echter niet mee) maar het gebeurt wel eens dat mensne hun nieuwe kernel copieren naar /boot zonder dat die gemount is (standaard zo ondr gentoo) en dan werkt dat ook niet.
Back to top
View user's profile Send private message
Its_me_117
n00b
n00b


Joined: 10 Dec 2004
Posts: 15
Location: The Netherlands

PostPosted: Sat Feb 26, 2005 7:01 pm    Post subject: Reply with quote

Zowel kernel-2.4.28-gentoo-r6 als initrd-2.4.28-gentoo-r6 staan in /boot.

Nog iets anders waar ik mogelijk een fout mee gemaakt heb?
Back to top
View user's profile Send private message
polle
Veteran
Veteran


Joined: 28 Feb 2003
Posts: 1498
Location: Belgium

PostPosted: Sat Feb 26, 2005 7:24 pm    Post subject: Reply with quote

Gebruik je devfs of udev?
als je het eerste nog gebruikt moet het zeker in de kernel mee gecompileerd zijn.
(check ook eens even of bij jouw de directory /dev wel bestaa)
Back to top
View user's profile Send private message
Its_me_117
n00b
n00b


Joined: 10 Dec 2004
Posts: 15
Location: The Netherlands

PostPosted: Sun Feb 27, 2005 10:45 am    Post subject: Reply with quote

Ik ga ervanuit dat ik devfs gebruik daar ik ng werk met een 2.4.28 kernel en de ondersteuning voor udev pas in de 1.6 kernel zit verwerkt. (dacht ik hoor :?)

De directory /dev bestaat ook en is gevult.

In /etc staat een bestandje devfs.d en devfs.conf. Beide bevatten geen tekst.

//edit devfs is ook in de kernel opgenomen. Dat wil zeggen.. in de .config file staat config_devfs_fs=y

config_devfs_mount en config_devfs_debug staan overigens als not set in deze lijst
Back to top
View user's profile Send private message
Its_me_117
n00b
n00b


Joined: 10 Dec 2004
Posts: 15
Location: The Netherlands

PostPosted: Sun Feb 27, 2005 12:12 pm    Post subject: Reply with quote

Gelukt...

real_root= is root= geworden. Kan nu gewoon inloggen als root. Nu ff een andere user aanmaken en dan verder.

Bedankt voor alle reacties...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum