Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge system error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
job2600
n00b
n00b


Joined: 04 Jan 2004
Posts: 35

PostPosted: Fri Feb 25, 2005 2:21 pm    Post subject: emerge system error Reply with quote

I am getting an error during the emerge system step of the installation:
Code:

06:59:44 (300.03 KB/s) - `/usr/portage/distfiles/openssl-0.9.7e.tar.gz' saved [3043231/3043231]
 
>>> md5 src_uri ;-) openssl-0.9.7e.tar.gz
>>> md5 src_uri ;-) openssl-0.9.6m.tar.gz
>>> Unpacking source...
>>> Unpacking openssl-0.9.7e.tar.gz to /var/tmp/portage/openssl-0.9.7e/work
>>> Unpacking openssl-0.9.6m.tar.gz to /var/tmp/portage/openssl-0.9.7e/work
* Applying openssl-0.9.7c-tempfile.patch ...                             [ ok ]
* Applying openssl-0.9.7e-gentoo.patch ...                               [ ok ]
* Applying openssl-0.9.7-arm-big-endian.patch ...                        [ ok ]
* Applying openssl-0.9.7-hppa-fix-detection.patch ...                    [ ok ]
* Applying openssl-0.9.7-alpha-default-gcc.patch ...                     [ ok ]>>> Source unpacked.
Operating system: x86_64-whatever-linux2
You need Perl 5.
 
!!! ERROR: dev-libs/openssl-0.9.7e failed.
!!! Function src_compile, Line 146, Exitcode 1
!!! config failed
!!! If you need support, post the topmost build error, NOT this status message.


If I try to emerge perl the first thing it tries to emerge is openssl and again errors out with the same message.

I also tried
Code:
use="-ssl" emerge perl
but it still tries to emerge openssl first.

Any ideas?
Back to top
View user's profile Send private message
gospleOfLinux
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2004
Posts: 81
Location: East Texas

PostPosted: Fri Feb 25, 2005 2:57 pm    Post subject: Reply with quote

It may be really stupid to ask, but did you enter
Code:
use="-ssl"

or
Code:
USE="-ssl"

To set USE at the command line it has to be in all caps. If you did that, I'm just a dork. Ignore me.

jdm
_________________
"I'm feeling HAPPY, I'M FEELING HAPPY" *thunk*
Back to top
View user's profile Send private message
lookinin
Guru
Guru


Joined: 21 Jan 2005
Posts: 486

PostPosted: Fri Feb 25, 2005 3:02 pm    Post subject: Reply with quote

This is odd anyway, perl should be installed first...

Code:
# emerge -ep system

[ebuild  N    ] sys-devel/libperl-5.8.5 
[ebuild  N    ] dev-lang/perl-5.8.5-r4 
[ebuild  N    ] dev-libs/openssl-0.9.7e


Maybe you could try (do the same for libperl if it's not installed):

Code:
# emerge --nodeps perl
Back to top
View user's profile Send private message
job2600
n00b
n00b


Joined: 04 Jan 2004
Posts: 35

PostPosted: Fri Feb 25, 2005 7:50 pm    Post subject: Reply with quote

I was using USE not use btw... but that still didn't work.

I finally got this to work by doing:
Code:
emerge -O libperl

followed by:
Code:
emerge -O perl
env-update


After that openssl is compiling ok. Weird that is was in line to be compiled first.
Back to top
View user's profile Send private message
smonijhay1
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 229
Location: Ann Arbor Michigan

PostPosted: Fri Feb 25, 2005 8:33 pm    Post subject: Reply with quote

you know, I saw someone else that had that error. I had that error too recently when rebuilding my machine. It threw that error the first time. I just ran the emerge system again a second time without changing anything.... it just worked (go figure?)
_________________
you mean you are going to remember me by what I type....here?
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7694
Location: Pelotas, BR

PostPosted: Sat Jun 04, 2005 10:24 pm    Post subject: Reply with quote

moved to dups, please continue discussion here, if necessary.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum