Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Update to kernel gentoo-sources-2.4.28-r7 failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Black Widow
n00b
n00b


Joined: 25 Feb 2005
Posts: 5
Location: Germany

PostPosted: Fri Feb 25, 2005 9:51 pm    Post subject: Update to kernel gentoo-sources-2.4.28-r7 failed Reply with quote

Hi everyone!

I'm using a Gentoo-System with kernel "gentoo-sources-2.4.28-r5". Few ago I wanted to update my whole system and started:
Code:
emerge --sync
emerge --update --deep world

After updating the portage-tree, the first package to emerge was the updated kernel "gentoo-sources-2.4.28-r7" (still up-to-date). How you can see (next listing) he unpacked the sources but the patch GRSecurity seems to have an error:
Code:
Calculating world dependencies  ..... .>>> Preparing to unpack ...
>>> Unpacking source...
>>> Unpacking linux-2.4.28.tar.bz2 to /var/tmp/portage/gentoo-sources-2.4.28-r7/work
 * gentoo-sources-2.4.28-r4.tar.bz2 unpacked
 * Applying gentoo-sources-2.4.binfmt_a.out.patch (-p0+)...
 * Applying gentoo-sources-2.4.77666.patch (-p0+)...
 * Applying gentoo-sources-2.4.78362.patch (-p0+)...
 * Applying 01-01.3.5-useraddress.patch (-p0+)...
 * Applying 01-02.lckbase-2.4.28_rc3.patch (-p0+)...
 * Applying 01-03.readlatency.patch (-p0+)...
 * Applying 01-04.ecc-20030225.patch (-p0+)...
 * Applying 01-05.OpenSWAN-2.1.4+natt.patch (-p0+)...
 * Applying 01-06.bootsplash-3.0.7.patch (-p0+)...
 * Applying 02-01.deviceMapper-1.00.17.patch (-p0+)...
 * Applying 02-02.superMount.1.2.11a.patch (-p0+)...
 * Applying 03-01.linux-ntfs-2.1.6b.patch (-p0+)...
 * Applying 03-02.squashfs-1.3r3.patch (-p0+)...
 * Applying 04-01.GRSecurity-2.0.2.patch (-p0+)...
patch: pch.c:614: intuit_diff_type: Assertion `i0 != NONE' failed.

 * Please attach /var/tmp/portage/gentoo-sources-2.4.28-r7/temp/04-01.GRSecurity-2.0.2.err to any bug you may post.

!!! ERROR: sys-kernel/gentoo-sources-2.4.28-r7 failed.
!!! Function unipatch, Line 562, Exitcode 0
!!! Unable to dry-run patch.
!!! If you need support, post the topmost build error, NOT this status message.


And the beginning of the file /var/tmp/portage/gentoo-sources-2.4.28-r7/temp/04-01.GRSecurity-2.0.2.err:
Code:
Attempting Dry-run:
cmd: patch -p0 --dry-run -f < /var/tmp/portage/gentoo-sources-2.4.28-r7/work/patches/1/2.4.28-gentoo-r4/04-01.GRSecurity-2.0.2.patch
=======================================================
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -urN linux-2.4.28/Documentation/Configure.help linux-2.4.28/Documentation/Configure.help
|--- linux-2.4.28/Documentation/Configure.help 2004-11-17 06:54:20.000000000 -0500
|+++ linux-2.4.28/Documentation/Configure.help 2004-11-22 17:13:30.000000000 -0500
--------------------------
No file to patch.  Skipping patch.
2 out of 2 hunks ignored
can't find file to patch at input line 972
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -urN linux-2.4.28/Makefile linux-2.4.28/Makefile
|--- linux-2.4.28/Makefile 2004-11-17 06:54:22.000000000 -0500
|+++ linux-2.4.28/Makefile 2004-11-22 17:13:30.000000000 -0500
--------------------------
...


As you can see, the patches of the 2.4.28-r4 kernel are used (i think with some additional patches after that ...). But is it OK, that the patch uses the file /var/tmp/portage/gentoo-sources-2.4.28-r7/work/patches/1/2.4.28-gentoo-r4/04-01.GRSecurity-2.0.2.patch? But if that's the reason, there must be other people with the same problem, but i couldn't find anything in the forum or with google!

I don't know where's the bug, or if it is an bug, but in this case what i did wrong.
Someone with the same problem there? Or someone with a hint for me?

THX a lot!

Black Widow
Back to top
View user's profile Send private message
Black Widow
n00b
n00b


Joined: 25 Feb 2005
Posts: 5
Location: Germany

PostPosted: Sat Feb 26, 2005 5:23 pm    Post subject: Reply with quote

No one any idea?
Or have at least someone the same problem?

Black Widow
Back to top
View user's profile Send private message
DavidMCS
n00b
n00b


Joined: 08 Feb 2004
Posts: 39
Location: Halifax, NS Canada

PostPosted: Sat Feb 26, 2005 6:05 pm    Post subject: Reply with quote

LC_ALL=C emerge gentoo-sources

worked for me the last couple of times I encountered this...

see https://bugs.gentoo.org/show_bug.cgi?id=77190 if you're curious.

--
David-
Back to top
View user's profile Send private message
Black Widow
n00b
n00b


Joined: 25 Feb 2005
Posts: 5
Location: Germany

PostPosted: Sat Feb 26, 2005 7:01 pm    Post subject: Reply with quote

Hi David!

Thanks a lot! I'm using gentoo just since 2-3 month and do not know all the "information-sources" where to get help! This forum was my first try! :lol:
But the BugTracker helps me a lot! Thanks again!

I found out, that, i think, the LC_ALL variable just have to be set to any locale, not strictly to LC_ALL=C! I set it to LC_ALL="de_DE@euro" and it works fine too!

Greetz,
Black Widow
Back to top
View user's profile Send private message
DavidMCS
n00b
n00b


Joined: 08 Feb 2004
Posts: 39
Location: Halifax, NS Canada

PostPosted: Sat Feb 26, 2005 7:22 pm    Post subject: Reply with quote

Yes that will work as well, I've set mine to en_CA a while back after hitting upon this issue twice.
Not knowing what your local preferences were I didn't want to get into local specifics. :wink:
Apparently temporarily un-setting you're LANG environment variable corrects this issue too.

--
David-
Back to top
View user's profile Send private message
Black Widow
n00b
n00b


Joined: 25 Feb 2005
Posts: 5
Location: Germany

PostPosted: Sat Feb 26, 2005 7:58 pm    Post subject: Reply with quote

I tried to unset LANG before but that didn't work for me! I didn't want to set LC_ALL=C because I thinks it's a little untidy! So I tried to set it to my locale (the same as my LANG variable) because I hadn't set it before ... I just used LANG! And ....... it worked! :o

Maybe the update (which part ever ...) needs the existing of the LC_ALL variable ...

Greetz,
Black Widow
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4923
Location: Gothenburg, Sweden

PostPosted: Tue Mar 08, 2005 4:31 pm    Post subject: Reply with quote

Moved from Portage & Programming in favour of https://forums.gentoo.org/viewtopic-t-281007-highlight-0401+grsecurity2.html
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum