Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge ncurses fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
nodrew
n00b
n00b


Joined: 13 Sep 2003
Posts: 11

PostPosted: Tue Mar 01, 2005 1:15 pm    Post subject: emerge ncurses fails Reply with quote

Hi guys, need some help here, been at it all night. I'm running an AMD 64 and decided to load Gentoo on last night, so far I've had nothing but problems. On running "emerge kernel-dev-sources" I get the following error once it get to "sys-libs/ncurses-5.4-r5"

Code:
make[1]: Entering directory '/usr/portage_tmp/portage/ncurses-5.4-r5/work/ncurses-5.4/c++'
cd ../obj_s; -I../c++ -I../include -I. -DHAVE_CONFIG_H -I. -I../include  -D=GNU_SOURCE =DNDEBUG -march=athelon64 -02 -pipe -fPIC -fPIC -c ../c++/cursesf.cc
/bin/sh: linq: -I../c++: No such file or directory
cd ../obj_s; -I../c++ -I../include -I. -DHAVE_CONFIG_H -I. -I../include  -D=GNU_SOURCE =DNDEBUG -march=athelon64 -02 -pipe -fPIC -fPIC -c ../c++/cursesm.cc
/bin/sh: linq: -I../c++: No such file or directory
make[1]: *** [../obj_s/cursesf.o] Error 127
make[1]: *** Waiting for unfinished jobs....
make[1]: *** [../obj_s/cursesm.o] Error127
make[1]: *** Leaving directory '/usr/portage_tmp/portage/ncurses=5.4-r5/wok/ncurses-5.4/c++'
make: *** [all] Error2


This is happening everytime I try to run the emerge. As I'm fairly new to Gentoo, I was hoping someone might be able to help, I'm stumped and I'm down my main box at this point.

Oh and here's my make.conf

Code:
USE="nptl multilib"
CHOST="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
LDFLAGS="-Wl,-O1"
PORTAGE_TMPDIR=/usr/portage_tmp
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
MAKEOPTS="-j2"
FEATURES="sandbox ccache distcc distlocks autoaddcvs"
GENTOO_MIRRORS="http://gentoo.ccccom.com"


Thank you all in advance.
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Tue Mar 01, 2005 1:20 pm    Post subject: Reply with quote

Have a look here:

https://forums.gentoo.org/viewtopic-t-299349.html

By the way, you seem to have -march=athelon64 twice in that error message. You might want to make sure the value in your /etc/make.conf doesn't have the extra e, or that could cause other things to start failing... :wink:
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Tue Mar 01, 2005 1:51 pm    Post subject: Reply with quote

Maedhros wrote:
Have a look here:

https://forums.gentoo.org/viewtopic-t-299349.html

Moved to dups, use the thread mentioned by Maedhros if questions are left.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum