Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libsdl won't compile ! [FIXED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
eniac
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 233
Location: Belgium, Brussels

PostPosted: Tue Mar 01, 2005 3:21 pm    Post subject: libsdl won't compile ! [FIXED] Reply with quote

Code:
 i686-pc-linux-gnu-gcc -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"SDL\" -DVERSION=\"1.2.7\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DHAVE_ALLOCA_H=1 -DHAVE_ALLOCA=1 -I. -I. -D_REENTRANT -I/usr/include/directfb -O2 -march=athlon-xp -Wall -DENABLE_DUMMYVIDEO -DDISKAUD_SUPPORT -DUSE_DLOPEN -DUSE_ASMBLIT -I./hermes -I../../../src/hermes -DOSS_SUPPORT -DALSA_SUPPORT -DARTSC_SUPPORT -DARTSC_DYNAMIC=libartsc.so.0 -I/usr/kde/3.3/include/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DESD_SUPPORT -DESD_DYNAMIC=libesd.so.0 -I/usr/X11R6/include -DENABLE_X11 -DXTHREADS -I./include -I./src/video -DXFREE86_VM -DXFREE86_VMGAMMA -DXFREE86_XV -DENABLE_DIRECTFB -DENABLE_SVGALIB -DHAVE_OPENGL -DUSE_INPUT_EVENTS -D_REENTRANT -DSDL_USE_PTHREADS -DHAVE_SIGACTION -I../../../include -I../../../include/SDL -I../../../src -I../../../src/main/linux -I../../../src/audio -I../../../src/video -I../../../src/video/XFree86/extensions -I../../../src/events -I../../../src/joystick -I../../../src/cdrom -I../../../src/thread -I../../../src/timer -I../../../src/endian -I../../../src/file -I../../../src/thread -MT SDL_DirectFB_yuv.lo -MD -MP -MF .deps/SDL_DirectFB_yuv.Tpo -c SDL_DirectFB_yuv.c -o SDL_DirectFB_yuv.o >/dev/null 2>&1
/bin/sh ../../../libtool --mode=link i686-pc-linux-gnu-gcc  -O2 -march=athlon-xp -Wall -DENABLE_DUMMYVIDEO -DDISKAUD_SUPPORT -DUSE_DLOPEN -DUSE_ASMBLIT -I./hermes -I../../../src/hermes -DOSS_SUPPORT -DALSA_SUPPORT -DARTSC_SUPPORT -DARTSC_DYNAMIC=libartsc.so.0 -I/usr/kde/3.3/include/artsc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -DESD_SUPPORT -DESD_DYNAMIC=libesd.so.0   -I/usr/X11R6/include -DENABLE_X11 -DXTHREADS -I./include -I./src/video -DXFREE86_VM -DXFREE86_VMGAMMA -DXFREE86_XV -DENABLE_DIRECTFB -DENABLE_SVGALIB -DHAVE_OPENGL -DUSE_INPUT_EVENTS -D_REENTRANT -DSDL_USE_PTHREADS -DHAVE_SIGACTION -I../../../include -I../../../include/SDL -I../../../src -I../../../src/main/linux -I../../../src/audio -I../../../src/video -I../../../src/video/XFree86/extensions -I../../../src/events -I../../../src/joystick -I../../../src/cdrom -I../../../src/thread -I../../../src/timer -I../../../src/endian -I../../../src/file -I../../../src/thread   -o libvideo_directfb.la   SDL_DirectFB_events.lo SDL_DirectFB_video.lo SDL_DirectFB_yuv.lo -ldirectfb -lpthread -ldl   -lpthread
grep: /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la: No such file or directory
/bin/sed: can't read /usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la: No such file or directory
libtool: link: `/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.4/libstdc++.la' is not a valid libtool archive
make[3]: *** [libvideo_directfb.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/libsdl-1.2.7-r3/work/SDL-1.2.7/src/video/directfb'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/libsdl-1.2.7-r3/work/SDL-1.2.7/src/video'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libsdl-1.2.7-r3/work/SDL-1.2.7/src'
make: *** [all-recursive] Error 1

_________________
Turns out the pony only had one trick.


Last edited by eniac on Tue Mar 01, 2005 7:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
X
Apprentice
Apprentice


Joined: 30 Apr 2002
Posts: 192
Location: Lexington KY

PostPosted: Tue Mar 01, 2005 4:24 pm    Post subject: Reply with quote

I had the same problem. The suggestion in the first post of this thread fixed it.

https://forums.gentoo.org/viewtopic.php?t=278673&highlight=valid+libtool+archive
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9220

PostPosted: Sun Jul 08, 2007 5:31 am    Post subject: Reply with quote

X wrote:
I had the same problem. The suggestion in the first post of this thread fixed it.

https://forums.gentoo.org/viewtopic.php?t=278673&highlight=valid+libtool+archive

Moved from Portage & Programming to Duplicate Threads.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum