Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg masked when trying to emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
drumaholik
n00b
n00b


Joined: 03 Aug 2004
Posts: 10

PostPosted: Fri Mar 04, 2005 12:11 am    Post subject: xorg masked when trying to emerge Reply with quote

im currently running xorg-6.7.0-r2 on ~x86
when i try to upgrade to xorg-6.8.2 i get this:

Code:
 # emerge -pv xorg-x11

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <x11-base/xorg-x11-6.8.0-r4 (from pkg x11-base/opengl-update-2.1.1-r1)
[ebuild     U ] media-libs/freetype-2.1.9-r1 [2.1.5-r1] -bindist -debug -doc +zlib 969 kB
[ebuild     U ] x11-base/opengl-update-2.1.1-r1 [1.8.1] 37 kB
[ebuild     U ] x11-misc/ttmkfdir-3.0.9-r2 [3.0.9-r1] -debug 0 kB
[ebuild     U ] x11-base/xorg-x11-6.8.2 [6.7.0-r2] -3dfx -3dnow +bitmap-fonts* -cjk -debug -dlloader -dmx -doc +font-server* -hardened -insecure-drivers +ipv6* -minimal -mmx +nls +opengl +pam -sdk -sse -static +truetype-fonts* +type1-fonts* (-uclibc) -xprint +xv 43,487 kB

Total size of downloads: 44,494 kB


why is it masking xorg-6.8.0-r4 when i want 6.8.2? It wont let me compile it. Do i need to unmerge my old xorg, then emerge the new one?
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Fri Mar 04, 2005 3:31 am    Post subject: Reply with quote

It tells you that in order to upgrade opengl-update you need to remove xorg-x11-6.8.0-r4. You need to either unmerge that xorg-x11 version, or mask the newer opengl-update version. Please read up the section of the Gentoo Handbook relevant to package management with portage, and this FAQ entry: https://forums.gentoo.org/viewtopic.php?t=26640
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum