Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Weird error when trying to emerge Subversion
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
BushGates
n00b
n00b


Joined: 28 Feb 2005
Posts: 11
Location: Auckland, New Zealand

PostPosted: Fri Mar 04, 2005 11:33 am    Post subject: Weird error when trying to emerge Subversion Reply with quote

Hi,

I'm a real newbie at linux, beening using Gentoo for 3 days - and loving it :) (after 2 weeks of torture with Mandrake :P)

I've got a question / problem thou: I'm trying to install Subversion via emerge, and i am getting a really weird error, when i run "emerge subversion".

Code:
!!! Error: the >=net-www/apache-2* package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.


Then i have run "emerge --pretend subversion" and this is the oputput that i am getting.

Code:
Calculating dependencies ...done!
[blocks B     ] >=net-www/apache-2* (from pkg dev-util/subversion-1.1.1-r3)
[ebuild  N    ] dev-lang/swig-1.3.21
[ebuild  N    ] net-misc/neon-0.24.7
[ebuild  N    ] dev-util/subversion-1.1.1-r3


At the moment i have the latest stable version of apache installed on my system (Apache/2.0.52)... can that be causing problem? If so, how can i resolve it?

TIA
_________________
Kind regards,
Nick Goloborodko

http://www.nickgoloborodko.com
Back to top
View user's profile Send private message
thebigslide
l33t
l33t


Joined: 23 Dec 2004
Posts: 790
Location: under a car or on top of a keyboard

PostPosted: Fri Mar 04, 2005 11:43 am    Post subject: Reply with quote

I think the ebuild is broken. The ebuild indicates that the package requires >=apache-2.0.49 and cannot coexist with >=apache-2* ?!? That doesn't make any sense to me.

I'm going to try emerging it with the second line of the RDEPEND statement removed and let you know if it's a bug.

EDIT: echo dev-util/subversion apache2 >> /etc/portage/package.use && emerge -pv subversion
should make you happy.
Back to top
View user's profile Send private message
BushGates
n00b
n00b


Joined: 28 Feb 2005
Posts: 11
Location: Auckland, New Zealand

PostPosted: Fri Mar 04, 2005 11:50 am    Post subject: Reply with quote

thebigslide wrote:
I think the ebuild is broken. The ebuild indicates that the package requires >=apache-2.0.49 and cannot coexist with >=apache-2* ?!? That doesn't make any sense to me.

I'm going to try emerging it with the second line of the RDEPEND statement removed and let you know if it's a bug.

EDIT: echo dev-util/subversion apache2 >> /etc/portage/package.use && emerge -pv subversion
should make you happy.


Thanks for the help - that works :) I still got a LONG way to go in order to fully understand linux... but one day i'll get there... :)
_________________
Kind regards,
Nick Goloborodko

http://www.nickgoloborodko.com
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4920
Location: Gothenburg, Sweden

PostPosted: Thu May 19, 2005 6:49 pm    Post subject: Reply with quote

Moved from Portage & Programming in favour of https://forums.gentoo.org/viewtopic-t-259109.html
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum