Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Apache-2.0 blocks subversion?!?!?!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
enigma_0Z
Guru
Guru


Joined: 29 Aug 2004
Posts: 531
Location: Either lurking here or at my forum (see sig)

PostPosted: Sat Mar 05, 2005 5:14 pm    Post subject: Apache-2.0 blocks subversion?!?!?! Reply with quote

Why does Apache-2.0 block subversion, and how can I fix it?
_________________
Check out my...
Website: (CURRENTLY DOWN) http://sledgehammer.ath.cx
Forum: (ALSO CURRRENTLY DOWN) http://sledgehammer.ath.cx/forum/
Back to top
View user's profile Send private message
steveb
Advocate
Advocate


Joined: 18 Sep 2002
Posts: 4564

PostPosted: Sat Mar 05, 2005 5:33 pm    Post subject: Reply with quote

Since when?
Code:
mail / # equery -q -C list apache ; equery -q -C list subversion
 * installed packages
[I--] [  ] net-www/apache-2.0.52-r1 (2)
 * installed packages
[I--] [  ] dev-util/subversion-1.1.1-r3 (0)
mail / #
Code:
mail / # emerge -pv apache subversion

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] net-www/apache-2.0.52-r1  +berkdb -debug -doc +gdbm -ipv6 +ldap +ssl -static -threads 0 kB
[ebuild   R   ] dev-util/subversion-1.1.1-r3  +apache2 -bash-completion +berkdb -emacs +java +perl +python +ssl 0 kB

Total size of downloads: 0 kB
mail / #


cheers

SteveB
Back to top
View user's profile Send private message
spb
Retired Dev
Retired Dev


Joined: 02 Jan 2004
Posts: 2135
Location: Cambridge, UK

PostPosted: Sat Mar 05, 2005 5:37 pm    Post subject: Reply with quote

From the latest stable Subversion ebuild:
Code:
RDEPEND="apache2? ( >=net-www/apache-2.0.49 )
        !apache2? ( !>=net-www/apache-2* )
        !dev-libs/apr


It needs Apache2 if you have apache2 in USE, and blocks it otherwise.
Back to top
View user's profile Send private message
steveb
Advocate
Advocate


Joined: 18 Sep 2002
Posts: 4564

PostPosted: Sat Mar 05, 2005 5:43 pm    Post subject: Reply with quote

spb wrote:
From the latest stable Subversion ebuild:
Code:
RDEPEND="apache2? ( >=net-www/apache-2.0.49 )
        !apache2? ( !>=net-www/apache-2* )
        !dev-libs/apr


It needs Apache2 if you have apache2 in USE, and blocks it otherwise.
COOL ;)
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4920
Location: Gothenburg, Sweden

PostPosted: Thu May 19, 2005 6:50 pm    Post subject: Reply with quote

Moved from Portage & Programming in favour of https://forums.gentoo.org/viewtopic-t-259109.html
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum