Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X won't emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
decrease789
Apprentice
Apprentice


Joined: 25 Jun 2004
Posts: 194
Location: The United Krapdom

PostPosted: Mon Mar 07, 2005 1:04 am    Post subject: X won't emerge Reply with quote

I am emerging Xorg from the package CD and it will not emerge it says that it is blocked because another package has been installed, which is Xorg-6.8.0 but it hasn't. When you try to emerge -C xorg-x11, it says that it is not installed. Anyone now how I can force it to merge?
Back to top
View user's profile Send private message
SZwarts
l33t
l33t


Joined: 13 Oct 2003
Posts: 629
Location: Sydney, NSW, Australia

PostPosted: Mon Mar 07, 2005 3:26 am    Post subject: Reply with quote

I guess xorg is blocked by Xfree version X and not Xorg?
Can you post your actually error message you get when you emerge -pv xorg-x11
Because it looks weird to me that a package should block itself...
_________________
only when it is dark enough, can you see the stars
Back to top
View user's profile Send private message
decrease789
Apprentice
Apprentice


Joined: 25 Jun 2004
Posts: 194
Location: The United Krapdom

PostPosted: Mon Mar 07, 2005 1:34 pm    Post subject: Reply with quote

nope it's blocked by Xorg-6.8.0-r4. i think thats the version. not sure what the actual message says but i will update this when i get a chance

it says something like[/url]
Code:
[B blocked] by Xorg-6.8.0-r4 [blocked opengl-update by xorg-something-something]
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Mar 07, 2005 2:01 pm    Post subject: Reply with quote

Unmerge both opengl-update and xorg-x11, then remerge xorg-x11. It should work then.
Back to top
View user's profile Send private message
decrease789
Apprentice
Apprentice


Joined: 25 Jun 2004
Posts: 194
Location: The United Krapdom

PostPosted: Tue Mar 08, 2005 1:20 am    Post subject: Reply with quote

i can't unmerge xorg-x11!!!!!! it says the package does not exist!!!!!!
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Mar 08, 2005 3:54 am    Post subject: Reply with quote

We can't help you if you don't post your exact error.
Back to top
View user's profile Send private message
decrease789
Apprentice
Apprentice


Joined: 25 Jun 2004
Posts: 194
Location: The United Krapdom

PostPosted: Tue Mar 08, 2005 10:50 am    Post subject: Reply with quote

i will do tonight....
Back to top
View user's profile Send private message
eunuque
n00b
n00b


Joined: 19 Aug 2003
Posts: 62

PostPosted: Tue Mar 08, 2005 11:12 am    Post subject: Reply with quote

I have the same problem.
Code:
# emerge -p xorg-x11

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <x11-base/xorg-x11-6.8.0-r4 (from pkg x11-base/opengl-update-2.1.1-r1)
[ebuild     U ] media-libs/freetype-2.1.9-r1 [2.1.5-r1]
[ebuild     U ] x11-base/opengl-update-2.1.1-r1 [1.7.2]
[ebuild     U ] x11-base/xorg-x11-6.8.2-r1 [6.8.0-r3]


To be updated, xorg needs opengl-update 2.1.1 that conflicts with my current xorg version.
I can always unmerge xorg+opengl-update and then re-emerge them, but it there a way to just force the install of opengl-update?
Back to top
View user's profile Send private message
decrease789
Apprentice
Apprentice


Joined: 25 Jun 2004
Posts: 194
Location: The United Krapdom

PostPosted: Tue Mar 08, 2005 12:12 pm    Post subject: Reply with quote

Code:
emerge xorg-x11

Calculating dependencies 
  ...done!
>>> emerge (1 of 4) x11-base/xorg-x11-6.8.2 to /
>>> md5 src_uri ;-) eurofonts-X11.tar.bz2
>>> md5 src_uri ;-) xfsft-encodings-0.1.tar.bz2
>>> md5 src_uri ;-) gentoo-cursors-tad-0.3.1.tar.bz2
>>> md5 src_uri ;-) gemini-koi8-u.tar.bz2
>>> md5 src_uri ;-) xorg-x11-6.8.2-files-0.1.tar.bz2
>>> md5 src_uri ;-) xorg-x11-6.8.2-patches-0.1.1.tar.bz2
>>> md5 src_uri ;-) X11R6.8.2-src.tar.bz2

 * Previous xorg-x11 installation detected
 * Enabling PAM features in xorg-x11...
 * See http://bugs.gentoo.org/show_bug.cgi?id=67996
 * The xv USE flag currently requires the opengl flag.

Code:
# emerge -p xorg-x11

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <x11-base/xorg-x11-6.8.0-r4 (from pkg x11-base/opengl-update-2.1.1-r1)
[ebuild     U ] media-libs/freetype-2.1.9-r1 [2.1.5-r1]
[ebuild     U ] x11-base/opengl-update-2.1.1-r1 [1.7.2]
[ebuild     U ] x11-base/xorg-x11-6.8.2-r1 [6.8.0-r3]

Code:
emerge -C xorg-x11

--- Couldn't find xorg-x11 to unmerge.

>>> unmerge: No packages selected for removal.


when i use the binary off the package cd i get
Code:
emerge =xorg-x11-6.7.0-r2.tbz2 --usepkg

Calculating dependencies    ...done!

!!! Error: the <x11-base/xorg-x11-6.8.0-r4 package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Mar 08, 2005 1:11 pm    Post subject: Reply with quote

eunuque wrote:
I have the same problem.
Code:
# emerge -p xorg-x11

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <x11-base/xorg-x11-6.8.0-r4 (from pkg x11-base/opengl-update-2.1.1-r1)
[ebuild     U ] media-libs/freetype-2.1.9-r1 [2.1.5-r1]
[ebuild     U ] x11-base/opengl-update-2.1.1-r1 [1.7.2]
[ebuild     U ] x11-base/xorg-x11-6.8.2-r1 [6.8.0-r3]


To be updated, xorg needs opengl-update 2.1.1 that conflicts with my current xorg version.
I can always unmerge xorg+opengl-update and then re-emerge them, but it there a way to just force the install of opengl-update?


It is best to simply unmerge xorg-x11 and opengl-update, and then remerge xorg-x11.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Mar 08, 2005 1:16 pm    Post subject: Reply with quote

decrease789 wrote:
Code:
emerge xorg-x11

Calculating dependencies 
  ...done!
>>> emerge (1 of 4) x11-base/xorg-x11-6.8.2 to /
>>> md5 src_uri ;-) eurofonts-X11.tar.bz2
>>> md5 src_uri ;-) xfsft-encodings-0.1.tar.bz2
>>> md5 src_uri ;-) gentoo-cursors-tad-0.3.1.tar.bz2
>>> md5 src_uri ;-) gemini-koi8-u.tar.bz2
>>> md5 src_uri ;-) xorg-x11-6.8.2-files-0.1.tar.bz2
>>> md5 src_uri ;-) xorg-x11-6.8.2-patches-0.1.1.tar.bz2
>>> md5 src_uri ;-) X11R6.8.2-src.tar.bz2

 * Previous xorg-x11 installation detected
 * Enabling PAM features in xorg-x11...
 * See http://bugs.gentoo.org/show_bug.cgi?id=67996
 * The xv USE flag currently requires the opengl flag.

Code:
# emerge -p xorg-x11

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] <x11-base/xorg-x11-6.8.0-r4 (from pkg x11-base/opengl-update-2.1.1-r1)
[ebuild     U ] media-libs/freetype-2.1.9-r1 [2.1.5-r1]
[ebuild     U ] x11-base/opengl-update-2.1.1-r1 [1.7.2]
[ebuild     U ] x11-base/xorg-x11-6.8.2-r1 [6.8.0-r3]

Code:
emerge -C xorg-x11

--- Couldn't find xorg-x11 to unmerge.

>>> unmerge: No packages selected for removal.


when i use the binary off the package cd i get
Code:
emerge =xorg-x11-6.7.0-r2.tbz2 --usepkg

Calculating dependencies    ...done!

!!! Error: the <x11-base/xorg-x11-6.8.0-r4 package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.


It looks like you may have a screwed up world file, please try running regenworld and see if that helps. It would also be helpful to know if you had a failed xorg merge or something similar. Did you previously have xorg-x11 installed? Did you previously have xfree installed?

Thanks
Back to top
View user's profile Send private message
decrease789
Apprentice
Apprentice


Joined: 25 Jun 2004
Posts: 194
Location: The United Krapdom

PostPosted: Wed Mar 09, 2005 1:15 am    Post subject: Reply with quote

no failed emerge. freshly installed system!!! I have not had xfree on it either. regenworld does not help still get same error? could it be related to the bug that is mentioned? They only i think this is going to work is if I can force it to merge
Back to top
View user's profile Send private message
eunuque
n00b
n00b


Joined: 19 Aug 2003
Posts: 62

PostPosted: Fri Mar 11, 2005 10:00 am    Post subject: Reply with quote

Quote:
It is best to simply unmerge xorg-x11 and opengl-update, and then remerge xorg-x11.


Yes it's what I did. It worked for me. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum