Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems with IBM ThinkPad 600E
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
goldeneyexs
n00b
n00b


Joined: 08 Mar 2005
Posts: 3

PostPosted: Tue Mar 08, 2005 10:06 pm    Post subject: Problems with IBM ThinkPad 600E Reply with quote

I have been looking around the net for around a month now, trying many distros and even knoppix doesn't work with this, so I figured I would ask someone.

I am using a gentoo 2.4.28-r7 kernel

The IBM Thinkpad needs the cs4232 driver in order to work,
I have done the grep audio /proc/pci and it shows:
Multimedia audio controller: Cirrus Logic CD 4610/11 [CrystalClear SoundFusion Audio Accelerator] (rev1).

I know the cs4232 driver needs the io/irq/dma/dma2 commands in order to work so I have tried
Code:
modprobe cs4232 io=0x530 irq=5 dma=1 dma2=0

I have been working at this so long I have that line memorized :(

It fails to load the module and looking at dmesg it says "No ISAPnP cards found, trying standard ones"

I have read the ALSA config guide however since I cannot get the kernel module loaded, ALSA bails because of the fact there aren't any sound cards..I have been looking all over and haven't found anything yet..
_________________
Never trust an operating system you do not have the sources for ;) -Unknown Source
Back to top
View user's profile Send private message
Eggplant!
n00b
n00b


Joined: 29 May 2003
Posts: 20

PostPosted: Wed Mar 09, 2005 1:54 am    Post subject: Reply with quote

Hmmmm... Isn't that a 46xx chip, and not the 4232? I have a 600X and the snd_cs46xx worked for me. I appear to have a similar sound device:

Code:

$ lspci
Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio Accelerator] (rev 01)


Under Gentoo and 2.6, alsaconf picked it right upafter I figured out my ACPI problems. I had similar errors to yours until I started passing acpi=force pci=noacpi to the kernel. I can't say why this works, only that from what I've read the ACPI support on the ThinkPad 600 series is a bit broken.
Back to top
View user's profile Send private message
goldeneyexs
n00b
n00b


Joined: 08 Mar 2005
Posts: 3

PostPosted: Wed Mar 09, 2005 8:51 pm    Post subject: Reply with quote

Hmm...Knoppix tries using the snd_cs46xx and it fails, but tells you to try the cs4232 driver..I don't know..

By pass to the kernel do you mean adding a
Code:
append="acpi=force pci=noacpi"
to my lilo config?

I'll try to upgrade to the 2.6 kernel later..(already emerged sources) I just have to make sure the pegasus module will load as that is how I am getting onto the internet w/o a built in nic. (last time I tried 2.6 it didn't go too well, not that I don't mind experimenting:wink: )

EDIT:
I got it working!
for everyone else:
Go into your bios and TURN OFF Quick Boot, then the kernel module will load, I didn't even have to install alsa for it to work just using OSS?
Code:
modprobe cs4232 io=0x530 irq=5 dma=1 dma2=0

_________________
Never trust an operating system you do not have the sources for ;) -Unknown Source
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3088
Location: Paris

PostPosted: Sat Mar 19, 2005 2:20 pm    Post subject: Reply with quote

Eggplant! wrote:
Hmmmm... Isn't that a 46xx chip, and not the 4232? I have a 600X and the snd_cs46xx worked for me. I appear to have a similar sound device:

Code:

$ lspci
Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio Accelerator] (rev 01)



The sound chipsets are different between 600X and 600E: http://www.linux-thinkpad.org/chipsets.html
Back to top
View user's profile Send private message
Deathwing00
Bodhisattva
Bodhisattva


Joined: 13 Jun 2003
Posts: 4087
Location: Dresden, Germany

PostPosted: Sat Mar 19, 2005 3:05 pm    Post subject: Reply with quote

Duplicate of https://forums.gentoo.org/viewtopic.php?t=191136
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum