Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kdevelop problem. ./configure for any project fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
LynZ
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 220
Location: MIPT

PostPosted: Wed Mar 09, 2005 8:35 pm    Post subject: Kdevelop problem. ./configure for any project fails Reply with quote

Running ./configure for any project fails it. the output:
Code:

Óhecking for correct ltmain.sh version... no

*** Gentoo sanity check failed! ***
*** libtool.m4 and ltmain.sh have a version mismatch! ***
*** (libtool.m4 = 1.5.10, ltmain.sh = 1.5a) ***

Please run:

  libtoolize --copy --force

if appropriate, please contact the maintainer of this
package (or your distribution) for help.



running this solves the problem for this project, but the new (even "Hello world" proj) fails again.
gcc runned manually does everything just fine. But how to solve this problem with kdevelop?
_________________
Athlon64 (Venice) 3200+ @ ABIT KN8 ULTRA
1 Gb DDR 400
ASUS GeForce 6200 64Mb PCI-X
2 x Samsung SpinPoint P80 80 Gb
SB Live! 5.1 Player
Sven IMHOO MT 5.1
Back to top
View user's profile Send private message
LynZ
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 220
Location: MIPT

PostPosted: Wed Mar 09, 2005 8:45 pm    Post subject: Reply with quote

Yepp.. And the versions:

libtool-1.5.10-r4

gcc (GCC) 3.3.5 (Gentoo Linux 3.3.5-r1, ssp-3.3.2-3, pie-8.7.7.1)

KDE 3.3.2 Kdevelop 3.1.2 if thus matters
_________________
Athlon64 (Venice) 3200+ @ ABIT KN8 ULTRA
1 Gb DDR 400
ASUS GeForce 6200 64Mb PCI-X
2 x Samsung SpinPoint P80 80 Gb
SB Live! 5.1 Player
Sven IMHOO MT 5.1
Back to top
View user's profile Send private message
Featherfoot
l33t
l33t


Joined: 28 Dec 2002
Posts: 997
Location: Stuart, Florida

PostPosted: Sun Mar 20, 2005 3:21 am    Post subject: KDevelop fails here, too. Reply with quote

I get the same error. This is upsetting! :cry:
Back to top
View user's profile Send private message
tbscope
n00b
n00b


Joined: 29 Mar 2004
Posts: 45

PostPosted: Sun Mar 20, 2005 7:58 am    Post subject: Reply with quote

I know that KDevelop uses an admin archive containing such files, and extracts them to your project/admin folder when you create a new project.

Maybe the problem is that the files in that archive are not up to date with the latest libtool.

So, a suggestion would be to check the files in that admin archive (somewhere in a kde shared folder I guess) and change the files there.
Please also add this to the bugtracker of kdevelop (if it is a kdevelop bug though).
Back to top
View user's profile Send private message
atom2103
n00b
n00b


Joined: 15 Mar 2004
Posts: 20

PostPosted: Sun Apr 03, 2005 6:03 pm    Post subject: Reply with quote

I had the same problem. Has nothing to do with KDevelop. I tryed to copy&paste the comand to the shell and got the same error. Don't blame KDevelop. :roll:

This solved my Problem:

Quote:
I did as the configure script said and ran libtoolize --copy --force in the folder of my src. Now it works fine.


Found it here:
https://forums.gentoo.org/viewtopic-t-309939.html

Hope it works for you too. :wink:
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9291

PostPosted: Fri Nov 02, 2007 3:59 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, refer to topic "Libtool.m4 and ltmain.sh Problems". This problem has been reported in the KDE bug tracking system, where it has been marked as an invalid bug, though it is also mentioned in the kdevelop FAQ.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum