Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] sys-kernel/linux-headers package conflicts --newuse
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
mody
Apprentice
Apprentice


Joined: 01 Oct 2004
Posts: 176

PostPosted: Thu Mar 10, 2005 8:48 am    Post subject: [SOLVED] sys-kernel/linux-headers package conflicts --newuse Reply with quote

I'm getting this error message with --deep ann --newuse;
this is my make.conf
Code:
CFLAGS="-O3 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
#USE="gnome qt kde dvd alsa"
USE="X a52 aac aalib acpi alsa apache2 apm audiofile avi bash-completion bmp bzlib cdb cdparanoia dedicated dga dio directfb divx4linux dv dvd dvdread emacs encode ethereal evo examples exif fam fbcon ffmpeg fdftk gb gd gif ginac glut gmp gnome gphoto2 gpm gps gtk2 gtkhtml hal imagemagick jabber jack java javascript jpeg kde ladcca libwww mad mime ming mmx mng mp3 mpeg ncurses ogg oggvorbis opengl pdflib png pnp portaudio python qt quicktime samba scanner sndfile source spell sse svg svga szip threads tiff truetype usb vcd videos wmf xine xinerama xml xml2 xmms xosd xpm xv xvid yahoo zlib x86"

Is it necessary to specify all these useflags? Any ideas on what reasonable USE flags settings would look like for a developers workstation? [c,c++,python,gtk+,gnome,qt,kde,openEV,openGL...] I also use this machine for all home use.

Code:
Trilobyte root # emerge emacs
Calculating dependencies ...done!

!!! Error: the sys-kernel/linux-headers package conflicts with another package.
!!!        both can't be installed on the same system together.
!!!        Please use 'emerge --pretend' to determine blockers.

Code:
Trilobyte root # emerge --update --deep --newuse --pretend world

These are the packages that I would merge, in order:

Calculating world dependencies -
!!! All ebuilds that could satisfy "sys-kernel/linux-headers" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-kernel/linux-headers-2.4.23_p3 (masked by: profile, -* keyword)
- sys-kernel/linux-headers-2.0.40 (masked by: profile, -* keyword)
- sys-kernel/linux-headers-2.4.21 (masked by: profile)
- sys-kernel/linux-headers-2.6.8.1-r2 (masked by: package.mask)
# <johnm@gentoo.org> (1/12/2004)
# Masking all 2.6 versions of kernel packages which were originally
# 2.4 only so that we can merge 2.6 with 2.4 without forcing a
# mass upgrade.
# this includes the headers too

- sys-kernel/linux-headers-2.4.23 (masked by: profile, -* keyword)
- sys-kernel/linux-headers-2.4.22 (masked by: profile, ~x86 keyword)
- sys-kernel/linux-headers-2.4.25 (masked by: profile, -* keyword)
- sys-kernel/linux-headers-2.4.21-r1 (masked by: profile)
- sys-kernel/linux-headers-2.4.26 (masked by: profile, -* keyword)
- sys-kernel/linux-headers-2.4.22-r1 (masked by: profile)
- sys-kernel/linux-headers-2.2.26 (masked by: profile, -* keyword)
- sys-kernel/linux-headers-2.6.10 (masked by: package.mask, -* keyword)
- sys-kernel/linux-headers-2.6.8.1-r4 (masked by: package.mask, ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
section 2.2 "Software Availability" in the Gentoo Handbook.
!!!    (dependency required by "sys-apps/util-linux-2.12i-r1" [ebuild])


!!! Problem with ebuild sys-apps/man-pages-2.01
!!! Possibly a DEPEND/*DEPEND problem.

!!! Depgraph creation failed.


Last edited by mody on Thu Mar 10, 2005 9:15 am; edited 1 time in total
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Thu Mar 10, 2005 9:08 am    Post subject: Reply with quote

mody wrote:
I'm getting this error message with --deep ann --newuse;
<etc etc>

If you want the linux-headers-2.6 line of packages from the testing branch (~arch), just unmask them.
https://forums.gentoo.org/viewtopic-t-33534.html
Please search before you post.
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
mody
Apprentice
Apprentice


Joined: 01 Oct 2004
Posts: 176

PostPosted: Thu Mar 10, 2005 9:15 am    Post subject: Reply with quote

I'm sorry about that... I'll try not to let it happen again.
Thanks for the head up....:)
Back to top
View user's profile Send private message
Earthwings
Bodhisattva
Bodhisattva


Joined: 14 Apr 2003
Posts: 7753
Location: Karlsruhe, Germany

PostPosted: Thu Mar 10, 2005 9:31 am    Post subject: Reply with quote

Moved to dups.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum