Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg 6.8.2 failes to compile with 2005.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
babo
Guru
Guru


Joined: 10 Aug 2004
Posts: 477
Location: Ljubljana

PostPosted: Thu Mar 10, 2005 11:01 am    Post subject: xorg 6.8.2 failes to compile with 2005.0 Reply with quote

Well, I did a routine morning emerge sync and emerge -Duv world, and as xorg 6.8.2 was marked stable i tried to emerge it. I am running profile 2005.0 and before emerging xorg I had to update emul-linux-x86-xlibs, if this is of any importance. Anyway the compile stops like this:

Code:
gzipping man page: XStandards.7x
gzipping man page: XProjectTeam.7x
gzipping man page: X.Org.7x
making executable: /usr/lib64/libFS.so.6.0
making executable: /usr/lib64/libGLU.so.1.3
making executable: /usr/lib64/libGLw.so.1.0
making executable: /usr/lib64/libI810XvMC.so.1.0
making executable: /usr/lib64/libICE.so.6.3
making executable: /usr/lib64/libOSMesa.so.4.0
making executable: /usr/lib64/libSM.so.6.0
making executable: /usr/lib64/libX11.so.6.2
making executable: /usr/lib64/libXRes.so.1.0
making executable: /usr/lib64/libXTrap.so.6.4
making executable: /usr/lib64/libXau.so.6.0
making executable: /usr/lib64/libXaw.so.6.1
making executable: /usr/lib64/libXaw.so.7.0
making executable: /usr/lib64/libXaw.so.8.0
making executable: /usr/lib64/libXcomposite.so.1.0
making executable: /usr/lib64/libXcursor.so.1.0.2
making executable: /usr/lib64/libXdamage.so.1.0
making executable: /usr/lib64/libXevie.so.1.0
making executable: /usr/lib64/libXext.so.6.4
making executable: /usr/lib64/libXfixes.so.3.0
making executable: /usr/lib64/libXfont.so.1.5
making executable: /usr/lib64/libXft.so.1.1
making executable: /usr/lib64/libXft.so.2.1.2
making executable: /usr/lib64/libXi.so.6.0
making executable: /usr/lib64/libXinerama.so.1.0
making executable: /usr/lib64/libXmu.so.6.2
making executable: /usr/lib64/libXmuu.so.1.0
making executable: /usr/lib64/libXp.so.6.2
making executable: /usr/lib64/libXpm.so.4.11making executable: /usr/lib64/libXrandr.so.2.0
making executable: /usr/lib64/libXrender.so.1.2.2
making executable: /usr/lib64/libXss.so.1.0
making executable: /usr/lib64/libXt.so.6.0
making executable: /usr/lib64/libXtst.so.6.1
making executable: /usr/lib64/libXv.so.1.0
making executable: /usr/lib64/libXvMC.so.1.0
making executable: /usr/lib64/libXxf86dga.so.1.0
making executable: /usr/lib64/libXxf86misc.so.1.1
making executable: /usr/lib64/libXxf86rush.so.1.0
making executable: /usr/lib64/libXxf86vm.so.1.0
making executable: /usr/lib64/libdps.so.1.0
making executable: /usr/lib64/libdpstk.so.1.0
making executable: /usr/lib64/libfontenc.so.1.0
making executable: /usr/lib64/libpsres.so.1.0
making executable: /usr/lib64/libxkbfile.so.1.0
making executable: /usr/lib64/libxkbui.so.1.0
making executable: /usr/lib64/libxrx.so.6.8
making executable: /usr/lib64/libxrxnest.so.6.8
QA Notice: /usr/bin/Xorg is setXid, dynamically linked and using lazy bindings.
This combination is generally discouraged. Try: CFLAGS='-Wl,-z,now' emerge xorg-x11
>>> Completed installing xorg-x11-6.8.2-r1 into /var/tmp/portage/xorg-x11-6.8.2-r1/image/

>>> Merging x11-base/xorg-x11-6.8.2-r1 to /
 * Migrating from /usr/X11R6/bin to /usr/bin...
 * Migration method is rsync.
 *   /usr/X11R6/bin doesn't exist, not migrating
 *     Symlinking //usr/X11R6/bin -> ../bin
 * Migrating from /usr/X11R6/include to /usr/include...
 * Migration method is rsync.
 *   /usr/X11R6/include doesn't exist, not migrating
 *     Symlinking //usr/X11R6/include -> ../include
 * Migrating from /usr/X11R6/lib to /usr/lib...
 * Migration method is rsync.
 *   /usr/X11R6/lib doesn't exist, not migrating
 *     Symlinking //usr/X11R6/lib -> ../lib
 * Migrating from /usr/X11R6/lib64 to /usr/lib64...
 * Migration method is rsync.
 *   /usr/X11R6/lib64 doesn't exist, not migrating
 *     Symlinking /usr/X11R6/lib -> lib64
 * Migrating from /usr/X11R6/man to /usr/share/man...
 * Migration method is rsync.
 *   /usr/X11R6/man doesn't exist, not migrating
 *     Symlinking //usr/X11R6/man -> ../man
 * Preparing any installed configuration files for font move...
 * //usr/X11R6/lib64/X11/fonts does not exist.
 * Migrating from /usr/X11R6/lib64/X11/fonts to /usr/share/fonts...
 * Migration method is rsync.
 *   /usr/X11R6/lib64/X11/fonts doesn't exist, not migrating
 *     Symlinking //usr/X11R6/lib64/X11/fonts -> ../../share/fonts
ln: creating symbolic link `//usr/X11R6/lib64/X11/fonts' to `../../share/fonts': No such file or directory
 * Preparing for /usr/X11R6 -> /usr migration...
removed `//usr/X11R6/bin'
removed `//usr/X11R6/include'removed `//usr/X11R6/lib'
removed `//usr/X11R6/man'
 * Remaining symlinks in /usr/X11R6:
//usr/X11R6/lib32
 * Migrating from /usr/X11R6 to /usr...
 * Migration method is rsync.
 *   /usr/X11R6 isn't a symlink, migrating...

!!! ERROR: x11-base/xorg-x11-6.8.2-r1 failed.
!!! Function check_migrate_return, Line 1510, Exitcode 1
!!! rsync failed. Exit code: 23.
!!! If you need support, post the topmost build error, NOT this status message.

!!! FAILED preinst: 1
root@rasta babo #




as the process ended in the final stages, my fear is that it's half installed, and if that's so xorg will no longer be working after restart. Can someone tell me if it is like so, or am I still safely running the same version of xorg as yesterday.

And if someone has a clue how to make it emerge that would be great.

Thank you in advance.
Back to top
View user's profile Send private message
babo
Guru
Guru


Joined: 10 Aug 2004
Posts: 477
Location: Ljubljana

PostPosted: Thu Mar 10, 2005 11:35 am    Post subject: Reply with quote

Well, I just tried to restart X, and it doesn't want to. So I have to write this from my other computer :)
Back to top
View user's profile Send private message
vyzivus
Apprentice
Apprentice


Joined: 05 Jul 2004
Posts: 173
Location: Slovakia

PostPosted: Thu Mar 10, 2005 1:23 pm    Post subject: Reply with quote

Same error here. I won't reboot my computer until it's fixed, I guess :)
_________________
I thought what I'd do was, I'd pretend I was one of those deaf-mutes or should I?
Back to top
View user's profile Send private message
babo
Guru
Guru


Joined: 10 Aug 2004
Posts: 477
Location: Ljubljana

PostPosted: Thu Mar 10, 2005 1:33 pm    Post subject: Reply with quote

vyzivus wrote:
Same error here. I won't reboot my computer until it's fixed, I guess :)


well, it's not so critical. I emerged xorg-x11-6.8.0-r5 and it is working again.

But the darn thing is that xorg-x11-6.8.2-r2 fails at the end and than you have to reemerge previous version again, what takes allmost an hour alltogether.
Back to top
View user's profile Send private message
marvin rouge
Veteran
Veteran


Joined: 01 Aug 2004
Posts: 1422
Location: Villa Lumierrante, Zonelibre

PostPosted: Thu Mar 10, 2005 3:41 pm    Post subject: Reply with quote

it won't help you, but xorg-x11-6.8.2-r1 works fine here.
Code:
# emerge -pv xorg-x11
These are the packages that I would merge, in order:
Calculating dependencies   ...done!
[ebuild   R   ] x11-base/xorg-x11-6.8.2-r1  (-3dfx) (-3dnow) +bitmap-fonts -cjk -debug -dlloader -dmx -doc +font-server -hardened -insecure-drivers +ipv6 -minimal (-mmx) +nls +opengl +pam -sdk (-sse) -static +truetype-fonts +type1-fonts (-uclibc) -xprint +xv 0 kB
Back to top
View user's profile Send private message
VValdo
Guru
Guru


Joined: 08 Jan 2005
Posts: 395

PostPosted: Thu Mar 10, 2005 4:26 pm    Post subject: Reply with quote

Same error here. Posting to bugzilla (if it's not already there)

W
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Thu Mar 10, 2005 7:34 pm    Post subject: Reply with quote

Please see this topic: https://forums.gentoo.org/viewtopic-t-292162.html

Moved from Gentoo on AMD64.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum