Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dell Inspiron 6000
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 14, 15, 16 ... 31, 32, 33  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Sun Aug 07, 2005 5:22 pm    Post subject: Reply with quote

What about downgrading to udev-056? The kernel 2.6.12 is said to need udev >= 058 but for custom udev rules but I don't have any. I hope the whole thing will be fixed soon - did you fill a bug report?
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Sun Aug 07, 2005 5:37 pm    Post subject: Reply with quote

seppelrockt wrote:
What about downgrading to udev-056? The kernel 2.6.12 is said to need udev >= 058 but for custom udev rules but I don't have any. I hope the whole thing will be fixed soon - did you fill a bug report?

Well, you could always try downgrading. I'll try customing UDEV but only when I have a little time (I already have lotsa things to do with Gentoo-for-colleagues :) ). I'll post whenever I get results. I haven't submitted any bug report; I didn't feel like it was required.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Sun Aug 07, 2005 10:49 pm    Post subject: Reply with quote

OK, downgrading didn`t change anything. As the udev-permissions file is not used anymore, one has to set the permissions in udev-rules via "mode". But udev-rules is calling a script for CDROMs and I'm not sure whether the modification should go into the script or into udev-rules (guess second one cause of emerge sync overrides).

Was not a good Gentoo day for me, ...
Back to top
View user's profile Send private message
BlueShark
n00b
n00b


Joined: 30 May 2005
Posts: 66
Location: Mainz, Germany

PostPosted: Mon Aug 08, 2005 2:04 pm    Post subject: Reply with quote

Hi,

after some maintenance work I have again problems with my DVD-burner. Because I noticed this error a short time ago, I do not know, which action caused this error.

As user I can only read Data, when its mounted on /mnt/dvdrw. Access to /dev/sr0 has root only. So as user I cannot rip audio-cds and I cannot burn any cds. As root it works fine.


My Kernel: 2.6.12-r6 without any patch, but I changed libata.h.

kernel config
fstab
dmesg
modules.autoload.d/kernel-2.6

In previous post there was mentioned, that you should deactivate ATA/ATAPI/MFM/RLL support. I need this for my PCMCIA CF-Cardreader, so I compiled it as a module. Because the modules are loaded after the compiled in driver, there are no conflicts.

I saw in other thread many people have similar problems, but I found no satisfactory answer for my problem. Because you all have the same laptop than me, I hope you can help me.

Regards,
BlueShark
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Tue Aug 09, 2005 10:08 am    Post subject: Reply with quote

For now my only (quick and dirty) way out is
Code:
chmod g+s /usr/bin/cdrecord


EDIT: make sure you are part of group cdrw and /usr/bin/cdrecord is owned by the same group.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Tue Aug 09, 2005 12:11 pm    Post subject: Reply with quote

I finally managed to get DVD playback and Audio CD playback work again with libata.h patch and udev.
You need udev-063 (package masked) - all the other versions seem to be unusable in this case and the following custom rule in /etc/udev/rules.d/10-local-rules:
Code:
 
# This custom udev rules should hopefully fix my group permission problems for
the DVD-CDRW Combo on Dell I6000
# For further information see
http://forums.gentoo.org/viewtopic-t-355069-postdays-0-postorder-asc-start-75.html
 
BUS=="scsi", KERNEL="sr[0-9]*", PROGRAM="/etc/udev/scripts/cdsymlinks.sh %k",
SYMLINK+="%c{1} %c{2} %c{3} %c{4} %c{5} %c{6}", GROUP:="cdrom"


Don't know about burning atm.
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Tue Aug 09, 2005 1:00 pm    Post subject: Reply with quote

seppelrockt wrote:
I finally managed to get DVD playback and Audio CD playback work again with libata.h patch and udev.
You need udev-063 (package masked) - all the other versions seem to be unusable in this case and the following custom rule in /etc/udev/rules.d/10-local-rules:
Code:
 
# This custom udev rules should hopefully fix my group permission problems for
the DVD-CDRW Combo on Dell I6000
# For further information see
http://forums.gentoo.org/viewtopic-t-355069-postdays-0-postorder-asc-start-75.html
 
BUS=="scsi", KERNEL="sr[0-9]*", PROGRAM="/etc/udev/scripts/cdsymlinks.sh %k",
SYMLINK+="%c{1} %c{2} %c{3} %c{4} %c{5} %c{6}", GROUP:="cdrom"


Don't know about burning atm.

Good to know, thanks a lot! I'm trying right now. I'll try burning later for I have no disk right now.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
BlueShark
n00b
n00b


Joined: 30 May 2005
Posts: 66
Location: Mainz, Germany

PostPosted: Tue Aug 09, 2005 3:13 pm    Post subject: Reply with quote

Hi,

your "quick and dirty" way gives me the idea of looking for the right and group management.
Till now, I checked only if the user is in the right group and there I found no mistake. But the problem was, that /dev/sr0 was owned by root an in the group root. So no user had acces to this device.

With the udev rule:
Code:
BUS="scsi", SYSFM{model}="DVD+-RW ND-6500A", KERNEL="sr[0-9]*", PROGRAM="/etc/udev/scripts/cdsymlinks.sh %k", SYMLINK+="%c{1} %c{2} %c{3} %c{4} %c{5}", GROUP:="cdrom" MODE:="0770"


I solved this problem. Now every user in the group cdrom can burn a cd.
Thank you for your help :D

But one problem is still not solved: no user can play any audio-cd, even if I set chmod 0777 to /dev/sr0. As root it works fine. So I think this problem is not only caused by the rights of /dev/sr0.

Regards,
BlueShark
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Tue Aug 09, 2005 4:39 pm    Post subject: Reply with quote

BlueShark wrote:
Hi,

your "quick and dirty" way gives me the idea of looking for the right and group management.
Till now, I checked only if the user is in the right group and there I found no mistake. But the problem was, that /dev/sr0 was owned by root an in the group root. So no user had acces to this device.

With the udev rule:
Code:
BUS="scsi", SYSFM{model}="DVD+-RW ND-6500A", KERNEL="sr[0-9]*", PROGRAM="/etc/udev/scripts/cdsymlinks.sh %k", SYMLINK+="%c{1} %c{2} %c{3} %c{4} %c{5}", GROUP:="cdrom" MODE:="0770"


I solved this problem. Now every user in the group cdrom can burn a cd.
Thank you for your help :D

Great!

BlueShark wrote:
But one problem is still not solved: no user can play any audio-cd, even if I set chmod 0777 to /dev/sr0. As root it works fine. So I think this problem is not only caused by the rights of /dev/sr0.

Regards,
BlueShark

If you install udev 063, as seppelrockt says, you get it working. So all you have to do is combine your rules with UDEV 063 and that's it, I think.

I've tried UDEV 065 and /dev/sr0 is... read-only for the group (:? :?: 8O ). Only UDEV 063 has correct (i.e. logical) rights put on /dev/sr0 - rw for group disk. All versions of UDEV I tried have /dev/sr0 owned by root:root. Hence your customized rule should set the appropriate group (cdrom) instead of root. All problems should be solved. I hope...
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
juniper
l33t
l33t


Joined: 22 Oct 2004
Posts: 763
Location: EU

PostPosted: Tue Aug 09, 2005 5:03 pm    Post subject: Re: Laptop freezes Reply with quote

mhanski wrote:
juniper wrote:
mhanski wrote:
Having tried pretty much everything to get rid of the hard lock ups, I went for Ubuntu and, alas, experienced exactly the same behaviour on this system too.
Now I'm going to to follow this advise for some time and see, if it helps:

http://ubuntuforums.org/showthread.php?t=48354

Quote:
Ubuntu uses the linux-2.6 kernel. Newer centrino laptops use a chipset that in linux-2.6 requries use of the libata drivers, rather than the tried & true IDE subsystem which I co-authored. Libata works well, though, but has a fatal race condition in the SCSI error handling code.

So.. if your laptop has the modern centrino chipset (ICH6M), *and* an IDE hard disk and IDE (ATAPI) optical drive, then it is probably using the libata "ata_piix" driver in the kernel. If that is the case, your system *will* lock up regularly whenever the optical drive has no disc in it.

Just still a non-blank disc in the CD/DVD drive and let it run for a day or two, and see if that "cures" the lockups. There's a kernel patch available for this as well, but it has not appeared in any official kernel yet. Anyone who wants to pick it up can grab it from my webspace here: http://rtr.ca/dell_i9300/


My lsmod output:
Code:

maciej@zeus:~$ lsmod | grep ata
ata_piix                9124  13
libata                 49316  2 ahci,ata_piix
scsi_mod              127552  6 sbp2,ahci,sr_mod,sd_mod,sg,libata
maciej@zeus:~$


P.S. This site http://rtr.ca/dell_i9300/ and these patches http://rtr.ca/dell_i9300/kernel/ seem really worth looking on, since it's basically the same laptop as ours, with the same NEC DVD+-RW drive.

M.


hmmm, this might sound a little stupid, but do you have laptop-mode-tools running? i stopped mine and the lockups *seem* to have stopped. my laptop has been running for about a few hours now and it hasn't locked up. even emerged some stuff. i think it had to do with the battery tools.

j


Hi Juniper,
no, I don't have laptop-mode-tools running (actually, I installed them, but didn't care to add them to a runlevel).

What is even more stupid, having a non-blank disc in the DVD drive seems to cure my lockups. I put some load on my CPU (like emerging firefox and thunderbird at once) and there weren't any.

Any idea, how to apply those 2.6.12.12 patches http://rtr.ca/dell_i9300/ to gentoo sources (2.6.12-r6)?

M.

P.S. I'm leaving for holidays today and won't be able to post anything for the next 3 weeks :)


well, it appears that laptop-mode wasn't the problem for me, as my lockups are back :( (i do think, however, laptop-mode tools was making it worse). but i just had a couple of lockups yesterday, both while doing an emerge.

i will apply the above patch and see how it goes. mhanski, did you manage to figure out how to apply the patch? i think vinzc see posted on how to do that.

will update.

j
Back to top
View user's profile Send private message
BlueShark
n00b
n00b


Joined: 30 May 2005
Posts: 66
Location: Mainz, Germany

PostPosted: Tue Aug 09, 2005 5:11 pm    Post subject: Reply with quote

Well, I think the rights for /sev/sr0 is not the problem. With udev 065 the rights are set correctly. When I start gnome-cd I see all the Tracks, but when I click the play button. Nothing happends, sometimes gnome-cd crashes.

I tried setting the rights and the owner by hand, to test several right- and own-combinations. Even when blueshark:users with 0777 is set on /dev/sr0 it is not working.

So I think there must be a problem on another place, but I don't know where. When I try to play audio-cds with gnome-cd as root, it works fine.
Back to top
View user's profile Send private message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Tue Aug 09, 2005 6:27 pm    Post subject: Reply with quote

BlueShark wrote:
Well, I think the rights for /sev/sr0 is not the problem. With udev 065 the rights are set correctly. When I start gnome-cd I see all the Tracks, but when I click the play button. Nothing happends, sometimes gnome-cd crashes.

I tried setting the rights and the owner by hand, to test several right- and own-combinations. Even when blueshark:users with 0777 is set on /dev/sr0 it is not working.

So I think there must be a problem on another place, but I don't know where. When I try to play audio-cds with gnome-cd as root, it works fine.


I had the same problem yesterday and tried to run my audiocd app (kaffeine in my case) as root - and it worked. Then I found out that it helped to set /dev/sg0 and /dev/sg1 (NOTE: this is with "g" not "r") to rw for group cdrom and it worked for user to. You can do this manual, with /etc/udev/10-local-rules or just use udev-063 (works out of the box). However I'm wondering why it works with udev-063 because it has /dev/sg* set to root root ...
Back to top
View user's profile Send private message
RBJ1128
Apprentice
Apprentice


Joined: 18 Jan 2005
Posts: 192

PostPosted: Tue Aug 09, 2005 9:07 pm    Post subject: Re: Laptop freezes Reply with quote

VinzC wrote:
mhanski wrote:
patch -p0 < $(ls ~/i9300) didn't work, but I managed to apply the patches one by one and am running the new kernel now. Let's wait and see...

Oops... I should have written
Code:
patch -p0 < ~/$(ls ~/i9300)

Glad to see you solved it. We're looking forward to hearing back from you. Have nice holidays.


Alright, I'm back. After I tried Ubuntu for about a week and became tired of how they tried to do EVERYTHING for me, I decided to switch back to Gentoo. I am in the process of installing everything right now, but I came across this post and it seems to explain why I too am having freezing issues. I have followed the instructions about applying the patches, but I am running into problems. I have never patched a kernel before, so I am not sure how to deal with the error message:
Code:
#cd /usr/src/linux
#patch -p0 < ~/$(ls ~/i9300)
-bash: ~/$(ls ~/i9300): ambiguous redirect


I have all of the files from the site in /root/i9300/ and I am trying to run it as root. First, the line patch -p0 ... is that a zero (0) or the letter o (O). 2nd, how do I go about dealing with this so that I can patch my kernel?

Thanks,
_________________
-RBJ1128
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Tue Aug 09, 2005 10:33 pm    Post subject: Re: Laptop freezes Reply with quote

RBJ1128 wrote:
...
I have followed the instructions about applying the patches, but I am running into problems. I have never patched a kernel before, so I am not sure how to deal with the error message:
Code:
#cd /usr/src/linux
#patch -p0 < ~/$(ls ~/i9300)
-bash: ~/$(ls ~/i9300): ambiguous redirect


I have all of the files from the site in /root/i9300/ and I am trying to run it as root. First, the line patch -p0 ... is that a zero (0) or the letter o (O). 2nd, how do I go about dealing with this so that I can patch my kernel?

Well, sorry... this was me trying to do my best to provide a command line instruction that would work whatever you name your patch file :oops: . It would have been simpler if I had written
Code:
patch -p0 < ~/i9300/[the name of your patch file]


This is a zero, which means try to guess files to patch from the location that is indicated in the patch. Files should be found using the first two lines (--- and +++) of the patch.
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Wed Aug 10, 2005 11:53 am    Post subject: Reply with quote

Arrrrrrr, new problem (udev again): my ptp digital kamera doesn't work anymore as user. There are many posts in the forum, I will have to read some more :evil:
Back to top
View user's profile Send private message
RBJ1128
Apprentice
Apprentice


Joined: 18 Jan 2005
Posts: 192

PostPosted: Wed Aug 10, 2005 12:23 pm    Post subject: Re: Laptop freezes Reply with quote

VinzC wrote:

This is a zero, which means try to guess files to patch from the location that is indicated in the patch. Files should be found using the first two lines (--- and +++) of the patch.


Alright, I got the patches to go through. I had to use
Code:

#patch -p1 < ~/i9300/[each patch file individually]


After I looked at the man page for patch, I understood it a little more. I am now running on the newly-patched (and compiled) kernel. I hope that this solves the problem. Thanks.
_________________
-RBJ1128
Back to top
View user's profile Send private message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Wed Aug 10, 2005 12:36 pm    Post subject: Reply with quote

BlueShark wrote:
Hi,

your "quick and dirty" way gives me the idea of looking for the right and group management.
Till now, I checked only if the user is in the right group and there I found no mistake. But the problem was, that /dev/sr0 was owned by root an in the group root. So no user had acces to this device.

With the udev rule:
Code:
BUS="scsi", SYSFM{model}="DVD+-RW ND-6500A", KERNEL="sr[0-9]*", PROGRAM="/etc/udev/scripts/cdsymlinks.sh %k", SYMLINK+="%c{1} %c{2} %c{3} %c{4} %c{5}", GROUP:="cdrom" MODE:="0770"


I solved this problem. Now every user in the group cdrom can burn a cd.
Thank you for your help :D

But one problem is still not solved: no user can play any audio-cd, even if I set chmod 0777 to /dev/sr0. As root it works fine. So I think this problem is not only caused by the rights of /dev/sr0.

Regards,
BlueShark


I'm getting crasy today - burning didn't worked here first. I had to add a udev rule for /dev/sg1 to 10-local-rules to set it to group cdrom. Now it works, but what is this fuc**** /dev/sg1 for - why scsi-emulation??? I have NOT changed perms for /usr/bin/cdrecord btw. and didn't used the k3b manager to set up my system.
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Wed Aug 10, 2005 4:49 pm    Post subject: Reply with quote

BlueShark wrote:
Well, I think the rights for /sev/sr0 is not the problem. With udev 065 the rights are set correctly. When I start gnome-cd I see all the Tracks, but when I click the play button. Nothing happends, sometimes gnome-cd crashes.

I tried setting the rights and the owner by hand, to test several right- and own-combinations. Even when blueshark:users with 0777 is set on /dev/sr0 it is not working.

So I think there must be a problem on another place, but I don't know where. When I try to play audio-cds with gnome-cd as root, it works fine.

Hmmm... It's a question of rights anyway since root succeeds in reading. Could it be due to an access right somewhere else? in /dev/dsp/*, /dev/sound/* or even /proc/[smthing] - basically somewhere else than the disk node itself?

EDIT: how about running the program from within a file-access tracer? Is that possible with Linux?
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
RBJ1128
Apprentice
Apprentice


Joined: 18 Jan 2005
Posts: 192

PostPosted: Wed Aug 10, 2005 5:43 pm    Post subject: Gnome Panel??? Reply with quote

The patched kernel seems to be running without any problems. Whenever I boot and Gnome loads I get a error message
Code:
I've detected a panel already running and will now exit
The only option is to click OK. The panel itself is intact sometimes, but other times it jsut isn't there. When it is not there I have to run
Code:
killall gnome-panel
and it brings it back up. Has anyone seen this before or know how to fix it? Thanks.
_________________
-RBJ1128
Back to top
View user's profile Send private message
BlueShark
n00b
n00b


Joined: 30 May 2005
Posts: 66
Location: Mainz, Germany

PostPosted: Wed Aug 10, 2005 5:50 pm    Post subject: Reply with quote

seppelrockt wrote:
I had the same problem yesterday and tried to run my audiocd app (kaffeine in my case) as root - and it worked. Then I found out that it helped to set /dev/sg0 and /dev/sg1 (NOTE: this is with "g" not "r") to rw for group cdrom and it worked for user to. You can do this manual, with /etc/udev/10-local-rules or just use udev-063 (works out of the box). However I'm wondering why it works with udev-063 because it has /dev/sg* set to root root ...


Unbelievable, it works. Just set with udev root:cdrom to sg0 and sg1. Thats it. Thank you.
Back to top
View user's profile Send private message
VinzC
Watchman
Watchman


Joined: 17 Apr 2004
Posts: 5028
Location: Dark side of the mood

PostPosted: Thu Aug 11, 2005 4:32 pm    Post subject: Re: Gnome Panel??? Reply with quote

RBJ1128 wrote:
Code:
I've detected a panel already running and will now exit
The only option is to click OK. The panel itself is intact sometimes, but other times it jsut isn't there. When it is not there I have to run
Code:
killall gnome-panel
and it brings it back up. Has anyone seen this before or know how to fix it? Thanks.

https://forums.gentoo.org/viewtopic.php?p=2631709#2631709
_________________
Gentoo addict: tomorrow I quit, I promise!... Just one more emerge...
1739!
Back to top
View user's profile Send private message
eis
Apprentice
Apprentice


Joined: 05 Aug 2005
Posts: 161
Location: Stuttgart, Germany

PostPosted: Fri Aug 12, 2005 5:47 am    Post subject: Reply with quote

Hi !

I have an Inspiron 6000 as well and I am trying to get it work.

So I tried "xorgconfig" and I tried to configure X reading the documented file.

But It doesn't work, because I get an error, that my screen modes (I guess the horizontal and vertikal sync rates) are not useable. And I con't know them.
So I have an 15'' Widescreen, too, however not Ultrasharp, so my highest resolution is 1280 x 800.

And the given file in the very first posting og this thread does not work for me either.


boris
Back to top
View user's profile Send private message
clizarralde
n00b
n00b


Joined: 11 Aug 2005
Posts: 1

PostPosted: Fri Aug 12, 2005 1:20 pm    Post subject: YUPI!!!!!! Reply with quote

I got my I6000 working with i915 chipset. I am so glad. It looks great.

I have been reading this forum for a week. And last night it worked

Greetings and thanks everybody.
_________________
Charly
Back to top
View user's profile Send private message
seppelrockt
Guru
Guru


Joined: 14 May 2004
Posts: 423

PostPosted: Fri Aug 12, 2005 2:07 pm    Post subject: Reply with quote

eis wrote:
Hi !
I have an Inspiron 6000 as well and I am trying to get it work.
So I tried "xorgconfig" and I tried to configure X reading the documented file.
But It doesn't work, because I get an error, that my screen modes (I guess the horizontal and vertikal sync rates) are not useable. And I con't know them.
So I have an 15'' Widescreen, too, however not Ultrasharp, so my highest resolution is 1280 x 800.
And the given file in the very first posting og this thread does not work for me either.

boris


I have posted my xorg.conf here. Btw, read the whole thread behind the link, it's worth it. And for further tweaking the xorg.conf (mine is for Intel graphics, not ATI) I would suggest to keep the xorg.conf as simple as possible. Xorg is quite good in "guessing" the right things from the hardware.

Code:
less /var/log/Xorg.0.log
is your friend!
Back to top
View user's profile Send private message
eis
Apprentice
Apprentice


Joined: 05 Aug 2005
Posts: 161
Location: Stuttgart, Germany

PostPosted: Fri Aug 12, 2005 6:45 pm    Post subject: Reply with quote

thx, I#m gonna try.

eis
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 14, 15, 16 ... 31, 32, 33  Next
Page 15 of 33

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum