Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge masked package confusion
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
DailyNodes
n00b
n00b


Joined: 07 Nov 2004
Posts: 67

PostPosted: Fri Mar 11, 2005 5:39 am    Post subject: emerge masked package confusion Reply with quote

So I ended up trying out e17. and boy do I love the eye candy!
But I keep running into a problem when I try to emerge some programs...

For instances, when I tried to emerge the latest examine ebuild...
Code:
Calculating dependencies   

!!! Problem in app-misc/examine-9999 dependencies.
!!! "Specific key requires an operator (app-misc/examine-9999) (try adding an '=')" exceptions


I'm assumming I'm getting this error because it hard masked or something.. but in my package.keywords I have this:
Code:
apps-misc/examine -*

shouldn't that be enough?
Back to top
View user's profile Send private message
thebigslide
l33t
l33t


Joined: 23 Dec 2004
Posts: 790
Location: under a car or on top of a keyboard

PostPosted: Fri Mar 11, 2005 5:52 am    Post subject: Reply with quote

Code:
emerge =app-misc/examine-9999

the = is critical if you want portage to install a specific version.
Also, there's a stickey for this. Maybe search for the error message next time :)
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4927
Location: Gothenburg, Sweden

PostPosted: Fri Mar 11, 2005 12:22 pm    Post subject: Reply with quote

Well, it's been unstuck for a while :arrow: https://forums.gentoo.org/viewtopic-t-136184.html

Moved from Portage & Programming.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum